Revit Architecture 2009 Families Guide

Imperial Tutorials

April 2008
Portions relating to JPEG © Copyright 1991-1998 Thomas G. Lane. All rights reserved. This software is based in part on the work of the Independent JPEG Group.

Portions relating to TIFF © Copyright 1997-1998 Sam Leffler. © Copyright 1991-1997 Silicon Graphics, Inc. All rights reserved. The Tiff portions of this software are provided by the copyright holders and contributors “as is” and any express or implied warranties, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose are disclaimed. In no event shall the copyright owner or contributors of the TIFF portions be liable for any direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict liability, or tort (including negligence or otherwise) arising in any way out of the use of the TIFF portions of this software, even if advised of the possibility of such damage. Portions of Libtiff 3.5.7 Copyright © 1988-1997 Sam Leffler. Copyright © 1991-1997 Silicon Graphics, Inc. Permission to use, copy, modify, distribute, and sell this software and its documentation for any purpose is hereby granted without fee, provided that (i) the above copyright notices and this permission notice appear in all copies of the software and related documentation, and (ii) the names of Sam Leffler and Silicon Graphics may not be used in any advertising or publicity relating to the software without the specific, prior written permission of Sam Leffler and Silicon Graphics.

Portions of Libxml2 2.6.4 Copyright © 1998-2003 Daniel Veillard. All Rights Reserved. Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated documentation files (the “Software”), to deal in the Software without restriction, including without limitation the rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the Software is furnished to do so, subject to the following conditions: The above copyright notices and this permission notice shall be included in all copies or substantial portions of the Software.

Government Use
Use, duplication, or disclosure by the U.S. Government is subject to restrictions as set forth in FAR 12.212 (Commercial Computer Software-Restricted Rights) and DFAR 227.7202 (Rights in Technical Data and Computer Software), as applicable.
<table>
<thead>
<tr>
<th>Chapter 4</th>
<th>Tutorial: Working with System Families</th>
<th>29</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Creating Custom Wall Materials</td>
<td>30</td>
</tr>
<tr>
<td></td>
<td>Creating a Custom Wall Type</td>
<td>35</td>
</tr>
<tr>
<td></td>
<td>Adding Reveals to the Custom Wall Type</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td>Creating a Custom Stacked Wall Type</td>
<td>43</td>
</tr>
<tr>
<td></td>
<td>Creating a Custom Floor Type</td>
<td>46</td>
</tr>
<tr>
<td></td>
<td>Creating a Custom Roof Type</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td>Transferring System Families Between Projects</td>
<td>51</td>
</tr>
<tr>
<td>Chapter 5</td>
<td>Standard Component Families Overview</td>
<td>57</td>
</tr>
<tr>
<td></td>
<td>Revit Architecture Standard Component Families</td>
<td>57</td>
</tr>
<tr>
<td></td>
<td>Workflow: Using Component Families in Your Projects</td>
<td>58</td>
</tr>
<tr>
<td></td>
<td>Using Existing Component Families</td>
<td>59</td>
</tr>
<tr>
<td></td>
<td>Viewing Component Families in a Project or Template</td>
<td>59</td>
</tr>
<tr>
<td></td>
<td>Viewing Elements with Component Family Types in a Project</td>
<td>60</td>
</tr>
<tr>
<td></td>
<td>Finding and Loading Component Families</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td>Creating Elements with Component Family Types</td>
<td>67</td>
</tr>
<tr>
<td></td>
<td>Deleting Component Families and Types</td>
<td>68</td>
</tr>
<tr>
<td></td>
<td>Creating Component Families</td>
<td>69</td>
</tr>
<tr>
<td></td>
<td>Understanding the Family Editor</td>
<td>70</td>
</tr>
<tr>
<td></td>
<td>Creating a Standard Component Family</td>
<td>72</td>
</tr>
<tr>
<td></td>
<td>Advanced Component Family Techniques</td>
<td>131</td>
</tr>
<tr>
<td></td>
<td>Modifying Component Families</td>
<td>145</td>
</tr>
<tr>
<td></td>
<td>Modifying Component Family Types</td>
<td>146</td>
</tr>
<tr>
<td></td>
<td>Modifying a Family</td>
<td>147</td>
</tr>
<tr>
<td></td>
<td>Modifying a Family to Create a New Family</td>
<td>148</td>
</tr>
<tr>
<td></td>
<td>Modifying Families in a Project (or Nested Family)</td>
<td>148</td>
</tr>
<tr>
<td>Chapter 6</td>
<td>Creating a Room Tag</td>
<td>153</td>
</tr>
<tr>
<td></td>
<td>Specifying Room Tag Parameters</td>
<td>153</td>
</tr>
<tr>
<td>Chapter 7</td>
<td>Creating a Titleblock Family</td>
<td>157</td>
</tr>
<tr>
<td></td>
<td>Drawing Linework for a Titleblock Sheet</td>
<td>158</td>
</tr>
<tr>
<td></td>
<td>Adding Graphics and Text to a Titleblock</td>
<td>160</td>
</tr>
<tr>
<td></td>
<td>Adding the Titleblock to a New Project</td>
<td>170</td>
</tr>
<tr>
<td>Chapter 8</td>
<td>Creating a Keyplan - Generic Annotation Family</td>
<td>173</td>
</tr>
<tr>
<td></td>
<td>Creating the Keyplan Geometry</td>
<td>174</td>
</tr>
<tr>
<td></td>
<td>Add Parameters to Control Keyplan Visibility</td>
<td>186</td>
</tr>
<tr>
<td>Chapter 9</td>
<td>Creating Detail Component Families</td>
<td>191</td>
</tr>
<tr>
<td></td>
<td>Creating a Window Sill Detail Component Family from a DWG</td>
<td>193</td>
</tr>
<tr>
<td></td>
<td>Creating a Full Window Detail Component Family</td>
<td>201</td>
</tr>
<tr>
<td></td>
<td>Adding the Full Window Detail Component to a Window Family</td>
<td>215</td>
</tr>
<tr>
<td>Chapter 10</td>
<td>Creating Planting Families</td>
<td>225</td>
</tr>
<tr>
<td></td>
<td>Creating the Existing Plant Base Family</td>
<td>226</td>
</tr>
<tr>
<td></td>
<td>Creating a Species Base Family</td>
<td>231</td>
</tr>
</tbody>
</table>
Creating a Planting Symbol Family .......................................................... 233
Testing Your Planting Families ............................................................... 236

Tutorials: 3D Component Families ....................................................... 239

Chapter 11 Creating a Window Family ................................................... 241
Specifying the New Window Parameters .............................................. 242
Creating the Window Frame Solid Geometry ......................................... 243
Creating the Window Sash Solid Geometry ........................................... 249
Creating the Window Glass Solid Geometry .......................................... 252
Creating the Window Mullion Solid Geometry ....................................... 257
Assigning Materials to the Window Components .................................. 269
Defining New Window Types ............................................................... 273

Chapter 12 Creating a Door Family ......................................................... 279
Drawing the Door Plan View Components ............................................ 280
Creating the Door Panel Solid Geometry .............................................. 286
Assigning Materials to the Door Components ....................................... 292
Defining New Door Types ................................................................. 294

Chapter 13 Creating a Baluster Family ................................................. 299
Creating a Baluster Family ................................................................. 301

Chapter 14 Creating a Basic Column Family .......................................... 311
Creating the Column Base ................................................................. 332
Creating the Upper Column .............................................................. 342
Adding Symbolic Lines for Plan Representation .................................... 357

Chapter 15 Creating a Bookcase (Furniture) Family ............................... 365
Creating the New Bookcase Family .................................................... 365
Creating the Family Skeleton ............................................................ 366
Creating Family Parameters and Types ............................................. 370
Creating Panels .................................................................................. 378
Creating the Base Plate ..................................................................... 388
Adding a Top Shelf ............................................................................ 395
Changing the Shape of the Side Panels ............................................. 403
Creating and Assigning Subcategories .............................................. 406
Adding Shelves .................................................................................. 407
Adding an Enclosure Panel .................................................................. 413
Adding a Door .................................................................................... 421
Managing Visibility ............................................................................ 429
Adding a Masking Region ................................................................... 431
Creating and Assigning Materials ..................................................... 432
Creating a Material Parameter ........................................................... 437
Controlling the Door Visibility ............................................................ 441
Creating a Type Catalog .................................................................... 444

Chapter 16 Using Reference Lines in Families ...................................... 447
Creating a Bookcase Door with a Reference Line .................................. 448
Creating an Angled Chair Back with a Reference Line ......................... 472

Tutorials: Advanced Standard Component Families ........................... 491

Chapter 17 Creating Shared Families .................................................... 493
Welcome to the Revit Architecture 2009 Families Guide! Families are an integral part of working in Revit Architecture, and key to creating custom content.

In this guide, you learn:
■ how to use families in your projects
■ concepts of parametric design and family creation
■ best practices to use when creating your own families

To better help you understand how to work with families, this guide contains conceptual explanations, hands-on tutorials, and reference information.

**Audience and Prerequisites**

This guide is intended for the beginning, intermediate, and advanced Revit Architecture families user. Although any sketching and 2D or 3D modeling experience is helpful to understand how to work with families, before you begin to work with this guide, you should have a basic understanding of Revit Architecture. If you do not, it is recommended that you use the tutorials included in the software. Access the tutorials by clicking Help ➤ Tutorials.

**Training Files**

The hands-on tutorials included in this guide use templates and family files that you download from [http://www.autodesk.com/revitarchitecture-documentation](http://www.autodesk.com/revitarchitecture-documentation). Most of these files have an .rfa, .rte, or .rvt extension, and are extracted by default to folders in C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2009\Training.
All of the elements that you add to your Revit Architecture projects – from the structural members, walls, roofs, windows, and doors that you use to assemble a building model to the callouts, fixtures, tags, and detail components that you use to document it – are created with families.

By using predefined families and creating new ones in Revit Architecture, you can add both standard and custom elements to your building models. Families also provide a level of control over elements that are similar in use and behavior, allowing you to easily make design changes and manage your projects more efficiently.

What Are Families?

A *family* is a group of elements with a common set of properties, called parameters, and a related graphical representation. Different elements belonging to a family may have different values for some or all of their parameters, but the set of parameters (their names and meanings) is the same. These variations within the family are called *family types* or *types*.

For example, the Furniture family includes families and family types that you can use to create different pieces of furniture, like desks, chairs, and cabinets. Although these families serve different purposes and are composed of different materials, they have a related use. Each type in the family has a related graphical representation and an identical set of parameters, called the family type parameters.

When you create an element in a project with a specific family and family type, you create an *instance* of the element. Each element instance has a set of properties, in which you can change some element parameters independent of the family type parameters. These changes apply only to the instance of the element, the single element in the project. If you make any changes to the family type parameters, the changes apply to all element instances that you created with that type.

Example: Creating a Furniture Element with a Family and Type

When you create an element in a project, that element is organized within the project first by element category, then by family, family type, and by instance. All 4 levels provide a different level of control of the element in your project. The following example demonstrates how you can create and control a bookcase in a project.
Determining the Element Category

All families that are in use or are available in your projects (and templates) are visible in the Project Browser under Families, grouped by element category.

The category defines a top level of identification and behavior for the element. When you start the command to create a piece of furniture, you automatically determine that the element will belong to the Furniture category. The category sets the basic role of the element within the building model, determines which elements it will interact with, and specifies that when tagged, it will be included in any furniture schedules that you create.

Selecting the Family

By expanding the Furniture category, you can see that it includes a number of different furniture families. All the furniture that you create in this project (unless it is specialized or you load other families), will belong to one of these families.

By itself, a family usually does not provide enough information to create a desired element in your project. While the family narrows the definition of the element you are creating in terms of its basic characteristics and graphic representation, it does not specify the size, material, or other specific characteristics of the element. For this reason, families include family types.

Specifying the Family Type

Family types are variations on the kind of element the family represents, and are shown under the furniture families shown below. For any of the types listed below, the family provides you with the kind of furniture you want to create (a bookcase, cabinet, chair, or desk), while the family type specifies the dimensions, material, and a few other characteristics of the element that you can create.
Creating an Instance

To add any of the furniture types in the Bookcase family to a project, start the Component command. The Type Selector lists the available Furniture family types in the project, listed first by family, then by name. You select the type that you want (in this case, a bookcase type), and add it to the project.

When you create an element in your project, you create what is called an instance of the family type. If you create one bookcase element, you have one instance of the type in your project.

If you create 4 bookcases, you have 4 instances of the type in your project.
Making Modifications

After you create an element in your project, you can make a number of changes to it. If you select one or more instances of the bookcase in the previous example, and then right-click and click Element Properties, you display the Element Properties of the bookcase or bookcases. This is a location where you can make a number of changes to the element and its parameters.

Changing Instance Parameters

In the Element Properties dialog, under Instance Parameters, scroll down to view the all of the instance parameters of the bookcase. You can change any of these values for the instance or instances of the bookcase.
that you selected. The changes will not be applied to all the bookcases of that type, only the instance or instances of the bookcase that you selected.

This family contains an instance parameter that determines whether or not the bookcase includes a door. In the above illustration, this DoorIncluded parameter is selected. If you clear the DoorIncluded parameter in the Element Properties dialog for one of the bookcase instances, that bookcase will no longer display a door.

Changing Type Parameters

In the Element Properties dialog, click Edit/New to view the Type Parameters of the bookcase type.

These parameters are shared by all bookcases in the project of the same family type. Any changes that you make to these parameters are applied to all bookcases of the same family type in the project, regardless of whether or not you selected them.
Changing the Family or Family Type

You can also change the family type, or family and family type of the bookcase element in the Element Properties dialog.

To change the family, at the top of the dialog, for Family, select a new family. In this example, you could change the bookcase to family to one that creates a different style bookcase or you could change the bookcase to a completely different piece of furniture, like a cabinet.

To change the family type, for Type, select a different type. After you exit the dialog, the instance or instances that you selected will reflect any changes that you made to the family or family type.

Role of Families in Your Building Models

Now that you have seen the control that you have over elements that you create with families and family types, you can imagine the flexibility that families, family types, and family parameters provide when creating and documenting your building models. Families, family types, and type and instance parameters allow for variation and change in the elements that you create, which is the basis of parametric modeling in Revit Architecture.

In addition to making the changes that were demonstrated in the previous section, you can use families, family types, and family parameters to:

- Add family types to existing families.
- Create your own family, and by adding family types, create a number of the same elements in a different size or that feature a different material, without having to draw the component more than once.
- Create family type parameters in a family that provide optional element geometry or material.
- Control the visibility and detail level of an element in different types of drawing views.

All families can be two-dimensional, three-dimensional, or both, but not all families have to be parametric. Elements created with families that do not need more than one size or type may remain non-parametric. Wall, door, and window families are examples of 3D families, which display accordingly in isometric and plan views. Annotation detail families are examples of 2D families that do not require 3D representations. A furniture family is an example of a family that might need separate 3D and 2D representations: a 3D representation to display in isometric views and a simplified 2D outline to display in a plan view.

NOTE Two- and three-dimensional content from other software packages that you import into Revit Architecture is not parametric, unless you recreate it as such.

Different Kinds of Families

There are 3 kinds of families in Revit Architecture:

- system families
- standard component (component) families
- in-place families

Most elements that you create in your projects are system or component families. Standard component families can be combined to create nested and shared component families. Non-standard or custom elements are created using in-place families.
System Families

System families create basic building elements such as walls, roofs, ceilings, floors, and other elements that you would assemble on a construction site. System settings, which affect the project environment and include types for levels, grids, drawing sheets, and viewports, are also system families.

System families are predefined in Revit Architecture. You do not load them into your projects from external files, nor do you save them in locations external to the project. If you cannot find the system family type that you need in a project, you can create a new one by changing the properties of an existing type, by duplicating (copying) a family type and changing its properties, or by copying and pasting one from another project. Any types that you modify are saved in your project.

For example, you may want to add a wood floor with a specific finish to a project. However, the only similar floor family type features smaller joists and a different finish. You would duplicate the system family type in your project, change its name to reflect the characteristics of the new floor, and edit its properties to feature the new size and finish. System families usually do not require you to model any new geometry.

Because system families are predefined, they are the least customizable of the 3 kinds of families, but they include more intelligent behavior than the other standard component families and in-place families. A wall that you create in a project automatically resizes to accommodate windows and doors that you place in it. There is no need to cut openings in the wall for the windows and doors before you place them.

Standard Component Families

Standard component families are families used to create both building components and some annotation elements. Component families create the building components that would usually be purchased, delivered, and installed in and around a building, such as windows, doors, casework, fixtures, furniture, and planting. They also include some annotation elements that are routinely customized, such as symbols and titleblocks.

Because of their highly customizable nature, component families are the families that you most commonly create and modify in Revit Architecture. Unlike system families, component families are created in external .rfa files and imported, or loaded, in your projects. For component families that contain many types, you can create and use type catalogs, which allow you load only the types that you need for a project.

When you create a standard component family, you begin with a template that is supplied in the software and contains information about the family that you are creating. You sketch the geometry of the family, create parameters for the family, create the variations or family types that it includes, determine its visibility and detail level in different views, and test it before using it to create elements in your projects.

Revit Architecture includes a library of content in which you can both access component families that are supplied by the software and save the component families that you create. You can also access component families from manufacturers’ websites and from an online Revit Web Content Library.

Nesting and Sharing Component Families

You can load instances of component families in other component families to create new families. By nesting existing families inside other component families, you can save yourself modelling time.

Depending on how you want instances of these families to act when you add them to your projects (as single element or as individual elements), you can specify whether the nested families are shared or not shared.

In-Place Families

In-place families are unique families that you create when you need to create a unique component that is specific to the current project. You can create in-place family geometry so that it references other project
geometry, resizing or adjusting accordingly if the referenced geometry changes. Examples of in-place families are:

- battered or tapered walls
- unique or unusual geometry, such as a non-standard roof
- a custom component that you do not plan reuse

An custom information counter created as an in-place family

geometry that must reference other geometry in your project

Wall caps created on a spiral staircase as in-place families

a family that does not require multiple family types
In-place families are created similarly to component families, but like system families, are not loaded from or saved to external files. They are created in the context of the current project, and are not intended to be used in other projects. They can be 2D or 3D, and by selecting a category in which to create them, can be included in schedules. Unlike both system and component families, you cannot create multiple types of in-place system families, as they are intended for limited use in your projects.

Although it may seem easier to create all your components as in-place families, the best practice is to use them only when necessary. Many in-place families in a project can increase your project file size and impede your system performance.

**Design Environment for Creating Families**

The Family Editor is a graphical editing mode in Revit Architecture that lets you create and modify the families that you use in your projects. The Family Editor has the same look and feel as the Revit Architecture project environment, but features a single Family Design Bar tab with different commands.

![A window family open in the Family Editor](image)

The Family Editor is not a separate application. You access the Family Editor when you create or modify the geometry of a component family or an in-place family.

Unlike system families, which are predefined, component and in-place families are always created in the Family Editor. However, system families may contain component families that are modifiable in the Family Editor, for example, a wall system families may include profile component family geometry to create caps, moulding, or reveals.

**Managing Families**

When you begin to modify and create your own families, learning to manage them is important. Most families can be used in more than one project. Depending on the type of family (system, standard component, and in-place) you are working with, you may be able to load them in projects and templates, save them to libraries, or copy them between projects.
System Families

Because system families are predefined in Revit Architecture, they are saved in projects and templates, and not in external files. You can share only system family types between projects. To do this, you can load system family types in project templates, copy and paste them between projects, or use a Transfer Project Standards command to transfer them between projects.

Standard Component Families

Standard component families are saved in external .rfa files and loaded in your projects. Both an imperial and metric standard component library that contains predefined component families is included in Revit Architecture. You can store standard component families that you create in these libraries, or you can save them to any location on your system or on a network. Like system families, you can also copy and paste standard component family types between projects.

You can load a standard component family in a project, and create additional family types, but those types will be saved only in the project, and not in the family file where they can be loaded into other projects.

In-Place Families

Because in-place families are families that you create in the context of a specific project, they are not intended for use in other projects. If necessary, you can copy and paste them into other projects, or save and load them as groups in other projects. Use both methods sparingly, as both copied and grouped in-place families can increase your file size and slow your system performance.

Getting Started with Families

Before you start to modify and create your own families, take some time to learn how to work with each different type of family (system, component, and in-place):

■ Review each family-specific section of this guide to understand which types of elements can be created with each type of family and for what purpose.

■ Perform the exercises in the tutorials that are included in each chapter, as hands-on practice is vital for learning how to create and work with families.

■ Before you modify or create your own families or family types, make sure the families and types do not already exist.
  If you can find a family or family type that is similar to the one that you need, copy and modify it to save yourself time.

■ As you create and work with your own families, use the information included in the appendices for reference.
System Families
System Families
Overview

System families contain family types that you use to create basic building elements such as walls, floors, ceilings, and stairs in your building models. System families also include project and system settings, which affect the project environment and include types for elements such as levels, grids, drawing sheets, and viewports. For specific information on project and system settings, see Customizing Project Settings and Templates in the Revit Architecture 2009 Tutorials.

System families are predefined in Revit Architecture and saved in templates and projects, not loaded into templates and projects from external files. You cannot create copy, modify, or delete system families, but you can duplicate (copy) and modify the types within system families to create your own custom system family types. You can delete all but one system family type in a system family, as you need at least one type per family to create new system family types.

Although you cannot load system families into templates and projects, you can copy and paste or transfer system family types between projects and templates. You can copy and paste any number of individual types, or use a command to transfer all types in the system families which you specify.

System families can also host other kinds of families, usually standard component families. For example, a wall system family may host a standard component door/window assembly.

Revit Architecture System Families and Settings

Revit Architecture includes the following system families and project and system settings.

To view a list of system families included in all Revit products, see Appendix A: Revit System Families and Settings on page 753.

System Families:

- Ceilings
- Curtain Systems
- Curtain Wall Mullions
- Detail Items
- Floors
- Fluids (a Revit®MEP-specific family)
- Model Text
Railings
Ramps
Roofs
Site (Pad)
Stairs
Structural Columns
Structural Foundations
Structural Framing
Walls

Project/System Settings:
Area and Volume Calculations
Arrowheads
Color Fill Schemes
Detail Level
Dimensions
Drawing Sheets
Elevations
Filled Regions/Fill Patterns
Filters
Grids
Keynoting
Levels
Lines
Load Types
Match Lines
Materials
Model Text
Object Styles
Phases
Project Browser Organization
Project Units
Sections
Site Settings
Spot Dimensions
Viewing System Families in a Project or Template

You can use the Project Browser to view the system families and system family types in a project or template. They display in the appropriate element category under Families in the Project Browser.

Some system families types may display in the Project Browser, even though they are not used with elements in the current project. To view the system family types that are in use, see Viewing Elements with Component Family Types in a Project on page 60.

1. Open a project or a template.
2. In the Project Browser, expand Families.

A list of all families in the project/template, organized by element category, displays. Each expandable category in the list includes the system families, as well as any standard component and in-place families that may be in the project/template.

**NOTE** Some system families and types, like a Site family and Pad type, do not display in the Project Browser until you create them in a project.
3 Expand the category that contains the system families and types that you want to view.  
In most cases, one or more system families display under the category.

4 Expand the system family to view the system family types.  
You can use these types to create elements, or you can duplicate and modify them to create new system family types.
Viewing Elements with System Family Types in a Project

You can highlight all the elements in a project that use a family type that you specify.

1. Open a project view.

2. In the Project Browser, expand Families.

3. Expand the category and system family that contains the type that you want to highlight.

4. Select the type, right-click, and click Select All Instances.

   **NOTE** If the current project does not contain any elements that use that system family type, the Select All Instances command is unavailable.

   All elements in the current view that use the family type display as red.

   In the lower right of your screen, the total number of selected elements in all project views displays.

   **IMPORTANT** If the element that uses the selected family type is not visible in the current view, but is in the project, you will not see it.
Creating and Modifying Elements with System Family Types

You can begin to create elements in your building models with system family types that are provided in the Revit Architecture templates or in templates that your office may provide. After you create an element with a system family type, you can change the system family type of the element. You can also change the individual properties of each element at any time, by right-clicking the element and selecting Element Properties.

If you need to modify the properties of a system family type, or create a new system family, see Creating and Modifying System Family Types on page 23.

Creating an Element with a System Family Type

1 Do one of the following:
   - On the Design Bar, click the command for the element that you want to create.
   - Select the family type in the Project Browser, and drag it to the drawing area.
   - Select the family type in the Project Browser, right-click, and click Create Instance.

2 In the Type Selector, select the type of element that you want to create.
The Type Selector displays the available system family types alphabetically: listing them first by family, and then after a colon, by type.
On the Options Bar, specify any necessary values or selections.

In the drawing area, create the element(s).

Creating an Element with a System Family Type from an Element in the Project

1 Select an element in the project, right-click, and click Create Similar.
2 On the Options Bar, specify any necessary values or selections.
3 In the drawing area, create the element.

Changing the System Family Type of an Element

You can use 3 different methods to change the system family type of an element in a current project. When you change the type, you can select a type in the same family, or a type in another family in the same element category. All 3 methods let you change the family type of more than one element at a time.

Method 1: Using the Type Selector

1 In the drawing area, select the element.
TIP To select more than one element, press and hold CTRL while selecting the elements.

2 In the Type Selector, do either of the following:
   ■ Select a new type in the same system family.
   ■ Select a new type in a different system family in the same element category.

Method 2: Changing the Element Properties

1 In the drawing area, select the element, right-click, and click Element Properties.

TIP To select more than one element, press and hold CTRL while selecting the elements.

2 In the Element Properties dialog, do either of the following:
   ■ To select a type in the same family, for Type, select a different type.
   ■ To select a type in a different family in the same element category, for Family and Type,
     select a different family and type.

3 Click OK.

Method 3: Using the Match command

1 In the Project Browser, expand Families.
2 Expand the family that contains the type that you want to match.
3 Select the family type, right-click, and click Match.
4 Move the cursor to the drawing area, and notice that it displays as an eyedropper.

5 Select the element that you want to match to the family type that you selected in the Project
   Browser.
Continue to select elements in the project to match to the selected type, or press ESC.

Creating and Modifying System Family Types

To create your own custom system families, you can do either of the following:

■ modify the properties of a system family type
■ duplicate (copy) a system family type, rename it, and modify its type properties

Any system family types that you do not use in a project or template can be deleted.

Modifying a System Family Type

You can access the properties of a system family type in the Project Browser or from an element that has been created with it in the current project.

1 Do either of the following:
■ In the Project Browser, under Families, right-click the system family type, and click Properties.
■ Select an element in the project, right-click, and click Element Properties. In the Element Properties dialog, click Edit/New.

2 In the Type Properties dialog:
■ Under Type Parameters, change any of the parameters that display.
  The parameters that display vary depending on the system family type that you are modifying.
The type properties for a wall system family type

If you change the type so that it is no longer accurately described by its name (for example, dimensions, material, or other properties have changed), in the upper left of the dialog, click Rename, and type a new name.

3 Click OK to exit all dialogs.

If you are modifying a system family type in a project, any instances of elements with system family type in the project update to reflect your modifications.

Duplicating a System Family Type to Create a New Type

1 In the Project Browser, expand Families.
2 Expand the category and family that contains the system family type that you want to duplicate.

**BEST PRACTICE** To minimize type property editing, select the system family type that most resembles the type that you want to create.

3 Select the system family type, right-click, and click Duplicate.

The new type displays in the Project Browser, with the same name and a 2 appended to it.

4 In the Project Browser, select the duplicate family, right-click, and click Rename.
5 Type a new name, and press **ENTER**.
6 Modify the system family type. See Modifying a System Family Type on page 23.
Deleting System Family Types

Although you cannot delete system families from your projects and templates, you can delete unused system family types. To delete the types, you can use 2 different methods: you can select and delete them in the Project Browser, or you can run the Purge Unused command. Whichever method you use, the following rules apply:

- A single system family type must remain in each family so that you can duplicate it to create any new system family types you may need.
- Any system family types that have dependencies (such as those that host other families) cannot be deleted.
- When you use the Purge Unused command, no system family types that are in use in the current project or template will be deleted.

Method 1: Selecting and deleting types in the Project Browser

1. In the Project Browser, expand Families.
2. Expand the category and family that contains the type that you want to delete.
3. Select a system family type or types.

   **TIP** To select more than one system family type, press and hold CTRL while selecting the types.

4. Do either of the following:
   - Right-click, and click Delete.
   - Press DELETE.

   The system family type is deleted from the project or template.
   If you are deleting a system family type from a project, and there an instance of the type in the project, a warning displays.
5. In the alert dialog, click OK to delete the instance(s) of the type, or click Cancel.
6. If you click Cancel, change the type of the instance(s) and redelete the type.

Method 2: Using the Purge Unused command

If the project is workset-enabled, all worksets must be open to use this command.

1. Click File menu ➤ Purge Unused.
   The Purge unused dialog lists all the families and family types that you can unload from the project, including standard component and in-place families. By default, all unused families are selected for purging.
2. Do either of the following:
   - To purge all unused family types, click OK.

   **NOTE** If there are no used family types in a system family, at least one of the types will be retained when you purge them.

   - To purge only the types that you select, click Check None, expand the families and subfamilies that contain the types that you want to purge, select the types, and click OK.
Loading System Family Types into a Project or Template

Because system families are predefined in Revit Architecture, you can load only system family types in projects or templates.

To load system family types, you can:

- copy and paste one or more selected types from one project or template to another
- transfer all system family types of a selected system family or families from one project to another

Copy and paste system family types when you have only have a few system family types that you need to load between projects or templates.

Transfer system family types when you are creating a new template or project, or anytime that you need to transfer all the types of a system family or families.

NOTE When you transfer system family types, you use the Transfer Project Standards command. You can also transfer system settings with this command.

Copying System Family Types Between Projects or Templates

Use this method when you have only a few system family types that you need to load into a project or template.

1. Open the project or template that contains the system family type(s) to copy.
2. Open the project into which you want to paste the type(s).
3. Click the Window menu, and click a view in the project that contains the family type that you want to copy.
4. In the Project Browser, expand Families, and expand the category and system family that contains the type that you want to copy.
5. Select the type(s) to copy.

TIP To select multiple family types, press and hold CTRL while selecting the types.

6. Do either of the following:
   - Click Edit menu ➤ Copy to Clipboard.
   - Press CTRL + C.

7. Click the Window menu, and click a view in the project into which you want to paste the family types.
8. Do either of the following:
   - Click Edit menu ➤ Paste from Clipboard.
   - Press CTRL + V.

The system family type is added to the project, and displays in the Project Browser.

Transferring System Family Types between Projects or Templates

Use this method when you have a number of system family types or system settings to transfer, such as when you need to create a new template.
1 Open the project from which you want to transfer system family types.
2 With the project open, do either of the following:
   ■ Create and save a new project.
   ■ Open the project in which you want to transfer system family types.
3 In the project that you want to transfer system family types to, click File menu ➤ Transfer Project Standards.
4 In the Select Items to Copy dialog, for Copy from, select the name of the project that you want to transfer the family types from.
   A dialog lists all the system family types that you can transfer from the project. By default, all types are selected for transfer.
5 Do either of the following:
   ■ To transfer all system family types, click OK.
   ■ To transfer only the types that you select, click Check None, select only the types that you want to transfer, and click OK.
   If any of the types that you transfer exist in the project into which you are transferring them, a Duplicate Types dialog displays.
6 Do either of the following:
   ■ Click Overwrite to replace the duplicate types with the transferred types.
   ■ Click New Only to transfer only new types from the to the project.
7 In the Project Browser, under Families, expand the system families to which you transferred types and confirm that the types display.
8 Save the project to which you transferred the types, and close the other project.
In this tutorial, you create a number of system family types for the design of a small log cabin. System families exist only in the Revit Architecture project environment, and cannot be loaded or created externally, like standard component families.

Exterior 3D view of the cabin

System families are predefined in Revit Architecture, and although you cannot create system families, you can create system family types. To create system family types, you duplicate (copy) types that are in a project, rename them, and change their properties.

In this tutorial, you create a custom wall type that displays stacked logs and cladding on both the interior and exterior layers of the cabin walls, a stacked wall type with a concrete stem wall, a custom floor type, and a roof type.
Creating Custom Wall Materials

In this exercise, you create 2 materials for the custom system family wall type that you create in the next exercise. You create the materials by duplicating (copying) existing materials, and then renaming and modifying the properties of the duplicated materials.

The first material that you create is an insulation material used between the exterior and interior wall layers. You define a granular fill pattern for the insulation material used in a detailed display.
The second material that you create is a wood log material that you apply later in this tutorial to the interior and exterior wood layers of the custom wall. In this exercise, you create the new material, add a wood color, and apply surface and cut patterns to the material to ensure a wood cladding effect when you display the cabin walls in model and section views.

**Wood material applied to the exterior wall layers**
Wood material applied to the interior wall layers

You begin this exercise by creating a project in which you create the materials. In the next exercise, you use the same project to create the custom wall family type.

Create a custom wall project

1. Click File menu ➤ New ➤ Project.
2. In the New Project dialog:
   - Under Create new, verify Project is selected.
   - Under Template File, verify the second option is selected, and click Browse.
3. In the Choose Template dialog:
   - In the left pane, click Training Files.
   - Open Imperial\Templates, select default.rte, and click Open.
4. Click OK.
5. Save the project:
   - Click File menu ➤ Save As.
   - In the Save As dialog, navigate to Training Files\Imperial.
   - For File Name, enter i_System_Families.
   - Click Save.

Next, create the insulation material to use in the walls of the cabin. You select an existing insulation material, copy it, and then modify it as necessary to create the new material.

Duplicate and modify an existing material to create the insulation

6. Click Settings menu ➤ Materials.
   The Materials dialog displays a list of all the available materials in the project.
7 In the left pane of the Materials dialog:
   - Select Insulation / Thermal Barriers - Semi-rigid Insulation.
   - Click (Duplicate).

8 In the Duplicate Revit Material dialog:
   - For Name, enter **Insulation/Thermal Barriers - Proprietary, Log Wall**.
   - Click OK.

The real-world insulation is a granular material, so you want the insulation material to display with a granular pattern in section views. Next, you assign a granular fill pattern to the cut pattern of the Proprietary Insulation material.

9 In the right pane of the Materials dialog, on the Graphics tab, under Cut Pattern, for Pattern, click .

10 In the Fill Patterns dialog:
   - Under Pattern Type, verify Drafting is selected.
   - Under Name, select Sand - Dense.

Drafting patterns, like this Sand pattern, depict materials in symbolic form. The density of drafting patterns is fixed with respect to the drawing sheet on which an associated element is placed.
Next, you create a log material to assign to the exterior walls of the cabin.

Create the log material

11 In the Materials dialog, with the Proprietary Insulation material selected, click OK.

12 In the Duplicate Revit Material dialog:
   □ For Name, enter **Finishes - Exterior - Proprietary, Log**.
   □ Click OK.

Next, assign a realistic wood color to the Proprietary Finish material.

13 In the Materials dialog, on the Graphics tab, under Shading click the color swatch.

14 In the Color dialog, click PANTONE.

15 In the Pantone® Color Picker dialog:
   □ Click OK to accept the disclaimer.
   □ For Find Color, enter **161**, and press **ENTER**.

16 Click OK twice.

Now that you have assigned a wood color, you create and add a surface pattern to the material to produce a wood effect when it is applied to the custom wall type.

17 In the Materials dialog, under Surface Pattern, click OK.

18 In the Fill Patterns dialog:
   □ Under Pattern Type, select Model.
   Model patterns represent the actual appearance of an element on a building, such as brick coursing or, in this case, wood cladding. Model patterns are fixed with respect to the model, meaning that they scale as the model scales.
   □ Click New.

19 In the Add Surface Pattern dialog:
   □ For Name, enter **8'' Parallel**.
   □ Under Simple, for Line angle, enter **0**.
For Line spacing 1, enter 8".

Verify Parallel Lines is selected.

20 Click OK twice.

Next, you add a cut pattern to the log material so that when you apply the material, the affected walls display realistically when cut.

21 In the Materials dialog, under Cut Pattern, for Pattern, click .

22 In the Fill Patterns dialog:

■ Under Pattern Type, verify Drafting is selected.

■ Under Name, select Wood 2.

23 Click OK twice.

In the next exercise, you assign both materials to a custom wall type. When you view the wall type in shaded or section views, the materials produce a realistic view of the walls.

24 Click File menu ➤ Save, but do not close the project.

25 Proceed to the next exercise, Creating a Custom Wall Type on page 35.

Creating a Custom Wall Type

In this exercise, you duplicate (copy) a system family wall type to create a custom system family wall type for the cabin walls. After you duplicate the wall type, you modify the wall assembly, assigning the materials that you created in the previous exercise to the different wall layers.

You begin by creating a wall from an existing system family type, and then note the changes to the wall instance as you duplicate and modify the wall type.

Initial wall type - plan view

Custom wall type - plan view

The custom cabin wall type features exterior and interior layers that display the Proprietary Finish material, while the middle layer displays the Proprietary Insulation material. In plan view (shown above), the wood and insulation patterns display for each wall layer. In a 3D view, the model pattern assigned to the exterior layer of the wall displays, creating the wood cladding.
View the wall families in the current project

1. In the Project Browser, expand Families ➤ Walls.
   There are 3 wall system families in Revit Architecture: Basic Wall, Curtain Wall, and Stacked Wall.

2. Expand Basic Wall.
   The list of available Basic Wall types displays. You can modify the properties of any of the existing types or duplicate, rename, and modify them to create new types.

Add a wall with an existing type to the project

3. Under Basic Wall, select Exterior - Brick on CMU, and drag it to the drawing area.

**NOTE** The exact wall type selection is not important. When creating a system family type, it is the best practice to select a system family type that is similar to the one that you want to create.
4 Add a 3’ wall:
- Select a wall start point.
- Move the cursor 3’ to the right, and click to complete the wall.
- On the Design Bar, click Modify.

View the wall in greater detail

5 Zoom in on the wall.

6 On the View toolbar, click (Thin Lines).

7 On the View Control Bar:
- Click Detail Level ➤ Fine.
- Click Model Graphics Style ➤ Shading with Edges.
All the separate wall layers display with appropriate materials, such as the diagonal hatch for the brick layer. In the next steps, you duplicate the wall type, and then modify the wall layers to create a new wall type.

Duplicate and modify the wall type to create a new wall type

8 On the Design Bar, click Modify.

9 Select the wall, and on the Options Bar, click (Properties).

10 In the Element Properties dialog, click Edit/New.

11 In the Type Properties dialog, click Duplicate.

12 In the Name dialog, enter Exterior - Log and Cladding, and click OK.

13 In the Type Properties dialog, under Construction, for Structure, click Edit.

14 In the Edit Assembly dialog, under Layers, view the current wall layers.
A number of the layers that display are not needed in the new wall type. Notice that the dialog lists the wall layers in numerical order, from the exterior to the interior of the wall.

15 Delete the extra wall layers, leaving one each of the following layers, as shown:
- Exterior Finish
- Thermal/Air
- Core
You do not need to keep interior finish layers. To delete a layer, select the layer number, and click Delete.

16 Add new materials and parameters to the remaining wall layers:

- For layer 1, Finish [4], click in the Material field, and click  
- In the Materials dialog, under Name, select Finishes - Exterior - Proprietary, Log, and click OK.
- Click in the Thickness field, and enter 1-3/4".
- Clear Wraps.

- For layer 4, Structure [1], click in the Material field, and click  
- In the Materials dialog, under Name, select Finishes - Exterior - Proprietary, Log, and click OK.
- For Thickness, enter 3 3/4".

- For layer 2, Thermal/Air Layer [3], click in the Material field, and click  
- In the Material dialog, under Name, select Insulation/Thermal Barriers - Proprietary, Log Wall, and click OK.
- For Thickness, enter 4".

The Layers list now features only the layers that you need for the custom wall.

17 Click OK 3 times.

18 On the Design Bar, click Modify.

The wall in the project now features the new wall type. Wood and insulation patterns show in plan for each wall component.
View the wall in 3D

19 On the View toolbar, click (Default 3D View).

20 On the View Control Bar:
   ■ Click Detail Level ➤ Fine.
   ■ Click Model Graphics Style ➤ Shading with Edges.

The proprietary finish material displays the 8” parallel line surface pattern on the exterior of the wall. For most design situations, this surface pattern is an adequate representation of the stacked logs. You could model the wall components rather than applying a finish material, although this would increase both file regeneration time and project size.

If you require an accurate 3D model, you can add 3D features to the wall layers. In the next exercise, you add angled recesses that represent the stacked logs and cladding to both the exterior and interior of the wall.

21 Save the project, but do not close it.

22 Proceed to the next exercise, Adding Reveals to the Custom Wall Type on page 39.

**Adding Reveals to the Custom Wall Type**

In this exercise, you add angled reveals to create the appearance of stacked logs on the exterior and interior layers of the cabin walls.
Custom wall type with reveals

To create the reveals, you place profiles at 8” intervals along the interior and exterior sides of the custom wall.

Profiles on the custom wall type

When the wall is complete, the reveal profiles cut into the wall, creating the angled recesses.

**View the wall structure**

1. Select the wall, and on the Options Bar, click ➤ (Properties).
2. In the Element Properties dialog, click Edit/New.
3. In the Type Properties dialog, under Construction, for Structure, click Edit.
4. In the Edit Assembly dialog:
   - Click Preview.
   - In the lower left pane, for View, select Section: Modify type attributes.
   The wall displays in section view in the preview. In the example shown, under Layers, layer 1 is selected. Notice that the corresponding layer displays as red in the preview.
Hold down the **CTRL** key, and click (SteeringWheels) to zoom to the bottom of the wall.

**NOTE** You must display the wall section in the preview image with enough height to include the reveals. If you do not, a warning displays, informing you that the reveals occur outside of the wall.

Create wall reveals

5 Under Modify Vertical Structure (Section Preview only), click Reveals.

6 Position the Reveals dialog on your screen so that you can view both the dialog and the preview image in the Edit Assembly dialog.

7 In the Reveals dialog, add the first reveal profile:
   - Click Load Profile.
   - In the Open dialog, browse to Training Files\Imperial\Families\Profiles, select Log_Angled_Reveal.rfa, and click Open.
   - In the Reveals dialog, click Add.
   - Click in the Profile field, and select Log_Angled_Reveal: angled 45.

8 Add another reveal:
   - In the Reveals dialog, click 1 to select the first reveal.
   - Click Duplicate.
   - For reveal 2, click in the Side field, and select Interior.
   - Click Apply.
   The preview image displays an internal and an external reveal at the bottom of the wall.
9 Add 2 additional reveals:
■ In the Reveals dialog, click 1 to select the first reveal.
■ Click Duplicate twice. The reveal in row 1 is moved to the bottom of the list in the Reveals dialog.
■ For reveal 2, click in the Side field, and select Exterior.
■ For reveals 1 and 2, click in the Distance field, and enter 8".
■ Click Apply, and view the preview image in the Edit Assembly dialog to visually confirm the placement.

10 Add the remaining reveals:
■ In the Reveals dialog, click 1 to select the first reveal.
■ Click Duplicate twice.
■ For reveal 2, click in the Side field, and select Exterior.
■ For reveals 1 and 2, click in the Distance field, and enter 1’ 4”.
■ Click Apply.
Click OK 4 times.

View the wall with reveals

11 On the Design Bar, click Modify.

12 Zoom in to the bottom of the wall.

The reveal profiles cut into the wall, creating angular recesses that give the appearance of stacked logs. If this level of detail is required for a project, you would continue to add reveals to the wall height. When using reveals, the surface pattern of the wall should be turned off.

13 Save the project, but do not close it.

14 Proceed to the next exercise, *Creating a Custom Stacked Wall Type* on page 43.

---

**Creating a Custom Stacked Wall Type**

In this exercise, you create a stacked wall by stacking 2 existing wall family types, including the Exterior - Log and Cladding wall type that you created in a previous exercise.
You begin by duplicating an existing wall type to create a new stacked wall type. You then stack the Exterior - Log and Cladding wall type on top of a foundation wall within the new stacked wall type. You use offset options to define the vertical relationship between both wall types.

**Add a stacked wall with an existing type to the project**

1. In the Project Browser, under Floor Plans, double-click Level 1.
2. In the Project Browser, expand Families ➤ Walls ➤ Stacked Wall.
3. Drag Exterior - Brick over CMU w Metal Stud into the drawing area.
4. Add a 3’ wall:
   - Select a wall start point.
   - Move the cursor 3’ to the right, and click to complete the wall.
   - On the Design Bar, click Modify.

**Create a new stacked wall**

5. Select the wall, and on the Options Bar, click (Properties).
6. In the Element Properties dialog, click Edit/New.
7. In the Type Properties dialog:
   - Click Duplicate.
   - In the Name dialog, enter **Exterior - Log and Cladding on Concrete**.
   - Click OK.
- At the bottom of the screen, verify that Preview is selected. A preview image of the current stacked wall type displays.

- Under Construction, for Structure, click Edit.

8 In the Edit Assembly dialog, under Types:
- For Type 1, click the Name field, and select Exterior - Log and Cladding.
- For Type 2, click the Name field, and select Foundation - 12" Concrete.

9 In the left pane, zoom to examine the wall junction.
10 In the Edit Assembly dialog, for Offset, select Wall Centerline.

11 Click OK 3 times.
12 Save the project, but do not close it.
13 Proceed to the next exercise, Creating a Custom Floor Type on page 46.

Creating a Custom Floor Type

In this exercise, you create a custom wood floor for the cabin by duplicating a Basic Floor system family type. The new floor type features 12” joists and a custom wood floor finish (blue-green stain) on both the top and bottom of each joist.

Custom floor type in a rendered view of the cabin

Duplicate a floor type

1 In the Project Browser, expand Families ➤ Floors ➤ Floor.
2 Under Floor, select Wood Joist 10' - Wood Finish, and drag it to the drawing area.
3 Sketch the floor:
   ■ On the Design Bar, click Lines.
   ■ On the Options Bar, click (Rectangle).
   ■ Sketch a 15' x 15' rectangular floor.
   ■ On the Design Bar, click Finish Sketch.

Create a custom material for the new floor type

4 On the Design Bar, click Modify.
5 Click Settings menu ➤ Materials.
6 In the left pane of the Materials dialog:
   ■ Select Wood - Flooring.
   ■ Click .
7 In the Duplicate Revit Material dialog:
   ■ For Name, enter Wood Flooring - Proprietary.
   ■ Click OK.
8 In the right pane of the Materials dialog, click the Render Appearance tab.
9 Click Replace.
10 In the Render Appearance Library dialog, enter Hardwood Flooring Wild Cherry Natural 1.
11 Click OK twice.

Create the custom wood floor type

12 Select the floor, and on the Options Bar, click (Properties).
13 In the Element Properties dialog, click Edit / New.
14 In the Type Properties dialog, click Duplicate.
15 In the Name dialog:
   ■ For Name, enter Proprietary Wood Joist 12" - Wood Finish.
   ■ Click OK.
16 In the Type Properties dialog, under Construction, for Structure, click Edit.
17 In the Edit Assembly dialog, verify that Preview is selected.
A preview image of the duplicated floor displays.

Modify the floor assembly

18 In the Edit Assembly dialog, under Layers:

- For layer 4, click in the Thickness field, and enter 11 3/4".
- For layer 1, click in the Material field, and click ...
- In the left pane of the Materials dialog, select Wood Flooring - Proprietary, and click OK.

19 Add a new layer to the floor assembly:

- At the bottom of the Layers pane, click Insert.
- With the new layer selected, click Down until the new layer is located at the bottom of the list, below the Core Boundary.
- For the new layer 6, click in the Function field, and select Finish 1 [4].
- Click in the Thickness field, and enter 3/4".

- Click the Material field, and click ...
- In the left pane of the Materials dialog, select Wood Flooring - Proprietary.
- Click OK 4 times.

20 On the Design Bar, click Modify.
View the custom floor

21 On the View toolbar, click (Default 3D View).
22 On the View Control Bar, verify:
   ■ Detail Level ➤ Fine.
   ■ Model Graphics Style ➤ Shading with Edges.

23 Save the project, but do not close it.
24 Proceed to the next exercise, Creating a Custom Roof Type on page 49.

Creating a Custom Roof Type

In this exercise, you create a custom roof for the cabin by duplicating an existing Basic Roof system family type. The custom roof features a 10" nominal rafter, a composition tile finish, and interior gypsum wallboard.
Create the roof finish material

1. Click Settings menu ➤ Materials.
2. In the left pane of the Materials dialog:
   - Select Roofing - Asphalt Shingle.
   - Click 🔄.
3. In the Duplicate Revit Material dialog:
   - For Name, enter Roofing - Composition Shingle, Proprietary.
   - Click OK.
4. In the right pane of the Materials dialog, click the Render Appearance tab.
5. Click Replace.
6. In the Render Appearance Library dialog, enter Roofing Composition Shingle Dark Gray.
7. Click OK twice.

Duplicate a roof type

8. In the Project Browser, expand Families ➤ Roofs ➤ Basic Roof.
   Select the closest match to your desired roof type.

9. Select Wood Rafter 8" - Asphalt Shingle - Insulated, and on the Options Bar, click (Properties).
10. In the Type Properties dialog, click Duplicate.
11. In the Name dialog:
    - For Name, enter Proprietary Wood Rafter - Composition Shingle - Insulated.
    - Click OK.
12. In the Type Properties dialog, under Construction, for Structure, click Edit.
13. In the Edit Assembly dialog, verify that Preview is selected.
A preview image of the duplicated roof type displays.

Modify the roof type assembly

14 In the Edit Assembly dialog, under Layers:
   - For layer 4, Structure [1], click in the Thickness field, and enter 9 3/4”.
   - For layer 1, Finish 1 [4], click in the Material field, and click ...
   - In the left pane of the Materials dialog, select Roofing - Composition Shingle, Proprietary, and click OK.

15 Add a new layer to the roof assembly:
   - At the bottom of the Layers pane, click Insert.
   - With the new layer selected, click Down until the layer is located at the bottom of the list, below the Core Boundary.
   - For the new layer 6, click in the Function field, and select Finish 1 [4].
   - Click in the Material field, and click ...
   - In the left pane of the Materials dialog, select Gypsum Wall Board.
   - Click OK.
   - For layer 6, click in the Thickness field, and enter 5/8”.
   - Click in any of the fields to update the preview.
   - Click OK twice.

16 Save and close the project.
17 Proceed to the next exercise, Transferring System Families Between Projects on page 51.

Transferring System Families Between Projects

In this exercise, you learn 2 different methods of transferring system family types from one project to another. Using the first method, you copy a single wall type from one project and paste it into another, where you apply it to a wall. Use this method when you need to transfer only a few specific types from project to project.
Using the second method, you copy all the wall types from one project to another using the Transfer Project Standards command. The command transfers all object types, so use this method when you have a number of system family types and other project-related settings to transfer between projects.

**Method 1: Copy and paste a single system family type**

1. Open the project that contains the type to copy:
   - Click File menu ➤ Open.
   - In the left pane of the Open dialog, click Training Files ➤ Common.
   - Open Imperial, select i_System_Families, and click Open.

2. Open the project into which you want to paste the family type:
   - Click File menu ➤ Open.
   - In the left pane of the Open dialog, click Training Files.
   - Open Common, select cabin.rvt, and click Open.

3. Copy a family type:
   - Click Window menu, and select a view in i_System_Families.
   - In the Project Browser, under Families, expand Walls ➤ Basic Wall.
   - Select Exterior - Log and Cladding.

   **TIP** To select multiple family types, press and hold **CTRL**, then select the family types that you want to copy.

   - Click Edit menu ➤ Copy to Clipboard.

4. Paste the Log and Cladding type in the cabin project:
   - Click Window menu ➤ cabin.rvt, and open a plan view of the project.
   - Click Edit menu ➤ Paste from Clipboard.
   - The system family type is added to the project.

   - In the Project Browser, expand Families ➤ Walls ➤ Basic Wall, and confirm that Exterior Log and Cladding displays in the list of Basic Wall types.

5. Assign the new wall type to the exterior walls in the cabin project:
   - In the Project Browser, under 3D Views, double-click {3D}.
   - Move the cursor over an exterior wall, press **TAB** until the chain of walls is selected, and click to select the chain.
On the Options Bar, in the Type Selector, select Basic Wall : Exterior - Log and Cladding.

On the Design Bar, click Modify.

Confirm that the proprietary finish material assigned to the copied family type is available in the project:

- Click Settings menu ➤ Materials.
- In the left pane of the Materials dialog, under Name, verify that Finishes - Exterior - Proprietary, Log material displays in the materials list.
- Click Cancel.

Close cabin.rvt, but leave i_System_Families open.

**Method 2: Use the Transfer Project Standards command to copy system family types**

8 With i_System_Families still open, create a new project:

- Click File menu ➤ New ➤ Project.
In the New Project dialog, under Create new, verify Project is selected.

Under Template file, verify the second option is selected, and click Browse.

In the left pane of the Choose Template dialog, click Training Files.

Open Imperial\Templates, select default.rte, and click Open.

In the New Project dialog, click OK.

9 Save the project:
- Click File menu ➤ Save As.
- In the Save As dialog, navigate to Training Files\Imperial.
- For File Name, enter transfer_project.
- Click Save.

10 View the Basic Wall family types in the transfer standards project:
- In the Project Browser, confirm that Exterior - Log and Cladding does not display under Families ➤ Walls ➤ Basic Wall.
- Expand Walls ➤ Stacked Wall to confirm that Exterior - Log and Cladding on Concrete does not display.

11 Transfer the wall type:
- Click in the drawing area.
- In transfer_project.rvt, click File menu ➤ Transfer Project Standards.
- In the Select Items To Copy dialog, for Copy from, select i_System_Families.rvt.
- Click Check None.
- In the list of items to copy, select Floor Types, Roof Types, and Wall Types.
- Click OK.
- In the Project Browser, under Families ➤ Walls ➤ Basic Wall, confirm that Exterior - Log and Cladding now displays.
- Confirm that the stacked wall, roof, and floor types you created display as well.

12 Save and close both projects.
Standard Component Families
Standard Component Families Overview

Standard component families are families used to create both building components and some annotation elements. Component families create the building components that would usually be purchased, delivered, and installed in and around a building, such as windows, doors, casework, fixtures, furniture, and planting. They also include some annotation elements that are routinely customized, such as symbols and titleblocks.

Because of their highly customizable nature, component families are the families that you most commonly create and modify in Revit Architecture. Unlike system families, component families are created in external .rfa files and imported (loaded) in your projects. For component families that contain many types, you can create and use type catalogs, which allow you load only the types that you need for a project.

When you create a standard component family, you begin with a template that is supplied in the software and contains information about the family that you are creating. You sketch the geometry of the family, use parameters to establish relationships between family components, create the variations or family types that it includes, and determine its visibility and detail level in different views. When you finish the family, you test it in a sample project before using it to create elements in your projects.

Revit Architecture includes a library of content in which you can both access component families that are supplied by the software and save the component families that you create. You can also access component families from manufacturers’ websites and from an online Revit Web Content Library.

Nesting and Sharing Component Families

You can load instances of component families in other component families to create new families. By nesting existing families inside other component families, you can save yourself modelling time.

Depending on how you want instances of these families to act when you add them to your projects (as single element or as individual elements), you can specify whether the nested families are shared or not shared.

Revit Architecture Standard Component Families

Revit Architecture includes the following standard component families:

- Annotations
- Balusters
- Casework
Workflow: Using Component Families in Your Projects

Component families are the most extensive and customizable families in Revit Architecture. You can create your own custom families, but a number of families are ready for use in the family library and on the web. Before you begin a project, use the workflow that follows to determine whether you can use existing families, or whether you need to create your own custom families.

1. Determine the component families that your project requires.
2. Search existing component families and determine if you can find the component families that you need in the library, on the web, or in Revit Architecture templates or in your office templates.
   See Finding and Loading Component Families on page 61.
3. If you find an appropriate family, but not the specific type that you need, create a new type.
   See Adding a Type to a Component Family on page 146.
4. If you can find component families that are similar to the families that you need, save design time by modifying existing families to your needs.
   See the topics in Modifying Component Families on page 145.
5. If you cannot find the component families that you need or modify similar families to your needs, create your own component families.
Using Existing Component Families

Revit Architecture includes a number of predefined component families. Some of these families are preloaded in templates, while others can be accessed from the Revit Architecture imperial and metric libraries, which are included in the software or accessible on the web. You can load and use these families and their types in your projects.

Viewing Component Families in a Project or Template

You can use the Project Browser to view the component families and family types in a project or template. Some component families types may display in the Project Browser, but are not used with elements in the current project. To view the component family types that are in use, see Viewing Elements with Component Family Types in a Project on page 60.

1. Open a project or a template.
2. In the Project Browser, expand Families.

A list of all families in the project/template displays. The list includes the component families, as well as any system and in-place families that may be in the project/template.

NOTE Some component families and types do not display in the Project Browser until you create them in a project.
3 Expand the component family category that contains the types that you want to view. In most cases, one or more families display under the component family.

4 Expand the family to view the component family types.

You can use these types to create elements, or you can duplicate and modify them to create new component family types.

**Viewing Elements with Component Family Types in a Project**

You can highlight all the elements in a project that use a component family type that you specify.

1 Open a project view.
2 In the Project Browser, expand Families.
3 Expand the component category and family that contains the type that you want to select.
4 Select the desired type, right-click, and click Select All Instances.

**NOTE** If the current project does not contain any elements that use that component family type, the Select All Instances command is unavailable.

All elements in the view that use the family type display as red (default color).

5 Open other project views.
   Any of the elements that use the family type display as red.
6 Press ESC to restore the original display of the elements.
Finding and Loading Component Families

To use component families in your projects or templates, you must load (import) them with the Load from Library ➤ Load Family command. After you load a family into a project, it is saved with that project.

Some component families are preloaded in the templates that are included with Revit Architecture. Any projects that you create with these templates include the component families loaded in the template.

You can find, preview, and load other families from the following sources:

- the Revit Architecture library that is installed with the software
- other local or networked libraries
- the Revit Web Content Library
- manufacturers’ websites
- other third-party websites

Most of the families that you load from the Revit Architecture library and Revit Web Content Library are fully editable.

When loading large families that contain many types into a project, you can use a type catalog to load only the types that you need. Type catalogs are easy to create, and by allowing you to load only selected family types, they help to keep your project sizes from growing needlessly large.

Loading Component Families

When you load component families into a project, the Revit Architecture imperial or metric family library (located in C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2009\Imperial or Metric Library) is accessed by default.

If your office is using a different library of content in another location, your system may access that library by default. Contact your CAD Manager for more information.

To change the library that is accessed by default, see Setting Shortcuts to Other Family Libraries on page 62.

1 Click File menu ➤ Load from Library ➤ Load Family. Depending on the current drawing units (imperial or metric), the Load Family dialog lists the family categories in either the Imperial or Metric Library.

2 In the Load Family dialog, double-click the category of the family that you want to load.

3 Preview any of the families (.rfa) in the category:
   - To preview a single family, select it in the list. At the top right of the dialog, under Preview, a thumbnail image of the family displays.
   - To display a thumbnail image in the list for all the families in the category, at the top right corner of the dialog, click Views ➤ Thumbnails.

4 Select the family that you want to load, and click Open. The family type is now available to place in the project, and displays in the appropriate component category under Families in the Project Browser.
### Setting Shortcuts to Other Family Libraries

Although you can browse to any library of content when you use the Load Family command, you can specify the location of the library that you want to access by default.

1. Click Settings menu ➤ Options.
2. In the Options dialog, click the File Locations tab.
3. Click Places.
4. In the Places dialog, for the Imperial or Metric Library, click in the Library Path field, and click open.
5. In the Browse for Folder dialog, navigate to the location that you would like to access, and click Open.
6. Click OK twice.
7. Click File menu ➤ Load from Library ➤ Load Family.
The new library location opens.

### Downloading Component Families from the Revit Web Content Library

The Revit Web Content Library contains different types of component families, including manufacturer families, that you can download and use in your projects. It also contains Ketiv Modern Medium content that has been converted to Revit Architecture families for use in your projects. Some restrictions apply; see Working with Modern Medium Families on page 63.

You can download and use families from previous releases of Revit Architecture. Download these families, and upgrade them by opening and saving them in your current version of the software.

**NOTE** After you upgrade a family to a more current release, it cannot be used in the previous release.

1. Do either of the following:
   - On the right side of the Revit Architecture opening screen, click Revit Web Content Library.
   - In your web browser, navigate to http://revit.autodesk.com/library/html/.
2. On the left side of the library dialog, click the family library that you want to access.
   The Revit Web Content Library contains different types of families, including manufacturer families and families created from Ketiv’s Modern Medium content.
3. Expand the list of families in the library.
4. Select each family to preview it in the right pane of the Web Library.
5. To download a single family:
   - In the right pane, double-click the family, and in the File Download dialog, click Save.
   - Navigate to the library of your choice (the Revit Architecture library is located by default in C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2009\Imperial or Metric Library), and click Save.
6 To download all the families in a directory:
   ■ In the left pane, select the directory that contains the families, and in the top right corner of the Revit Web Content Library, click (download directory).
   ■ In the File Download dialog, click Save, and save the extractable file to a location that you specify.
   ■ Navigate to the location where you saved the file, and double-click it.
   ■ Specify the location in which you want to extract the families, either the appropriate category in the Revit Architecture Imperial or Metric Library, or to another library that you specify.

7 Load the families that you downloaded from the library into a project or template. See Loading Component Families on page 61.

**Working with Modern Medium Families**

Ketiv’s Modern Medium Library has been converted into Revit Architecture families and made available in the Revit Web Content Library on the Web. Modern Medium families cannot be altered structurally within Revit Architecture. You can, however, change the appearance of a Modern Medium family type by changing the render appearance of the material linked to its object style.

**NOTE** Loading a large number of families from the Modern Medium Library can substantially increase the project file size and impede system performance.

For example, you could download and load a Modern Medium piano so the family displays under Families\Specialty Equipment in the Project Browser. To change the color to natural wood, you can create a new material called Piano, and then select the color and texture desired. The appearance of the piano will change after you apply the new material to the object style of the piano.

**To apply a different render appearance to a Modern Medium family**

1 Download Modern Medium families from the Revit Web Content Library, and add them to a project. See Downloading Component Families from the Revit Web Content Library on page 62.
2 Click Settings menu ➤ Object Styles, and click the Imported Objects tab.
3 Under the Category heading, select the layer name of the Modern Medium family.
4 Click in the Material Field, and click .
5 In the Materials dialog, select a material, and click OK twice. See Materials in the Revit Architecture 2009 Help.
6 Save the family.

**Copying Family Types Between Project**

You can copy family types from one project into another. If the family does not exist in the target project, Revit Architecture loads it when you paste the type.
For example, you want to copy a French door from one project into another. The French door type belongs to the Custom Door family. In the target project, the Custom Doors family is not loaded. Revit Architecture will load the family along with the specific French door.

You can copy family types from the Project Browser or by copying an element with a desired type in the drawing area. Copying elements from the drawing area is available in most views, such as floor plans, ceiling plans, and 3D Views.

The family type that you copy must have a unique name. If the family type already exists in the target project, rename the type, and then copy and paste it.

To copy a family type from the Project Browser
1 Select the family type to be copied.
2 Do either of the following:
   ■ Click Edit menu ➤ Copy to Clipboard.
   ■ Press CTRL + C.
3 Open the target project.
4 Do either of the following:
   ■ Click Edit menu ➤ Paste from Clipboard.
   ■ Press CTRL + V.

To copy family types from elements in the drawing area
1 In the drawing area, select the family type that you want to copy.
    **TIP** To select multiple family types, such as a specific wall, window, and door, press and hold CTRL, and select each type.
2 Do either of the following:
   ■ Click Edit menu ➤ Copy to Clipboard.
   ■ Press CTRL + C.
3 Open the target project, and click in the drawing area.
4 Do either of the following:
   ■ Click Edit menu ➤ Paste from Clipboard.
   ■ Press CTRL + V.
5 In the drawing area, do either of the following:
   ■ Drag the element to the necessary location.
   ■ If the element requires a host (for example, a window must be placed in a wall), select a location on the host element.
6 If necessary, on the Options Bar, click Finish Paste.

The element displays in the drawing area, and its family type displays in the Project Browser under the appropriate category and family.
Using Type Catalogs to Load Large Component Families

When you load a family with many types into a project, using a type catalog allows you to select and load only those types that you need. The type catalog provides a dialog that lists the available family types that you can sort through and select before you load types into a project.

Type catalogs are most useful when used with large families that contain many types. By loading only the types that you need, you prevent your project size from growing needlessly larger and you minimize the number of types that display in the Type Selector list.

**BEST PRACTICE**  Create type catalogs for families that contain more than 6 types.

Although Revit Architecture includes a type catalog you can use when loading structural families, you can create type catalogs for any existing or user-created families. See Creating a Type Catalog on page 65.

Creating a Type Catalog

A type catalog is an external text file (TXT) that contains the parameters and their values that create the different types in a specific family.

Following is a sample type catalog TXT file:

```
,Manufacturer##other##,Length##length##centimeters,Width##length##centimeters,Height##length##centimeters
MA36x30,Revit,36.5,2.75,30
MA40x24,Revit,40.5,3.25,24
```

When loading the corresponding family, you would see the following type catalog:

<table>
<thead>
<tr>
<th>Type</th>
<th>Manufacturer</th>
<th>Length</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>MA36x30</td>
<td>Revit</td>
<td>36.5cm</td>
<td>2.75cm</td>
<td>30cm</td>
</tr>
<tr>
<td>MA40x24</td>
<td>Revit</td>
<td>40.5cm</td>
<td>3.25cm</td>
<td>24cm</td>
</tr>
</tbody>
</table>

There are several ways to create a comma-delimited .txt file. You can type it in using a text editor like Notepad, or you can use database or spreadsheet software to automate the process.

You can export your project to a database using ODBC, and then download the element type tables in comma-delimited format. See Exporting to ODBC in the Revit Architecture 2009 Help.
As you create the type catalog, follow these rules:

- Save the type catalog file name with a .txt extension; the file must have the same name and same directory path as the Revit Architecture family, for example, Doors/door.rfa and Doors/door.txt.
- The left column lists types.
- The top row of the file is for parameter declaration. Format is columnname##type##unit.
- Use decimals.
- Parameter names are case sensitive.
- You can use single or double quotes. If you are using double quotes, you need to enter "" for Revit Architecture to understand it as double quotes.
- Valid unit types are length, area, volume, angle, force, and linear force.
- Valid units: Valid units and suffixes:
  - For length: inches ("), feet ('), millimeters (mm), centimeters (cm), or meters (m).
  - For area: square_feet (SF), square_inches (in2), square_meters (m2), square_centimeters (cm2), square_millimeters (mm2), acres, or hectares.
  - For volume: cubic_yards (CY), cubic_feet (CF), cubic_inches (in3), cubic_centimeters (cm3), cubic_millimeters (mm3), liters (L), gallons (gal).
  - For angle: decimal_degrees (°), minutes ('), seconds (")
  - For force: newtons (N), decanewtons (daN), kilonewtons (kN), meganewtons (MN), kips (kip), kilograms_force (kgf), tonnes_force (Tf), and pounds (P).
  - For linear force: newtons_per_meter (N/m), decanewtons_per_meter (dan/m), kilonewtons_per_meter (kN/m), meganewtons_per_meter (MN/m), kips_per_foot (kip/ft), kilograms_force_per_meter (kgf/m), tonnes_force_per_meter (Tf/m), pounds_per_foot (P/ft).
- You can enter a value for parameters of type Family Type. To declare the Family Type parameter in the parameter declaration, you would enter column-name##other##. The column name is the same as the Family Type parameter name. In the type catalog file, enter values as Family Name : Family Type. Be sure there are spaces before and after the colon. So for a family file called Chair-Executive.rfa with a type called Big Boss, you would enter Chair-Executive : Big Boss. If the family file has only one type, and it is the same name as the family, you do not need to include the Family Name.
- Revit Architecture applies project unit settings to type catalogs when loading a family.

**Loading a Family with a Type Catalog**

After you create a type catalog for a family, you can use it to load only the family types that you need into your projects and templates.

1. Create and place the type catalog in the same location (directory) as the family that you want to load.
2. In a Revit Architecture project or template, click File menu ➤ Load from Library ➤ Load Family.
3. Navigate to the directory containing the family you want to open.
4. Select the family (.rfa file) that you want to load.
   - The Type Catalog displays.
5. In the Type column of the Type Catalog, select the family type or types to load.
You can select multiple types by pressing \textit{CTRL} during selection. You can also narrow the range of search items by selecting specific parameters from the list at the top of each column.

6 Click Open.

\textbf{Saving Loaded Component Families}

You can save a family that is loaded in the current project or template as an .rfa file in a location that you specify. You can save the family to a location on your system or to a network location. All family types are saved with the family.

1 Do either of the following:
   - Click File menu ➤ Save to Library ➤ Save Family.
   - Right-click a family in the Project Browser, and click Save.

2 In the Save Family dialog:
   - If you are using Save to Library ➤ Save Family, for Family to save, select the family from a list of families loaded in the project.
   - For Save in, navigate to the location in which you want to save the family.
   - Specify the name and file type for the family, and click Save.

\textbf{Creating Elements with Component Family Types}

You can begin to create elements in your building models with component family types that are provided in the Revit Architecture templates or in templates that your office or firm may provide, and loaded from libraries. Some elements that you create with component family types are host-based, which means they require another element to be added to a project (for example, a window or a door must be inserted in a wall).

After you create an element with a component family type, you can change the component family type of the element. You can also change the individual properties of any element at any time, by right-clicking the element and selecting Element Properties.

If you find that you need to modify the properties of a component family type, or if you need to create a new component family, see \textit{Modifying Component Families} on page 145 or \textit{Creating Component Families} on page 69.

\textbf{Creating an Element with a Component Family Type}

1 On the Design Bar, click the command for the element that you want to create.
2 In the Type Selector, select the type of element that you want to create.
   - The Type Selector displays the available component family types first by family or subfamily and then by type, separated by a colon.
3 On the Options Bar, specify any necessary values or selections.
4 In the drawing area, create the element.
5 Create another element, or on the Design Bar, click Modify.
Creating an Element with a Component Family Type from an Element in the Project

1. Do one of the following:
   - Select an element in the project, right-click, and click Create Similar.
   - In the Project Browser, under Families, right-click the component family type, and click Create Instance.

2. On the Options Bar, specify any necessary values or selections.
3. In the drawing area, create the element or elements.

Changing the Component Family Type of an Element

You can use 3 different methods to change the component family type of an element in a current project. The third method, the Match command method, lets you change the type of more than one element at a time.

Method 1: Using the Type Selector

1. In the drawing area, select the element.
2. In the Type Selector, select a new type.

Method 2: Changing the Type Properties

1. In the drawing area, select the element, right-click, and click Element Properties.
2. In the Element Properties dialog, for Type, select a new type.
3. Click OK.

Method 3: Using the Match command

1. In the Project Browser, expand Families.
2. Expand the family that contains the new type that you want to use.
3. Select the family type, right-click, and click Match.
4. Move the cursor to the drawing area.
   - Notice that it displays as an eyedropper.
5. Select the element that you want to match to the family type that is selected in the Project Browser.
6. Continue to select elements in the project to match to the selected type, or press ESC.

Deleting Component Families and Types

You can delete unused component families or unused family types from your projects and templates using either of 2 methods: you can select and delete the families and types in the Project Browser, or you can run the Purge Unused command.

Select and delete families and types when you have only a few families or types that you need to delete. Run the Purge Unused command when you need to “clean up” your projects. Removing all of the unused families and types usually decreases the project file size.
Whichever method you use, you cannot delete:

- any component family types that have dependencies (such as those that host other families).
- component families with types that are in use in the current project or template.

**Method 1: Selecting and deleting families and types in the Project Browser**

1. In the Project Browser, expand Families.
2. Expand the category that contains the family or type that you want to delete.
3. If you want to delete a component family type, expand the family.
4. Select the component family or type that you want to delete.

**TIP** To select more than one component family or type, press and hold CTRL while selecting.

5. Do either of the following:
   - Right-click, and click Delete.
   - Press *DELETE*.

   The component family or type is deleted from the project or template.

   If you are deleting a component family or type from a project, and there is one or more instances of a type in the project, a warning displays.

6. In the alert dialog:
   - Click OK to delete any instances of the type.
   - Click Cancel, change the type, and repeat the previous step.

**Method 2: Using the Purge Unused command**

1. Click File menu ➤ Purge Unused.

   The Purge unused dialog lists all the families and family types that you can unload from the project, including system and in-place families. By default, all unused families are selected for purging.

   **IMPORTANT** If the project is workset-enabled, all worksets must be open to use this command.

2. Do either of the following:
   - To purge all unused family types, click OK.
   - To purge only the types that you select, click Check None, expand the families and subfamilies that contain the types that you want to purge, select the types, and click OK.

---

**Creating Component Families**

If you need to create families for a project, Revit Architecture gives you that facility. Creating a new family is easy, because Revit Architecture provides many templates, including templates for doors, structural members, windows, furniture, and electrical fixtures, and lets you graphically draw the new family. The templates contain much of the information that you need to start creating the family and that Revit Architecture needs to place the family in projects.
Understanding the Family Editor

The Family Editor is a graphical editing mode in Revit Architecture that allows you to create families to include in your project. When you start creating a family, you open a template to use in the Family Editor. The template can include multiple views, such as plan and elevation views. The Family Editor has the same look and feel as the project environment in Revit Architecture, but features different commands located on a single Design Bar tab.

You can access the Family Editor by:

- Opening or creating a new family (.rfa) file.
- Selecting an element created by a component or in-place family type, and clicking Edit Family on the Options Bar.

Family Editor Commands

- The Family Types command opens the Family Types dialog. You can create new family types or new instance and type parameters. See Creating Family Types on page 89.
- The Dimension command adds permanent dimensions to the family, in addition to ones that Revit Architecture automatically creates as you sketch the geometry. This is important if you wish to create different sizes of the family.
- The Model Lines command lets you sketch two-dimensional geometry for when you do not need to show solid geometry. For example, you could sketch door panels and hardware as 2D rather than sketch solid extrusions. Model lines are always visible in 3D views. You can control their visibility in plan and elevation views by selecting the lines and clicking Visibility from the Options Bar.
The **Symbolic Lines** command lets you sketch lines that are meant for symbolic purposes only. For example, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic lines are not part of the actual geometry of the family. Symbolic lines are visible parallel to the view in which you sketch them.

You can control symbolic line visibility on cut instances. Select the symbolic line and click Visibility from the Options Bar. Select Show only if instance is cut.

In this dialog, you can also control the visibility of lines based on the detail level of the view. For example, if you select Coarse, that means that when you load the family into a project and place it in a view at the Coarse detail level, the symbolic lines are visible.

**TIP** Use this dialog to control visibility of generic annotations loaded into model families. See [Loading Generic Annotations into Model Families on page 142](#).

The **Lines** command sketches lines to define the geometry of the family.

The **Opening** command is available in host-based family templates only, for example, wall-based or ceiling-based. You create an opening by sketching its shape to the reference planes and then modifying its dimensions. After creating an opening, you can select it and set it to display as transparent in 3D and/or elevation views when loaded into the project. From the Options Bar, select the 3D and/or Elevation check boxes next to Transparent in.

**NOTE** The Opening command is also available in the project environment.

The **Ref Plane** command creates a reference plane, an infinite plane which serves as a guide for sketching lines and geometry.

The **Reference Lines** command creates a line similar to a reference plane, but that has logical start and end points.

The **Control** command lets you place arrows to rotate and mirror the geometry of the family, after you add it to your design. In the Options Bar, choose from a Vertical or Horizontal arrow, or from a Double-Vertical or Double-Horizontal arrow. You can also select more than one choice. Revit Architecture rotates or mirrors the geometry about the origin. With 2 opposite-facing arrows, you can mirror back and forth horizontally or vertically.

You can place the controls anywhere in the view. It is best to place them where it is obvious what they control.

**TIP** Controls are useful when creating a door family. The double-horizontal control arrows change which side the door is hinged. The double-vertical control arrows change the swing of the door from inside-out to outside-in.

The **Text** command allows you to add text notes to the family. This is typically used in an annotation family. The text is simply a text note.

The **Model Text** command can be used to add signage on a building or letters on a wall.

The **Section** command allows you to create a section view.

The **Components** command selects the type of component to be inserted into the Family Editor. After clicking this command, the Type Selector becomes active and you can select the component.

The **Symbol** command allows you to place 2D annotation drawing symbols.

The **Detail Component** command allows you to place a detail component.

The **Masking Region** command allows you to apply a mask to a region of the family. The masking region will obscure model elements when the family is used to create an element in a project. See Masking Regions in the Revit Architecture 2009 Help.
The **Filled Region** command allows you to apply fill to a region of the family.

The **Solid Form** command provides access to tools that let you create solid geometry in the family.

The **Void Form** command provides access to tools that let you cut solid geometry in the family.

The **Label** command allows you to place intelligent text in the family. This text actually represents a family property. When the property value is specified it will show up in the family.

NOTE This command is available for annotation symbols only.

The **Load into Projects** command allows you to load a family directly into any open project or family.

---

### Creating a Standard Component Family

Typically, the standard component families that you need to create are standard sizes and configurations of common components and symbols used in a building design.

To create a component family, you define the geometry and size of the family using a family template that is provided in the Revit Architecture. You can then save the family as a separate Revit family file (.rfa file) and load it into any project you want.

Depending on the complexity of the family, the creation process can be time-consuming. If you can identify a family that is similar to the one you want to create, you can save time and effort by copying, renaming, and modifying the family to create the new family. See **Modifying a Family to Create a New Family** on page 148.

The topics in this section apply to the creation of model (3D) families, but some are relevant to 2D families, including titleblocks, annotation symbols, and detail components. For specific information on 2D family creation, see **Tutorials: 2D Component Families** on page 151.

**TIP** It is recommended that you complete 3D standard component family tutorials included in this section before creating your own model families. See **Tutorials: 3D Component Families** on page 239.

---

### Workflow: Creating a Standard Component Family

For best results when creating a component family, follow the workflow below.

1. Before beginning family creation, plan your family.
   - See **Planning the Component Family** on page 73.

2. Create a new family file (.rfa) with the appropriate family template.
   - See **Choosing a Family Template** on page 74.

3. Define subcategories for the family to help control the visibility of the family geometry.
   - See **Creating Family Subcategories** on page 78.

4. Create the family skeleton, or framework:
   - Define the origin (the insertion point) of the family.
     - See **Defining the Family Origin** on page 80.
   - Lay out reference planes and reference lines to aid in sketching component geometry.
     - See **Laying Out Reference Planes** on page 81 and **Using Reference Lines** on page 83.
   - Add dimensions to specify parametric relationships.
     - See **Dimensioning Reference Planes and Lines** on page 87.
Creating a Standard Component Family

If you consider this list of requirements before creating your family, you will have an easier time creating it. Of course, there are bound to be changes as you create families. The Family Editor is flexible enough to allow you to make those changes without having to start over.

■ Will the family need to accommodate multiple sizes?
For a window that is available in several preset sizes, or a bookshelf that can be built in any length, create a standard component family. However, if you need to create a custom piece of furniture that only comes in one configuration, you may want to create it as an in-place family, instead of a component family. See
Size variability and the degree of complexity of the object determine whether you create a standard component family an in-place family.

■ How should the family display in different views?
The way the object should display in views determines the 3D and 2D geometry that you need to create, as well as how to define the visibility settings. Determine whether the object should display in a plan view, elevation view, and/or sectional views.

■ Does this family require a host?
For objects typically hosted by other components, such as a window or light fixture, start with a host-based template. How the family is hosted (or what it does or does not attach to) determines which template file should be used to create the family.

■ How much detail should be modeled?
In some cases, you may not need 3D geometry. You may only need to sketch a 2D shape to represent your family. Also, you may simplify the 3D geometry of your model to save time in creating the family. For example, less detail is required for a wall outlet that will only be seen in interior elevations from a distance, than for a door with raised panels and a sidelight that will be seen in an interior rendering.
What is the origin point of this family?
For example, the insertion point for a column family could be the center of the circular base. The insertion point for an accessible toilet may be 18 inches off the adjacent wall to meet code. Determining the appropriate insertion point will help users place the family in a project.

Choosing a Family Template

After you plan your new family, your next step is to choose the template that you will use to create the new family. When you create a new family, you are prompted to select a family template that corresponds to the type of element that your family will create.

The template serves as a building block, containing the information that you need to start creating the family and that Revit Architecture needs to place the family in projects.

For a list and description of the family templates included in Revit Architecture, see Appendix B: Exploring Family Templates on page 759.

What is in the Family Templates?

Family templates have .rft extensions and are available in the software, organized by element category (Annotation, Door, Wall, etc.). The category determines the category of the element that the family will create, and is used to control the visibility and scheduling of elements created with the family.

Depending on the template, it can also include:

- Subcategories (or categories within the object category) that you can use to control the visibility and material of individual pieces of geometry within the family.
  For example, a door family that you create with the Door template contains the subcategories Panel, Opening, Frame/Mullion, Glass, Hidden Lines, and Swing.

- Views in which you create the geometry of your family.
  For example, a furniture family that you create with the Furniture template contains plan views, elevation views, and a 3D view that you can use to create a furniture family.

- Reference planes and predefined parameters.
  Reference planes are 3D planes that you use as a references or work planes when you create family geometry. They do not display when you create an element with the family.

- Line types with predefined visibility settings.
  For example, if you create a door family with the Door template, a number of line types are available for you to sketch the different representation of each door component.

- If the family is a host-based object, host geometry.
  For example, if you create a window family with the Window template, wall segments in which to create the window are provided by the template. Host-based geometry does not display when you create an element with the family.

- Controls that allow you to change the position of geometry that you use to create your family.
  For example, a door family that you create with the Door template includes controls to reverse both the swing and hinge side of the door.

- Embedded text notes.
  Door and window families that you create with the Door and Window templates contain wall segments that include text notes to define the interior and exterior of the wall host. Text notes do not display when you create an element with the family.
Different Kinds of Family Templates

While most of the family templates are named according to the type of element family that you use them to create, there are a number of templates that include one of the following descriptors after the family name:

- wall-based
- ceiling-based
- floor-based
- roof-based
- line-based
- face-based

Wall-based, ceiling-based, floor-based, and roof-based templates are known as host-based templates. A host-based family can only be placed in a project if an element of its host type is present.

Review the following descriptions of the different types of templates to determine which one best suits your needs.

**Wall-based Templates**

Use the wall-based templates to create components that will be inserted into walls. Wall components can include openings, such that when you place the component on a wall, it also cuts an opening in the wall. Some examples of wall-based components include doors, windows, and lighting fixtures. Each template includes a wall; the wall is necessary for showing how the component fits in a wall.

**Ceiling-based Templates**

Use the ceiling-based templates to create components that will be inserted into ceilings. Ceiling components can include openings, so that when you place the component on a ceiling, it also cuts an opening in the ceiling. Examples of ceiling-based families include sprinklers and recessed lighting fixtures.

**Floor-based Template**

Use the floor-based template for components that will be inserted into floors. Floor components can include openings, so that when you place the component on a floor, it also cuts an opening in the floor. An example of a floor-based family is a heating register.

**Roof-based Template**

Use the roof-based template for components that will be inserted into roofs. Roof components can include openings, so that when you place the component on a roof, it also cuts an opening in the roof. Examples of roof-based families include soffits and fans.

**Standalone Template**

Use the standalone template for components that are not host-dependent. A standalone component can appear anywhere in a model and can be dimensioned to other standalone or host-based components. Examples of standalone families include columns, furniture, and appliances.
Line-based Template

Use the line-based templates to create detail and model families that use 2-pick placement similar to structural beams.

Face-based Template

Use the face-based template to create work plane-based families that can modify their hosts. Families created from the template can make complex cuts in hosts. Instances of these families can be placed on any surface, regardless of its orientation. See Creating Work Plane-based and Face-based Families on page 144.

Where to Find Family Templates

When you create a new family, you are prompted to select a family template from a list of available templates. You usually do not need to access the templates directly unless you need to modify them. They are installed by default in:

C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2009\Imperial Templates or Metric Templates

The Imperial or Metric folder contains templates for creating model elements, as well as 2 folders that contain templates to create titleblocks and annotation families.

NOTE If you cannot locate the family templates, they may have been installed in another location. Contact your CAD Manager for more information.

Creating a New Family with a Template

To create a new component family, you select a family template, and then name and save the family file. Name the family so it adequately describes the element that it is intended to create. Later, when the family is complete and you load it into a project, the family name displays in both the Project Navigator and Type Selector.

Predefined imperial and metric component families are installed by default in library folders located in:

C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2009\Imperial Library or Metric Library.

You can save your families in the folders in these libraries, or you can save them to any local or network location. After you create families, you can use the Copy and Paste commands in Microsoft® Windows Explorer to move your families to different locations.

BEST PRACTICE Do not save the family to a location where others can access it until you complete and test the family.

To create a family with a template

1 Click File menu ➤ New ➤ Family.

NOTE If you are creating an annotation or titleblock family, click File menu ➤ New ➤ Annotation Symbol or Titleblock.

Depending on the current drawing units, the New Family - Select Template File dialog displays the available imperial or metric family templates that are installed on your system in C:\Documents and Settings\All Users\Application Data\Autodesk\RAC 2009\Imperial Templates or Metric Templates.
NOTE Depending on your software installation or office standards, your family templates may be installed in another location, either locally or on a network. Contact your CAD Manager for more information.

2 Optionally, to preview a template, select it.
The template preview image displays in the upper-right corner of the dialog.

3 Select the family template that you want to use, and click Open.
The new family opens in the Family Editor. For most families, 2 or more dashed green lines display. These are reference planes, or the working planes that you will use when you create the family geometry.

If you are creating a host-based family, such as a window family, host geometry may also display.

4 In the Project Browser, view the family views.
The family views vary depending on the type of family that you create. If necessary, you can create additional views by duplicating and renaming the existing views.

5 Click File menu ➤ Save As.
6 In the Save dialog, navigate to the location in which you want to save the family, enter a name for the family, and click OK.
BEST PRACTICE Use title case for the family name.

Creating Family Subcategories

When you create a family, the template assigns it to a category that you can use to define the line weight, line color, line pattern, and material assignment of the family geometry. To assign different line weights, line colors, line patterns, and material assignments to different geometric components of the family, you need to create subcategories within the category. Later, when you create the family geometry, you assign the appropriate components to the subcategories.

For example, in a window family, you could assign the frame, sash, and mullions to one subcategory and the glass to another. You could then assign different materials (wood and glass) to each subcategory to achieve the following effect.

Revit Architecture features some predefined subcategories for different categories of families. Other families have no subcategories, which means that you can define your own. The Object Styles dialog lists family categories and subcategories. It also displays the line weight, line color, line pattern, and material assigned to each category and subcategory.

TIP You can apply a drafting pattern to a family. When you create and define a subcategory to apply to the family, you can set its surface and cut pattern materials to have a drafting pattern. You cannot apply a model pattern to a family. Only flat or cylindrical surfaces can have drafting patterns. See Fill Patterns in the Revit Architecture 2009 Help.

1 With the family open, click Settings menu ➤ Object Styles.
2 On the Model Objects tab, under Category, select the family category.
3 Under Modify Subcategories, click New.
4 In the New Subcategory dialog, for Name, enter a new name.

Revit Architecture automatically selects the appropriate category in the Subcategory of list.
5 Click OK. Although you will not immediately create and assign the family geometry the subcategory, you can specify the line weight, line color, line pattern, and material for the subcategory.

6 Set values for line weight, line color, line pattern, and material:
   ■ Click in the Projection and Cut fields for Line Weight, and select values from the lists.
   ■ Click the button in the Line Color field, and select a color from the Color dialog. If desired, define a custom color.
   ■ Click the Line Pattern field, and select a line pattern from the list. If desired, define a new line pattern for the line display.
   ■ Click in the Material field, and specify a material, cut pattern, surface pattern, or render appearance.

7 To define additional subcategories, repeat steps 3 - 6.
8 Click OK.

Creating the Family Skeleton

After you plan your family, your next step is to create the family skeleton. The skeleton is a framework of lines and parameters in which you later create the family geometry. It also defines the origin (insertion point) of elements that you create with the family.

To create the family skeleton, you begin by defining the family origin. You then build the skeleton with elements called reference planes and reference lines. After you have and define family parameters. The parameters that you define at this stage usually control the size (length, width, height) of the element, and allow you to add family types.

A view of a furniture family skeleton

When the skeleton is complete, you test it by changing the parameter values and ensuring that the reference planes resize. By creating solid skeletons from the information that you gather in your planning stage before you create the family geometry, you ensure the stability of the families that you create.
Defining the Family Origin

After you create a new component family, define the family origin and pin (lock) it in place. Later, when you create an element with the finished family, the family origin specifies the element insertion point.

The intersection of 2 reference planes in a view defines the origin of a family. You can control which reference planes define the origin by selecting them and changing their properties. Many family templates create families with predefined origins, but you may need to set the origin of some families. For example, an accessible toilet family that creates toilet elements that must always be placed a certain distance from an adjacent wall to meet code, would need an origin located at the specified distance from the wall.

To define the family origin

1. Verify whether an origin has been defined for the family by selecting the reference planes.
   If a pin displays on 2 of the reference planes, the origin is defined for the family, and you can skip the remaining steps.

2. On the Family Editor Design Bar, click Ref Plane.
3. Sketch the reference plane.
4. Click Modify and select the reference plane.
5 Click (Element Properties).
6 In the Element Properties dialog, select Defines Origin.
7 Create or open a family.
8 In a plan view, while pressing CTRL, select both reference planes.
9 On the Edit toolbar, click (Pin).
10 With the reference planes still selected, click .
11 In the Element Properties dialog, under Other, select Defines Origin.
The intersection of these reference planes now defines the origin/insertion point of the family. By pinning the planes, you ensure that you do not accidentally move them, changing the family insertion point.

Laying Out Reference Planes

Sketch reference planes before creating any family geometry to define the family skeleton. You can then use the reference planes as you create geometry, snapping sketches and geometry to them.

- Position new reference planes so that they align with the major axes of the planned geometry.
- Name reference planes so that you can assign it to be the current work plane. Without a name, you must be able to see the reference plane so you can select it to use as a work plane.
- Specify the Is Reference property for reference planes that will be dimensioned to when the family is placed in a project.

A bookcase family created within a framework of reference planes

To layout reference planes

1 On the Family Editor Design Bar, click Ref Plane.
2 Specify a start and end point for the reference plane.
3 Name the reference plane so that you can identify it in when you open other views:

- Select the reference plane, and on the Options Bar, click (Element Properties).
- In the Element Properties dialog, under Identity Data, for Name, enter a name for the reference plane.
- Click OK.
Defining Priorities for Reference Planes

Reference planes have a property called Is Reference. By setting this property, you specify that the reference plane can be dimensioned to when you place a family into a project. Only a reference plane defined as an origin or as Is Reference can be dimensioned to when the family is placed in a project. For example, if you create a table family and want to dimension the edges of the table, create the table by creating reference planes at the table's edges and set the Is Reference property for the reference planes. When you create dimensions for the table, you can then select either the origin or the table's edges or both.

Is Reference also sets a reference point for dimensions when you use the Align command. Setting Is Reference allows you to select different lines of aligned components for dimensioning.

When you set Is Reference for a reference plane, you have several choices for its value. They are:

- Not a reference
- Strong reference. See Setting Strong and Weak References on page 82.
- Weak reference. See Setting Strong and Weak References on page 82.
- Left
- Center (Left/Right)
- Right
- Front
- Center (Front/Back)
- Back
- Bottom
- Center (Elevation)
- Top

When you give Is Reference a name from the list, if you ever swap a family member out of a project and replace it with another family member, any dimensions automatically switch to the new family member, if you create the same property name in the second family.

For example, you could create 2 families, a table and a chair family, and set the left side reference plane property value to Left for both of them and then place the table in a building and dimension it from the wall to the left side of the table. If you decide to replace the table with the chair, the dimension to the left side would remain to the left side of the chair, because they both had a property value of Left.

Setting Strong and Weak References

To dimension families placed in a project, you need to define family geometry references in the Family Editor. You set geometry references as either strong references or weak references.

A strong reference has the highest priority for dimensioning and snapping. For example, you create a window family and place it into a project. As you are placing the family, temporary dimensions snap to any strong references in the family. When you select the family in the project, temporary dimensions appear at the strong references. If you place a permanent dimension, the strong references in the window geometry highlight first. A strong reference takes precedence over a wall reference point, such as its centerline.
A weak reference has the lowest priority for dimensioning. When you place the family into the project and dimension to it, you may need to press TAB to select a weak reference, as any strong references highlight first.

**NOTE** You may also be able to zoom in on the model to highlight weak references, as elements in the model appear farther apart as you zoom in.

This procedure changes references for selected line instances. It does not set reference values for any new lines.

1. On the Family Editor Design Bar, click Lines or Ref Plane and sketch a line or reference plane.
2. Select the line or reference plane and click ![Element Properties](Element Properties).
3. In the Instance box of the Element Properties dialog, set the value of Reference to Strong Reference. For reference planes, set the value of Is Reference to Strong Reference.

**NOTE** By default, Revit Architecture sets the reference property for all reference planes and sketched lines to Weak Reference.

4. Click OK.

You can sketch lines and set them to strong references. To create strong references for solid geometry, such as extrusions, sketch reference planes and set them to strong references. Then sketch the solid geometry to the reference planes.

### Using Reference Lines

You can use reference lines to create a parametric family skeleton that elements of the family can attach to. For example, you would use reference lines to parametrically maintain the angular relationships within a web, or use it to precisely control the angle of a door swing. Angular parameters applied to a reference line also control the elements attached to its face.

*A bookcase family featuring a door with a swing controlled by a reference line*
In both look and behavior, reference lines are very similar to model lines. However, there are significant differences between model lines and reference lines. For example, reference lines are annotation objects with their own category. When selected, they display dual faces. When printing, their visibility is affected by the Hide ref/work planes option.

Straight reference lines provide 2 planes for you to sketch on. One plane is parallel to the work plane of the line itself; the second plane is perpendicular to that plane. Both planes go through the reference line. The planes display when the reference line is selected, when the reference line is highlighted, or when using the Work Plane tool. When selecting a work plane, you can place the cursor over a reference line and use the Tab key to switch between the 2 faces. The plane in which the line was sketched always displays first. You can also create arc reference lines, however, they do not define any planes.

**Reference Line Behavior in the Project**

Once a family is loaded into a project, the behavior of Reference Lines is identical to that of Reference Planes. Reference Lines have no visibility property, they are generally invisible in a project and do not highlight when the instance is selected. They highlight and generate shape handles in the same contexts as Reference Planes currently do, depending on their Reference property.

**Selected reference in multiple views**
Adding a Reference Line

While in the Family Editor, you can add a reference line in any view and use the same drawing tools and techniques used when adding model lines. When you sketch a reference line, it displays as a single line. In a view where the model graphics are set to hidden line or wireframe, the sketched line displays as a solid line and the plane extents display with dashed lines.

To add a reference line

2. Using the drawing tools on the Options Bar, sketch the line.
   The line displays as a solitary solid line until selected or when highlighted during preselection.

Example of reference lines sketched as a polygon

When selected or highlighted, the associated planes display according to the active view.

Example of reference line chain highlighted in a 3D view

To use reference lines and linear dimensions to control model geometry

3. Align the face of a model element to the reference line and lock it.
4. Add a dimension line referring to the reference line and label it as an instance or type parameter.
5. Flex the model by changing and applying a new value within the Family Types dialog.
Controlling Angular Dimensions with Reference Lines

The preferred method to control the angular dimensions of a family is to apply a labelled angular dimension to a reference line. Unlike reference planes which have infinite extents, a reference line has a specific start and end point which allows it to control the angular constraints within components such as a web truss or a door with a instance door swing.

To add and dimension a reference line

1. In the drawing area, add a reference line with the point of origin located at the point of expected rotation.
2. Add an angular dimension referring to the reference line.
3. Label the dimension.
4. On the Design Bar, click Family Types.
5. Change the angular value for the labelled dimension and click Apply.
   This is known as flexing the model. It is important to make sure the reference line adjusts as expected before adding model geometry to it.

To add and align model geometry to a reference line

6. Set the current work plane to one of the faces of the reference line and add the model geometry that you intend to have controlled by the angular dimension.
   The geometry moves with the reference line as the angle changes.
7. Flex the model to make sure the design works as expected.

Modifying Reference Line Properties

1. In the drawing area, select the reference line, and click (Element Properties).
2. In the Element Properties dialog, specify the following:
   ■ Work Plane: This is read-only and reports the work plane that the reference line resides on. To change this, click Edit Work Plane on the Options Bar when the reference line is selected.
   ■ Visible: Select this setting if you want the reference line to be visible when the family is loaded into a project.
   ■ Length: This is read-only and reports the length of the line. To control the line length, drag the shape handles in the drawing area or add a labelled dimension to the reference line.
   ■ Reference: Specify Not a reference, Strong Reference, or Weak Reference.
3. Click OK.
Adding Parameters to the Family Skeleton

Although you have not yet created any family geometry, you can define the main parametric relationships in the family. The parameters that you define at this stage usually control the size (length, width, height) of the element. To create a parameter, you place dimensions between the reference planes of the skeleton and label them.

**IMPORTANT** Families in Revit Architecture are not parametric until you explicitly add labeled dimensions to them.

Dimensioning Reference Planes and Lines

The first step to creating family parameters is to place dimensions between the reference planes and lines of the skeleton to mark the parametric relationships that you intend to create. Dimensions alone do not create the parameters; you must label them to create parameters.

1. Identify the reference planes of the skeleton that you want to dimension to create parameters.
2. On the Family Editor Design Bar, click Dimension.
3. On the Options Bar, select the desired dimension options.
4. Place the dimensions between reference planes, or on reference lines.
5. Continue to dimension reference planes until all the parametric relationships have been dimensioned.

**TIP** You may need to open the different views in the family to create some of the dimensions.

Labeling Dimensions to Create Parameters

After you dimension the family skeleton, you label the dimensions to create parameters. For example, the dimensions below have been labeled with length and width parameters.

If the parameters already exist in the family, you can simply select them as a label. If not, you must create the parameter, specifying its type and whether it is an instance or type parameter.
To label dimensions and create parameters

1 On the Family Editor Design Bar, click Modify, and highlight the dimension value.
2 Right-click the dimension, and click Edit Label.
3 Select a predefined parameter from the drop-down list, or choose <Add parameter...>, and create
   a new parameter.
   See Creating Parameters on page 117.

TIP You can add formulas to parameters. A simple example would be a width parameter set to equal
   twice the height of an object. See Using Formulas for Numerical Parameters on page 121.

Alternate procedure for labeling

1 Click Modify, and select the dimension value.
2 On the Options Bar, from the Label list, choose a predefined parameter, or create a new parameter.
   See Creating Parameters on page 117.
3 If desired, select Leader to create a leader line for the dimension.

Flexing the Family Skeleton

You can flex, or test, the parameters that you have applied to the family skeleton. To flex the skeleton, you
adjust the parameter values, making sure that the reference planes to which you applied the parameter
change accordingly. Flexing is a way to test the integrity of the parametric relationships. Flexing early and
often in the creation of your families ensures the stability of your families.

To flex the skeleton

1 On the Family Editor Design Bar, click Family Types.
   The Family Types dialog displays. Although you have not defined any family types yet, the
dialog lists the parameters that you created.
2 Reposition the Family Types dialog on the screen, so you can view the skeleton.
3 In the Family Types dialog, under Parameters, locate the parameters that you created previously,
   and enter different values in their corresponding Value field.
4 Click Apply. The family skeleton should adjust to reflect the parameter values that you specified in the Family Types dialog.

Below is a diagram of the Family Types dialog:

5 Continue to flex the skeleton by specifying different parameter values. The more extensively you test the parameters, the more likely you are to create a stable family.

6 When you finish flexing the skeleton, click OK.

Creating Family Types

Creating family types allows you to create a single family and create many types (sizes) for it. To do this you need to have labeled the dimensions and created the parameters that are going to vary.

A bookcase family that creates 4 different bookcase types (sizes)

The Family Types command available in the Family Editor sets up new types. Each new type has a set of properties (parameters) that include the labeled dimensions and their values. You can also add additional values for standard parameters of the family, such as Material, Model, Manufacturer, Type Mark, and others.
To create family types

1. On the Family Editor Design Bar, click Family Types.
2. In the Family Types dialog, click New Type.
3. Enter new family name, and click OK.
4. In the Family Types dialog, enter the new values for the type parameters.
5. Click OK.

Flexing the Family

After you create family types, you can flex, or test, the family. To flex the family, you switch between family different types, ensuring that the family adjusts properly on your screen. You can flex the family before and after you create the family geometry, to make sure the family types and parameters are working correctly. Flexing early and often in the creation of your families ensures the stability of your families.

To flex the family

1. On the Family Editor Design Bar, click Family Types.
   The Family Types dialog displays.
2. Reposition the Family Types dialog on the screen, so you can view the family skeleton.
3. At the top of the dialog, select a family type, and click Apply.
   The family should adjust to reflect the parameter values specified in the family type.
4 Continue to flex the family by selecting each type in the family.
The more thoroughly you test the family, the more likely you are to create a stable family.

5 When you finish flexing the family, click OK.

Creating Family Geometry

You can use both two- and three-dimensional geometry to create families. Create solid geometric shapes to create the solid geometry of the element that the family is intended to create. Sketch 2D linework to add detail to solid geometry in certain views or to create a symbolic plan representation of an element.

As you create the family geometry, you can set the visibility, material, and optional subcategory of the geometry. These settings determine how and when the specific geometric components of the family display.

To ensure the stability of your parametric families, build the family geometry incrementally, testing (flexing) the parametric relationships in each increment.

Creating Solid (3D) Geometry

To create solid family geometry, you use three-dimensional solid and void forms. Solid forms are 3D shapes that you sketch to represent the solid geometry of your family.
Void forms are 3D shapes that you create and use to cut volume from solid forms, allowing you to create complex solid forms. You can sketch void forms at the location where you want them to cut solid forms, or you can move them after you create them and use the Cut Geometry command to perform the cut.

You can also use the Join Geometry command on the Tools toolbar to join solid geometry to create complex forms.

The Family Editor provides you with tools that you can use to create solid and void forms. Access these tools from the Family Design Bar by clicking Solid Form or Void Form. The tools offer 5 different methods that you can use to create both solid and void geometry. These methods include creating both solid and void extrusions, blends, revolves, sweeps, and swept blends. Both sweeps and swept blend use profiles that swept
along a path; to create profile families that you can load and use, see *Creating and Using Profile Families* on page 108.

**NOTE** You can also create extrusions, blends, revolves, sweeps, and swept blends as mass families. See Conceptual Design with Massing Studies in the Revit Architecture 2009 Help.

When you create your geometry, you can determine how it displays in the family. You can:

- Set the visibility and detail level of the geometry.
  See *Managing the Family Visibility and Detail Level* on page 127.

- Assign a material to the geometry.
  See Material in the Revit Architecture 2009 Help.

- Assign the geometry to a subcategory.
  See *Creating Family Subcategories* on page 78 and *Assigning Family Geometry to Subcategories* on page 126.

### Creating an Extrusion

A solid or void extrusion is the easiest form to create. You sketch a 2D profile of the form on a work plane, and then extrude that profile perpendicular to the plane on which you sketched it.

**Sample polygonal concrete isolated foundation extrusion**

Before you extrude the shape, you can specify its start and end points to increase or decrease the depth of the form. By default, the extrusion start point is 0. The work plane does not need to be either the start or end point of the extrusion – you only use it to sketch on and to set the extrusion direction.

The following procedure is a general method for creating a solid or void extrusion. Steps may vary depending on your design intent.

**To create a solid or void extrusion**

1. On the Family Editor Design Bar, click Solid Form ➤ Solid Extrusion or Void Form ➤ Void Extrusion.

**NOTE** If necessary, set the work plane before you sketch the extrusion. Click Tools menu ➤ Set Work Plane, or on the Design Bar, click Set Work Plane.
2 Use the sketching tools to sketch the extrusion profile:
   ■ To create a single solid form, sketch a closed loop.
   ■ To create more than one form, sketch multiple, non-intersecting, closed loops.

3 To extrude the profile from the default start point of 0, on the Options Bar, for Depth, enter a positive or negative extrusion depth. This value changes the endpoint of the extrusion.

   **NOTE** The extrusion depth is not retained after you create the extrusion. If you need to make multiple extrusions with the same endpoint, sketch the extrusions, select them, and then apply the endpoint.

4 Specify the extrusion properties:
   ■ On the Design Bar, click Extrusion Properties.
   ■ To extrude the extrusion from a different start point, under Constraints, for Extrusion Start, enter a new point.
   ■ To set the visibility of a solid extrusion, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings. See Managing the Family Visibility and Detail Level on page 127.
   ■ To apply a material to a solid extrusion by category, under Materials and Finishes, click in the Material field, click , and specify a material. See Materials in the Revit Architecture 2009 Help.
   ■ To assign a solid extrusion to a subcategory, under Identity Data, for Subcategory, select a subcategory. See Assigning Family Geometry to Subcategories on page 126.
   ■ Click OK.

5 On the Design Bar, click Finish Sketch. Revit Architecture completes the extrusion and returns you to the view in which you started the extrusion.

6 To view the extrusion, open a 3D view.
7 To resize the extrusion in the 3D view, select and use grips to edit it.

### Editing an Extrusion

You can modify an extrusion after creating it.

**To edit an extrusion**

1 In the drawing area, select the extrusion.
2 If you are in the project environment:
   a On the Options Bar, click Edit Family.
   b Click Yes to open the family for editing.
   c In the Family Editor, select the extrusion in the drawing area again.
3 On the Options Bar, click Edit.
4 If desired, modify the extrusion profile.
5 To edit the extrusion properties, on the Design Bar, click Extrusion Properties, and change the visibility, material, or subcategory of the extrusion.

6 To change the extrusion to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.

7 Click OK.

8 On the Design Bar, click Finish Sketch.

Creating a Blend

The Blend command blends 2 profiles together. For example, if you sketch a large rectangle and a smaller rectangle on top of it, Revit Architecture blends the 2 shapes together.

Sample base and top profiles for a blend.

![Finished blend](image)

**NOTE** If you want to dimension a solid blend after you create it, you can dimension from lines at the top of the blend to lines at the base of the blend. You cannot dimension from lines at the base of the blend to lines at the top of the blend.

To create a solid or void blend

1 On the Family Editor Design Bar, click Solid Form ➤ Solid Blend or Void Form ➤ Void Blend.

**NOTE** If necessary, set the work plane before you sketch the extrusion. Click Tools menu ➤ Set Work Plane, or on the Design Bar, click Set Work Plane.

2 Use the sketching tools to sketch the base profile of the blend, for example sketch a square.
3 To specify the depth of the blend, do either of the following:

- To specify a depth that is calculated from a default start point of 0, on the Options Bar, for Depth, enter a value.
- To specify a depth that is calculated from a start point other than 0, on the Design Bar, click Blend Properties. Under Constraints, enter new Second End and First End values.

**NOTE** If specified, Revit Architecture does not retain the end point value during creation of the blend. If you need to make multiple blends with the same end point, first sketch the blends, then select them, and then apply the end point.

4 When finished with the base profile, on the Design Bar, click Edit Top.

5 Sketch a profile for the top of the blend, for example another square.

6 If necessary, edit the vertex connections to control the amount of twist in the blend:

- On the Design Bar, click Vertex connect.
- Vertex points become available on one of the blend sketches.

The dotted lines with blue open-dot controls are suggested connections. Each control is a switch between adding and removing connections.

- To display the vertex points on the other blend sketch, on the Options Bar, for Controls on loop, select 1 or 2 (whichever option is currently unselected).
- Click a control, and the line becomes a solid connection. A filled blue control displays on the connection.

- Click a solid control to remove a connection; the line reverts to a dashed line with an open dot control.
As you click the controls, some possible edges disappear and other ones appear.

On the Options Bar, click Twist >> or Twist << to twist the selected blend profile in a clockwise or counter-clockwise direction.

7 Specify the blend properties:
   ■ On the Design Bar, click Blend Properties.
   ■ To set the visibility of a solid blend, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings.
      See Managing the Family Visibility and Detail Level on page 127.
   ■ To apply a material to a solid blend by category, under Materials and Finishes, click in the Material field, click , and specify a material.
   ■ To assign a solid blend to a subcategory, under Identity Data, for Subcategory, select a subcategory.
      See Assigning Family Geometry to Subcategories on page 126.
   ■ Click OK.

8 Click Finish Sketch.

9 To view the blend, open a 3D view.

10 To resize the extrusion in the 3D view, select and use grips to edit it.

**Editing a Blend**

1 In the drawing area, select the blend.

2 If you are in the project environment:
   a On the Options Bar, click Edit Family.
   b Click Yes to open the family for editing.
   c In the Family Editor, select the blend in the drawing area again.

3 On the Options Bar, select an editing option:
   ■ Enter a value in the Depth text box to change depth of the blend.
   ■ Click Edit Top to edit the top profile of the blend.
   ■ Click Edit Base to edit the base profile of the blend.

4 To edit other blend properties, on the Design Bar, click Blend Properties, and change the visibility, material, or subcategory of the blend.

5 To change the blend to a solid or a void, under Identity Data, for Solid/ Void, select Solid or Void.

6 Click OK.

7 Click Vertex connect, and edit the blend vertexes.

8 On the Design Bar, click Finish Sketch.
Creating a Revolve

A revolve is a form that you create by revolving a shape around an axis. You can revolve the shape in a circle or any fraction of a circle. If the axis touches the revolve shape, the result is a solid.

Solid revolved geometry created near axis

If you sketch away from the axis, the resulting geometry has a hole in it.

Revolved geometry created away from axis

Use solid revolves to create family geometry like door and furniture knobs, columns, and dome roofs.

The following procedure is a general method for creating revolved geometry. Steps may vary depending on your design intent.

To create a solid or void revolve

1 On the Family Editor Design Bar, click Solid Form ➤ Solid Revolve or Void Form ➤ Void Revolve.

**NOTE** If necessary, set the work plane before you sketch the revolve. Click Tools menu ➤ Set Work Plane, or on the Design Bar, click Set Work Plane.

2 Place an axis of revolution:
   - On the Design Bar, click Axis.
Specify the start and endpoint of the axis at the desired orientation.

3 Use the sketching tools to sketch a shape to revolve around the axis:
   ■ To create a single revolve, sketch a closed loop.
   ■ To create more than one revolve, sketch multiple, non-intersecting, closed loops.

IMPORTANT If the axis touches the revolve shape, the result is a solid. If the axis does not touch the revolve shape, the revolve will have a hole in it.

4 Change the revolution properties:
   ■ On the Design Bar, click Revolution Properties.
   ■ To change the start and end points of the geometry to revolve, enter a new Start and End Angle.
   ■ To set the visibility of a solid revolve, under Graphics, for Visibility/Graphics Overrides, click Edit.
     See Managing the Family Visibility and Detail Level on page 127.
   ■ To apply a material to a solid revolve by category, under Materials and Finishes, click in the Material field, and click to specify a material.
   ■ To assign a solid revolve to a subcategory, under Identity Data, for Subcategory, select a subcategory.
     See Assigning Family Geometry to Subcategories on page 126.
   ■ Click OK.

5 Click Finish Sketch.
6 To view the revolve, open a 3D view.
7 To resize the revolve in the 3D view, select and use grips to edit it.

NOTE You cannot drag the start and end faces of a 360-degree revolution.

Editing a Revolve

1 In the drawing area, select the revolve.
2 If you are in the project environment:
   a On the Options Bar click Edit Family.
   b Click Yes to open the family for editing.
   c In the Family Editor, select the revolve in the drawing area again.

3 On the Options Bar, click Edit.
4 If desired, modify the revolve sketch.
5 To edit other revolve properties, on Design Bar, click Revolution Properties, and change the start and end points, visibility, material, or subcategory.
6 To change the revolve to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.
7 Click OK.
8 On the Design Bar, click Finish Sketch.

Creating a Sweep

A sweep is a tool for creating families that requires you to sketch or apply a profile (shape) and extrude that profile along a path. You might use a sweep to create moldings, railings, or simple pipes.

The following procedure is a general method for creating a sweep. Steps may vary depending on your design intent.

To create a solid or void sweep

1 On the Family Editor Design Bar, click Solid Form ➤ Solid Sweep or Void Form ➤ Void Sweep.

   NOTE If necessary, set the work plane before you sketch the revolve. Click Tools menu ➤ Set Work Plane, or on the Design Bar, click Set Work Plane.

2 Specify the sweep path:
   ■ To sketch a new path for the sweep, click Sketch 2D Path.
     The path can either be a single closed or single open path. You cannot have multiple paths.
     The path can be a combination of straight lines and arcs, or it can be a circle. If you choose the Pick option while sketching the path, the path is confined to one work plane.
   ■ To select an existing line for the sweep, click Pick Path.
     You can select edges of other solid geometry, such as extrusions or blends, or you can pick existing sketch lines. Watch the status bar to know what you are picking. This method of picking automatically locks the sketch lines to the geometry you are picking. Also, using the Pick Path method allows you to sketch the path in multiple work planes, hence allowing for a 3D path. If you click existing sketch lines, you actually delete them.

3 Sketch or pick the path, and then click Finish Path.

4 Load or sketch a profile:
   ■ To load a profile:
     a On the Options Bar, select a profile from the list.

        ![Profile Options](image)

        If the profile you need is not already loaded in the project, click Load profiles to load the profile.
     b Use the X, Y, Angle, and Flip options to adjust the position of the profile.
       Enter values for X and Y to specify the offset for the profile.
       Enter a value for Angle to specify the angle of the profile. The angle rotates the profile around the profile origin. You can enter negative values to rotate in the opposite direction.
       Click Flip to flip the profile.
     c Click Apply.
     d Select the path, and zoom in to see the profile.
To sketch a profile:

a. On the Options Bar, verify <By Sketch> is displayed, and click Edit.

b. In the Go To View dialog, select the view where you want to sketch the profile, and click OK.

For example, if you sketched the path in a plan view, you would choose an elevation view to sketch the profile. The profile sketch can be a single-closed loop or multiple closed loops that do not intersect. Sketch the profile near the intersection of the profile plane and the path.

c. Sketch the profile. Profiles must be closed loops.

d. Click Finish Profile.

5 Specify the sweep properties:

- On the Design Bar, click Sweep Properties.

- To set the visibility of a solid sweep, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings.

  See Managing the Family Visibility and Detail Level on page 127.

- To apply a material to a solid sweep by category, under Materials and Finishes, click in the Material field, click , and specify a material.


- To assign a solid sweep to a subcategory, under Identity Data, for Subcategory, select a subcategory.

  See Assigning Family Geometry to Subcategories on page 126.

- Click OK.

6 Click Finish Sweep.

Creating a Segmented Sweep

Segmented sweeps are useful for creating mechanical duct work elbows. You create a segmented sweep by setting 2 sweep parameters and sketching a path with arcs. The parameters affect only arcs in the path. The minimum number of segments for a sweep is 2.

1. Follow the steps in Creating a Sweep on page 100 to access the sweep tool.
2. On the Sketch Design Bar, click Sweep Properties.
3. Select the check box for Trajectory Segmentation.
4. Enter a value for Maximum Segment Angle. Valid values are between 0 and 360 degrees.
5. Sketch or pick a path with arcs.
6. Click Finish Path to complete the path.
7. Create a profile or use a pre-loaded profile, and select the sweep path.
8. Click Finish Sweep to complete the sketch of the sweep.
Sample segmented sweep with 30 degree Maximum Segment Angle.

TIP You can change a segmented sweep to a non-segmented sweep by clearing the check box for Trajectory Segmentation.

Editing a Sweep

1 In the drawing area, select the sweep.
2 If you are in the project environment:
   a On the Options Bar click Edit Family.
   b Click Yes to open the family for editing.
   c In the Family Editor, select the sweep in the drawing area again.
3 On the Options Bar, click Edit Sweep.
4 To modify the sweep path:
   ■ Select the sweep, and on the Options Bar, click Edit.
   ■ Grip-edit the sweep path.
   ■ Click Finish Path.
5 To modify the sweep profile:
   ■ On the Design Bar, click Profile.
   ■ On the Options Bar, use the commands that display to select a new sweep profile or change the sweep profile location.
6 To edit other sweep properties, on the Design Bar, click Sweep Properties, and change the visibility, material, segmentation, or subcategory of the sweep.
7 To change the sweep to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.
8 Click OK.
9 On the Design Bar, click Finish Sweep.
Sweep Tips

When creating a sweep with a tangent arc in the path, be sure the profile is small enough to sweep around the arc without the resulting geometry intersecting itself. An error occurs if the geometry intersects. See Error Handling in the Revit Architecture 2009 Help.

If you create a sweep path by using the Pick Path command, you can drag the end points of the path lines as you are sketching it.

Creating a Swept Blend

The Swept Blend tool allows you to create a blend that has 2 different profiles and then sweep it along a path. The shape of a swept blend is determined by the 2D path you either sketch or pick and the 2 profiles you either sketch or load.

The following procedure is a general method for creating a swept blend. Steps may vary depending on your design intent.

To create a solid or void swept blend

1. In the Family Editor, click Solid Form ➤ Solid Swept Blend or Void Form ➤ Void Swept Blend on the Family tab of the Design Bar.
2. Specify the path for the swept blend. Do one of the following on the Sketch tab of the Design Bar:
   - Click Sketch 2D Path to sketch a new path for the swept blend.
■ Click Pick Path to pick an existing line for the swept blend.

**NOTE** If necessary, set the work plane before you sketch or pick the path for the swept blend. Click Tools menu ➤ Set Work Plane, or on the Design Bar, click Set Work Plane.

3 Sketch or pick the path, and then click Finish Path.

**NOTE** A swept blend path can only have one segment.

4 Load or sketch Profile 1.
■ To load a profile:
  a On the Design Bar, click Profile 1.
  b In the drawing area click the end point for Profile 1 on the swept blend path.
  c On the Options Bar, select a profile from the list.

If the profile you need is not already loaded in the project, click Load profiles to load the profile.

  d Zoom in to see the profile.

  e Use the X, Y, Angle, and Flip options to adjust the position of the profile.
Enter values for X and Y to specify the offset for the profile. Enter a value for Angle to specify the angle of the profile. The angle rotates the profile around the profile origin. You can enter negative values to rotate in the opposite direction. Click Flip to flip the profile.

f Click Apply.

To sketch a profile:
a On the Design Bar, click Profile 1. Alternatively, in the drawing area click the end point for Profile 1 on the swept blend path, select <By Sketch> from the list on the Options Bar, and click Edit.
b If the Go To View dialog displays, select the view where you want to sketch the profile, and click OK.
c Sketch the profile. Profiles must be closed loops.
d Click Finish Profile.

5 Load or sketch Profile 2 using the steps above.

6 Optionally, edit the vertex connections. By editing vertex connections, you control the amount of twist in the swept blend. You can edit vertex connections in plan or 3D views.
a On the Sketch tab of the Design Bar, click Vertex Connect.
b On the Options Bar, select Controls on Loop 1 or Loop 2.
c In the drawing area, click the blue controls to move the vertex connections.
d On the Options Bar, click the Twist buttons to twist the swept blend.

7 Specify the swept blend properties:
a On the Design Bar, click Swept Blend Properties.
b To set the visibility of a solid swept blend, under Graphics, for Visibility/Graphics Overrides, click Edit, and specify the visibility settings. See Managing the Family Visibility and Detail Level on page 127.
c To apply a material to a solid swept blend, under Materials and Finishes, click in the Material field, click , and specify a material. See Materials in the Revit Architecture 2009 Help.
d To assign a solid swept blend to a subcategory, under Identity Data, for Subcategory, select a subcategory. See Assigning Family Geometry to Subcategories on page 126.

8 When finished, click Finish Swept Blend.

**Editing a Swept Blend**

1 In the drawing area, select the swept blend.
2 If you are in the project environment:
   a On the Options Bar click Edit Family.
   b Click Yes to open the family for editing.
   c In the Family Editor, select the swept blend in the drawing area again.

3 On the Options Bar, click Edit Swept Blend.

4 To edit the path:
   a In the drawing area, select the path and click Edit on the Options Bar.
   b Make the necessary modifications to the path, and click Finish Path.

5 To edit the profiles:
   a In the drawing area, select the profile you want to edit.
   b On the Options Bar, select a different loaded profile from the drop down list, or select <By Sketch> from the list to sketch a new profile.
   c If you selected <By Sketch>, click Sketch Profile 1 or Sketch Profile 2 on the Design Bar.
   d Sketch the path and then click Finish Path.

6 To edit other swept blend properties, on the Design Bar, click Sweep Properties, and change the visibility, material, or subcategory of the sweep.

7 To change the swept blend to a solid or a void, under Identity Data, for Solid/Void, select Solid or Void.

8 Click OK.

9 On the Design Bar, click Finish Swept Blend.

**Cut Geometry**

With the Cut Geometry command, you can pick and choose which geometry gets cut and which does not, regardless of when you created the geometry.

**NOTE** While this command and the Don't Cut Geometry command are primarily for families, you can use them to embed curtain walls. See Embedded Walls in the Revit Architecture 2009 Help.

1 Create solid geometry; it can be a single primitive or some joined primitives.

2 Create a void through the solid geometry.
3 Create another solid geometry shape and join it to the existing geometry. See Joining Geometry in the Revit Architecture 2009 Help.

4 Click Tools menu ➤ Cut Geometry and select the void you created. Notice the cursor changes shape.

5 Select the geometry you created in Step 3.

Revit Architecture cuts the selected geometry.
Don't Cut Geometry

1 Click Tools menu ➤ Don't Cut Geometry.
2 Select the void.
3 Select the appropriate solid primitives that you do not want to cut.

NOTE If you select all geometry to not be cut, then the void appears at all times in the view.

Creating 2D Geometry

To create 2D family geometry, you use the Revit Architecture Model and Symbolic lines commands that are available in the Family Editor.

The Model Lines command lets you sketch two-dimensional geometry for when you do not need to show solid geometry. For example, you could sketch door panels and hardware as 2D rather than sketch solid extrusions. Model lines are always visible in 3D views. You can control their visibility in plan and elevation views by selecting the lines and clicking Visibility from the Options Bar.

The Symbolic Lines command lets you sketch lines that are meant for symbolic purposes only. For example, you might sketch symbolic lines in an elevation view to represent a door swing. Symbolic lines are not part of the actual geometry of the family. Symbolic lines are visible parallel to the view in which you sketch them.

You can control symbolic line visibility on cut instances. Select the symbolic line and click Visibility from the Options Bar. Select Show only if instance is cut.

In this dialog, you can also control the visibility of lines based on the detail level of the view. For example, if you select Coarse, that means that when you load the family into a project and place it in a view at the Coarse detail level, the symbolic lines are visible.

Creating and Using Profile Families

A profile family contains a two-dimensional loop shape that you can load into your project and apply to certain building elements. For example, you can sketch the profile loop for a railing and then use that shape on a railing in your project.
Elements for which you can define profiles include wall sweeps, reveals, railings, mullions, stair treads, and sweep profiles. When you define one profile family, you can reuse it multiple times on building elements in the project. Loaded profiles display in the Project Browser under Families.

Create profile families using family templates supplied with Revit Architecture. These templates are Profile.rft, Profile-Rail.rft, Profile-Reveal.rft, Profile-Stair Nosing.rft, and Wall Sweep Profile.rft.

**Creating a Profile Family**

To create a profile family, open a new family, and sketch a profile using lines, dimensions, and reference planes. After you save the profile family, you can load and apply it to solid geometry in the project.

This procedure describes creating a generic profile shape that is available to multiple building elements in the project. Your specific building and design intentions may differ.

**To create a profile**

1. Click File menu ➤ New ➤ Family.
2 In the Open dialog, select a profile template, and click Open.
   The Family Editor opens a plan view that includes 2 reference planes. There are no other views
   available in which to sketch geometry.

3 If necessary, sketch reference planes for constraining the lines in the profile.
4 Click Lines and sketch the profile loop.
   For more information about the sketching tools, see Sketching in the Revit Architecture 2009
   Help.

5 If necessary, click Detail Component to place a detail component into the profile family.
   
   **TIP** You can change the sorting order of any detail components in the family by using the detail
   component draw order commands. See Sorting Element Draw Order in the Revit Architecture 2009
   Help.

6 To set the detail at which the profile family displays in the project, select any of the lines of the
   profile sketch, and click Visibility on the Options Bar.
7 Select the desired detail levels, Fine, Medium, or Coarse, and click OK.
   
   **TIP** You can also set the detail level for detail components using the same methods.

Next, define the profile usage.

8 Click Settings menu ➤ Family Category and Parameters.
9 Under Family Parameters, for Profile Usage, click in the Value field, and select the profile type.
   For example, if you are creating a mullion profile, select Mullion.
   
   **TIP** This setting ensures that only relevant profiles are listed when using profiles within a project. For
   example, when selecting a mullion profile, stair nosing profiles do not display.

10 Add any dimensions required.
   
   **Sample profile sketch**

   ![Sample profile sketch](image)

11 Save the family.
Loading a Profile Family into a Project

1 Click File menu ➤ Load From Library ➤ Load Family.
2 Navigate to the profile family file you created, select it and click Open.
3 In the Project Browser, expand Families, and expand Profiles.
   The family that you created and loaded displays under Profiles.

You can now apply the profile to building elements in the project.

Using the Profile Family with a Building Element

This procedure provides an example of a way to apply the profile to an element.

1 Click File menu ➤ New ➤ Family, and select the Profile-Rail family template.
2 Create a new profile-rail family by sketching the shape you want for the rail.
   Make sure that the sketched shape is a single closed loop of lines.
3 Save the new profile-rail family.
4 Open the project in which you want to use the new profile-rail family.
5 Click File menu ➤ Load from Library ➤ Load Family, select the profile family that you created, and click Open.
6 Click Modelling menu ➤ Stairs, or on the Modelling tab of the Design Bar, click Stairs.
7 Sketch a run of stairs.
8 Open a 3D view, and select the default railing.
9 Click 
, and then click Edit/New in the Element Properties dialog.
10 Next to the Rail Structure parameter, click Edit.
11 In the Edit Rails dialog, in the Profile column, click the current profile family name.
12 Select the profile family name, and click OK three times.
   Revit Architecture applies the new profile shape to the railing.

Stair rails with profile created from procedure above
Host Sweep Profiles with Nested Detail Components

You can nest a detail component within a host sweep profile family and use the visibility controls to specify when the detail component displays within a project. Examples of host sweeps are wall sweeps, roof fascia, gutters, and slab edges. When the sweep is cut in the project, the detail component displays depending on the visibility settings you specified within the host sweep family file. You can also have multiple detail components display at particular visibility levels for a specific view cut host sweep.

Example of curtain mullion with nested detail component

TIP You can also import a detail, such as a DWG file, and apply the same visibility controls to it.

See also Nesting and Sharing Component Families on page 132.

To load a detail component

1. Open or create a host sweep family.
2. On the Design Bar, click Detail Component.
3. On the Options Bar, click Load.
4. Select a detail component family, and click open.

To add the detail component to the host sweep

5. Add the detail component to the host sweep family.
6. If necessary, use alignments or dimensions to constrain the location of the detail component.

To specify detail component visibility

7. Select the nested detail component.
8. On the Options Bar, click Visibility.
9. Specify the detail level when the detail displays, and click OK.
   Once loaded in a project, the host sweep detail displays when cut and at the detail level you specified.
**Dimensioning Family Geometry**

As you create the geometry of your component families, you place dimensions to define the geometric relationships that you want to control with parameters. By labeling the dimensions that you place, you create a parameter that you can control.

To add dimensions, you can use the Dimension command on the Family Editor Design Bar, or you can turn on automatic dimensions. Revit Architecture creates automatic dimensions to help control your design intent. These automatic dimensions are not displayed by default.

**Automatic Sketch Dimensions**

Revit Architecture creates automatic dimensions to help control your design intent. These automatic dimensions are not displayed by default.

To turn them on, check Automatic Sketch Dimensions in the Visibility dialog. You can then modify these dimensions or create your own dimensions using the Dimension command. You can also lock dimensions to keep a distance constant. This is very useful if you plan to have several sizes of the family and want to keep certain dimensions constant while the family changes size.

**Effects of Automatic Dimensions on Your Geometry**

Until you are aware of automatic sketch dimensions and that they are constraining your geometry to reference planes, you may see some unexpected behavior. The automatic sketch dimensions are Revit Architecture's way of solving how to grow or shrink your geometry based on changes in value of a family parameter.

For example, you have added a rectangular window to a fire door that has a labeled dimension for the width, but you have not dimensioned the window.

You decide to change the width of the door, but you want the window width to stay the same. You expect its position not to change; however, observe what happens when you increase the width of the door through the Family Types command.
In this example, the window is constrained to the centerline of the door and the right side of the door panel. Both the centerline and the right side of the panel are represented by reference planes. The window's position remains fixed relative to those reference planes.

To see the automatic sketch dimensions, edit the sketch of the window and turn on the visibility of the dimensions. You will see how the vertical sketch lines of the window are dimensioned to the center and right reference planes.

**Image legend:**

1. Auto sketch dimension to right reference plane.
2. Auto sketch dimension to center reference plane.
To achieve the desired results with your geometry, add locked dimensions. For example, you could add a locked dimension to represent the width of the window and a locked dimension from the window to the right reference plane.

**Visibility of Automatic Sketch Dimensions in the Family Editor**

Automatic sketch dimensions are turned off by default in a view. They appear if there is at least one labeled dimension in the family.

Notice in this next image that there is a dimension added to this geometry, but the dimension has no label.

No automatic sketch dimensions are visible.

**To turn on visibility of automatic sketch dimensions:**

1. While you are in sketch mode, click View menu ➤ Visibility/Graphics, or press VG on your keyboard.
2. Click the Annotation Categories tab.
3. Expand the Dimensions category, and select Automatic Sketch Dimensions below it.
4. Click OK.
5. Place and label a dimension.

The automatic sketch dimensions display.

Revit Architecture now knows where each line of this geometry exists with respect to reference planes or other sketch lines.
As you explicitly add locked dimensions, the automatic sketch dimensions go away in favor of the dimensions. In the next image, explicit dimensions appear with locked padlocks.

Dimensioning with Families

Families in Revit Architecture are not parametric until you explicitly add labeled dimensions to them. By adding labeled dimensions, you are creating new parameters for the family.

Labeling Dimensions

1 Click Modify, and highlight the dimension text.
2 Right-click the dimension, and click Edit Label.
3 Select a label name from the drop-down list, or choose <Add parameter...> and create a new parameter.

Alternate procedure for labeling

1 Click Modify, and select the dimension text.
2 On the Options Bar, choose a name from the Label list, or create a new parameter. See x.
3 If desired, select Leader to create a leader line for the dimension.
Dimensioning Families Tips

- You cannot type text as a label when you select a dimension. You can only select from a list of family parameters that are of the correct type, or you can create a new parameter.
- Labeled dimensions become modifiable parameters for families. You can modify their values using the Family Types command. See X. When the family is loaded into a project, you can also modify them through the Element Properties dialog.
- Values for labeled parameters can be calculated using formulas. You create the formulas in the Family Types dialog. See Using Formulas for Numerical Parameters on page 121.
- An array number can be a parameter for a family. After you create the array, select it and then label it. The array number becomes a parameter for the family. You can then modify the parameter value and increase or decrease the number of members in the array. See Creating an Array in the Revit Architecture 2009 Help.

Adding Family Parameters

You can create new instance or type parameters for any family type. By adding new parameters, you have more control over the information contained in each family instance or type. You can create dynamic family types for increased flexibility within the model.

Example 1: A table with different finishes

Create a table family with 2 material parameters called table top finish and table leg finish. Assign a material to the parameters and load the family into your project. Now you can change materials in the project. Table tops come in 3 different finishes, Oak, Pine, and Beech. Table legs are painted and offered in Teal, Navy Blue, and Black. Rather than make 9 different family types, you can make one family type and add an instance parameter for the tabletop finish and another instance parameter for the table legs finish. This allows you to alter the appearance for each table instance within your model.

Example 2: Trying different paints on a window

In this model, the customer wants to instantly view different color paints on the installed window frames. Within the window family, create a new type parameter named Paint, and assign the parameter to the window frames. Save the family and load it into the project. Create 2 new materials: Window Paint-White and Window Paint-Brown. You can now apply either the white or brown paint to the Paint type parameter, and view the changes to the entire model instantly.

Creating Parameters

1. Click Settings menu ➤ Family Types, or click Family Types on the Design Bar.
2. In the Family Types dialog, click New, and enter a name for the new type.
   This creates a new family type that will be available in the Type Selector when you load it into a project.
3. Under Parameters, click Add.
4. In the Parameter Properties dialog, under Parameter Type, select Family Parameter.
5. Type a name for the parameter.
6. Select a Discipline: Common or Structural.
7. On the Type of Parameter menu, click the appropriate parameter type.
Choices are:

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Completely customizable. Can be used to collect unique data.</td>
</tr>
<tr>
<td>Integer</td>
<td>A value that is always expressed as an integer.</td>
</tr>
<tr>
<td>Number</td>
<td>Used to collect miscellaneous numeric data. Can be defined by a formula. Can also have real numbers.</td>
</tr>
<tr>
<td>Length</td>
<td>Can be used to establish the length of an element or subcomponent. Can be defined by a formula.</td>
</tr>
<tr>
<td>Area</td>
<td>Can be used to establish the area of an element or subcomponent. Formulas can be used in this field.</td>
</tr>
<tr>
<td>Volume</td>
<td>Can be used to establish the length of an element or subcomponent. Formulas can be used in this field.</td>
</tr>
<tr>
<td>Angle</td>
<td>Can be used to establish the angle of an element or subcomponent. Formulas can be used in this field.</td>
</tr>
<tr>
<td>Slope</td>
<td>Can be used to create parameters that define slope.</td>
</tr>
<tr>
<td>Currency</td>
<td>Can be used to create currency parameters.</td>
</tr>
<tr>
<td>URL</td>
<td>Provides web link to user defined url.</td>
</tr>
<tr>
<td>Material</td>
<td>Establishes parameters in which a specific material can be assigned.</td>
</tr>
<tr>
<td>Yes/No</td>
<td>Used most often for instance properties when the parameter is defined with either a Yes or No.</td>
</tr>
<tr>
<td>Family Type</td>
<td>Used with nested components and allows you to swap components after the family is loaded into a project.</td>
</tr>
</tbody>
</table>

8 For Group parameter under, select a value.  
After the family is loaded into a project, this value determines which group header the parameter displays under in the Element Properties dialog.

9 Select either Instance or Type. This defines whether the parameter is an Instance or Type parameter.

10 Click OK.

**NOTE** To assign a material to a family element, save the family and load it into a project. Place the family in the project and select it. Click (Element Properties) and set a value for the material parameter.
Modifying Family Parameters

Select the desired parameter and click Modify in the Family Types dialog. You can rename the parameter and change whether it is a type or instance parameter. You can also replace it with a shared parameter.

Instance Parameters and Shape Handles

As you create families, you can set labeled dimensions as instance parameters; the parameters are modifiable when the family instance is placed in the project. Labeled dimensions set as instance parameters can also have shape handles that appear when the family is loaded into a project.

Creating Instance Parameters

1. Sketch family geometry using Family Editor tools.
2. Create dimensions for the family geometry.
3. Label the dimensions. See Labeling Dimensions to Create Parameters on page 87.
4. Select the dimensions and, on the Options Bar, click Instance Parameter.
   NOTE If you label dimensions by selecting a label on the Options Bar, you can check the Instance Parameter option without re-selecting the dimensions.
5. On the Design Bar, click Family Types.
   In the Family Types dialog, notice the new instance parameter. The (default) label indicates the value for the instance parameter when you place the family in the project. For example, if you create an instance parameter called length with a default value of 3000 mm, the family instance will have a length of 3000 mm when placed in the project.
6. Save changes and load the family into a project and click (Element Properties). For information about loading a family, see Finding and Loading Component Families on page 61.
   Notice that the labeled dimensions appear as parameters in the Instance pane of the Element Properties dialog. You can change the values in the dialog.

Adding Shape Handles to a Component Family

You can add shape handles to a component family that display when loaded into a project. The shape handles allow you to resize the component in the project, which means you can make many different sized instances in the project without the need to create multiple types beforehand in the Family Editor. See Controls and Shape Handles in the Revit Architecture 2009 Help.
Example of a generic component in plan and 3D views with shape handles added

To add shape handles to a component family, you must do the following:

■ Add reference lines or reference planes to the family.
■ Align the reference lines or reference planes to the edge of the component where you want the shape handle to display.
■ Add a dimension to the reference lines or reference planes.
■ Label the dimension as an instance parameter.
■ Save the family and load it into a project. When you select the component, shape handles display where the reference lines are aligned and dimensioned.

To add shape handles:

1 Within the Family Editor, add reference planes or reference lines parallel to where you want the shape handles to display.
   In the following image, a generic component with a simple extrusion is shown in plan and 3D views. Reference lines have been added parallel to the left and right edges.

2 Select each of the reference lines or reference planes, and click . Verify that the Is Reference parameter is a value other than Not a Reference.
3 Align and lock the reference lines or reference planes to the parallel edges of the component. When loaded into a project, the shape handles will display at this location.

Generic component family with reference lines aligned and locked to the extrusion edges

4 Add a dimension between the reference lines or reference planes that you aligned in the previous step.
5 Select the dimension.
6 On the Options Bar, select a label from the Label list, or click Add Parameter and create a new parameter for the dimension. See Adding Family Parameters on page 117.
7 On the Options Bar, select Instance Parameter.

NOTE When adding a new parameter, you can select Instance for the type in the Parameter Properties dialog.

8 Save changes and load the family into a project. See Finding and Loading Component Families on page 61.

After the family is loaded into the project, select the component. Shape handles display and allow you to resize the family without the need for creating new sizes in the Family Editor.

Using Formulas for Numerical Parameters

Formulas allow you to create parameters that depend on other parameters for their values. A simple example would be a width parameter set to equal twice the height of an object. In practice, formulas can be used in many ways, both simple and sophisticated. Typical uses include embedding design relationships, relating a number of instances to a variable length, and setting up angular relationships. For example, formulas can be used to

- Calculate area or volume of geometry
Create a clearance dimension parameter controlled by element size
- Convert continuously variable values into integer values
- Add shelves as the height of casework increases
- Add diagonals in an open web joist as the length increases

**Adding a Formula to a Parameter**

1. In the Family Editor, lay out reference planes.
2. Add dimensions, as required.
3. Label the dimensions. See Labeling Dimensions to Create Parameters on page 87.
4. Add the geometry, and lock the geometry to the reference planes.
5. On the Design Bar, click Family Types.
6. In the Family Types dialog, in the Formula column next to the appropriate parameter, type the formula for the parameter. For more information about entering formulas, see Valid Formula Syntax and Abbreviations on page 122.

**Valid Formula Syntax and Abbreviations**

Formulas support the following arithmetic operations: addition, subtraction, multiplication, division, exponentiation, logarithms, and square roots. Formulas also support the following trigonometric functions: sine, cosine, tangent, arcsine, arccosine, and arctangent.

The valid formula abbreviations for arithmetic operations and trigonometric functions are

- Addition— +
- Subtraction— -
- Multiplication—*
- Division—/
- Exponentiation—^: x^y, x raised to the power of y
- Logarithm—log
- Square root—sqrt: sqrt(16)
- Sine—sin
- Cosine—cos
- Tangent—tan
- Arcsine—asin
- Arccosine—acos
- Arctangent—atan
- e raised to an x power—exp
- Absolute Value—abs
You can enter integers, decimals, and fractional values in formulas, using normal mathematical syntax, as shown in the examples below:

- Length = Height + Width + sqrt(Height*Width)
- Length = Wall 1 (11000mm)+ Wall 2 (15000mm)
- Area = Length (500mm) * Width (300mm)
- Volume = Length (500mm) * Width (300mm) * Height (800 mm)
- Width = 100m * cos(angle)
- x = 2*abs(a) + abs(b/2)
- ArrayNum = Length/Spacing

Parameter names in formulas are case sensitive. For example, if a parameter name begins with a capital letter, such as Width, you must enter it in the formula with an initial capital letter. If you enter it in a formula using lower-case letters instead, for example, width * 2, the software will not recognize the formula.

### Conditional Statements in Formulas

You can use conditional statements in formulas to define actions in a family that depend on the state of other parameters. With conditional statements, the software enters values for a parameter based on whether a specified condition is satisfied. Conditional statements are useful in certain circumstances; however, they make families more complex and should be used only when necessary.

For most type parameters, conditional statements are unnecessary because the type parameter itself is like a conditional statement: If this is the type, then set this parameter to a specified value. Instance parameters are a more productive place to use conditional statements, particularly when they are used to set a parameter that does not vary continuously.

#### Syntax for Conditional Statements

A conditional statement uses this structure: IF (<condition>, <result-if-true>, <result-if-false>)

This means that the values entered for the parameter depend on whether the condition is satisfied (true) or not satisfied (false). If the condition is true, the software returns the true value. If the condition is false, it returns the false value.

Conditional statements can contain numeric values, numeric parameter names, and Yes/No parameters. You can use the following comparisons in a condition: <, >, =. You can also use Boolean operators with a conditional statement: AND, OR, NOT. Currently, <= and >= are not implemented. To express such a comparison, you can use a logical NOT. For example, a<=b can be entered as NOT(a>b).

The following are sample formulas that use conditional statements.

**Simple IF:** =IF (Length < 3000mm, 200mm, 300mm)

**IF with a text parameter:** =IF (Length > 35', “String1”, “String2”)

**IF with logical AND:** =IF ( AND (x = 1 , y = 2), 8 , 3 )

**IF with logical OR:** =IF ( OR ( A = 1 , B = 3 ) , 8 , 3 )

**Embedded IF statements:** =IF ( Length < 35', 2' 6", IF ( Length < 45', 3' , IF ( Length < 55', 5' , 8' ) ) )

**IF with Yes/No condition:** =Length > 40 (Note that both the condition and the results are implied.)
Examples of Conditional Statement Usage

Typical uses for conditional statements in formulas include calculating array values and controlling an element's visibility based on a parameter value. For example, you can use conditional statements to

- Prevent an array parameter from taking a value less than 2.

  In Revit Architecture, arrays can only have an integer value of 2 or greater. In some situations, it may be useful to create a conditional formula that maintains an array parameter of 2 even if the calculated value is 1 or 0. With such a formula, if the calculated array value is 2 or greater, the formula retains the value. However, if the calculated value is 1 or 0, the formula changes the value to 2.

  **Formula:** Array number = IF (Arrayparam < 2, 2, Arrayparam)

- Make muntins visible only when the number of window lights is greater than 1.

  For example, if you have a Lights parameter that you want to use to control the visibility of muntin geometry, you can create a Yes/No parameter like MuntinVis, and assign it to the Visible parameter in the Element Properties dialog of the muntin geometry. Because the MuntinVis parameter is a Yes/No (or Boolean) operation, both the condition (IF) and the results are implied. In this example, when the condition is met (true), the MuntinVis parameter value is selected, and the muntin geometry is visible. Conversely, when the condition is not met (false), the MuntinVis parameter is cleared, and the muntin geometry is not visible.

  **Formula:** MuntinVis = Lights > 1

Duplicating Parameterized Elements

When creating a component in the Family Editor, you often need to create identical elements that are controlled by the same parameters, such as labelled dimensions or visibility parameters. For example, if you create a window family with muntins controlled by a visibility parameter, you can create the first muntin, apply the visibility parameter to it, and then copy, array, or mirror the muntin. The visibility parameter of the original muntin is applied to the duplicated muntins.

If you copy, array, or group a parameterized element, the parameters that control that element are also copied.

In the example shown below, a generic family was created with 2 extrusions. The bottom of both extrusions are aligned to the horizontal reference plane. The height of the large extrusion on the left is controlled by the labelled dimension, H. The height of the smaller extrusion on the right is controlled by the labelled dimension, (H/2). In the Family Types dialog, a formula was added to the (H/2) parameter to make it equal to Height/2. In addition, a visibility parameter was created and applied to the small extrusion. The smaller extrusion also has a split and painted face.
Elements controlled by parameters (labelled dimensions in this case)

Continuing with the example shown above, to create a series of elements identical to the sub-height element, you can copy, array, or mirror the element and the associated parameters are copied with it. In the image below, you can see the smaller element was arrayed and the labelled dimension, painted face, and visibility parameters are applied to each arrayed element.

Array of parameterized elements

In the Family Types dialog, if the Height value in this example is changed from 6 to 8, notice the arrayed elements adjust to the new values.
Assigning Family Geometry to Subcategories

You can assign different pieces of your family geometry to subcategories within the family category. A subcategory controls the line weight, line color, line pattern, and material assignment of the geometry assigned to it, independent of the family category settings. By assigning portions of the family geometry to different subcategories, you can display it with different line weights, line colors, line patterns, and material assignments.

For example, in a window family, you could assign the frame, sash, and mullions to one subcategory and the glass to another. You could then assign different materials (wood and glass) to each subcategory to achieve the following effect.
If you haven’t created subcategories or your family does not contain them by default, you can create them at any time. See Creating Family Subcategories on page 78.

To assign family geometry to a subcategory

1. On the Family Editor Design Bar, click Modify.
2. Select the family geometry that you want to assign to the subcategory, and click (Element Properties).
3. In the Element Properties dialog, for Subcategory, select a subcategory.
4. Click OK.

Managing the Family Visibility and Detail Level

Visibility of a family determines in which view the family displays and what it looks like in that view. Typically, when an element is created by a family, the geometry of the element will change, depending on the current view. In a plan view, you may want to see a 2D representation of the element. In a 3D or elevation view, you may want a fully detailed 3D representation of the element. You have the flexibility to display different levels of geometry.

For example, you could create a door frame and use lines to represent it. Or you could extrude the door frame, so it has a 3D representation.

Detail Level determines the visibility of elements at different levels of detail. For example, you might create a door with certain embellishments. You then may decide that the embellishments should only appear at a certain detail level. You control the detail level in a project view with the Detail Level option on the View Control Bar.

You can set the visibility and detail level of any 2D and 3D geometry in the family before or after you create it.
1 Do either of the following:
   ■ To set the visibility before you sketch the geometry, click the command that you want to use to create the geometry, and click Visibility.
   ■ If you have already created the geometry, select it, and on the Options Bar, click Visibility.

2 On the Options Bar, click Visibility.

3 In the Family Element Visibility Settings, select the views in which you want the geometry to display:
   ■ Plan/RCP
   ■ Front/Back
   ■ Left/Right

   **NOTE** All geometry automatically displays in 3D views.

4 If desired, select When cut in Plan/RCP (if category permits).

   If you select this option, the geometry appears cut if it is intersected by the cut plane of the view. See View Range in the Revit Architecture 2009 Help. If the element is cut by a section view, it also shows if you select this option. See **Cuttable Families** on page 129 to determine if you can show a family category as cut in plan or RCP views.

5 Select the detail levels at which you want the geometry to display in a project:
   ■ Coarse
   ■ Medium
   ■ Fine

   Detail levels are dependent upon view scale. See Detail Level in the Revit Architecture 2009 Help for more information.

   **NOTE** The Family Element Visibility Settings dialog is different for profile and detail component families. For these families, you can set only the detail level.

6 Click OK.

   **TIP** You can set family elements to be visible or not visible in the project by associating the Visible parameter of solid geometry tools with a family parameter for that element. The Visible parameter is available for solid and void geometry tools (blends, sweeps, swept blends, revolves, and extrusions). This lets you create one family type with optionally visible geometry on it. For example, you might create a door and have a coat hook or kick plate on that door be optional. Note that the family geometry still exists in the project, it is just invisible. For example, it may still be involved when you join geometry in the project.

7 If you set the visibility before you created the geometry, create the geometry.

**Cuttable and Non-Cuttable Family Categories**

Revit Architecture families are either cuttable or non-cuttable. If a family is cuttable, the family displays as cut when the cut plane of a plan view intersects that family in all types of views. If the family is non-cuttable, it displays in projection, regardless of whether it is intersected by the cut plane.

You can determine if a family category is cuttable in the Object Styles dialog (click Settings menu ➤ Object Styles). If the Line Weight Cut column is disabled, the category is non-cuttable.
Setting the Visibility of Imported Geometry

1 Import the geometry.
2 Select it, and on the Options Bar, click Visibility.
3 Specify the views and detail levels in which the imported geometry should appear, for example, plan and 3D views and coarse and medium detail levels.
When you load the family into a project and place an instance of it, the imported geometry displays based on the settings you specify.

Cuttable Families

If a family is cuttable, the family displays as cut when the cut plane of a view intersects that family in all types of views.

In the Family Element Visibility Settings dialog, there is an option called When cut in Plan/RCP. This option determines if family geometry is shown when the cut plane intersects that family. For example, in door families, the geometry for plan swing is set to be shown when the door is cut in plan views and not shown when the door is not cut.

This option is never made available and is never selected for non-cuttable families. For some cuttable families, the option is made available, and you can select it. For other cuttable families, the option is never made available, but it is always selected.

The following table lists cuttable families and whether the option is made available for that family.

<table>
<thead>
<tr>
<th>Family Category</th>
<th>Option Made Available</th>
</tr>
</thead>
<tbody>
<tr>
<td>Casework</td>
<td>Yes</td>
</tr>
<tr>
<td>Ceilings</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Columns</td>
<td>Yes</td>
</tr>
<tr>
<td>Curtain Wall Panels</td>
<td>No</td>
</tr>
<tr>
<td>Doors</td>
<td>Yes</td>
</tr>
<tr>
<td>Floors</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Generic Models</td>
<td>No</td>
</tr>
<tr>
<td>Roofs</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Site</td>
<td>Yes</td>
</tr>
<tr>
<td>Structural Columns</td>
<td>Yes</td>
</tr>
<tr>
<td>Structural Foundations</td>
<td>Yes</td>
</tr>
</tbody>
</table>

NOTE Not Applicable means the category is a system family that cannot be made from a family template.
<table>
<thead>
<tr>
<th>Family Category</th>
<th>Option Made Available</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural Framing</td>
<td>Yes</td>
</tr>
<tr>
<td>Topography</td>
<td>No</td>
</tr>
<tr>
<td>Walls</td>
<td>Not Applicable</td>
</tr>
<tr>
<td>Windows</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Non-Cuttable Families**

The following families are not cuttable and are always shown in projection in views:

- Balusters
- Detail Items
- Electrical Equipment
- Electrical Fixtures
- Entourage
- Furniture
- Furniture Systems
- Lighting Fixtures
- Mechanical Equipment
- Parking
- Planting
- Plumbing Fixtures
- Specialty Equipment

**Adding a Website Link to a Family**

You can add a website link to the Type or Instance properties of a family in both the Family Editor and in the project environment. Selecting the URL opens the default web browser to the selected location. For example, if you are creating a manufacturer-specific window family, you could add the URL and provide the user with a direct link to the manufacturer’s website.

**Testing a Family in a Project**

After you have finished a family, load it in at least one project, and create elements with the family types to ensure it works correctly. Make sure you select a test project that contains any geometry with which the family must interact. For example, if the family is a host-based family like a window, ensure that the test project contains the host elements, in this case, walls.
BEST PRACTICE Until you successfully test the family, do not save it in a library where it is accessible to others.

To test a family in a project

1. Open a test project.

   NOTE Imperial and metric testing projects are available in the Training Files folder. Click File ➤ Open, click Training Files in the left pane of the Open dialog, and open Imperial or Metric. Open Imperial_Family_Testing_Template.rvt or Metric_Family_Testing_Template.rvt.

2. To load the family in the project, do either of the following:
   ■ With the project and the family open, on the Family Design Bar, click Load into Projects.
   ■ In the project, click File menu ➤ Load from Library ➤ Load Family, navigate to the location of the family, select it, and click Open.

3. In the project, on the appropriate tab of the Design Bar, start a command to create an element from one of the new family types.

4. In the Type Selector, select a type in the new family.

5. Add the element to a view in the project.
   If the element is host-based, place it in a host element.

6. In the current view, test the element:
   ■ On the View Control Bar, change the Detail Level and/or Model Graphics style to ensure that visibility settings work correctly.
   ■ Change the current scale to ensure the element resizes.
   ■ Click View ➤ Visibility/Graphics and change the visibility for the element by category and, if applicable, by subcategories.
   ■ Select the element, right-click, click Element Properties, change any of the instance parameters, and click OK to view and verify the changes.
   ■ If the family contains multiple types, select the element, and in the Type Selector, select a different family type.

7. Open additional project views, and repeat step 6.

8. If the family contains more than one type, repeat steps 3-6 to test other types in the family.

9. If you find any errors in the family, edit the family, and retest it in a project.

10. When you finish testing the family, save it in the imperial or metric Revit Architecture library or in another location of your choice.

Advanced Component Family Techniques

After you understand the basics of creating parametric component families, there are more complex techniques that you can use when you create families. These techniques include:

■ Nesting and sharing families to combine the geometry of two or more families
■ Linking family parameters
■ Creating face- and workplane-based families

The concepts in this section are demonstrated in the advanced tutorials in this guide. See Tutorials: Advanced Standard Component Families on page 491.
Nesting and Sharing Component Families

You can nest (insert) families within other families to create new families that contain the combined family geometry.

For example, rather than model a combination window family from scratch, you can create the combination-window family below by loading the Double Hung and Instance - Fixed families into a new window family. Place the fixed window instance in the center with a double hung window on each side.

Whether or not you share families before you nest them determines the behavior of the nested geometry in elements that you create with the family.

- If you nest a family that is not shared, components created by the nested family act with the rest of the element as a single unit. You cannot select (edit), tag, or schedule the components separately. In the sample window family shown above, an instance of the nested and unshared family would have only one window tag and would schedule as a single unit.

- If you nest a shared family, you can select, tag, and schedule the components separately. In an instance of the shared window family, the 3 windows would tag and schedule separately, even though the nested family would behave as a single component within the building model.
Nesting Restrictions

There are certain restrictions regarding the type of families that you can load and nest in other families.

- Only annotation families can be loaded into other annotations.
- Only detail families and generic annotations can be loaded into details.
- Model families, details, generic annotations, section heads, level heads, and grid heads can be loaded into model families.

Nesting Families with Interchangeable Components

By applying a family type parameter to a nested component, you can create families with interchangeable subcomponents. After you load and create an element with the nested family, you can swap components at any time.

Creating a Family with Nested Components

To nest families in another family, create or open a host (base) family, and then load and insert instances of one or more family types into it. The base family can be a new empty family or an existing family.

To create a family with nested components

1. Create or open a family into which you want to nest a family.
2. In the Family Editor, click File menu ➤ Load from Library ➤ Load Family.
3. Select any families that you want to nest, and click Open.
5. In the Type Selector, choose the component type that you want to nest.
6. Click in the drawing area to place the nested component in the family.
7. If necessary, repeat steps 4-6 to nest components in the family.
8. Save the family.

Creating a Family with Nested and Shared Components

To create a family with nested and shared components, share the families before you nest them in a host family. The host family does not need to be a shared family.

When you create a nested family of shared components, the first decision you need to make is in what category the host family will belong. This decision has many downstream implications for tagging, scheduling, and ODBC information, as described in the example below.

A ganged window unit is created as a nested and shared family. In this case, the large center window was opened as the host family and the 2 side windows were nested in as shared families. This window is intended to be built on-site using the subcomponents that are purchased as separate units by the builder. The family was saved as Triple_window.rfa.
When the ganged unit shown above is loaded into a project, tagged, and scheduled, the result is as follows:
Nested and shared families loaded into a project

Notice that each window is tagged and scheduled separately. However, notice the ganged window name, Triple Window, is listed with the subcomponents. This window also represents the main window of the 3 window set.

In the example shown below, the same triple window family was created, but with a new window family used as the host family and both the fixed window and the double-hung windows loaded as shared families. Notice the difference in the tagging and scheduling.

Ganged window family started as a new family
In the example shown above, notice the host family schedules with each of the 3 subcomponent windows. If this is not your design intent, you should follow the previous example, where one of the subcomponents is the host family.

To share a family before nesting it

1. Open a family to be shared, and click Settings menu ➤ Family Category and Parameters.

   IMPORTANT Annotation, profile, and in-place families cannot be shared families.

2. In the Family Categories and Parameters dialog, under Family Parameters, select Shared.
   Although you can set most families as shared families, it only becomes relevant when the family is nested into another family and loaded into a project.

3. Click OK.

4. Save and close the family.

To nest shared families in a host family

1. Open the host family or start a new family.

2. Open the families that you want to nest and share them.

3. Load and place a nested component within the host family.

4. Repeat this process for each nested component.

5. Save the family.

Loading Families with Shared Components into a Project

You load families that contain nested or nested and shared families into a project using the same methods as any other family. When you load a family comprised of nested or nested and shared components into a project, the following rules apply:

- The host family, along with all nested and shared components, is loaded into the project. Each nested component is available within the Project Browser under its respective family category.
- A nested component family can exist within a project and be shared by more than one host family.
- When loading shared families, if a version of one of the families already exists within the project, you have the option to use the version from the project or from the family you are loading.

IMPORTANT Once a shared family is loaded into a project, you cannot reload an unshared version of the same family and overwrite it. You must delete the family and reload it.

1. Do either of the following:
   - Within the project, you can click File menu ➤ Load from Library ➤ Load Family.
   - Within the family, you can select Load into Projects on the Design Bar.

2. Add instances of the family to your projects.

Working with Shared Components in a Project

A family that contains nested and shared families works as any other family within a project. However, you can use the TAB key to toggle to the nested and shared components.
Selecting sub-instances of a shared family

If you select a nested instance, you can do the following:

- Click and in the Element Properties dialog, modify some instance properties, such as Mark and Comments.
- Modify type properties. When you do this, all instances of that type also update to reflect the changes.

If you select a nested instance, you cannot do the following:

- Select and delete a nested instance.
- Mirror, copy, move, or array a nested instance.
  If you do this, the entire host family adapts, not just the nested instance.
- Modify the position, the size, or shape of a nested instance.

Scheduling Shared Components

To create a schedule containing shared families, you use the same method as any other schedule. See Schedule Views in the Revit Architecture 2009 Help.

The biggest advantage to nesting and sharing families is the ability to schedule shared families as individual instances. A family comprised of shared and nested families allows each instance of a nested family schedule separately. Within the schedule, you can renumber each instance of a nested family.
Family comprised of 2 shared window families loaded into a project

If a nested family is comprised of multiple categories, each instance of a nested family displays in its respective schedule and all components will display on a multi-category schedule.

In contrast, in a family where none of the nested families are shared, instances of the nested families schedule only as one instance.

**Creating a Nested Family with Interchangeable Components**

You can create families that feature interchangeable nested components when added to your projects. To control the type of family within a nested family, you create a family type parameter that can be either an instance or type parameter. After you label a nested component as a family type parameter, subsequently loaded families of the same type automatically become interchangeable without any further work.

For example, if you add 2 transoms to a door family shown below, you only have to position one of the transoms, label it as a family type parameter, and the other transom becomes part of the list of available transoms. If you load 5 more transom types, they are all available for selection.
If you need the nested family components to tag and schedule individually, make sure each family that you load into the host family is shared.

1. Open or start a new family.
2. Load the components that you want to nest within the family. For example, if you are in a door family, load several transom types.
3. On the Design Bar, click Component and place the first component at its desired location.

   **NOTE** In the door family example, you would also want to tie the width of the transoms to the width of the door. Depending on your specific circumstances, you may want to consider a similar action. This ensures that as components swap, they remain in the same position and the same size.

4. Select the nested component.
5. On the Options Bar, in the Label drop-down list, select Add Parameter.

   **NOTE** When adding a parameter in the Family Types dialog, click Add Parameter, select Family Type as the Category, and select the category from the Select Category dialog. When you add the parameter using the Options Bar, the parameter is automatically assigned to Family Type and the respective family category is assigned.

7. Enter a name for the Parameter, and select either Instance or Type parameter.
8. Select a value for Group Parameter under.
   
   This designates under which group the parameter displays in the Element Properties dialog.
9. Click OK.
10. Save the file and load it into a project.

11. Add the component to the building model, select it, and click .
12. Locate the family type parameter and select a different component from the list.
Controlling the Visibility of Families with Nested and Shared Components

You can control the visibility of nested family instances in the host family. See Managing the Family Visibility and Detail Level on page 127.

1. In the host family, select the nested family.
2. On the Options Bar, click Visibility.
3. In the Family Element Visibility Settings dialog, set the View Specific Display and Detail Level settings.

**NOTE** In nested families, you cannot set the When cut in Plan/RCP visibility option.

4. Click OK.

Linking Family Parameters

By linking family parameters, you can control the parameters of families nested inside host families from within a project view. You can control either instance or type parameters.

To link parameters, they have to be the same type. For example, link a text parameter in the host family to a text parameter in the nested family.

You can link a host-family parameter to more than one nested family parameter of the same type. Also, you can link this parameter to multiple nested families.

Creating Family Parameter Links

1. Create a family with either instance or type parameters of the available types.
   See Creating Parameters on page 117.

2. Save the family and load it into a host family.
   See Finding and Loading Component Families on page 61.

3. With the new family open, click Component on the Design Bar and place as many instances of the loaded family as desired.

4. Click Settings menu ➤ Family Types, or click Family Types on the Design Bar.

5. Under Parameters, click Add.

6. Follow the steps for creating a new parameter of the same type as the parameter you wish to control in the nested family.
   See Creating Parameters on page 117.

7. Click OK to close the Family Types dialog.

8. Select an instance of the loaded family in the host family and click .
   There is a column for both instance and type properties that has an equal sign (=) in the column heading. There are also gray buttons next to certain parameters, indicating that they can be linked to other parameters.
9 Click the button next to a parameter, either instance or type, that is of the same type as the one you created in Step 6. For example, if you created a text parameter, you must select a text parameter here.

10 In the dialog that appears, select the parameter you created in Step 6 to associate it with the current parameter, and click OK.

NOTE When you associate 2 parameters, an equal sign appears on the button: ▪

11 Click OK to close either the Type and Element properties dialogs, or both.
12 Continue creating the host family and save it.
13 Load the family into a project and place a few instances of it.

14 Select an instance of the family and click .
15 Locate the type or instance property you created.
16 Set it to the desired value and click OK.
   The nested family changes according to the value you entered.

Creating Parameter Links for Model Text

If you place model text into a family, it acts like a nested family. You can create parameters in the host family to control the text and depth of the model text in the project.

To control text

1 Place some model text in the host family.
2 On the Design Bar, click Family Types and add a family parameter that is of type text. This will be the parameter that controls the text of the model text in the project.
3 Enter some text in the Value box for the new parameter. For example, if you created a parameter called Mtext, you might enter "default" in the Value box next to this new parameter. Click OK to close the Family Types dialog.

NOTE Do not leave the Value box empty. If you do, Revit Architecture issues a warning.

4 Select an instance of model text in the family and click .
5 Click next to the parameter Text.
6 In the dialog that appears, select the parameter you created to link to the model text parameter.
7 Click OK twice.
8 Continue creating the host family and save it.
9 Load that family into a project and place a few instances of it.

10 Select an instance of the family and click .
11 Edit the model text parameter.
   The model text updates to the new value. If you created an instance parameter, just the one instance changes. If you created a type parameter, all current and future instances of the model text change.
To control depth

Controlling model text depth is similar to controlling text, only you create a family parameter that is of type length. Follow the above procedure to link parameters for model text depth.

**Loading Generic Annotations into Model Families**

You can nest generic annotation families inside host model families, so that the annotations appear in the project. This is useful if you want to include a label with a model family and display that label in the project.

Generic annotations hosted by model families scale with the view when they are loaded into the project. When you place these generic annotations on a sheet, they appear at the same size, regardless of view scale. For example, a 3/32” text label in a model family always prints at that size on a sheet, even if that label appears on the sheet in a view with a 1/8” = 1’0” scale or a view with a 1/4” = 1’0” scale.

You can also control their visibility in the project separately from the host model family.

**Adding a Generic Annotation**

You can create your own generic annotation family or load one from the available annotation families in the Revit Architecture library. This procedure uses an existing annotation family.

**NOTE** Though this procedure uses specific family files, the steps are common to any generic annotation you may want to add to a model family.

1. Open the microwave.rfa family from the Specialty Equipment\Domestic folder in the Imperial library. The microwave from the Metric library is in the same folder and is called M_microwave.rfa.
2. Click File menu ➤ Load From Library ➤ Load Family.
3. Navigate to the Annotations folder and select the Label Annotation 3-32.rfa family. For metric, choose the M_Label Annotation.rfa family.
4. Open a floor plan view in the microwave.rfa file. You can place a generic annotation in plan only.
5. Click Symbol on the Design Bar and place an instance of the label at the intersection of the 2 reference planes in the center of the microwave.

Now you need to associate this label with a parameter in the host family.

6. On the Design Bar, click Family Types.
7. In the Family Types dialog, click Add under Parameters.
8. In the Parameter Properties dialog, select Family parameter.
9 Type a name for the parameter. In this case, type Label.

10 From the Type menu, choose Text and click OK. This parameter will be stored by type.

   New family parameter appears in Family type dialog

   ![Family Types dialog]

11 Click OK to close the Family Types dialog.

12 Select the label instance you placed on the microwave and click .

13 Click Edit/New and locate the Label parameter.

14 Click the button under the equal sign (=) column next to the Label parameter.

   ![Type Properties dialog]

15 In the Associate Family Parameter dialog, select the parameter Label. This is the parameter you created in steps 6-10.

16 Click OK to close the dialog.

17 Click OK to close the Type Properties dialog.

18 If desired, you can set at which detail level the label appears in a project. Click the Edit button next to the Visibility instance parameter. Select coarse, medium, or fine detail levels. If you do not select a detail level, the label does not show in a project view set at the same detail level.

19 Save the microwave.rfa family and load it into your project.

   For information about loading a family, see Loading Component Families on page 61.

20 Click Component on the Design Bar and place the microwave in a plan view.

21 Click , and in the Element Properties dialog enter MW for the value of the Label parameter.

22 Click OK.

   You see the microwave now has this label in the view.

   ![MW]

23 If desired, change the detail level of the view to change the visibility of the label.

   See Managing the Family Visibility and Detail Level on page 127.

   **NOTE** You can also change the visibility of the label by turning off Generic Annotations in the Annotation Categories tab of the Visibility/Graphics dialog.
Creating Work Plane-based and Face-based Families

You can create a family that is hosted by the active work plane. This can be very useful both in a project environment and within a nested family where you may need a nested sub-component to reside on a particular plane. You can make any non-hosted family a work plane-based family. For example, a generic component, a furniture component, and a site component can all be work plane-based families because they are not required to be hosted by another component. Doors and windows cannot be work plane-based because they are wall-hosted components.

Example of generic component family nesting a work plane-based component. On the left, the work plane is selected; on the right, the work plane-based component was added.

Another way to create components that can be placed with any orientation is to use face-based families. A face-based family must be created from the Generic Model face based.rft template. A face-based component can be placed on any surface, including walls, floors, roofs, stairs, reference planes, and other components. If the family contains a void cutting the host, the component will cut its host, but only if the host is a wall, floor, roof, or ceiling. When a component with a void is placed on any other host, it will not cut.

Creating a Work Plane-based Family

1 Open or create a non-hosted family.

NOTE Only non-hosted components can become work plane-based families. Doors and windows, for instance, are hosted by walls and cannot become work plane-based components.

2 In the Family Editor, click Settings menu ➤ Family Category and Parameters.
3 In the Family Category and Parameters dialog, under Family Parameters, select Work Plane-Based.
4 Click OK.

NOTE You can make a family both work plane-based and always vertical. Examples of both are shown below.

In the nested family below, the rectangular extrusion is a work plane-based component. On the left, the extrusion is work plane-based but not always vertical. On the right,
the same extrusion was reloaded into the family after designating it work plane-based and always vertical.

Creating Vertical Families

You can create vertical or non-vertical families. This option pertains only to families hosted by walls, floors, ceilings, roofs, and site surfaces. You can set a family component, such as a tree or a chandelier, to Always Vertical; once loaded into a project, the component remains vertical regardless of the slope of the host. In the case of a car or a park bench, you can set the Always Vertical option to No; this allows the car and the park bench to adapt to the slope of the host.

NOTE The Always Vertical parameter does not apply to families created in non host-based templates.

Example of Vertical and Non-Vertical Families; 3 trees are set to Always Vertical, 2 trees are not.

To set the always vertical parameter for a family

1 In the Family Editor, click Settings menu ➤ Family Category and Parameters.
2 Select the check box to enable the Always Vertical parameter.
3 Click OK.

Modifying Component Families

You can modify component families that are loaded in your projects or saved in libraries. When you decide that you need to modify a family, determine whether you can simply add or modify a family type to meet
your needs. If not, you can modify a family or copy and modify a family to create a new family. If you modify and save a family that is in use in a project, you need to reload the family.

Modifying Component Family Types

To customize component families, you can:

- add family types to a family
- modify the properties of a component family type

You can modify family types in the project environment, or you can modify them in the Family Editor.

Adding a Type to a Component Family

After loading a family into a project, you can create different family types from within the project. You can also open a family in the Family Editor, and add a type.

To add a type to a family in the project environment

1. In the Project Browser, expand Families.
2. Expand the family category.
3. Expand the family.
4. Do either of the following:
   - Select the family, right-click, and click New Type.
   - Select a type, right-click, and click Duplicate.

   **BEST PRACTICE** To minimize type property editing, duplicate the family type that most resembles the type that you want to create.

5. Enter a new name for the type, and press ENTER.
6. Select the type, right-click, and click Properties.
7. In the Type Properties dialog, enter new parameter values, and click OK.

To add a type to a family in the Family Editor

1. Open the family (.rfa file) to which you want to add a type.
2. On the Family Editor Design Bar, click Family Types.
3. In the Family Types dialog, under Family Types, click New.
4. Enter a name for the type, and click OK.
5. In the Family Types dialog, enter new values for the type parameters.
6. Click OK.
7. Save and close the family.

Modifying a Component Family Type

You can access the properties of a component family type in the Project Browser or from an element that uses that type in a current project.
To modify a type in the project environment

1 Do one of the following:
   ■ In the Project Browser, under Families, right-click the component family type, and click Properties.
   ■ Select an element in the project, right-click and click Element Properties. In the Element Properties dialog, click Edit/New.

2 In the Type Properties dialog:
   ■ Under Type Parameters, change parameter values as desired.
     The parameters that display vary depending on the component family type that you are modifying.
   ■ If desired, in the upper-left corner, click Rename, and type a new name.

3 Click OK to exit all dialogs.

4 If you are modifying a component family type in a project, any instances of elements with component family type in the project update to reflect your modifications.

To modify a type in the Family Editor

1 Open the family (.rfa file) that contains the type that you want to modify.
2 On the Family Editor Design Bar, click Family Types.
3 In the Family Types dialog, enter new values for the type parameters.
4 Click OK.
5 Save and close the family.

Modifying a Family

You can modify a family by opening it in the Family Editor and editing it. After you modify it, you can load it from the Family Editor into any open projects.

To modify a family in the Family Editor

1 Click File menu ➤ Open.
2 Open the family that you want to modify.
3 In the Family Editor, modify the family:
   ■ Create or modify family types. See Creating Family Types on page 89.
   ■ Modify or add geometry to the family. Creating Family Geometry on page 91.
   ■ Change the visibility settings, detail level, materials, and subcategory of the family. See Managing the Family Visibility and Detail Level on page 127 and Assigning Family Geometry to Subcategories on page 126.
   ■ Add or modify parameters. Adding Family Parameters on page 117.
4 When you finish modifying the family, save it.
5 To load the family into any open projects, on the Options Bar, click Load into Projects.
6 In the Load into Projects dialog, select the projects in which you want to load the family, and click OK.
If the family is already loaded into the project, the Reload Family dialog displays the following:

<table>
<thead>
<tr>
<th>If...</th>
<th>Then the dialog informs you...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the family already exists within the project and has not been used in the building model</td>
<td>that the family is already loaded in the project, although it is not currently in use.</td>
</tr>
<tr>
<td>the family already exists within the project and is being used in the building model</td>
<td>that the family is already in use in the project.</td>
</tr>
</tbody>
</table>

You are asked if you want to overwrite the existing version of the family. In addition, you have the option to override the parameter values of the existing types. If you select the override option, the parameter values of the existing family are overridden by the parameter values of the family you are loading.

**IMPORTANT** If the family is in use within the building model and you override the parameter values of existing types, the family will update throughout the project with the new values.

- Click Yes to overwrite the existing version of the family.
- Click No to end the load process.

**TIP** When reloading multiple families, you can click Yes to All.

### Modifying a Family to Create a New Family

If you can identify a family that is similar to the one that you want to create, you can save time and effort by copying, renaming, and modifying the family to create the new family.

1. Do one of the following to copy a family:
   - In Windows Explorer, navigate to location of the family (a.rfa file), and copy and rename it.
   - In the Family Editor, click File menu ➤ Save to Library ➤ Save Family.
   - In a project, right-click the family in the Project Browser, and click Save.
2. If necessary, in the Save Family dialog, specify the name and file type for the family.
3. Open the family in the Family Editor, and modify it.
   - See Modifying a Family on page 147.
4. Save and close the family.

### Modifying Families in a Project (or Nested Family)

Within a project or family, you can edit a loaded family and reload it into the same project or any other open projects or families. Before or after reloading the family into the project, you can save the family to a library with the same or a new name.

1. In the drawing area, select the component family that you want to edit.
2 Do either of the following:
   ■ On the Options Bar, click Edit Family.
   ■ In the drawing area or Project Browser, right-click the family, and click Edit.

3 In the alert dialog, click Yes to edit the family.
   The family opens in the Family Editor. The original project is still open in the background.

4 Modify the family.

5 If you want to save a copy of the modified family, click File menu ➤ Save.

6 To load the family into any open projects, on the Options Bar, click Load into Projects.

7 In the Load into Projects dialog, select the projects in which you want to load the family, and click OK.
   If the family is already loaded into the project, the Reload Family dialog displays the following:

<table>
<thead>
<tr>
<th>If...</th>
<th>Then the dialog informs you...</th>
</tr>
</thead>
<tbody>
<tr>
<td>the family already exists within the project and has not been used in the building model</td>
<td>that the family is already loaded in the project, although it is not currently in use.</td>
</tr>
<tr>
<td>the family already exists within the project and is being used in the building model</td>
<td>that the family is already in use in the project.</td>
</tr>
</tbody>
</table>

You are asked if you want to overwrite the existing version of the family. In addition, you have the option to override the parameter values of the existing types. If you select the override option, the parameter values of the existing family are overridden by the parameter values of the family you are loading.

**IMPORTANT** If the family is in use within the building model and you override the parameter values of existing types, the family will update throughout the project with the new values.

   ■ Click Yes to overwrite the existing version of the family.
   ■ Click No to end the load process.

**TIP** When reloading multiple families, you can click Yes to All.

8 Close the family file.
Tutorials: 2D
Component Families
Creating a Room Tag

In this tutorial, you create a room tag that displays various label parameters: room name, floor and ceiling finish, and area.

Specifying Room Tag Parameters

In this exercise, you specify the room tag parameters.

Create a tag based on the default room tag template

1. Click File menu ➤ New ➤ Annotation Symbol.
2. In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Room Tag.rft.
3. Click View menu ➤ Zoom ➤ Zoom All to Fit.
   The reference planes that display are part of the default room tag template.

Edit the 1/8' label

5. On the Options Bar, click (Element Properties).
6. In the Element Properties dialog, click Edit/New.
7. In the Type Properties dialog, select the Underline check box, and click OK.

Add a 3/32' label

8. In the Element Properties dialog, click Edit/New.
9 In the Type Properties dialog, click Duplicate.
10 In the Name dialog, for Name, enter $3/32''$, and click OK.
11 In the Type Properties dialog, under Text, for Text Size, enter $3/32''$.
12 Clear Underline.
13 Click OK twice.

Combine labels into a room tag

14 In the Type Selector, select Label : 1/8''.
15 On the Options Bar, verify that (Center) and (Middle) are selected.
16 Specify the location for the first label as shown. The intersection of the reference planes is used as the insertion point of the tag.

17 In the Edit Label dialog, under Category Parameters, select Name, click Add parameter(s) to label, and click OK.
18 Zoom in to the label. The name label displays with the text underlined.

Name

19 In the Type Selector, select Label : 3/32''.
20 Specify a point below the Name label for the next label location.
21 Select Floor Finish, click Add parameter(s) to label and click OK.

Name

Floor Finish

22 Specify a point below the Floor Finish label for the next label location.
23 Select Ceiling Finish, click Add parameter(s) to label and click OK.

Name

Floor Finish

Ceiling Finish
24 Specify a point below the Ceiling Finish label for the last label location.
25 Select Area, and click Add parameter(s) to label.
26 Under Label Parameters and Sample Value, enter Area.
   The Area label is a text placeholder. When the room tag is placed in a project, the project settings
determine the units for the area calculation (for example, square feet or square meters).

<table>
<thead>
<tr>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Floor Finish</td>
</tr>
<tr>
<td>Ceiling Finish</td>
</tr>
<tr>
<td>Area</td>
</tr>
</tbody>
</table>

27 Save the new room tag with the name Finish Area Tag.rfa.
   The new room tag is now ready for use in a project.
Creating a Titleblock Family

In this tutorial, you create a custom titleblock sheet based on the D-size titleblock template.

The titleblock has linework, text, and labels. You customize the titleblock with a new text style, graphics, and your project data.

Skills used in this tutorial:

■ Drawing lines for a titleblock

■ Adding a graphic to a titleblock

■ Adding text boxes to a titleblock

■ Adding labels to a titleblock

■ Adding a titleblock to a new project
Drawing Linework for a Titleblock Sheet

In this exercise, you draw all of the linework necessary to create a custom D-size sheet.

Open a titleblock template

1 Click File menu ➤ New ➤ Titleblock.
2 In the left pane of the New dialog, click Training Files, and open Imperial\Templates\D - 36 x24.rft.
The default titleblock template consists of 4 border lines. The lines in the blank template represent the edges of the paper. Custom page sizes can be created by changing the dimensions of these lines.

Sketch the inside border

3 On the Design Bar, click Lines.
4 On the Options Bar, click , and for Offset, enter -1/2”.
5 Click the upper left corner of the sheet to specify the first rectangle corner, and click the lower right corner of the sheet to specify the second corner of the rectangle.

Add vertical and horizontal lines

6 On the Options Bar, click , and for Offset, enter 4 1/2”.
7 Move the cursor over the right inside border line, and click to draw a new vertical line.
8 On the Options Bar, click \( \text{\textcopyright} \), and click \( \text{\textregistered} \).

9 On the Options Bar, clear Chain.

10 For Offset, enter 0.

11 Draw a horizontal line 4" below the upper inside border, as shown.

12 Draw a horizontal line 3" below the last horizontal line, as shown.

13 Draw a horizontal line 3" above the lower inside border as shown.

14 On the Design Bar, click Modify, press CTRL, and select the second and third horizontal lines.

15 In the Type Selector, select Wide Lines.

**NOTE** The wide line style is not visible until the titleblock is loaded into a new project.

16 Zoom in to the lower-right corner of the sheet.

17 On the Design Bar, click Lines.
18 In the Type Selector, select Title Blocks.

19 On the Options Bar, click , and for Offset, enter 0’ 1/2”.

20 Move the cursor over the third horizontal line that you originally drew, and click to draw a new horizontal line 1/2” below the existing line.

21 Using the same method, add 2 more horizontal lines below the existing lines, as shown.

22 On the Options Bar, for Offset, enter 3/4”.

23 Move the cursor over the third horizontal line, and click to draw a new horizontal line 3/4” above the existing line.

24 Using the same method, add 2 more horizontal lines above the existing lines, as shown.


26 Zoom out to view the entire sheet.
   The titleblock linework is now complete.

Adding Graphics and Text to a Titleblock

In this exercise, you add a company logo, text notes, and labels to your titleblock.

Add a company logo

1 Click File menu ➤ Import/Link ➤ Image.
2 In the left pane of the Open dialog, click Training Files, and open Common\CorporateLogo.jpg.
3 Place the image in the upper right corner of the sheet, and use the drag handles to resize the image, as shown.

4 Zoom in to the logo.

Create a 3/8” text style

5 On the Design Bar, click Text.

6 On the Options Bar, click .

7 In the Element Properties dialog, click Edit/New.

8 In the Type Properties dialog, click Duplicate.

9 In the Name dialog, for Name, enter 3/8” Bold, and click OK.

10 In the Type Properties dialog, under Text, for Text Size, enter 3/8”, and select Bold.

11 Click OK twice.

Add company name text

12 Draw a text box under the first horizontal line, as shown.
13 Enter Arch Design Inc. in the text box.
14 Click outside of the text box to complete the text.

Add address and phone number

15 In the Type Selector, select Text : Text Note 1.
16 Draw a text box below the company name, and add an address and phone number, as shown. Press ENTER to add each new line of text and click outside of the text box to complete the text.
17 On the Design Bar, click Modify, and select the last text note.
18 Select the drag handle, and drag the text note down, as shown.

19 Click outside the text box to complete the modification.

**Add consultant information**

20 On the Design Bar, click Text.
21 Draw a text box below the second horizontal line, and enter the following text:
   - Consultant:
   - Address:
   - Address:
   - Telephone:

22 On the Design Bar, click Modify, and select the consultant text note.

23 On the Edit toolbar, click (Copy).
24 On the Options Bar, verify Copy is selected, select Constrain and Multiple.
25 Click inside the Consultant text group.
26 Move the cursor down 4”, and click to specify the first copied text note position.

27 Move the cursor down another 4”, and click to specify the second copied text note location.
Create a 3/16” text style

28 On the Design Bar, click Text.

29 On the Options Bar, click .

30 In the Element Properties dialog, click Edit/New.

31 In the Type Properties dialog, click Duplicate.

32 In the Name dialog, for Name, enter 3/16”, and click OK.

33 In the Type Properties dialog, under Text, for Text Size, enter 3/16”.

34 Click OK twice.

Add drawing data text

35 In the Type Selector, select Text : 3/16”.

36 Draw a text box in the lower right space of the titleblock, and enter Sheet Number:

37 Using the same method, add the remaining text, as shown.
Add drawing data labels

38 On the Design Bar, click Label.

39 On the Options Bar, select (Right) and (Bottom).

40 Place the cursor at the lower right corner of the Date field, and click to specify the label location.

<table>
<thead>
<tr>
<th>Date:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawn By:</td>
</tr>
<tr>
<td>Checked By:</td>
</tr>
<tr>
<td>Sheet Number:</td>
</tr>
</tbody>
</table>

41 In the Select Parameter dialog, select Project Issue Date, click the green arrow to add it to the label, and click OK.

The label displays a default value wrapped to 2 lines.

<table>
<thead>
<tr>
<th>Date:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawn By:</td>
</tr>
<tr>
<td>Checked By:</td>
</tr>
<tr>
<td>Sheet Number:</td>
</tr>
</tbody>
</table>

42 Select the left drag handle on the label, and drag to the left until the label displays on one line.

<table>
<thead>
<tr>
<th>Date:  Project Issue Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawn By:</td>
</tr>
<tr>
<td>Checked By:</td>
</tr>
<tr>
<td>Sheet Number:</td>
</tr>
</tbody>
</table>

NOTE Move the label if necessary (using arrow keys) to line it up properly with the existing text.
Place the cursor at the lower right corner of the Drawn By field, and click to specify the label location.

In the Edit Label dialog, under Category Parameters, select Drawn By, and click the green arrow to add it to the label.

Click OK.

Place the cursor at the lower right corner of the Checked By field, and click to specify the label location.

In the Edit Label dialog, under Category Parameters, select Checked By, click the green arrow to add it to the label, and click OK.

Create a 3/8" label style

On the Design Bar, click Label.

On the Options Bar, click .

In the Element Properties dialog, click Edit/New.

In the Type Properties dialog, click Duplicate.

In the Name dialog, for Name, enter 3/8" Label, and click OK.

In the Type Properties dialog, under Text, for Text Size, enter 3/8".

Click OK twice.

Add sheet number and project data labels

In the Type Selector, select Label : 3/8" Label.

Place the cursor at the lower right corner of the Sheet Number field, and click to specify the label location.

In the Edit Label dialog, select Sheet Number, click the green arrow to add it to the label, and click OK.
On the Options Bar, click (Center) and (Middle).

Place the cursor near the center of the field above the Date field, and click to specify the label location.

In the Edit Label dialog, select Project Number, and click OK.

Select the left drag handle on the label, and drag to the left until the label displays on one line.

Place the cursor near the center of the field above the Project Number field, and click to specify the label location.

In the Edit Label dialog, select Project Name, and click OK.

Place the cursor near the center of the field above the Project Name field, and click to specify the label location.

In the Edit Label dialog, select Client Name, and click OK.
Click Modify, and using arrow keys, move any labels that need to be aligned.

<table>
<thead>
<tr>
<th>Client Name</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Name</td>
<td></td>
</tr>
<tr>
<td>Project Number</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Date:</th>
<th>Project Issue Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drawn By:</td>
<td>DRW</td>
</tr>
<tr>
<td>Checked By:</td>
<td>CHK</td>
</tr>
</tbody>
</table>

Sheet Number: A101

**NOTE** You can also create custom project parameters and sheet parameters. For more information, see the Construction Documents section in the Revit Architecture 2009 Online Help.

**Create a 1/16” label style**

66 On the Design Bar, click Label.

67 On the Options Bar, click .

68 In the Element Properties dialog, click Edit/New.

69 In the Type Properties dialog, click Duplicate.

70 In the Name dialog, for Name, enter 1/16” Label, and click OK.

71 In the Type Properties dialog, under Text, for Text Size, enter 1/16”.

72 Click OK twice.

**Add Project Path label**

73 In the Type Selector, select Label : 1/16” Label.

74 On the Options Bar, click (Left) and (Middle).

75 Place the cursor in the border area below the Sheet Number field, and click to specify the label location. (Left-align the label with the Sheet Number field.)

76 In the Edit Label dialog, select File Path, and click OK.

77 On the Design Bar, click Modify, and then adjust the width of the File Path field so that it is approximately equal to the width of the Sheet Number field.
Adding the Titleblock to a New Project

In this exercise, you add the titleblock that you created to a new project.

Load the titleblock family into a project

1 Click File menu ➤ New ➤ Project.
2 In the New Project dialog, under Template file, click Browse.
3 In the left pane of the Choose Template dialog, click Training Files, and open Imperial\Templates\default.rte.
4 Under Create new, verify that Project is selected, and click OK.
5 On the View tab of the Design Bar, click Sheet.
6 In the Select a Titleblock dialog, click Load.
7 In the Open dialog, navigate to the location of Training D-Size Titleblock.rfa file, select it, and click Open.
8 In the Select a Titleblock dialog, select Training D-Size Titleblock, and click OK.

Modify titleblock properties

9 On the Design Bar, click Modify, and select the titleblock.
10 On the Options Bar, click .
11 In the Element Properties dialog, under Other, for Drawn By, enter Name, and click OK.
12 Zoom in to the lower-right corner of the sheet.
13. Click Settings menu ➤ Project Information.
14. In the Element Properties dialog:
   - For Project Issue Date, enter **January 1, 2008**.
   - For Project Status, enter **In Progress**.
   - For Client Name, enter **Jane Smith**.
   - For Project Name, enter **Office Building**.
   - For Project Number, enter **2008-01**.

15. Click OK.

16. Zoom to fit the titlesheet in the view.

17. Close the project with or without saving it.

This completes the Creating a Titleblock Family lesson.
In this tutorial, you use a generic annotation family to create a keyplan symbol that can be used on multiple sheets in a project.

You export a building plan to use as the basis for the keyplan geometry.

You create a keyplan annotation with 2 family types. Depending on the type selected, the corresponding wing is shaded and labeled in the annotation, as shown:
Skills used in this tutorial:

- Exporting a building plan as a DWG file
- Importing a DWG file to use as the basis for a keyplan annotation
- Creating annotation geometry
- Defining object styles
- Adding filled regions
- Adding parameters to control keyplan shading and labelling
- Adding the keyplan to a project sheet

Creating the Keyplan Geometry

In this exercise, you create the geometry for the keyplan by importing a DWG file and tracing the outline of the building plan. You add object styles to the family, and create filled regions to shade the 2 sections of the keyplan.

Export the plan of the building to a DWG file

1 Click File menu ➤ Open.
2 In the left pane of the Open dialog, click Training Files, and open Imperial\i_Dependent_Views.rvt.
3 Zoom to fit (ZF) the Level 2 floor plan in the window.

4 Click File menu ➤ Export ➤ CAD Formats.
5 In the left pane of the Export dialog, click Desktop, accept the default file name, and click Save.
You trace this DWG file to define the keyplan geometry.

Create a family from a generic annotation family template

6 Click File menu ➤ New ➤ Family.
7 In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Generic Annotation.rft.
8 Click File menu ➤ Import/Link ➤ CAD Formats.
You import the DWG file that you exported in the previous steps.
9 In the left pane of the Import/Link dialog, click Desktop, click i_Dependent_Views.dwg, and click Open.
A message displays that there are no paper space objects to import.
10 Click Yes to import the model space objects.
11 Zoom to fit the plan in the view.

NOTE You may not see the plan until you zoom to fit the view.

There are 2 buildings in the plan view of this bird sanctuary: the aviary and observation area in the upper-left and the lab building in the lower-right. In this tutorial, the aviary is referred to as Wing A and the lab building as Wing B.
12 Click File menu ➤ Save As.
13 In the left pane of the Save As dialog use the scroll button, click Training Files, and save the file as \Imperial\Families\Annotations\Keyplan.
   The family file is saved automatically with the .rfa extension.

**Resize the plan for a keyplan**

You use the Resize tool to make the plan the required size (printed size) for the keyplan. The keyplan will be used on sheets in Revit Architecture projects, so it will have no scaling applied.

14 In the drawing area, select the imported geometry.

15 On the Edit toolbar, click (Resize).
16 Zoom in to the far right area of Wing A (near where the wings connect).
17 Click the center (intersection) point defined by the reference planes.

18 Zoom out if necessary, and click near the right edge of the imported geometry; the exact position is not critical.
19 Enter 2", and press ENTER.
Because you are resizing from the center point, this value is 1/2 the size of the desired printing size of 4". The imported geometry will be approximately 4" from the left extents of the geometry to the right extents of the geometry.

20 Zoom to fit the geometry into the view.
Trace the outline of the plan

21 Zoom in to the intersection of the reference planes.

22 On the View toolbar, click (toggles Thin Lines).

23 Zoom in to the upper-left corner of the model, as shown:

24 On the Design Bar, click Lines.

25 On the Options Bar, click (Draw), and select Chain.
26 Select the upper endpoint.

27 Select the lower-left endpoint.

28 Continue to draw lines counterclockwise to trace the outline of the plan. (Zoom out as needed.)

29 On the Design Bar, click Modify.

After you trace the outline of the plan, you can delete the imported DWG geometry.

30 Select the imported DWG, and press DELETE.
31 On the Tools toolbar, click (Trim/Extend).

32 Extend the outline between the buildings:
   - Select the left line of the lab building.

   ![Diagram of lab building with selected lines]

   - Select the top line of the lab building.

   ![Diagram of lab building with selected lines]

The division between Wing A and Wing B is clear.
Add object styles to the family for lineweights/linetypes

33 Click Settings menu ➤ Objects Styles.

34 Define a dashed line for the match line:
   - In the Object Styles dialog, under Modify Subcategories, click New.
   - In the New Subcategory dialog, for Name, enter **Dashed Line**, and click OK.
   - For Dashed Line, under Line Weight Projection, select 4, and for Line Pattern, select Dash.

35 Define a thick line for the keyplan outline:
   - In the Object Styles dialog, under Modify Subcategories, click New.
   - In the New Subcategory dialog, for Name, enter **Thick Line**, and click OK.
   - For Thick Line, under Line Weight Projection, select 5.

36 Click OK.

Draw lines representing the match line of the plan

37 On the Design Bar, click Lines.

38 In the Type Selector, select Dashed Line.

39 Sketch the match line, as shown:
   - Select the 5 points as shown to create a matchline around the corner of Wing B.

**NOTE** Even with Chain selected on the Options Bar, you must select a start point and endpoint for each segment of the matchline.
On the Design Bar, click Modify.

Create filled regions to shade the keyplan sections

41 On the Design Bar, click Filled Region.

42 On the Design Bar, click Region Properties.

43 Modify the region properties to use a gray background rather than the harsh black. (This user preference for the keyplan can be tailored to match office standards.)
   ■ In the Element Properties dialog, click Edit/New.
   ■ In the Type Properties dialog, click Rename.
   ■ In the Rename dialog, for New, enter Shaded, and click OK.
   ■ In the Type Properties dialog, under Graphics, click the value for Color.
   ■ In the Color dialog, click the light gray swatch.
   ■ Click OK 3 times.

44 In the Type Selector, select Thick Line, and click (Pick Lines).
   You use the Thick Line object style to create filled regions to shade the 2 sections of the keyplan.

   NOTE These thick lines appear oversized in the family file. However, when loaded into the project, the lines are the correct thickness.

45 Create the filled region for Wing A:
   ■ Select the lines for the outline for Wing A. There is no need to lock the filled region.
On the Tools toolbar, click (Trim/Extend), and trim the lines to clean up the outline, as shown:

On the Design Bar, click Finish Sketch. Click as needed to manage display of the lines.
46 Create the filled region for Wing B:
- On the Design Bar, click Filled Region.
- On the Options Bar, click (Pick Lines).
- Select the outline for Wing B, as shown:
- On the Design Bar, click Finish Sketch.
47 Click File menu ➤ Save.
48 Proceed to the next exercise, Add Parameters to Control Keyplan Visibility on page 186.

Add Parameters to Control Keyplan Visibility

In this exercise, you create 2 family types: 1 type shows wing A shaded and labeled; the other type shows wing B shaded and labeled. You then create a sheet in a Revit Architecture project, and add the 2 keyplan types to the sheet.

Define 2 family types
1 On the Design Bar, click Family Types.
2 In the Family Types dialog, under Family Types, click New.
3 In the Name dialog, enter Wing A, and click OK.
4 Using the same method, create a family type named Wing B.

Create Yes/No parameters for Wing A and Wing B
5 In the Family Types dialog, under Parameters, click Add. You create a Yes/No parameter for each wing. You then associate these parameters with the visibility of the filled regions and the text labels.
6 In the Parameter Properties dialog, under Parameter Data, for Name, enter Wing A, for Type of Parameter, select Yes/No, and click OK.
7 Using the same method, create a yes/no parameter for Wing B.

Specify the visibility for each type
8 In the Family Types dialog, for Name, verify that family type Wing B is selected.
9 Under Other, clear the Value for Wing A.
10 Under Name, select Wing A, and clear the Value for Wing B.
11 Click OK.

Assign the yes/no parameter to the visibility of the filled regions
12 In the drawing area, select Wing A, and click (Element Properties).
13 In the Element Properties dialog, for Visible, click .
14 In the Associate Family Parameter dialog, select Wing A, and click OK twice.
15 Using the same method, assign the Wing B parameter to the visibility for Wing B.

16 On the Design Bar, click Modify.

Create a text label for the keyplan

17 On the Design Bar, click Text, and click (Element Properties).
18 In the Element Properties dialog, click Edit/New.
   You create a text type. The size of the text label for a keyplan is typically determined by office standard text sizes/fonts.
19 In the Type Properties dialog, click Duplicate.
20 For Name, enter 1/8", and click OK.
21 In the Type Properties dialog, under Text, for Text Size, enter 1/8".
22 Click OK twice.
23 Click in the lower left area of the drawing area, and enter Key Plan -.

24 On the Design Bar, click Modify.
25 In the drawing area, select the new text box.
26 On the Edit toolbar, click (Move Copies).

27 Click the bottom left corner of the text box for the start point, and click to the right of the existing text box to place the copy.

This second text box will be connected to the visibility parameters and will contain text specific to each family type (that is, Wing A or Wing B). You create 2 copies of the second text box, one copy for each of the 2 family types.

28 Edit the second text box to read Wing A.

Key Plan - Wing A

29 On the Design Bar, click Modify.

30 Select the Wing A text, and click (Element Properties).

31 In the Element Properties dialog, for Visible, click .

32 In the Associate Family Parameter dialog, select Wing A.

33 Click OK twice.

34 Create a Wing B text box:
   ■ Create a copy of the Wing A text box.
   ■ Select the copy, and change the text to Wing B.

Key Plan - Wing A

Wing B

■ With the Wing B text box still selected, click (Element Properties).

■ In the Element Properties dialog, for Visible, click .

Notice that = displays on the button because the visibility is already associated with Wing A.

■ In the Associate Family Parameter dialog, select Wing B.

■ Click OK twice.

■ Drag the Wing B text box so that it is positioned directly over the Wing A text box.

35 On the Design Bar, click Modify.

36 Select the notes in the template file, and press DELETE.
37 Click File menu ➤ Save.
38 On the Design Bar, click Load into Projects.
39 If necessary, in the Load into Projects dialog, select i_Dependent_Views.rvt, and click OK.
   The i_Dependent_Views project opens and the keyplan family is loaded into the project.

Create a sheet for the keyplan
40 In the Project Browser, right-click Sheets (all), and click New Sheet.
41 In the Select a Titleblock dialog, select the default titleblock, and click OK.

Add the generic annotation to the sheet
42 On the Drafting tab of the Design Bar, click Symbol.
43 Click in the upper-right corner of the sheet.

44 Click to place a second instance of the annotation below the first so the 2 types can be tested and compared.

45 On the Design Bar, click Modify.
46 Select the second instance of the annotation, and in the Type Selector, select Keyplan : Wing B.
47 On the Design Bar, click Modify.
48 Zoom in to see the keyplans.
   The appropriate wing is shaded and labeled in each annotation.

49 Close the project with or without saving it.
In this tutorial, you learn how to create detail component families and nest them in other families.

You begin the tutorial by creating a window sill detail component family from an existing DWG detail.

After you create the sill detail, you combine it with an existing head detail and create a full window detail component family by sketching additional detail geometry.
When the full window detail component family is complete, you nest it in a window family. You specify visibility options to display the detail component only in cut views and in fine detail. Then, by adding a window type from the new window family to a project, you test the visibility of the detail component.
Skills used in this tutorial include:

- Importing a DWG file to create new detail component families
- Implementing best practices when importing geometry
- Nesting detail components within other families
- Testing the family in a project

Creating a **Window Sill Detail Component Family from a DWG**

In this exercise, you create a window sill detail by importing an existing detail drawn in DWG format.

![Complete Revit Architecture sill detail](image)

You begin by creating a new detail component family into which you import the existing detail. All the DWG objects (including any blocks or external references) are imported as a single Revit Architecture element called an import symbol. When the DWG is imported, the DWG layers create object styles in the import symbol.

After you import the DWG detail, you explode the import symbol and convert its components to Revit Architecture objects. You then remove the unused object styles created from the import of the DWG layers from the new family.

**Create a detail component family**

1. Click File menu ➤ New ➤ Family.
2. In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Detail Component.rft.

The new family opens in the Family Editor.

3. Save the detail component family:
   - Click File menu ➤ Save As.
   - In the Save As dialog, for File name, enter **Window_Sill**, and click Save.
     The new family is saved as an RFA file.

**Import a detail from a DWG file**

4. Click View menu ➤ Zoom ➤ Zoom All to Fit.
5 Click File menu ➤ Import/Link ➤ CAD Formats.
6 In the Import/Link dialog:
   ■ Navigate to Training Files\Imperial.
   ■ Select Wood_Window_Details_Sill.dwg.
     A preview image of the detail displays on the right side of the dialog.
   ■ For Colors, select Preserve.
     Later, you replace the AutoCAD colored linework with Revit lines.
   ■ Verify the following:
     ■ For Layers, All is selected.
     ■ For Import units, Auto-Detect is selected.
     ■ For Positioning, Auto - Center to Center is selected.
     ■ For Place at, Ref. Level is selected.
     ■ Orient to View is selected.
   ■ Click Open.
     The DWG detail is imported into the family as a single import symbol. It is the correct size
     (life-size). Later, you change the scale, which does not affect the detail size (full-size), but
     lets you manage the display of lineweights and the size of dimensions.
7 Select the detail, and in the Type Selector, notice the detail is identified as an import symbol. Next, you change the scale of the family to an appropriate detail scale to manage the text and dimension size. Later in this exercise, you assign individual components of the detail to different object styles to vary their lineweight. The correct scale will help you select and assign object styles. If the thickness of the lines obscures their position, the screen display of the linework can be turned on or off with the Thin Lines tool ( ).

Change the current scale and resize the reference planes

8 On the View Control Bar, click the current scale, and click 3"=1'-0". Because no text is placed in the detail, the selected scale is only of interest for managing the thickness of linework as you draft.

NOTE In Revit Architecture, you can set values for the width of linework for a particular scale by assigning a lineweight number (1-16) to a line width. Click Settings menu ➤ Line Weights to add scales and assign weights.

9 Resize the reference planes:

- Select the horizontal reference plane. The reference plane displays as red and its label, Center (Front/Back), also displays.

- Select the right endpoint of the reference plane, and drag it toward the detail. Size the reference planes so they extend beyond the overall size of the detail.

- Repeat for the other end of the horizontal reference plane and for the vertical reference plane.
Click View menu ➤ Zoom ➤ Zoom All to Fit.

Next, you position the detail so that the intended insertion point of the detail aligns with the intersection (0,0) of the reference planes. When you later insert the detail in a view, the reference plane intersection defines its origin. When you place a detail, the cursor position is attached to the detail origin.

Align the imported detail with the reference planes

10 On the Tools toolbar, click (Align).

11 Select the Center (Front/Back) reference plane.

12 Select the lower horizontal edge of the sill, as shown.
13 Select the Center (Left/Right) reference plane.

14 Select the right edge of the wall fastener plate, as shown.

The detail now aligns with both reference planes. In this case, you aligned the components with the reference planes to move them to the correct location.
Next, you explode the detail to convert it to objects.

**Explode the detail**

15 On the Design Bar, click Modify.

16 Move the cursor over the detail until a frame displays around the detail, and select the detail.

   The detail displays in red, and new options display on the Options Bar. In the next step, you fully explode the import symbol into lines and curves.

   ![Image of exploded detail]

   **NOTE** This detail does not contain either blocks or xrefs, but if you import a DWG that does contain them, using the Partial Explode option will explode the import symbol into separate nested import symbols created by any blocks and xrefs.

17 On the Options Bar, click Full Explode.

18 A warning dialog displays, notifying you that some of the lines in the detail may be slightly off axis.

   This could cause problems if you want to add geometry to the detail. Because you do not need to add geometry to the detail, close the warning dialog without making changes.

19 Select a line in the detail.

20 In the Type Selector, notice that an AutoCAD layer name displays.

   When you exploded the detail import symbol, the layer names and properties imported with the DWG are still in use as Revit Architecture object styles. Although not required, it is a best practice to convert the detail elements to Revit Architecture object styles and remove the AutoCAD object styles with the DWG layer names.

**Filter and convert elements to use similar Revit Architecture object styles**

21 Using a window selection, select the detail.
22 On the Options Bar, click \( \text{Filter Selection} \).
In the Filter dialog, a list of lines displays; the 3 object styles were created by the layers A-Deti-Hvy, A-Deti-Lgt, and A-Deti-Med.

23 Filter lines with the A-Detl-Heavy style:
- In the Filter dialog, click Check None.
- Select Lines (A-Detl-Hvy).
- Click OK.
The lines from the A-Detl-Hvy layer highlight in red.

24 In the Type Selector, select Heavy Lines.

The lines that used the A-Detl-Hvy object style display as thick black lines.
26 Using the same method, filter and convert the remaining lines to use the Light Lines and Medium Lines object styles.

Next, you remove the unused object styles from the family. Deleting these from the family before saving and using the family in a project is not required, but is a best practice. If you do not delete unused styles, they can degrade the performance of projects into which you add the detail component family.

**Remove unused object styles from the family**

27 Click Settings menu ➤ Object Styles.

28 In the Object Styles dialog, on the Model Objects tab:

- Under Category ➤ Detail Items, select A-Detl-Hvy.
- At the bottom right of the dialog, under Modify Subcategories, click Delete.
- In the Revit dialog, click Yes.
- Using the same method, remove the A-Detl-Lgt and A-Detl-Med object styles.
Next, you perform the same process on the Imported Objects tab.

29 Click the Imported Objects tab:
   • Under Category ➤ Imports in Families, select 0.
   • At the bottom right of the dialog, under Modify Subcategories, click Delete.
   • In the Revit dialog, click Yes.

30 Click OK.
   You imported and converted a DWG detail, which is now ready to be inserted in detail views in your Revit Architecture projects.

31 Save and close the new detail component family.

32 Proceed to the next exercise, Creating a Full Window Detail Component Family on page 201.

Creating a Full Window Detail Component Family

In this exercise, you create a detail component for the full window by combining the sill detail that you created previously with an existing head detail, and then sketching the remaining window geometry. You add reference planes and a parameter to the full window detail that allow you to specify the overall height of the window, while allowing for some required space between the window and the rough opening.

Full window detail
When complete, you can use the full window detail component as an adjustable standalone detail, or you can nest it into a window family for inclusion in a wall section, as demonstrated in the final exercise in this tutorial.

Create a new detail component family

1 Click File menu ➤ New ➤ Family.
2 In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Detail Component.rft.

The new family file opens in the Family Editor.

3 Save the detail component family:
   ■ Click File menu ➤ Save As.
   ■ In the Save As dialog, for File name, enter Wood_Window_Detail, and click Save.

The new family is saved as an RFA file.

View and pin the template reference planes

4 In the Project Browser, under Floor Plans, verify Ref. Level is the current view.
   Next, to ensure proper parametric relationships, you pin the reference planes. This is a best practice that is implemented before you create family geometry. Pinning the reference planes ensures that they cannot be accidentally moved.

5 Pin the reference planes:
   ■ While pressing CTRL, select both reference planes.
   ■ On the Edit Toolbar, click (Pin).
Change the scale to an appropriate detail scale

6 On the View Control Bar, click the current scale, and click 1\(\frac{1}{2}\)'=1'-0'.'

Add a reference plane for the window height

7 On the Design Bar, click Ref Plane.
8 To specify the reference plane start point, click 1'-6'' above the left endpoint of the Center (Front/Back) reference plane.

9 Move the cursor to the right, and specify the endpoint directly above the end point of the existing reference plane.

Dimension the horizontal reference planes

10 On the Design Bar, click Dimension.
11 Select the Center (Front/Back) reference plane, and then select the new reference plane.
12 Click above the dimension to place it.
13 On the Design Bar, click Modify.

**Label the dimension to create a Height parameter**

14 Select the dimension that you just placed.
15 On the Options Bar, for Label, select Add parameter.
16 In the Parameter Properties dialog:
   - Under Parameter Data, for Name, enter **Height**.
   - For Group parameter under, select Dimensions.
   - Click OK.
     Do not lock the parameter, as you want to be able to adjust the height of the window.
   - On the Design Bar, click Modify.
     The new Height parameter displays.

Next, you add 2 horizontal reference planes that you will use to align the window head and window sill at a specific distance from the rough opening. This distance is normally specified by the window manufacturer.

**Add 2 reference planes to align both detail components**

17 Zoom to the right of the reference plane intersections.
18 On the Design Bar, click Ref Plane.
19 On the Options Bar:

■ Click (Pick Lines).

■ For Offset, enter 1/4".
  This is the clearance between the window and the rough opening.

20 Place the cursor on the upper horizontal reference line, move it slightly downward, and click to place the reference plane.

21 Place the cursor on the lower horizontal reference line, move it slightly upward, and click to place the reference plane.

22 On the Design Bar, click Modify.

23 Dimension and constrain the upper reference planes to each other:

■ Zoom to the upper horizontal reference planes.

■ On the Design Bar, click Dimension.

■ Select the upper horizontal reference plane.

■ Select the lower horizontal reference plane.

■ Click below the dimension to place it.

■ Click to lock the alignment.

24 Using the same method, dimension and lock the 2 bottom reference planes.

Next, you load the window head and window sill detail components into the Wood Window Detail family, and position them on the 2 inner reference planes.

Add the window head and window sill detail components

25 Load the window head component in the project:

■ On the Design Bar, click Detail Component.

■ In the alert dialog, click Yes to load a Detail Items family into the project.

■ In the left pane of the Open dialog, click Training Files.
■ Open Imperial\Families\Detail Components, and select Window_Head.rfa.
■ Click Open.

26 Add the window head to the drawing area:
■ In the Type Selector, verify Window Head is selected.
■ Click to specify a placement point below the upper horizontal reference planes. Alignment with the reference planes is not necessary at this point. You use the Align command later to align the head and sill with the reference planes.

■ On the Design Bar, click Modify.

27 Load the window sill component:
■ On the Design Bar, click Detail Component.
■ On the Options Bar, click Load.
■ In the left pane of the Open dialog, click Training Files.
■ Open Imperial\Families\Detail Components, and select Window_Sill.rfa.
■ Click Open.

28 Add the window sill:
■ In the Type Selector, verify Window Sill is selected.
■ Locate the sill above the lower horizontal reference planes but below the window head, and click to place it.
29 Align the window head with the reference planes:

- On the Tools toolbar, click Align.
- Select the Center (Left/Right) reference plane.
- Select the top window head component on the right face of the wall fastener plate, as shown.

- Click to lock the alignment.
- Select the lower horizontal reference plane that displays above the window head.
- Select the top edge of the window head component.
Click to lock the alignment.

30 Align the window sill with the reference planes:
  - Select the Center (Left/Right) reference plane, which represents the face of a wall.
  - Select the right edge of the sill wall fastener plate, and click .
  - Select the upper of the 2 lower horizontal reference planes that display below the window sill.
  - Select the bottom edge of the sill detail component, and click .

Next, you test (flex) the detail component family to ensure that the window head is constrained to the reference planes. When you adjust the value of the height parameter, the window head will move up or down.

Flex the family

31 On the Design Bar, click Family Types.
32 In the Family Types dialog:
  - Under Dimensions, for Height, enter 1’.
  - Click Apply.
    The window head repositions in relation to the lower horizontal reference plane.

  - Under Dimensions, for Height, enter 2’.
  - Click Apply, and click OK.
    The window head and sill are now in position and are constrained to reference planes in the detail component family. In the remainder of the tutorial, you add detail lines to the tutorial to complete the full window representation. You begin by adding reference planes that you use to connect the window head and sill details.
Add reference planes below the head and above the sill

33 On the Design Bar, click Ref Plane.
34 Sketch 2 reference planes as shown, beginning at the endpoint of the line on the far left of each component.

Dimension and constrain the reference planes at the window head

35 On the Design Bar, click Dimension.
36 Dimension the window head reference plane and the upper of the 2 new horizontal reference planes, as shown, and lock the alignment.
Next, you add 6 lines with endpoints that are constrained to the reference planes. You sketch one line and constrain it, and then you copy it so you don’t have to constrain each line.

**Sketch and constrain the first line**

37 Add the first line:
- On the Design Bar, click Lines.
- In the Type Selector, select Light Lines.
- While pressing *SHIFT*, select a start point on the top horizontal reference plane. Pressing *SHIFT* constrains you to drawing only vertical or horizontal lines.

Select the parallel point on the bottom reference plane.
- On the Design Bar, click Modify.
Select the line that you just drew, and click the locks that display near the upper and lower reference planes.

Copy the line to create another constrained line

38 Place copies of the line using endpoints so that you have 6 connecting lines:

- With the line selected, on the Tools toolbar, click (Copy).
Click the upper end point on the original constrained line to specify the move start point.
Move the cursor to the left, and click the end of the upper vertical line, as shown.

The vertical lines on the head and sill are connected by the copied line. There are 5 additional sets of vertical lines to connect. Notice that locks display on the horizontal reference planes, indicating that relationship to the reference planes has been copied along with the line.

On the Design Bar, click Modify.

39 Repeat until all 6 sets of vertical lines connect.
40 Select and delete the original constrained line. The connecting lines will not stretch between the 2 details when the height is adjusted.

41 Zoom out so you can see the full window detail and the Height parameter.

Next, test the family by changing the value of the Height parameter. If all the constraints are working properly, the window detail will resize vertically as the value of the Height parameter changes.

Flex the Height parameter

42 On the Design Bar, click Family Types.

43 In the Family Types dialog:
   ■ Under Dimensions, for Height, enter 1'.
   ■ Click Apply.
      The window detail resizes to reflect the new vertical height.
Under Dimensions, for Height, enter 1'6".

Click Apply.
The window detail resizes to reflect the new vertical height.

Click OK.

44 Save the detail component family, but do not close it.
   In the next exercise, you nest (insert) the full window detail component into a window family.

45 Proceed to the next exercise, Adding the Full Window Detail Component to a Window Family on page 215.
Adding the Full Window Detail Component to a Window Family

In this exercise, you nest the window detail component family in a window family to create a new window family. You then set the visibility of the detail component in the window family to display only in cut views and at a fine detail level.

After you create the new family, you open an art gallery project and replace a gallery window with one that features the new window family type. You cut a section through the window and wall, change the window type, and then change the detail level in the view to display the window detail.

Open the window family in which to nest the detail component family

1. With the Wood_Window_Detail family open, click File menu ➤ Open.
2. In the left pane of the Open dialog, click Training Files, and open Imperial\Families\Windows.
3 Select M_Casement_with_Trim.rfa, and click Open.

**Load the detail component in the window family**

4 Click Window menu ➤ Wood_Window_Detail.rfa - Floor Plan: Ref. Level.

5 On the Design Bar, click Load into Projects.

6 If the Load into Projects dialog displays, select Casement_with_Trim.rfa, and click OK.

   The Casement_with_Trim family opens.

**Add the detail component to the left elevation view of the window**

7 In the Project Browser, expand Views ➤ Elevations (Elevation 1), and double-click Left.

8 Zoom in to the middle of the window.

9 In the Project Browser, expand Families ➤ Detail Items ➤ Wood_Window_Detail.

10 Drag the Wood_Window_Detail into the view.

11 In the Work Plane dialog:
   - Under Specify a new Work Plane, for Name, select Reference Plane:Left.
Click OK.

12 In the drawing area, click to place the detail component to the right of the window. Exact placement is not necessary, as you align and position the detail in the following steps.

13 On the Design Bar, click Modify.

**Align and position the detail**

14 On the View Control Bar, click the current scale, and click 11/2" = 1'-0".
15 Zoom in to the bottom of the detail.
16 Align and lock the detail component to the sill reference plane:
   - On the Tools toolbar, click (Align).
   - Select the Sill reference plane.
   - Select the reference line below the bottom edge of the sill detail.

**NOTE** Make sure that you select the reference line below the bottom of the sill, and not the bottom edge graphic. There is a tolerance gap so that the window can be easily fitted into the rough opening.
17 Align and lock the detail component to the window offset plane:

- Select the window offset reference plane (second vertical reference plane from the left).
- Select the right edge of the sill wall fastener plate.
18 On the Design Bar, click Modify.

Link the detail component Height parameter to the window family height

19 Select the detail component, and on the Options Bar, click (Element Properties).
20 In the Element Properties dialog, click Edit/New.
21 In the Type Properties dialog:
   ■ Under Dimensions, for Height, click .
   ■ In the Associate Family Parameter dialog, select Height.
22 Click OK 3 times.
23 On the Design Bar, click Modify.

Flex the family

24 On the Design Bar, click Family Types.
25 In the Family Types dialog:
   ■ For Name, select 36” x 24”.
   ■ Click Apply.
      The window and detail component resize.
Click OK.

Set the visibility so that the detail component displays in fine detail only

26 Select the detail component, and on the Options Bar, click Visibility.
27 In the Family element visibility settings dialog:
   - Under Symbolic Element Visibility, select Show only if Instance is cut. The full window detail will show in a section view.
   - Under Detail Levels, clear Coarse and Medium. The embedded full window detail now shows only in fine detail.
   - Verify that Fine is selected.
   - Click OK.

Turn off detail component geometry in 3D views

28 In the Project Browser, under 3D Views, double-click View 1.
29 On the View toolbar, click ![SteeringWheels].
30 Spin the window until it displays as shown.
31 On the Design Bar, click Modify.
32 Select the detail component geometry, including the window detail.

33 Click (Filter Selection).
34 Clear Other to remove the window detail from the selection.
35 Click OK.
36 On the Options Bar, click Visibility.
37 In the Family Element Visibility Settings dialog, under Detail Levels, clear Fine.
   The window model geometry will not be seen in a fine detail view.
38 Click OK.
39 On the Design Bar, click Modify.

Save the new window family for use in multiple projects

40 Click File menu ➤ Save As.
41 In the Save As dialog, navigate to Imperial\Families\Windows, and save the window family as
   Casement_with_Trim_and_Details.rfa, but do not close it.
Load the new window family into the art gallery project

42 Open the art gallery project:
   ■ Click File menu ➤ Open.
   ■ In the left pane of the Open dialog, click the Training Files icon.
   ■ Navigate to the Imperial folder, select i_art_gallery.rvt, and click Open.

43 Minimize the art gallery project, but do not close it.
44 In the Casement_with_Trim_and_Details family, on the Design Bar, click Load into Projects.
45 In the Load into Projects dialog, select i_art_gallery.rvt, and click OK.
   The art gallery project displays as the current project.

Create a section view that cuts through the right exterior wall of the art gallery

46 In the Project Browser, under Floor Plans, double-click Level 1.

47 On the Basics tab of the Design Bar, click Section.
48 In the Type Selector, verify that Section: Building Section displays.
49 Draw a section line through the right exterior wall at a window location:
   ■ Specify a point inside a window.
   ■ Move the cursor to the right (outside the window), and specify an endpoint for the section line.
Open the new section view and view the window

50 In the Project Browser, under Sections, double-click Section 2.

51 Zoom in to the window, and select it.
   The current window type displays in the Type Selector.

Replace the window with a Casement_with_Trim_and_Details window type

52 With the window still selected, in the Type Selector, select Casement_with_Trim_and_Details : 36'' x 48''.

53 On the View Control Bar, select Detail Level: Fine.

54 Zoom in to the window and view the nested detail component.
55 Save and close all open drawings.
Creating Planting Families

In this lesson, you create a planting symbol family that contains existing planting and new or proposed planting. The plants are represented in plan by a base symbol, representing either an existing species (dashed lines) or a proposed new plant (solid lines) having a unique plan symbol, which differentiates it from other species. The planting family requires unique plan symbols and they are created separately as a base family before being nested within a project planting family.

In the project planting family a 2D plan symbol is matched with a realistic representation of the tree species. The 2D plan symbol displays only in plan views. A plant outline displays for elevations and in 3D views a realistic plant image is available for rendering. The third part content used for the exercise is delivered with the product - RPC content from Archvision.
To create the planting symbol family, you begin by creating the base symbol - a plan symbol with one model line to represent the plant height. You then import the base family into another family, where you create family types and assign both the plan symbol and RPC rendering assignments as parameters. This technique lets you match symbolic plan symbols (2D) to specific species.

In the final exercise in this lesson, you use the family types that you created to add multiple trees to a project. After you add the trees, you render a 3D scene to view the results.

Creating the Existing Plant Base Family

In this exercise, you create a base family that represents an existing plant symbol in plan and create constraints to relate the plant canopy width to plant height.

When you create the plan view representation of the tree, you use symbolic lines to sketch the trunk and canopy. You then add a single model line to represent the height of the tree. This model line is used to relate the plan symbol canopy width to the plant height. In the example, a mature gray birch tree has a canopy diameter of 20’ and a height of 40’ (a 1:2 ratio). The purpose of the model line is to establish the ratio of canopy width to height for the plant species and ensures that the plan symbol changes in proportion to the height. This ratio would vary depending on plant species. A Gray Birch is a 1:2 ratio (canopy width to height). Later, you create a species base (01 Deciduous Tree Base) for use with a Japanese Maple and a Flowering Cherry. Both of these plants have a 1:1 ratio (canopy width to height). You use these species as examples in creating a project planting family.
You use a single model line, constrained between reference planes, to establish the height.

**Create a new family with the Planting template**

1. Click File menu ➤ New ➤ Family.
2. In the left pane of the New Family dialog, click Training Files, and open Imperial/Templates/Planting.rft.
   
   The new family file opens in the Family Editor.
3. Save the planting family:
   - Click File menu ➤ Save As.
   - In the Save As dialog, for File name, enter **Existing Plant Base**, and click Save.
     
     The new family is saved as an RFA file.
     
     Next, you sketch the symbolic plan symbol.

**Sketch a plan symbol**

4. In the Project Browser, expand Views (all) ➤ Floor Plans, and double-click Ref. Level.
5. If necessary, maximize the view.
6. Sketch the canopy circumference:
   - On the Design Bar, click Symbolic Lines.
     Symbolic lines only display parallel to the view in which they are sketched. Symbolic line geometry, in this case represents an existing plant.
   - On the Options Bar, click \[\text{Circle}\], and click \[\text{Circle}\].
   - Select Radius, enter 10', and press **ENTER**.
   - Select the intersection of the horizontal and vertical reference planes to specify the center of the circular canopy.
7 Sketch a trunk circumference:
- With the command still active, on the Options Bar, change the radius value to 6”, and press `ENTER`.
- Select the reference plane intersection. The trunk and canopy circumference display as solid black lines, but you want to display them as dashed lines to represent existing plants in plan views. To accomplish this, you change the Object Styles settings, which control the line weight, line color, line pattern, and material of the family.

Object Style settings are arranged in categories and subcategories. Subcategories allow you to assign different settings to specific elements of the family, without affecting the other elements.
Change Object Styles settings

8 Click Settings menu ➤ Object Styles.

9 In the Object Styles dialog, verify that the Model Objects tab displays, and view the Category information.

This family currently has a Planting category and a Hidden Lines subcategory. You add an Existing Plants category that displays objects assigned to it with a dashed line pattern.

10 Create a subcategory:
   ■ Under Modify Subcategories, click New.
   ■ In the New Subcategory dialog, for Name, enter Existing Plants.
   ■ Click OK.
   ■ In the Existing Plants Category, click the Line Pattern value, and select Long Dash.
   ■ Click OK.

The new Existing Plants subcategory exists, but both the canopy and trunk still display with solid lines. You need to apply the new category to the canopy and trunk.

Assign the Existing Plant category

11 On the Design Bar, click Modify.

12 While pressing CTRL, select both circles.

13 In the Type Selector, select Existing Plants.

The canopy and trunk circumferences display as dashed lines.

Next, you add the model line to represent the height of an existing tree.

Constrain the model line to reference planes in an elevation view of the tree

14 In the Project Browser, under Elevations, double-click Front.

15 On the Design Bar, click Ref Plane and draw a horizontal plane above the reference level.

16 On the Design Bar, click Dimension, and dimension the 2 reference planes.

17 On the Design Bar, click Modify.

18 Select the dimension, and on the Options Bar, for Label, select Height, and click OK.

19 On the Design Bar, click Family Types. Under Dimensions, enter 40’ for Height, and click OK.

This is for an existing species where the ratio of the canopy width to the height is 1:2.
20 Sketch the model line representing the tree height:
- On the Design Bar, click Model Lines.
- Select the lower reference plane intersection, drag the cursor vertically up and select the upper reference plane.

21 On the Design Bar, click Modify.

22 Select the vertical model line and lock both ends and the alignment with the plane (3 locks total).

Make the model line invisible

23 On the Design Bar, click Modify.

24 In the Front elevation view, select the model line.

25 Right-click, and click Element Properties.

26 Under Graphics, clear Visible.

You will see the model line in the Family Editor, but not in a project.

Create family types for the base symbol

27 On the Design Bar, click Family Types.

28 In the Family Types dialog, click New.

29 For Name, enter 1-2 (for a 1:2 ratio), and click OK.

30 Click Apply.

31 Under Family Types, click New.

32 For Name, enter 1-1, and click OK.

33 Under Dimension, for Height, enter 20'.

34 Click OK.

35 Click File menu ➤ Save.

36 Proceed to the next exercise, Creating a Species Base Family on page 231.
Creating a Species Base Family

In this exercise, you create a base plant symbol for a deciduous tree (a new plant species symbol). The tree is assumed to be a Japanese Maple or Japanese Flowering Cherry with a 20' canopy and a height of 20'.

The steps are similar to the previous exercise. You create a plan view of the base with symbolic lines and a constrained model line in an elevation view.

**Plan view**

![Plan view diagram of a deciduous tree base family](image)

**Create a deciduous tree base family**

1. Create a new family with the Planting.rft template, and save it as 01 Deciduous Tree Base.rfa.

   **NOTE** In practice you would have multiple base symbols that differentiate between species.

**Sketch a symbolic view of the tree in plan view**

2. In the Project Browser, under Floor Plans, double-click Ref. Level.
4. On the Options Bar:
   - Click ▼, and click □ (Circle).
   - Verify that Radius is selected, enter 10', and press ENTER.
5. Select the intersection of the reference planes to place the canopy radius.
6 On the Options Bar, click (Line).
7 Sketch the plan view of the symbol, as shown.

Constrain a model line to reference planes in an elevation view of the tree

8 In the Project Browser, under Elevations, double-click Front.
9 On the Design Bar, click Ref Plane, and draw a horizontal plane above the reference level.
10 On the Design Bar, click Dimension, and dimension the 2 reference planes.
11 On the Design Bar, click Modify.
12 Select the dimension, and on the Options Bar, for Label, select Height.
13 On the Design Bar, click Family Types. Under Dimensions, enter 20' for Height, and click OK. This dimension is for a species where the ratio of the canopy width to the height is 1:1.
14 Sketch the model line representing the tree height:
   ■ On the Design Bar, click Model Lines.
Select the lower reference plane intersection, drag the cursor vertically up and select the upper reference plane.

15 On the Design Bar, click Modify.
16 Select the vertical model line and lock both ends and the alignment with the plane (3 locks total).

**Make the model line invisible**

17 On the Design Bar, click Modify.
18 In the Front elevation view, select the model line.
19 Right-click, and click Element Properties.
20 Under Graphics, clear Visible, and click OK.

You will see the model line in the Family Editor but not in a project.

**Create a family type for the base symbol**

21 On the Design Bar, click Family Types.
22 In the Family Types dialog, click New.
23 For Name, enter 1-1 (for a 1:1 ratio).
24 Click OK twice.
25 Click File menu ➤ Save, and close the family.
26 Proceed to the next exercise, Creating a Planting Symbol Family on page 233.

---

**Creating a Planting Symbol Family**

In this exercise, you create a planting library, such as might be used for a project. To use the plan symbols, you nest the base families that you created in the previous exercises in the new planting family.

After you create the family, you add new family types - an existing Gray Birch tree, an existing Japanese Maple, and a proposed Japanese Flowering Cherry. To differentiate the trees, you modify Family Categories and Settings so you can use third party content with actual images for species. You then create a family type parameter so you can assign the plan symbol, and you add rendering assignments and plant heights that control the RPC content for each type. In the final exercise of this lesson, you add the existing Gray birch and Japanese Maple, and new Flowering Cherry types to a project, where you view the differences in height and rendered appearance.

**Create a planting family**

1 Create a family with the Planting.rft template, and save it as Project Planting.rfa.

**Change settings so you can add third party content.**

2 Under Settings, click Family Categories and Parameters.
3 For Rendering Appearance Source, click the value, select Third Party from the drop-down list, and click OK.

A default Red Ash placeholder appears in the view.

4 On the Design Bar, click Family Types to see the Render parameters that were added.

**Create a Family Type parameter that will be used to assign the plan symbol**

5 On the Family Type dialog, for Parameters, click Add.
6 For Name, enter plan_symbol.
7 For Type of Parameter, select Family Type, and click Planting.
This will let you assign nested base symbols. If you have no planting symbols loaded, you are prompted to load them.

8 Click OK twice.
9 Click Yes to load a planting family in the project.

Nest the base family in the symbol family

10 Browse to the location of Existing Plant Base.rfa, and click Open.
11 In the Family Types dialog, click OK.
12 On the Design Bar, click Component.
13 On the Options Bar, click Load.
14 Browse to the location of 01 Deciduous Tree Base, and click Open.
15 On the Design Bar, click Modify.

Both base families are now nested in the planting family.

Create family types with assignments

16 On the Design Bar, click Component.
17 In the Type Selector, select Existing Base:1-2.

This is the symbol suitable for a Gray Birch.

18 Select the reference plane intersection to place the plant base.

The symbolic plan view of the existing plant base that you created in the previous exercise displays.

19 On the Design Bar, click Modify.
20 Select the symbol.
21 On the Options Bar, for Label, select plan_symbol.

Define an existing plant type

22 On the Design Bar, click Family Types.
23 Create an existing birch tree type:

- In the Family Types dialog, under Family Types, click New.
- In the New dialog, for Name, enter Existing Gray Birch 20' Canopy, and click OK.
Under Dimensions, for Height, enter 40'. This is the height of the rendering assignment.

Under Identity Data, for Render Appearance, click Red Ash (Fall).

In the Render Appearance Library dialog, for Class, select Trees [General], select Gray Birch, and click OK.

Under Identity Data, for Description, enter Betula populifolia.

Under Other, for plan_symbol, select Existing Plant Base 1-2.

Click OK.

Hide the placeholder in plan and RCP views

24 Select the RCP placeholder.
25 Right-click, and select Element Properties.
27 In the Family Element Visibility Settings dialog, clear Plan/RCP, and click OK twice. You continue to see the placeholder in the Family Editor but not in a project.
28 On the Design Bar, click Modify.

Create an existing Japanese Maple

29 Using the same method, create an existing Japanese Maple:
   ■ In the Family Types dialog, under Family Types, click New.
   ■ In the New dialog, for Name, enter Existing Japanese Maple 20' Canopy, and click OK.
   ■ Under Dimensions, for Height, enter 20'. This is the height of the rendering assignments.
   ■ Under Identity Data, for Render Appearance, select Class: Trees [General], select Japanese Maple, and click OK.
   ■ Under Identity Data, for Description, enter Acer palmatum.
   ■ Under Other, for plan_symbol, select Existing Plant Base 1-1, as this tree is usually as wide as it is high.
   ■ Click OK.

Create an proposed Flowering Cherry

30 Using the same method, create a Flowering Cherry:
   ■ In the Family Types dialog, under Family Types, click New.
   ■ In the New dialog, for Name, enter Flowering Cherry 20' Canopy, and click OK.
   ■ Under Dimensions, for Height, verify that the value is 20'.
   ■ Under Identity Data, for Render Appearance, select Class: Trees [General], select Japanese Flowering Cherry, and click OK.
   ■ Under Identity Data, for Description, enter Prunus serrulata.
   ■ Under Other, for plan_symbol, select 01 Deciduous Tree Base 1-1, as this tree is usually as wide as it is high.
   ■ Click OK.
Click File menu ➤ Save, and close the family.

Proceed to the next exercise, Testing Your Planting Families on page 236.

Testing Your Planting Families

In this exercise, you add existing and new plant symbols to the art gallery project to verify that they display as designed.

At the end of the exercise, you render a 3D view to display the materials assigned to the different trees. The differences in height and materials are visible in the scene.

Open the art gallery project

1 Click File menu ➤ Open.
2 In the left pane of the Open dialog, click Training Files, and open Imperial\i_art_gallery.rvt.
3 In the Project Browser, under Floor Plans, double-click Site.
4 On the View Control Bar, click Model Graphics Style, and select Hidden Line.

Add existing and new planting symbols

5 On the Basics tab of the Design Bar, click Component.
6 On the Options Bar, click Load.
7 In the Open dialog:
   ■ Browse and select Project Planting.rfa.
Click Open.

8 In the Type Selector, select Existing Gray Birch 20’ Canopy, and place it in the drawing, as shown.

9 Select and place one Existing Japanese Maple 20’ Canopy to the right of the entry.

10 Place 3 Flowering Cherries 20’ Canopy between the path and the building.
Render a 3D view

11 In the Project Browser, under Views, Expand 3D Views, and double-click 3D View 1.
12 On the Rendering tab of the Design Bar, click Rendering Dialog.
13 For Quality, select Medium.
14 Click Render.
15 When the on-screen rendering is complete, on the Rendering dialog, click Export, and save the image as Project Trees.jpg.

When the rendering is finished, the trees that you added are visible. Because you applied materials to each planting family, you can distinguish the different types of trees in the scene.

16 Save and close the project.
Tutorials: 3D
Component Families
Creating a Window Family

In this tutorial, you create a custom window family based on the definition of a fixed rectangular window with 9 lights. You create a grille and mount it on the exterior of the window to create the appearance of 9 equally spaced lights. You use a sweep to create the window frame, and extrusions for the sash, glazing, and grille (mullions). You then assign parameters to the window family to allow for the creation of different-sized versions of the 9-light prototype. You create and directly assign materials (glass and a pine finish) to the window components.

Finally, you assign new dimension values to the window to create new types within the window family.
Specifying the New Window Parameters

In this exercise, you specify the parameters for the new window family. The window type has a variable height and width, equally spaced vertical mullions, and an adjustable height of the top and bottom row of lights.

Create a new family based on the default window template

1. Close any open projects or families.
2. Click File menu ➤ New ➤ Family.
3. In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Window.rft
5. Enter ZF (Zoom to Fit).
6. Two dimension strings display with their labels, Height and Default Sill Height. The label name, also one of the window properties, is one of the type parameters. When you add labels to dimensions, these specific type parameters are adjustable after the window is part of a project.

Modify the new window type height and width parameters

7. On the Design Bar, click Family Types.
   Move the dialog so that you can see the window opening.
8. In the Family Types dialog, specify the following:
   ■ Under Dimensions, for Height, enter 4' 6".
   ■ For Width, enter 6' 0".
   ■ Click Apply.
   Change the height and width values again, and click Apply. Notice how the window opening adapts to the changing dimension values. This process is called "flexing the model," and is done to detect conflicting or missing constraints and to ensure that all model geometry adjusts to changes as designed.
9. In the Family Types dialog:
   ■ For Height, enter 4' 0".
   ■ For Width, enter 8' 0".
   ■ Click Apply, and click OK.
   This is the starting point for the new window.
10 Click File menu ➤ Save.

11 Navigate to the location of your choice and save the new window family with the name, *Training Window.rfa*.

12 Proceed to the next exercise, *Creating the Window Frame Solid Geometry* on page 243.

### Creating the Window Frame Solid Geometry

In this exercise, you use a sweep to create the solid geometry of the window frame. To create sweep geometry, you first sketch the sweep path and then sketch the sweep profile. The profile is swept along the path to create the solid geometry.

**Create a sweep path for the window frame solid geometry**

2. On the Design Bar, click Sketch 2D Path.
4. On the Options Bar, click .
5. Starting at the upper-left corner of the opening and ending at the lower right corner, sketch a rectangle to represent the sweep path.

6. Click all 4 symbols to lock the sweep to the opening size.
7. On the Design Bar, click Finish Path.
Add a reference plane for the sweep profile

8. On the Design Bar, click Sketch Profile.
9. In the Go To View dialog, select Elevation: Right, and click Open View.
10. On the View Control Bar, click the Scale control, and select 1/2" = 1'-0".
12. Zoom in to the red dot in the middle of the wall.

The red dot indicates the intersection of the sweep path and the profile plane.

14. On the Options Bar, click (Pick Lines), and for Offset, enter 0' 2 1/4".
15. Pick the exterior wall face so that a reference line is offset to the left of the exterior wall face as shown.

17. On the Options Bar, for Prefer, select Wall faces.
18. Add a dimension between the exterior wall face and the new reference plane.
19. On the Design Bar, click Modify, and select the dimension.
20. Use the Drag text control to move the dimension value off to the side as shown.


22. Select the new reference plane, and on the Options Bar, click (Element Properties).

23. In the Element Properties dialog, under Identity Data, for Name, enter Sash, and click OK.
   The Sash reference plane is used later as an active work plane for creation of the sash.

**Sketch the window frame profile**


25. On the Options Bar, select Chain, and click (Line).

26. Below the red dot, sketch the frame profile approximately as shown.

   **NOTE** When you sketch the frame profile, the exact dimensions are not critical. However, the frame profile should extend beyond the edges of the wall so that there are no implied constraints. Precise dimensions are assigned to the frame profile in subsequent steps to fix the size of the sketch shape.

27. On the Design Bar, click Modify.

28. Select the right edge of the frame profile, and drag it to the exterior face of the wall.
29 Click □ to constrain the frame to the exterior wall face.

30 Select the left edge of the frame profile, drag it to the interior face of the wall, and click □.

31 Select the short line parallel and to the right of the Sash reference plane. Drag it to the left, align it with the Sash reference plane, and click □.
32 On the Design Bar, click Dimension.

33 Add a vertical dimension of 0' 1 1/2'' to the left side of the frame and another vertical dimension of 0' 0 3/4'' to the right side of the frame, as shown.

**TIP** After adding the dimension, click Modify, select the line you want to move, and specify the dimension value.

Modify each dimension if necessary.

**Align the new profile to the window opening edge**

34 Select the 0' 1 1/2'' dimension, and click .
TIP If you don’t see the lock icon, zoom out until it displays.

35 Using the same method, lock the other dimension.

36 On the Tools toolbar, click \( \text{(Align)}. \)
37 Align to the top of the window opening:
   - Select the Top reference plane (intersects the red dot); this is the top of the window opening.
   - Select the top horizontal line of the frame profile.
   - Click \( \text{.} \)

38 On the Design Bar, click Finish Profile.
39 On the Design Bar, click Finish Sweep.

   The window frame profile is swept around the window opening.

40 In the Project Browser, under Views (all), expand 3D Views, and double-click View 1.
41 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

42 If necessary, on the View toolbar, click \( \text{(SteeringWheels)}, \) and spin the model so you can see the interior of the frame.
In the Project Browser, under Elevations, double-click Exterior.

Click File menu ➤ Save.

Proceed to the next exercise, Creating the Window Sash Solid Geometry on page 249.

Creating the Window Sash Solid Geometry

In this exercise, you use an extrusion to create the solid geometry of the window sash. You create 2 rectangular sketches, one inside the other. The inner sketch is interpreted as a void.

Specify the window sash extrusion parameters

1 On the Design Bar, click Solid Form ➤ Solid Extrusion.
2 On the Design Bar, click Set Work Plane.
3 In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane: Sash, and click OK.
4 On the Design Bar, click Lines.
5 On the Options Bar:
   ■ Click (Pick Lines).
   ■ For Depth, enter - 0' 2".
   ■ Select Lock.
NOTE Viewed from the exterior, with the work plane on the Sash reference plane, a negative number for depth ensures the sash will extrude toward the inside of the window.

Pick the sash profile lines

6 Place the cursor over the center line on the left side of the frame, press TAB to cycle through the selection options, and select the option, Chain of walls or lines.

The entire sash outline is selected, and lock icons display on each line. This is the outer rectangular sketch for the frame.

Draw offset extrusion lines

7 On the Options Bar:

- Click (Draw).
- For Offset, enter - 0’ 2”.
  You specify a negative offset value to indicate an offset direction inside of the window frame.
- Click .

8 To sketch the rectangle, select the upper left outside corner of the window frame, and then select the lower right outside corner.
  The resulting inner rectangle is offset by the specified distance.
9 On the Design Bar, click Finish Sketch. The inner rectangle is interpreted as a void.

10 In the Project Browser, under Elevations, double-click Right.

11 In the Project Browser, under 3D Views, double-click View 1.
Spin the model if necessary to view the sash and frame at various angles.

The window sash extrusion is now complete.

12 Click File menu ➤ Save.
13 Proceed to the next exercise, Creating the Window Glass Solid Geometry on page 252.

Creating the Window Glass Solid Geometry

In this exercise, you use an extrusion to create the solid geometry of the window glass.

Add a named reference plane for Glazing.

1 In the Project Browser, under Elevations, double-click Right.
2 On the Design Bar, click Ref Plane.
3 On the Options Bar, click (Pick Lines), and for Offset, enter 0' 1 1/2".
4 Select the left edge of the sash so that a vertical reference plane is added to the right, as shown.

5 On the Design Bar, click Dimension.
6 Dimension the left edge of the sash and the new reference plane.
7 Drag the dimension text to the right, as shown:

8 On the Design Bar, click Modify.
9 Select the reference plane, and on the Options Bar, click (Element Properties).
10 In the Element Properties dialog, under Identity Data, for Name, enter Glazing, and click OK.
You can later specify that you want the work plane to match the named reference plane, so you create the glazing sketch at the correct location.

11 In the Project Browser, under Elevations, double-click Exterior.

**Pick lines to define the glass extrusion**

12 On the Design Bar, click Solid Form ➤ Solid Extrusion.
13 On the Design Bar, click Set Work Plane.
14 In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane: Glazing, and click OK.
15 On the Design Bar, click Lines.
16 On the Options Bar:
   - Click (Pick Lines).
   - For Depth, enter 0 0 1/2".
   - Select Lock.

17 Select each of the sash extrusion lines to create the glass boundary.

18 On the Design Bar, click Finish Sketch.

**View the window model with frame, sash, and glass**

19 In the Project Browser, under Elevations, double-click Right.
20 Select the glass extrusion.
21 On the Options Bar, click (Element Properties).

22 In the Element Properties dialog, under Identity Data, for Subcategory, select Glass, and click OK.

**NOTE** Assigning subcategories to model elements is important. After the family is loaded into a project, you can control subcategory visual style using the Objects Styles dialog.

23 On the Design Bar, click Modify.

24 In the Project Browser, under 3D Views, double-click View 1.

Spin the model if necessary to view the sash and frame at various angles.
Flex the window model

25 On the Design Bar, click Family Types. Move the Family Types dialog off to the side so you can see the window model.

26 In the Family Types dialog:
   ■ Under Dimensions, for Height, enter 6’ 0”.
   ■ For Width, enter 6’ 0”.
   ■ Under Other, for Default Sill Height, enter 2’ 0”.
   ■ Click Apply.

Notice that the window adapts to the new dimension parameters.
NOTE After flexing the model, it is important to verify that all model elements adapted to the changes as expected. For example, make sure the window frame stretched with the opening and that the glass extrusion remains attached to the interior edge of the sash. You should flex the model at regular intervals to catch problems early. Most problems can be resolved by aligning and locking lines.

27 Click Cancel.

28 On the Edit toolbar, click (Undo) to return the window to its original dimensions.

29 Click File menu ➤ Save.

30 Proceed to the next exercise, Creating the Window Mullion Solid Geometry on page 257.

Creating the Window Mullion Solid Geometry

In this exercise, you use reference planes and extrusions to create the solid geometry of the window mullions.
Add reference planes to specify mullion centerline locations

1. In the Project Browser, under Elevations, double-click Exterior.
2. On the Design Bar, click Ref Plane.
3. Add 2 horizontal and 2 vertical reference planes inside the window opening to approximate the mullion centerline locations, as shown.

**NOTE** When you draw each reference plane, the exact location is not critical. You assign precise dimensions to the reference planes in subsequent steps.

5. Add a multi-segmented dimension referencing all of the vertical reference planes except the Center (Left/Right), as shown.
6. Click the EQ symbol to make the dimension segments equal.

Using the equal constraint is one way to incorporate your design intent for equal spacing. Another way is to use length parameters and formulas, which you will do in subsequent steps for the horizontal spacing of the window grille (mullions).
7 Add a dimension between the Top reference plane of the window opening and the horizontal reference plane below it, as shown. Do not be concerned with dimension values.

8 Add a dimension between the Sill reference plane (bottom of the window opening) and the horizontal reference plane above it, as shown. Do not be concerned with dimension values.

Add a mullion offset family parameter

9 On the Design Bar, click Modify.
10 Select the dimension that references the top 2 horizontal reference planes.
11 On the Options Bar, for Label, select <Add parameter>.
12 In the Parameter Properties dialog:
   ■ For Parameter Type, select Family parameter.
   ■ Under Parameter Data, for Name, enter Mullion Offset.
   ■ Under Group parameter under, select Dimensions.
   ■ Select Instance.
      The choice of instance indicates your intent to allow a different value for Mullion Offset for each instance of the same window type.
   ■ Click OK.
13 On the Design Bar, click Family Types.
14 In the Family Types dialog, under Dimensions, for Mullion Offset, enter 1' 2", and click OK.

   **TIP** Due to the length of the dimension label, you may want to drag the dimension value as shown.

15 Select the horizontal reference plane second from the bottom.
   Notice the dimension value becomes editable.
16 Click the dimension value, enter 1'2", and press ENTER.
17 On the Design Bar, click Modify.
18 Select the dimension you just modified.
19 On the Options Bar, for Label, select Mullion Offset.
20 As you did before, move the dimension value.

21 On the Design Bar, click Modify.
The Mullion Offset value lets you control the horizontal spacing. The design intent at this stage is for mullions with equal distances from the top and bottom. The middle light height would vary depending on window height.

Create the vertical mullion extrusions

22 On the Design Bar, click Solid Form ➤ Solid Extrusion.
23 On the Design Bar, click Set Work Plane.
24 In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane: Glazing, and click OK.
   You are going to draft the mullions on the outside of the glass.
26 On the Options Bar, for Depth, enter 0' 0 5/8'', and click .
27 Sketch a rectangle centered on the left reference plane approximately as shown. Do not be concerned with precise dimensions. However, it is critical that the short horizontal lines align with the horizontal edges of the sash. Watch the Status Bar to be sure that the lines are snapping to the sash.
After you complete the sketch, notice that lock icons display on the interior horizontal edges of the sash.

28 Click both of the locks so that the mullion adapts to changes in window height.

29 On the Design Bar, click Dimension.
30 Dimension the mullion extrusion:
   ■ Select the left edge of the extrusion.
   ■ Select the vertical reference plane.
   ■ Select the right edge of the extrusion.
   ■ Place the dimension.
   ■ Click EQ.
   ■ On the Design Bar, click Modify.
   ■ Move the dimension text as shown.
31 Add a dimension from the left edge of the extrusion to the right edge of the extrusion, and place it above the EQ dimension.

32 On the Design Bar, click Modify, and select the left dimension you added.

33 On the Options Bar, for Label, select <Add parameter>.

34 In the Parameter Properties dialog:
   - For Parameter Type, select Family parameter.
   - Under Parameter Data, for Name, enter **Mullion Width**.
   - Under Group parameter under, select Dimensions.
   - Select Type. Selecting Type indicates that your intent is for Mullion Width to be consistent for all instances of the same window type.
■ Click OK.

Move the Mullion Width value to the left, as shown.

35 Using the same method, create an identical mullion centered on the right vertical reference plane as shown. Follow these basic steps:

■ Sketch the rectangle similar to the mullion on the left.

**NOTE** You are creating multiple rectangles as part of one sketch. You do not need to lock the second rectangle to the sash edge; it is locked automatically.

■ Dimension mullion edges and the reference plane at the center of the mullion, and click the equality constraint.

■ Add a dimension between the left and right mullion edges.

■ Select the dimension, and on the Options Bar, select Mullion Width for Label.

Do not be concerned with the value of the mullion width. This is changed in later steps.

36 On the Design Bar, click Finish Sketch.
Specify the mullion width parameter

37 On the Design Bar, click Family Types.

38 In the Family Types dialog, under Dimensions, for Mullion Width, enter 0’ 1 1/2”, and click Apply.
Notice that the mullions remain centered and equally spaced on the reference planes.

Flex the window model

39 In the Family Types dialog:
■ Under Dimensions, for Height, enter 6’ 0”.
■ For Width, enter 6’ 0”.
■ Under Other, for Default Sill Height, enter 2’ 0”.
■ Click Apply.
Notice that the window adapts to the new dimension parameters, and the mullions stretch with the new window height.

NOTE After flexing the model, it is important to verify that all model elements adapted to the changes as expected. In this case, you should pay close attention to the new mullions and make sure they remain centered, evenly spaced, and aligned with the sash edge. You should flex the model after making a change to catch problems early. It is best not to make too many changes before flexing so you can more easily identify which action in sketching, dimensioning, or assigning parameters caused any unexpected behavior. Most problems can be resolved by editing sketches, aligning and locking lines, or undoing the same.

40 Click Cancel.

41 On the Edit toolbar, click (Undo) to return the window to its original dimensions.
Sketch the horizontal mullion extrusions

42 On the Design Bar, click Solid Form ➤ Solid Extrusion.
43 On the Design Bar, click Set Work Plane.
44 In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane: Glazing, and click OK.
45 On the Design Bar, click Lines.
46 On the Options Bar, click (Rectangle).
   Notice that the Depth value on the Options Bar remains at the previously specified value.
47 Sketch a rectangle centered on the upper horizontal mullion reference plane approximately as shown, and then lock the left and right edges to the edge of the sash.

48 Using the method used previously, add an EQ dimension and an overall dimension to the new mullion.

49 On the Design Bar, click Modify, and select the overall dimension you added in the previous step.
50 On the Options Bar, for Label, select Mullion Width.
51 Move the dimension value as shown.
52 Using the same method, create an identical mullion centered on the lower horizontal reference plane, and dimension it, as shown:

53 On the Design Bar, click Finish Sketch.
Join the mullion geometry

54 Click Tools menu ➤ Join Geometry.
55 Select the horizontal mullions, and then select the vertical mullions.

56 In the Project Browser, under 3D Views, double-click View 1.
If necessary, spin the model to get a good view of the mullions. Notice the mullion extrusions are joined.

Flex the window model

57 On the Design Bar, click Family Types.
In the Family Types dialog:

- Under Dimensions, for Height, enter 6’ 0”.
- For Width, enter 6’ 0”.
- Under Other, for Default Sill Height, enter 2’ 0”.
- Click Apply.

Notice that the window adapts to the new dimension parameters and the mullions stretch with the new window height.

59 Click Cancel.

60 On the Edit toolbar, click (Undo) to return the window to its original dimensions.

61 Click File menu ➔ Save.

62 Proceed to the next exercise, Assigning Materials to the Window Components on page 269.

### Assigning Materials to the Window Components

In this exercise, you assign materials to the frame, sash, and mullions that you want to display in renderings of the new window. Assigning the materials directly in the Family Editor assumes that the materials are not changeable in a project. The assumption, in this exercise, is that you are creating a window with materials as available from the manufacturer.
Create a new material based on the existing yellow pine material

1. Click Settings menu ➤ Materials.
2. In the Materials dialog, click Duplicate.
3. In the New Material dialog, for Name, enter Pine Frame, and click OK.
4. On the Render Appearance tab, click Replace.
5. In the Material Library dialog, navigate to Wood, Pine, Yellow, Stained, Dark, No Gloss.
6. In the Materials dialog, click OK twice.

Assign the Pine Frame material to the frame, sash, and mullions

7. In the Project Browser, under Elevations, double-click Exterior.
8. On the View Control Bar, click the Model Graphics Style ➤ Shading with Edges.
9. While pressing CTRL, select the window frame sweep, the sash, and the mullions.

10. On the Options Bar, click (Element Properties).
11. In the Element Properties dialog, under Identity Data, for Subcategory, select Frame/Mullion.

By assigning the window components to subcategories, you allow for the application of visibility options specific to the subcategory.
12 Under Materials and Finishes, for Material, click "By Category), and click 📜.
13 In the Materials dialog, under Name, verify Pine Frame is selected, and click OK.
14 In the Element Properties dialog, under Graphics, for Visibility/Graphics Overrides, select Edit.
15 In the Family Element Visibility Settings dialog, under View Specific Display, clear Plan/RCP, and clear Left/Right.
16 Under Detail Levels, verify that Coarse, Medium, and Fine are selected.
17 Click OK twice.
   The window frame is assigned the new Pine Frame material.
18 On the Design Bar, click Modify.

![Image of window frame](image)

*Modify the glass visibility*

19 In the Project Browser under Elevations, double-click Right.
20 Select the glass extrusion, and on the Options Bar, click Visibility.
21 In the Family Element Visibility Settings dialog, under View Specific Display, clear Plan/RCP and clear Left/Right.
22 Under Detail Levels, verify that Coarse, Medium, and Fine are selected, and click OK.
23 In the Project Browser, under 3D Views, double-click View 1.
24 On the Design Bar, click Modify.
25 Zoom in to a window corner.
The window frame, sash, mullions, and glass display their assigned materials.

26 Zoom to fit the window in the view.
27 Click File menu ➤ Save.
28 Proceed to the next exercise, Defining New Window Types on page 273.
Defining New Window Types

In this exercise, you define new window types based on the window model that you just created. You begin by adding a formula to the mullion offset parameter in order to specify horizontal divisions of one third the overall height of the window. You then create multiple window types that will be available after the family is loaded into a project.

Add a mullion offset formula to the family type

1. On the Design Bar, click Family Types.
2. In the Family Types dialog, under Dimensions, for Mullion Offset Formula, enter Height/3, and click Apply.
   The horizontal mullions are now spaced at one third the height of the window. This is an alternate way to achieve the design intent of equal spacing. You have seen both how to use a dimension string with equal spacing and use of a formula, where a parameter makes use of other parameters (such as Height).

Flex the window model

In addition to flexing the model after the addition or modification of model geometry, it is also a good idea to flex the model after a new formula is applied.

3. In the Family Types dialog, under Dimensions, for Height, enter 8' 0", and click Apply.
The window height is doubled, but the one third height spacing is maintained in the horizontal mullions.

4 In the Family Types dialog, enter 4' 0" for Height, and click Apply.

Define new window types with various heights and widths

5 In the Family Types dialog, under Family Types, click New.
6 In the Name dialog, for Name, enter 96" w x 48" h, and click OK.
7 In the Family Types dialog:
   ■ For Width, enter 8' 0".
   ■ For Height, enter 4' 0".
   ■ Click Apply.
8 Under Family Types, click New.
9 In the Name dialog, for Name, enter 102” w x 52” h, and click OK.
10 In the Family Types dialog:
   - For Width, enter 8’ 6”.
   - For Height, enter 4’ 4”.
   - Click Apply.

**Define the final window type**

11 Under Family Types, click New.
12 In the Name dialog, for Name, enter 72” w x 60” h, and click OK.
13 In the Family Types dialog:
   - For Width, enter 6’ 0”.
   - For Height, enter 5’ 0”.
   - Click Apply, and click OK.

You now have three new window types defined within the window family.

14 Click File menu ➤ Save.

**Load the training window family into a new project**

15 On the Standard toolbar, click [New] to start a new project based on your default template.
16 On the Basics tab of the Design Bar, click Window.
17 On the Options Bar, click Load.
18 In the Open dialog, navigate to the location of Training Window.rfa, select it, and click Open.
Place new window types in the project

19 On the Design Bar, click Wall.

20 Draw a generic wall segment from right to left 40’ long. (The outside of the wall is the bottom face.)

21 On the Design Bar, click Window.

22 On the Options Bar, clear Tag on Placement.

23 In the Type Selector, select Training Window : 72” w x 60” h.

24 Add the window to the left side of the wall. Click on the outside (bottom) face of the wall.

25 In the Type Selector, select Training Window : 96” w x 48” h, and add this window to the center of the wall.

26 In the Type Selector, select Training Window : 102” w x 52” h, and add the third window to the right side of the wall.

27 On the Design Bar, click Modify.

28 Click View menu ➤ Thin Lines.

29 Zoom in to the center window.

Notice the detail that displays. This is because you set the visibility values to display when cut in plan/RCP.

30 On the View toolbar, click (Default 3D View).

31 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
32 Close the project with or without saving it.

You have 3 new fixed 9-light windows based on a new window family prototype.
Creating a Door Family

In this tutorial, you create a custom door family based on the definition of a flush exterior door. After you create the door panel extrusion and the vision light, you create new door types based on size and then assign parameters.

You also learn how to constrain the door design by adding labelled dimensions (parameters) to specify values for the door width, height, and thickness.

Skills used in this lesson:

- Creating symbolic lines for the plan view of the door
- Adding parameters to control door dimensions and swing angle
- Creating solid geometry with extrusions
- Assigning materials to geometry
- Defining family types for door sizes
Drawing the Door Plan View Components

In this exercise, you draw the plan view components for the new door family. You use symbolic lines for the door panel and swing because symbolic lines are only seen parallel to the view in which they are created. When you draw the lines in the plan view, they are only seen in plan. The door type has a variable height, width, thickness, and swing angle.

Create a family based on the default door template

1. Click File menu ➤ New ➤ Family.
2. In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Door.rft.

The reference planes that display are part of the default door template, and represent the door opening profile. The door opening is aligned and locked to the reference planes. Labelled dimensions, part of the door properties, are also displayed.

3. Click File menu ➤ Save.
4. In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Training Door.rfa.

Draw plan view representation for the door panel

   These lines are only seen in the plan view.
6. In the Type Selector, select Plan Swing [cut].
   This is the line type that controls the look of the line.
7. On the Options Bar, click (Rectangle).
8. Starting at the door hinge point on the upper right corner of the door opening, sketch a rectangle for the door panel, approximately as shown:
9 On the Design Bar, click Modify.

**Rotate the symbolic geometry**

Because you want the door family to have an adjustable swing, you rotate the symbolic geometry so it is at an angle to the wall. You then dimension and label the angle relationship of the symbolic door panel and the wall.

10 Select the symbolic lines that you just sketched.

11 On the Edit toolbar, click ![Rotate](image) (Rotate).

12 Click the center of rotation icon and drag it down to the hinge point, where the door panel geometry connects to the wall.
13 Select a point vertically above the door panel (symbolic rectangle) as the start of the rotation.

14 Move the cursor to the left, enter 45, and press ENTER. The geometry is at a 45 degree angle to the wall.
Dimension the swing angle of the door.

15 On the Design Bar, click Dimension.

16 On the Options Bar, click (Angular).

17 Select the long exterior sketch line, select the reference plane on the exterior face of the wall, and select a point to the left of the angle to place the angular dimension.

You just created a hinge point and angle for the exterior line of the door sketch. The hinge point (origin) of the angle is the top right corner of the door opening.

Dimension the thickness and width of the door panel

18 On the Options Bar, click (Aligned).

19 Click on each of the short lines of the sketch and place the door length dimension above the door.

20 Click on each of the long lines and place the door thickness dimension clear of the door end.

The dimension values are not important at this time; you change them in later steps.
21 On the Design Bar, click Modify to exit the command.

Label the dimensions

22 Select the angle dimension, and on the Options Bar, for Label, click <Add parameter>.
23 In the Parameter Properties dialog, for Name, enter Swing Angle, select Instance, and click OK. The instance selection allows you to specify different door swings for each instance of the same door type in a project.

24 Select the long left sketch line, select the thickness dimension, enter 1-3/4”, and press ENTER.
26 Select the thickness dimension, and on the Options Bar, for Label, select Thickness.
27 Using the same method, assign the Width parameter to the width dimension.

28 On the Design Bar, click Family Types. You change the thickness, width, and swing angle to test that the geometry is responding as expected.

29 In the Family Types dialog:
- Under Dimensions, for Thickness, enter 2".
- For Width, enter 3'.
- Under Other, for Swing Angle, enter 60.
- Click Apply.

30 In the Family Types dialog, specify the following:
- Under Dimensions, for Thickness, enter 1.75".
- For Width, enter 2'6".
Under Other, for Swing Angle, enter 45.

Click Apply, and click OK.

Add the arc for the plan door swing

31 On the Design Bar, click Symbolic Lines.
32 In the Type Selector, select Plan Swing [projection].

33 On the Options Bar, click [Arc from center and end points).
   When drawing an arc from center and end points, you first specify the arc center, and then you
   specify each end point.
34 Select the hinge point for the arc center point.
35 Select the upper right endpoint of the door panel for the arc start point.
36 Select the upper left corner of the door opening for the arc endpoint.
   In the following image, the arc is selected so you can see the arc center and each end point.

37 On the Design Bar, click Modify.
38 Click File menu ➤ Save.
39 Proceed to the next exercise, Creating the Door Panel Solid Geometry on page 286.

Creating the Door Panel Solid Geometry

In this exercise, you use extrusions to create the solid geometry for the door panel and the vision light.

Create an extrusion for the door panel

1 In the Project Browser, expand Elevations, and double-click Exterior.
2 On the Design Bar, click Solid Form ➤ Solid Extrusion.
3 On the Design Bar, click Set Work Plane.
4 In the Work Plane dialog, under Name, select Reference Plane: Exterior, and click OK.
5 On the Options Bar, for Depth, enter 1.75”, and press ENTER.
6 On the Options Bar, click (Rectangle).
7 Sketch a rectangle within the door opening (for the door panel).
   A best practice is to sketch the lines away from the final placement, and then use the Align tool to align them to reference planes. This practice ensures that Revit Architecture does not make automatic and perhaps unwanted constraints.

8 On the Tools toolbar, click (Align).
9 Align and lock each of the sketch lines, one at a time, to the reference planes, as shown:
Sketch a void inside the door panel for the vision light

10 On the Design Bar, click Lines.

11 On the Options Bar, click \( \text{Rectangle} \).

12 Sketch a small rectangle inside the top part of the door panel, and on the Design Bar, click Modify.

A closed sketch within the first closed sketch is interpreted as a void. A third sketch within the void be interpreted as solid.

Dimension the sketch to adjust the size of the inner rectangle

13 On the Design Bar, click Dimension.

14 Dimension the sketch:

- Add 2 dimensions to locate the inner sketch 6” from the outer sketch top-right corner.
- Add 2 dimensions to size the void 8”x24”.
- Adjust the inner rectangle to the dimensions by clicking on the sketch lines and editing the temporary dimensions.
- Lock the dimensions because the void is to be at the same location and size in all door types.
15 On the Design Bar, click Finish Sketch.

16 Select the extrusion, and on the Options Bar, click (Properties).

17 In the Element Properties dialog, under Identity Data, for Subcategory, select Panel, and click OK.
Assigning the extrusion to a subcategory ensures that materials and display properties can be controlled after you load the family into a project.

Create an extrusion for the glass vision light in the door

18 On the Design Bar, click Solid Form ➤ Solid Extrusion.
19 On the Design Bar, click Extrusion Properties.
20 Specify options in the Element Properties dialog:
   - Under Constraints, for Extrusion Start, enter 1/2".
     This positions the beginning of the glass away from the door face, which is on the Exterior reference plane.
- For Extrusion End, enter 1”.
- Under Identity Data, for Subcategory, select Glass.
- Click OK.

21 On the Options Bar, click □ (Rectangle).
22 Select diagonally opposite corners of the vision light void in the door panel.
23 Click the 4 lock icons to constrain the sketch.

Because the model is simple with no overlapping reference planes or multiple overlapping solid faces, you can constrain sketches to faces.

**NOTE** The door family should be flexed to ensure that constraints work; you do this in later steps. Following the best practice recommendation, you could edit the sketch, constrain the void sketch with locked dimensions from the reference planes, and flex the model to check the results match your design intent. For complex models, constraining to reference planes is safer and is best practice.

24 On the Design Bar, click Finish Sketch.
26 Drag the Frame Projection labels away from the door for a cleaner view.
27 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

28 While pressing CTRL, select the panel extrusion and glass extrusion, and on the Options Bar, click Visibility.

29 In the Family Element Visibility Settings dialog, clear Plan/RCP, and When cut in Plan/RCP (if category permits), and click OK.

The symbolic lines will show in plan view, but the 3D geometry won’t display. This reduces the regeneration time required to show the door in plan view, where only the symbolic lines display.

Modify the visibility of the extrusions
NOTE: You can confirm the visibility settings in a project only. The 3D geometry remains visible in the Family Editor so that you can select and edit it.

30. Click File menu ➤ Save.
31. Proceed to the next exercise, Assigning Materials to the Door Components on page 292.

Assigning Materials to the Door Components

In this exercise, you assign materials to the door panel and the trim. This material designation controls how the door displays in shaded and rendered views.

Create a new material based on the existing red oak material

1. In the Project Browser, under Floor Plans, double-click Ref. Level.
2. Click Settings menu ➤ Materials.
3. In the Materials dialog, click Duplicate.
4. In the New Material dialog, for Name, enter Oak Door, and click OK.
5. On the Render Appearance tab, click Replace.
6. In the Render Appearance Library dialog, navigate to Wood Oak Red Stained Dark Low Gloss.
7. Click OK twice.

Assign the Oak Door material to the door panel

8. Select the door panel extrusion.
9. On the Options Bar, click (Element Properties).
10. In the Element Properties dialog, under Materials and Finishes, for Material, click <By Category>, and click .
11. In the Materials dialog, under Name, select Oak Door.
12. Click OK twice.

The door panel is assigned the new Oak Door material. You replaced By Category, which allows material to be assigned to the door panel within a project, with a material applied directly to the door.

Assign the Oak Door material to the door trim

14. Using the same method, apply the Oak Door material to the interior door trim and to the exterior door trim.

The door frame is assigned the new Oak Door material.

View the new door

15. In the Project Browser, under Views (all) ➤ 3D View, double-click [3D].
17 Zoom in to a door corner.

Flex the door model

18 Zoom out to view the entire door.
Next, you flex the door family to ensure that it properly adjusts to changes.

19 On the Design Bar, click Family Types.
Move the dialog to the side so that you can see the door family. This allows you to apply changes in the dialog and see how the new door reacts.

20 In the Family Types dialog:
- Under Dimensions, for Height, enter 8' 0".
- For Width, enter 4' 6".
- Under Other, for Frame Width, enter 0' 6".
- Click Apply.
Notice the door geometry adapts to the new dimension values.
21 Return the door parameters to their original values:

- Under Dimensions, for Height, enter 7' 0".
- For Width, enter 2' 6".
- Under Other, for Frame Width, enter 0' 3".
- Click Apply, and click OK.

22 Click File menu ➤ Save.

23 Proceed to the next exercise, Defining New Window Types on page 273.

**Defining New Door Types**

In this exercise, you define new door types for the door family.

**Define new door types with various heights and widths**

1 On the Design Bar, click Family Types.
2 In the Family Types dialog, under Family Types, click New.
3 In the Name dialog, for Name, enter 32"x80", and click OK.
4 In the Family Types dialog:
   - Under Dimensions, for Height, enter 6' 8".
   - For Width, enter 2' 8".
   - Click Apply.

Define the second new door type.
5 Under Family Types, click New.
6 In the Name dialog, for Name, enter 36''x84'', and click OK.
7 In the Family Types dialog:
   ■ Under Dimensions, for Height, enter 7' 0''.
   ■ For Width, enter 3' 0''.
   ■ Click Apply.

Define the third new door type.
8 Under Family Types, click New.
9 In the Name dialog, for Name, enter 48''x90'', and click OK.
10 In the Family Types dialog:
    ■ Under Dimensions, for Height, enter 7' 6''.
    ■ For Width, enter 4' 0''.
    ■ Click Apply, and click OK.

You now have 3 new door types defined within the door family.
11 Click File menu ➤ Save.

Load the door family into a project
12 Click Window menu ➤ Project1 - Floor Plan: Level 1.
13 On the Basics tab of the Design Bar, click Door.
14 On the Options Bar, click Load.
15 In the Open dialog, navigate to the location where you saved Training Door.rfa, select it, and click Open.

Place new door types in the project
16 On the Design Bar, click Wall.
    Use the default wall selection in the Type Selector.
17 Drawing from right to left, draw a horizontal wall segment 30' long.
    You draw from right to left so that the exterior of the wall is the bottom face.
18 On the View toolbar, click (Default 3D View).
19 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
20 On the Design Bar, click Door.
21 In the Type Selector, select Training Door : 32"x80".
22 Add the door to the wall by clicking on the bottom edge of the closer face (exterior), as shown.

23 In the Type Selector, select Training Door : 36"x84".
24 Add this door to the center of the wall, as shown.
25 In the Type Selector, select Training Door: 48"x90".
26 Add the third door type to the right side of the wall, as shown.

27 Close all files with or without saving.

You now have 3 new flush exterior doors based on the new door family model.
Creating a Baluster Family

In this tutorial, you create a baluster family composed of 2 steel plates connected by chrome brackets.

You open an existing project and create a railing family, adding the baluster to the railing definition.
Finally, you create 2 profile families: one for the handrail of the baluster, and a bullnose profile for the stair tread. You load these profiles into the project and assign them to the railing and stair.

Skills used in this lesson:

- Creating solid geometry
- Assigning materials to geometry
- Isolating elements in a project for easier viewing and modification
- Duplicating and modifying a railing system family
- Adjusting railing properties, such as baluster placement and rail structure specifications
- Creating rail and stair tread profile families and applying them to project elements
Creating a Baluster Family

Creating the Baluster

In this exercise, you create a baluster family from a template. You create the baluster geometry using solid extrusions for the baluster plates and for the brackets connecting the plates. You also define and assign the steel and chrome materials to the geometry.

Open the family template file

1 Click File menu ➤ New ➤ Family.
2 In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Baluster.rft.
3 Click Window menu ➤ Family1 - Floor Plan: Ref. Level, and maximize the view.
4 Click File menu ➤ Save As.
5 In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Double Plate Baluster.rfa. The family file is saved automatically with the .rfa extension.

Add and name reference planes to define geometry

6 On the Design Bar, click Ref Plane.

7 On the Options bar, click (Pick Lines), for Offset, enter 1 1/2", and press ENTER.

8 Click to add reference planes to both sides of the Center (Left/Right) and Center (Front/Back) reference planes (for a total of 6 reference planes).

9 On the Design Bar, click Modify.

10 Select the bottom horizontal reference plane, and click (Properties).

11 In the Element Properties dialog, under Identity Data, for Name, enter Front, and click OK.

12 Using the same method, name the remaining reference planes:
   ■ Name the top horizontal reference plane Back.
Name the left vertical reference plane **Left**.

Name the right vertical reference plane **Right**.

13 Zoom in to the intersection of the reference planes.

Create the steel plate extrusion

14 On the Design Bar, click Solid Form ➤ Solid Extrusion.

15 Specify values on the Options Bar:
   - For Depth, enter 30'', and press **ENTER**.
   - Click (Pick Lines).
   - For Offset, enter 1/4'', and press **ENTER**.

16 Select the Back reference plane so that the sketch line is positioned below it.

17 Select the sketch line to create a second sketch line below the first.

18 On the Options bar, click (Draw).

19 On the Options bar, clear Chain.

20 At the right of the Left reference plane, sketch a vertical line that connects to both horizontal sketch lines, and press **ESC**, as shown:

21 On the Options bar, for Offset, enter 0'', and press **ENTER**.

22 Sketch a similar vertical line to the left of the Right reference plane.
23 On the Edit toolbar, click (Trim/Extend), and trim the lines to create a closed loop sketch, as shown:

24 Align and lock the sketch lines with the Left and Right reference planes:

- On the Edit toolbar, click (Align).
- Select the Left reference plane, select the left sketch line, and click .
- Select the Right reference plane, select the right sketch line, and click .
- On the Design Bar, click Modify.

25 Mirror the sketch lines along the horizontal midpoint of the baluster:

- Select the sketch lines.
- On the Tools toolbar, click (Mirror).
■ Select the Center (Front/Back) reference plane as the axis of reflection. A mirror image of the sketch displays above the Front reference plane.

26 On the Design Bar, click Finish Sketch.

27 In the Project Browser, expand Views ➔ Elevations, and double-click Front.

28 Align and lock the top of the extrusion with the top reference plane:
■ Select the extrusion, and drag the top shape handle down slightly.
On the Edit toolbar, click \(\text{Align}\).

Select the Top reference plane, select the top of the extrusion, and click \(\text{Align}\).

On the Design Bar, click \(\text{Ref Plane}\).

On the Options bar, click \(\text{Pick Lines}\), for Offset, enter 4", and press \texttt{ENTER}.

Click to create a reference plane offset below the top reference plane.

Create brackets connecting the steel plates

29 Create reference planes for the brackets:

- On the Design Bar, click \(\text{Ref Plane}\).

- On the Options bar, click \(\text{Pick Lines}\), for Offset, enter 4", and press \texttt{ENTER}.

- Click to create a reference plane offset below the top reference plane.
30 On the Design Bar, click Solid Form ➤ Solid Extrusion.

31 In the Work Plane dialog, under Specify a new Work Plan, verify Pick a plane is selected, and select Reference Plane: Back from the drop-down list, and click OK.

When working in a front view, you need to define a work plane. The current work plane, Ref level, is perpendicular to the current view. When sketching, define the sketch on a work plane that is parallel to the current view (unless in a 3D view). In this case, you select the Back reference plane as the work plane.

32 On the Options bar:

- For Depth, enter 3".

- Click (Circle).

  If (Circle) does not display on the Options bar, select it from the drop-down list.

- Select Radius.

- For Radius, enter 1".
33 Click to sketch a circle at each of the intersections of the inner horizontal reference planes, as shown:

34 On the Design Bar, click Finish Sketch.

View the extrusions in 3D and plan views

35 On the Standard toolbar, click (Default 3D View).

36 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
37 In the Project Browser, expand Floor Plans, and double-click Ref. Level.

38 On the Standard toolbar, click (Default 3D View).

39 Click Settings menu ➤ Materials.

40 Define a chrome material:

- In the Materials dialog, verify that Default is selected for Name, and click (Duplicate).
- In the Duplicate Revit Material dialog, enter Metal - Chrome, Polished, and click OK.
- In the right pane of the Materials dialog, click the Render Appearance tab.
- Click Replace.
- In the Render Appearance Library dialog, enter Chrome Polished.
- Click OK twice.

41 Define a blue paint material:

- In the Materials dialog, verify that Default is selected for Name, and click .
- In the Duplicate Revit Material dialog, enter **Metal - Steel, Painted Blue**, and click OK.
- In the right pane of the Materials dialog, click the Render Appearance tab.
- Click Replace.
- In the Render Appearance Library dialog, enter Paint Navy Glossy.
- Click OK twice.

42 In the drawing area, select the extrusion for the steel plates, and click (Properties).

43 In the Element Properties dialog, under Materials and Finishes, for Material, click <By Category>, and click .

44 In the Materials dialog, for Name, verify that Metal - Steel, Painted Blue is selected.
45 Click OK twice.
46 select the extrusion for the brackets, and use the same method to assign the Metal - Chrome, Polished material to the brackets.
47 On the Design Bar, click Modify.

48 Click File menu ➤ Save.

49 Proceed to the next exercise, Adding the Baluster to a Railing Family on page 311.

**Adding the Baluster to a Railing Family**

In this exercise, you create a custom railing and use the new baluster in the railing family definition. You also modify the stair family by altering the stringer so that the sides of the stair are not enclosed in the stringer.
Open the art gallery project

1 Click File menu ➤ Open.
2 In the left pane of the Open dialog, click Training Files and open Imperial\i_art_gallery.rvt.
3 Zoom in to the stair, and on the Standard toolbar, click (SteeringWheels).
4 Use the steering wheel tools to spin the view so all elements making up the staircase and railings can be selected and isolated, as shown:

5 Click Window menu ➤ Double Plate Baluster.rfa - 3D View: [3D].

Select and isolate the stair and railings

6 On the Design Bar, click Load into Projects.
   The baluster family is loaded into the art gallery project.
7 Select the stair and railings as shown:
8 On the View Control Bar, click Temporary Hide/Isolate ➤ Isolate Element.

9 On the Design Bar, click Modify.

Now it is easier to see and evaluate changes to the stair and railing families.

Create a custom handrail

10 Select the left railing, and click (Properties).

11 In the Element Properties dialog, click Edit/New.

12 In the Type Properties dialog, click Duplicate.
Railings are system families. Using Duplicate and then modifying properties is the only way to create a system family.

13 In the Name dialog, enter **Handrail - Custom**, and click OK.

14 In the Type Properties dialog, under Construction, for Baluster Placement, click Edit. You modify the spacing as well as the kinds of balusters used in the railing family.

15 In the Main pattern section of the Edit Baluster Placement dialog, for the Baluster Family value of the Regular baluster, select Double Plate Baluster : Double Plate Baluster.

**NOTE** A complex pattern using different combinations of balusters can be defined in this dialog. This example only uses 1 baluster with simple spacing.

16 Edit the baluster spacing:

**NOTE** The spacing value for baluster panels and linear baluster elements is based on the center of the baluster geometry.

- For the Regular baluster, for Dist. From previous, enter **1'**.
- For Break Pattern at, select Never.
- For Justify, select Spread Pattern To Fit.

17 Specify the selection for post geometry (although this is separate from the baluster geometry, you use the same element in this railing):

- Under Posts, for Start Post, Baluster Family, select Double Plate Baluster : Double Plate Baluster.
- For Corner Post and End Post, select Double Plate Baluster.

- Verify that Use Baluster Per Tread On Stairs is cleared.
- Click OK 3 times.

18 On the Design Bar, click Modify.
19 Select the right railings.

20 In the Type Selector, select Railing : Handrail - Custom.

21 On the Design Bar, click Modify.

Modify the stringer to reveal the sides of the stairs

22 Select the stair, and click (Properties).
In the Element Properties dialog, click Edit/New.

In the Type Properties dialog, under Stringers, for Right Stringer, select Open.

For Left Stringer, select Open.

Click OK twice.

On the Design Bar, click Modify.

Offset the balusters

23 Select the left railing, and click (Properties).

24 In the Element Properties dialog, click Edit/New.

25 In the Type Properties dialog, under Construction, for Baluster Placement, click Edit.

26 In the Main pattern section of the Edit Baluster Placement dialog, for the Regular baluster, enter -6" for Base Offset.

27 Under Posts, for Start Post, Corner Post, and End Post, enter -6" for Base offset, and click OK 3 times.

28 On the Design Bar, click Modify.

29 Zoom in closer to see if the railing is meeting the stair edge as intended.

Notice that the railing is currently intersecting the landing.
30 Adjust the railing family so that it meets at the edge of the stair and landing:

- Select the railing, and click (Properties).
- In the Element Properties dialog, click Edit/New.
- In the Type Properties dialog, under Construction, for Baluster Offset, enter -1.5".
- Click OK twice.
- On the Design Bar, click Modify.

**Constrain the upper bracket to the top of the baluster**

The chrome bracket on the top of the baluster shifted down when the base of the baluster was extended. To maintain the proper relationship between the elements, constrain the upper chrome bracket to the top of the baluster.

31 Click Window menu ➤ Double Plate Baluster.rfa - Elevation: Front.
Dimension and constrain the top and bottom extrusions to the top and bottom reference planes:

- On the Design Bar, click Dimension.

- Select the Top reference plane, select the reference plane directly below, click to place the dimension, and click .

- Using the same method, dimension and lock the bottom 2 horizontal reference planes.

**NOTE** Press **TAB** to select the lower reference plane instead of the Ref Level.
33 Click File menu ➤ Save.
34 On the Design Bar, click Load into Projects.
35 In the Reload Family dialog, click Yes.
   The upper brackets are now positioned appropriately.

Create new rails for the railing family

36 Select the railing, and click (Properties).
37 In the Element Properties dialog, click Edit/New.
38 In the Type Properties dialog, under Construction, for Rail Structure, click Edit.
   Rail Structure is used for horizontal elements in a railing family, and Baluster Placement is used for the vertical elements.
39 Modify the values for Rail 1:
   ■ In the Edit Rails dialog, for Offset, enter 1 1/2".
   ■ For Profile, select Circular Handrail : 1 1/2".
40 Insert a new rail:
   ■ In the Edit Rails dialog, click Insert.
   ■ For Height, enter 4".
For Offset, enter 3/4”.

For Profile, select **Circular Handrail : 1”**.

41 Click Duplicate to insert 7 more rails, and increment the Height value by 4” for each new rail, as shown:

42 Click OK 3 times.

43 On the Design Bar, click Modify.

44 Zoom to fit the stair in the view.
45 Click File menu ➤ Save.

46 Proceed to the next exercise, Adding Profiles on page 321.

Adding Profiles

In this exercise, you create a rail profile family and assign it to the top rail of the railing family.

You also create a bullnose profile and apply it to the stair tread.
NOTE The 2 profile examples in this exercise are for use in specific family types. However, a variety of profile family templates are available to create profiles for many purposes. All profiles must be a closed loop sketch.

Open a profile family template

1 Click File menu ➤ New ➤ Family.
2 In the left pane of the New dialog, click Training Files and open Imperial\Templates\Profile-Rail.rft.

3 Click File menu ➤ Save As.
4 In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Custom Top Rail.rfa.
   The family file is saved automatically with the .rfa extension.

Create reference planes

5 On the Design Bar, click Ref Plane.
6 On the Options bar, click (Pick Lines), for Offset, enter 1 1/2", and press ENTER.
7 Select the Centerline reference plane to create a reference plane offset to the left.
8 On the Options Bar, for Offset, enter 4 1/2", and press ENTER.
9 Select the new reference plane to create a reference plane offset to the right.
The extents of the profile geometry are now defined.

Draw a profile for a top rail

10 On the Design Bar, click Lines, and on the Options Bar, select Chain.
11 Add lines for the profile:
   ■ Select the intersection of the left-most reference planes.

   ■ Select the intersection of the right-most reference planes.

   ■ Move the cursor down 1 1/2", and select a point on the right reference plane.
On the Options Bar, click (Pick Lines), for Offset, enter 1/2", and press ENTER.

Select the horizontal sketch line so that the new line is offset below.

On the Options Bar, for Offset, enter 1", and press ENTER.

Zoom in to the sketch lines, and select the right vertical sketch line so the new line is offset to the left.
12 Trim the profile:
- On the Edit toolbar, click (Trim/Extend).
- Trim the lower horizontal and right sketch lines, as shown:

13 Finish the closed loop profile:
- On the Design Bar, click Lines, and sketch a line on the left to connect the upper and lower horizontal lines.

- On the Options bar, click (Arc passing through three points).
- Connect the right vertical sketch lines using an arc segment: select the endpoint of each vertical sketch line, and select a center point at 1/2".

14 On the Design Bar, click Modify.
15 Click File menu ➤ Save.
16 On the Design Bar, click Load into Projects.
17 If the Load into Projects dialog displays, select i_art_gallery.rvt, and click OK.

**Assign the new profile to the top rail**

18 Select the left railing, and click \( \text{Properties} \).
19 In the Element Properties dialog, click Edit/New.
20 In the Type Properties dialog, under Construction, for Rail Structure, click Edit.
The new custom profile is available from the drop-down list under Profile.
21 Under Rail 1, for Profile, select Custom Top Rail.

**Assign the chrome material to the handrail**

22 For Rail 1, Material, click <By Category>, and click \( \text{...} \).
23 In the Materials dialog, under Name, select Metal - Chrome, Polished.
24 Click OK 4 times.

26 Zoom in to the end of the handrail on the upper stair.
Draw a bullnose profile for the stair tread

27 Click File menu ➤ New ➤ Family.
28 In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Profile-Stair Nosing.rft.

29 Click File menu ➤ Save As.
30 In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Stair Nosing - Bullnose.rfa.
31 On the Design Bar, click Lines.
32 Sketch a closed loop profile to use for the stair nosing.
Select the intersection of the reference planes.

Move the cursor down, enter 1 1/2", and press \textit{ENTER}.

Move the cursor left, enter 1", and press \textit{ENTER}.

On the Options bar, click (Arc).

Sketch an arc to connect the line segment to the Top of Tread reference plane.

On the Options bar, click (Line).

Sketch a line to form a closed loop.

33 On the Design Bar, click \textit{Modify}.

34 Click File menu ➤ Save.
Assign the new stair tread profile

35 On the Design Bar, click Load into Projects.
36 If the Load into Projects dialog displays, verify that i_art_gallery.rvt is selected, and click OK.
37 Select the stair, and click (Properties).
38 In the Element Properties dialog, click Edit/New.
39 In the Type Properties dialog, under Treads:
   ■ For Nosing Profile, select Stair Nosing - Bullnose.
   ■ For Tread Thickness, enter 1 1/2''.
   ■ For Nosing Length, enter 1 1/2''.
   You modify the stair tread thickness to match the depth defined in the nosing profile.
40 Under Materials and Finishes, for Tread Material, click <By Category>, and click .
41 In the Materials dialog, under Name, click Stone - Granite - Black, Polished.
42 Click OK 3 times.
43 On the Design Bar, click Modify.
   Notice the bullnose profile on the stair treads.
44 Close the project with or without saving it.
Creating a Basic Column Family

In this tutorial, you create a basic family, a family that is used in more than one project, and requires little parametric control. You use solid modeling to create the column geometry for the basic column family:

You then add constraints to control the column proportions as you change the height:
Finally, you sketch symbolic lines and modify visibility settings to display a simple column representation in plan views.

Skills used in this lesson:
- Creating solid geometry (extrusions, revolves, and sweeps)
- Adding constraints to maintain column proportions
- Assigning materials to 3D geometry
- Controlling visibility
- Loading the family into a project
- Sketching symbolic lines
- Modifying visibility settings
- Adjusting detail level visibility for symbolic lines

**Creating the Column Base**

In this exercise, you create the column base with 2 extrusions, one for the plinth and one for the pedestal. You then add sweeps to create a molding detail to the top and bottom of the pedestal.
Open the column family template

1. Click File menu ➤ New ➤ Family.
2. In the left pane of the Open dialog, click Training Files, and open Imperial\Templates\Column.rft.

3. Click File menu ➤ Save As.
4. In the Save As dialog, for File Name, enter Classic Column - 16in Base, and click Save.

Enter Depth and Width parameters values

5. On the Design Bar, click Family Types.
6. Under Dimensions, for Depth, enter 1' 4".
7. Under Dimensions, for Width, enter 1' 4".
8. Click OK.
9. Zoom in to the intersections of the reference planes.

Create the column plinth

11 On the Options Bar, for Depth, enter 5', and click \(\text{Rectangle}\).

12 Sketch a square slightly inside the reference planes, as shown:

**NOTE** The actual size is not important.

13 On the Tools toolbar, click \(\text{Align}\).

14 Align and lock the sketch lines to the reference planes, as follows:

- Select the Back reference plane, select the top sketch line, and click \(\text{Align}\).
- Use the same method to align and lock the sketch lines to the Left, Front, and Right reference planes.

15 On the Design Bar, click Finish Sketch.

**Create the pedestal**

16 On the Design Bar, click Ref Plane.

17 On the Options bar:

- Click \(\text{Pick Lines}\).
For Offset, enter 1.5".

Press ENTER.

18 Create 4 reference planes inside the existing reference planes:

- Select the Left reference plane so the offset is to the right.
- Use the same method to offset new reference planes to the inside of the Right, Back, and Front reference planes, as shown:

```
  |     |     |
  |     |     |
  |     |     |
  |     |     |
```

19 On the Design Bar, click Solid Form ➤ Solid Extrusion.

20 Click Extrusion Properties.

21 In the Element Properties dialog:

- Under Constraints, for Extrusion End, enter 1'10".
- For Extrusion Start, enter 5".
- Click OK.

22 Create a solid extrusion for the pedestal:

- On the Options Bar, click (Rectangle).
- Sketch a square in the center of the new reference planes, as shown:
23 On the Tools toolbar, click ![Align](Align), and align and lock the sketch lines to the reference planes, as shown:

24 On the Design Bar, click Finish Sketch.

25 In the Project Browser, expand Elevations, and double-click Front.
Add a reference plane and align the top of the pedestal:

- On the Design Bar, click Ref Plane.
- Sketch a horizontal reference plane 2' above the Lower Ref. Level.

On the Tools toolbar, click (Align).

- Select the reference plane, select the top sketch line of pedestal, and click .
27 On the Standard toolbar, click (3D).

Create decorative molding

28 On the Design Bar, click Solid Form ➤ Solid Sweep.
29 On the Design Bar, click Pick Path.
   The profile for the sweep is defined in a plane perpendicular to the midpoint of the first line
   selected or sketched while specifying the path.

30 Define the path:
   ■ In the drawing area, select the top right edge of the pedestal, as shown:
Moving clockwise, select the remaining 3 top edges.

On the Design Bar, click Finish Path.

31 Load a profile for the sweep:
- In the drawing area, select the target plane for the profile (red dot).

On the Options Bar, click Load Profiles.
A profile is a 2D shape that can be used in place of a sketched profile. Profile families save time and decrease the chance of errors in drafting a sketched profile.

- In the left pane of the Open dialog, click Training Files, and open Imperial\Families\Profiles\Moulding Profile.rfa.
- On the Options Bar, select Moulding Profile from the drop-down list.

On the Options Bar, click Flip.
On the Design Bar, click Finish Sweep.

On the Design Bar, click Solid Form ➤ Solid Sweep.

On the Design Bar, click Pick Path.

In the drawing area, select the bottom right edge of the pedestal, as shown:

On the View Control Bar, click Model Graphics Style ➤ Wireframe. Switch to a wireframe view so the remaining path lines can be selected.
Moving clockwise, select the remaining 3 bottom edges of the pedestal.

On the Design Bar, click Finish Path.

In the drawing area, select the target plane for the profile (red dot).

On the Options Bar, select Moulding Profile from the drop-down list.

On the Options Bar, click Flip.

On the Design Bar, click Finish Sweep.

On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
34 Click File menu ➤ Save.
35 Proceed to the next exercise, Creating the Upper Column on page 342.

Creating the Upper Column

In this exercise, you create a solid for the upper portion of the column using the Revolve tool. You import the geometry to create the solid from another project. After the solid is in place, you add constraints to maintain column proportions as you increase the height.

After the column geometry is complete, you assign a material to the column, and test the family in a project.
Copy the revolve geometry

1 In the Project Browser, under Elevations, double-click Front.

2 Click File menu ➤ Open.

3 In the left pane of the Open dialog, click Training Files, and open Imperial\Column Shape.rvt.
4 In the drawing area, use a selection window to select the column shape, and click Edit menu ➤ Copy to Clipboard.
5 Click Window menu ➤ Classic Column - 16in Base.rfa - Elevation: Front.
6 On the Design Bar, click Solid Form ➤ Solid Revolve.
7 On the Design Bar, click Set Work Plane.
8 In the Work Plane dialog, under Specify a new Work Plane, select Reference Plane: Center (Front/Back), and click OK.
9 Click Edit menu ➤ Paste from Clipboard.
10 Click to paste the geometry to the left of the column base.
   Exact placement is not important.

11 On the Edit toolbar, click (Move).
12 For the Move start point, select the bottom right end point of the sketch.

13 For the Move end point, select the midpoint of the top molding sweep at the intersection of the reference planes.
14 On the Options bar, click Finish.

Create the column

15 On the Design Bar, click Axis, and on the Options Bar, click (Pick Lines).

Using the the Pick Lines tool, you can select and lock the axis of rotation to the center line of the column.

16 In the drawing area, select the Center (Left/Right) reference plane as the axis of rotation, and click .
17 Align and lock the bottom sketch line of the column shape to the reference plane for the pedestal:

■ Select the bottom sketch line of the column shape, and drag it up slightly.

■ On the Tools toolbar, click (Align).

■ Select the horizontal reference plane.

■ Select the bottom sketch line of the column shape.

■ Click .
18 Align and lock the top sketch line to the Upper Ref Level.

19 On the Design Bar, click Finish Sketch.
Flex the model

20 Select the Upper Ref Level, and drag it up.
You flex the model to ensure that the column geometry is stretching as expected.

21 On the Standard toolbar, click (Undo).

Constrain the proportions of the column

Create reference planes and constraints in order to control the proportions of the bottom (straight) section of the column to the top (entasis) section. The ratio must remain 1/3 : 2/3 regardless of the height of the column.
22 On the Design Bar, click Ref Plane.
23 Sketch 2 horizontal reference planes through the upper column, and 1 above the column.
   Reference plane placement is not critical. In subsequent steps, you specify constraints to control
   the position of the planes.

24 On the Design Bar, click Modify.
25 Align and lock the top reference plane to the Upper Ref Level.

26 On the Design Bar, click Modify.
27 Dimension the reference planes:

- On the Design Bar, click Dimension.

- Dimension and lock the lower reference level and the horizontal reference plane directly above (constraining the column base).

- Dimension the remaining 3 horizontal reference planes for the upper column.

**NOTE** Press TAB to select the upper reference plane instead of the Upper Ref Level.

- Click the EQ symbol to constrain the dimensions and make them equal.
28 On the Design Bar, click Modify.
29 Establish a constraint between the sketch and a reference plane:
   - Select the upper column geometry (the solid revolve).
   - On the Options Bar, click Edit.
   - Zoom in to the third horizontal reference line through the column.
Select the left vertical sketch line in the straight section of the upper column. Drag the top endpoint down, as shown:

Drag the endpoint back up until it snaps to the reference line above it.
On the Design Bar, click Finish Sketch.

Zoom to fit the column in the view.

Select the Upper Ref Level, select the value, enter 15', and press ENTER.

You change the height to see if the applied constraints are producing the desired results.
31 Click Modify.

32 Click File menu ➤ Open.
33 In the left pane of the Open dialog, click Training Files, and open Imperial\i_art_gallery.rvt.
34 In the Project Browser, under 3D Views, double-click [3D].

35 On the View toolbar, click (SteeringWheels).
36 Adjust the view, as shown:
Assign materials

37 Click Window menu ➤ Classic Column - 16in Base.rfa - 3D View: [3D].

38 Zoom to fit.

39 Click Settings menu ➤ Materials.

40 In the Materials dialog, click (Duplicate).

41 Create a material:
   ■ In the duplicate Revit Material dialog, for Name, enter Interior Finishes - Paint, White, and click OK.
   ■ On the Graphics tab, select Use Render Appearance for Shading.
   ■ On the Render Appearance tab, click Replace.
   ■ In the Render Appearance Library dialog, for Class, select Paint, and click Paint White Cool Glossy.
Click OK twice.

**Assign the material to the column geometry:**

- Use a selection window to select the column geometry, and click (Properties).
- In the Element Properties dialog, under Materials and Finishes, for Material, click <By Category>, and click .
- In the Materials dialog, for Name, verify that Interior Finishes - Paint, White is selected, and click OK twice.

**Click Modify.**

**Click File menu ➤ Save.**

**Load the family into the project**

- On the Design Bar, click Load into Projects.
- In the Load into Projects dialog, select i_art_gallery.rvt, and click OK.
- Select the 2 columns in the lobby area of the 3D view.
48 In the Type Selector, select Classic Column - 16in Base.
49 Click Modify.

Click File menu ➤ Save.
51 Proceed to the next exercise, Adding Symbolic Lines for Plan Representation on page 357.

Adding Symbolic Lines for Plan Representation

In this exercise, you change the visibility of 3D geometry and create symbolic lines for use in the plan representation of the column family. In addition, you create detail level visibility controls for the symbolic lines of the column base so they only show in Medium and Fine Detail Levels.

Observe the columns in plan view

1 Continue working in the project, i_art_gallery.rvt.
2 In the Project Browser, under Floor Plans, double-click Level 1.

Currently, all the detail work on the column profile is visible. Only the outline of the column is required for plan view.
Control visibility of 3D geometry

3 Click Window menu ➤ Classic Column - 16in Base.rfa - 3D View: {3D}.
4 Select the upper column, and on the Options Bar, click Visibility.

5 In the Family Element Visibility Settings dialog, clear Plan/RCP, and click OK.
6 Using the same method, turn off plan visibility for the pedestal, the 2 sweeps (mouldings), and the plinth.
7 In the Project Browser, under Floor Plans, double-click Lower Ref. Level.

Sketch symbolic lines
8 Zoom in to the column.
9 On the Design Bar, click Symbolic Lines.
10 In the Type Selector, verify that Columns [projection] is selected.
11 On the Options bar, click (Pick Lines).
12 Select the top horizontal line in the column base, and click .
13 Using the same method, lock the other 3 symbolic lines to the 3D geometry.
14 In the Type Selector, select Columns [cut].

15 On the Options Bar, click (Draw), and click (Circle).

**NOTE** If Circle is not displayed, select it from the drop-down list.

16 In the drawing area, sketch a circle to represent the upper column with a radius of 6 3/4", as shown:
17 On the Design Bar, click Modify.

**Change visibility settings**

18 Select the 4 symbolic lines for the column base, and on the Options Bar, click Visibility.

19 In the Family element visibility settings dialog, clear Coarse, and click OK.

20 Click File menu ➤ Save.

**Ttest visibility settings**

21 On the Design Bar, click Load into Projects.

22 In the Load into Project dialog, select i_art_gallery.rvt, and click OK.

23 In the Reload Family dialog, click Yes.

The Visibility settings are not correct. The column 3D geometry is still being displayed.
Adjust Visibility settings

24 Click Window menu ➤ Classic Column - 16in Base.rfa - Floor Plan: Lower Ref. Level.
25 Select the column geometry, and on the Options Bar, click Visibility.

26 In the Family Element Visibility Settings dialog, clear When cut in Plan/RCP (if category permits), and click OK.

NOTE Because the columns were being cut, they were still being displayed even with When cut in Plan/RCP selected.

27 On the Design Bar, click Modify.
Geometry in the Family Editor is now half-toned, indicating the visibility of the element is turned off.

28 On the Design Bar, click Load into Projects, verify that i_art_gallery.rvt is selected, and click OK.
29 In the Reload Family dialog, click Yes.
Now columns are displaying as expected at Coarse Detail Level.

30 On the View Control Bar, click Detail Level ➤ Medium.
In Medium and Fine detail level, the symbolic lines for the column base are also displayed.

31 If desired, save the project and the column family files.
In this tutorial, you create a bookcase family that contains 3 different types (sizes) of bookcases. The bookcase family is designed so that you can change the overall dimensions of the bookcase and its components. The bookcase also has options to assign materials and to include or remove the door.

Creating the New Bookcase Family

In this exercise, you use the Furniture family template to create the bookcase family, an RFT file. Revit Architecture provides family templates, like this Furniture family template, for you to use to create your own families. These templates are named according to the type of family that you want to create.

NOTE To ensure all users access the same template file for this tutorial, you create the bookcase family from the Furniture template in the Training Files folder. When creating your own families, use the templates that Revit Architecture provides in C:\Documents and Settings\All Users\Application Data\RAC 2009\ImperialTemplates.

Create a new family with the Furniture template

1. Click File menu ➤ New ➤ Family.
2. In the left pane of the New dialog, click Training Files, and open Imperial/Templates/Furniture.rft. A new family file opens and 2 dashed green lines, called reference planes, display. You will use these reference planes (and additional ones that you create) to position and constrain the family.
geometry that you create later in this tutorial. Although visible in the family, the reference planes do not display when you load and add the finished family to a project.

Save and name the family

3 Click File menu ➤ Save As.
4 In the Save As dialog, for File name, enter Bookcase, and click Save. This name forms the first part of the family name. When you load the finished family into a project later in the tutorial, it displays by this name in the Type Selector.

5 Proceed to the next exercise, Creating the Family Skeleton on page 366.

Creating the Family Skeleton

In this exercise, you create a skeletal framework of reference planes that represent the front, back, left, right, and top of the bookcase. Later in this tutorial, you create the solid forms that represent the bookcase geometry, and constrain them to the appropriate reference planes.

Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_00.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

View the reference planes provided by the template

1 Click View menu ➤ Zoom ➤ Zoom All To Fit.
The 2 reference planes provide the starting point for the bookcase skeleton:

- The family origin is at the intersection of the pinned reference planes.
  Later in this tutorial, when you add a finished bookcase to a project, the bookcase insertion point corresponds to this intersection point.
- The horizontal plane is the plane along which you will sketch the back panel of the bookcase.
- The vertical plane marks the center of the bookcase.

Next, make sure the reference planes are locked to their current positions, ensuring that you do not inadvertently move them as you create the family geometry.

2 Verify each reference plane is pinned in position:

- Select the vertical reference plane.
  A blue pushpin displays on the reference plane, indicating that it has been locked in place with the Pin command.

**TIP** To pin reference planes and other elements, select the element, and on the Edit toolbar, click (Pin). To unpin an element, select the element, and in the drawing area, click .
■ Select the horizontal reference plane. This reference plane is also pinned in place. Notice that a label displays the reference plane name at its right endpoint. Because you want the insertion point to be at the back of the bookcase along this plane, you want to rename the reference plane.

**Relabel the Center Front/Back reference plane**

3 With the Center Front/Back reference plane selected, on the Options Bar, click (Element Properties).

4 In the Element Properties dialog:
   ■ Under Identity Data, for Name, enter **Back**.
   ■ Under Other, for Is Reference, select Back.
   ■ Click OK.
   The new label displays on the reference plane.

Next, you add and label the following reference planes to complete the family skeleton:

■ A Left reference plane that you will use to position the left bookcase panel.
A Right reference plane that you will use to position the right bookcase panel.

A Front reference plane that you will use to position bookcase geometry relative to the front face of the bookcase.

A Top reference plane that you will use to control the height of the bookcase.

Create the Left, Right, and Front reference planes

5 On the Design Bar, click Ref Plane.

6 Sketch 2 parallel reference planes, one on either side of the vertical center plane, and a horizontal one below the Back reference plane.

Precise placement of the planes is not necessary, as you control their locations in the next exercise.

7 On the Design Bar, click Modify.

8 Select the left reference plane, and click .

9 In the Element Properties dialog:
   - Under Identity Data, for Name, enter Left.
   - Under Other, for Is Reference, select Left.
   - Click OK.

Later, you will move your drafting plane or work plane onto a named reference plane.

10 Select the right reference plane, and on the Options Bar, click .

11 In the Element Properties dialog:
   - Under Identity Data, for Name, enter Right.
   - Under Other, for Is Reference, select Right.
   - Click OK.

12 Select the bottom horizontal reference plane, and click .

13 In the Element Properties dialog:
   - Under Identity Data, for Name, enter Front.
Under Other, for Is Reference, select Front.

Click OK.

**Create a Top reference plane**

14 In the Project Browser, under Elevations (Elevation1), double-click Front.
15 On the Design Bar, click Ref Plane.
16 Sketch a horizontal reference plane above the existing horizontal reference plane.
   Precise placement of the plane is not necessary, as you control its location in the next exercise.

17 On the Design Bar, click Modify.

18 Select the reference plane that you just sketched, and click .

19 In the Element Properties dialog:
   - Under Identity Data, for Name, enter Top.
   - Under Other, for Is Reference, select Top.
   - Click OK.

20 Proceed to the next exercise, Creating Family Parameters and Types on page 370.

**Creating Family Parameters and Types**

In this exercise, you add parameters and types to the bookcase family to determine the 3 different size bookcases that you want the family to create.

You begin by dimensioning the reference planes of the family skeleton to control the width, height, and length of the bookcase family. After you place the dimensions, you add a named parameter to each dimension. The parameters will allow the width, height, and length of the bookcase geometry to vary depending on the values that you assign them.

After you create the parameters, you add 3 bookcase types that contain the width, height, and length parameters to the bookcase family. By assigning different values to these parameters in each type, each family type will create a different size bookcase.
Training File
■ Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_01.rfa.

■ If you are using the supplied training file, click File menu ➤ Save As.

■ In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Dimension the reference planes
1 Click Window menu ➤ Bookcase.rfa - Floor Plan: Ref. Level.

2 Dimension the Left and Right reference planes:
   ■ On the Design Bar, click Dimension.
   ■ Select the Left reference plane.
   ■ Select the Right reference plane.
   ■ Move the cursor above the reference planes, and click to the right of the dimension to place it. The dimension values are not important at this point.
3 Using the same method, dimension the Front and Back reference planes, and place the dimension to the left.

4 Dimension the Left, Center Left/Right, and Right vertical reference planes.‘

5 Click the symbol.
   The symbol, called an equality constraint, displays without a slash, indicating that both dimension segments are equal. The Left and Right reference planes are equidistant from the Center Left/Right reference plane, even if the overall dimension changes.
6 Dimension the Top and Bottom reference planes:

- On the Design Bar, under Elevations, double-click Front.

- On the Design Bar, click Dimension.

- Move the cursor over the Bottom reference plane and Ref. Level level line.

- Press TAB until the reference plane highlights, and select it.
■ Select the Top reference plane, and place the dimension on the left.

Create family parameters

7 Create a height parameter for the dimension that you just placed:
   ■ On the Design Bar, click Modify.
   ■ Select the dimension, and on the Options Bar, for Label, select <Add parameter>.
   ■ In the Parameter Properties dialog, under Parameter Data, for Name, enter `height`, and click OK.

8 Add a length parameter to the top horizontal dimension:
   ■ In the Project Browser, under Floor Plans, double-click Ref. Level.
   ■ On the Design Bar, click Modify.
   ■ Select the top horizontal dimension, and on the Options Bar, for Label, select <Add parameter>.
   ■ In the Parameter Properties dialog, under Parameter Data, for Name, enter `length`, and click OK.
9 Using the same method, add a parameter named width to the vertical dimension.

Organize the parameters

10 On the Design Bar, click Family Types. In the Parameter list, notice that the width, height, and length parameters display under Other.

11 Regroup the parameters:

- In the Family Types dialog, under Other, select width.
- On the right side of the dialog, under Parameters, click Modify.
- In the Parameter Properties dialog, under Parameter Data, for Group parameter under, select Dimensions, and click OK.

12 Using the same method, group the length and height parameters under Dimensions.

Next, test the family by assigning new dimension values to the width, length, and height parameters. After you apply new dimension values, the reference planes should resize accordingly,
an indication that your family is working properly. Testing a family in this manner is called "flexing the family."

**Flex the family**

13 In the Family Types dialog:

14 ■ Under Dimensions, for width, enter 1'6".

■ For length, enter 6'.

■ For height, enter 4', click Apply, and do not close the dialog. The reference planes resize to the dimensions that you entered.

Next, create 3 bookcase types, or sizes, in the family. To create the bookcase type names, you use a length by width by height naming convention. Later in the tutorial, when the completed family is loaded into a project, the different sizes display in the Type Selector with this naming convention.

**Create 3 bookcase types (sizes)**

15 Create a 72x18x48 bookcase:

■ In the Family Types dialog, under Family Types, click New.

■ In the Name dialog, enter 72x18x48, and click OK.

16 Create a 60x18x60 bookcase:

■ Under Family Types, click New.

■ In the Name dialog, enter 60x18x60, and click OK.

■ In the Family Types dialog, under Dimensions, for width, verify a value of 1'6".

■ For length, enter 5'.

■ For height, enter 5'.

■ Click Apply.
17 Create a 36x12x36 bookcase:
   ■ Under Family Types, click New.
   ■ In the Name dialog, enter 36x12x36, and click OK.
   ■ In the Family Types dialog, under Dimensions, for width, enter 1'.
   ■ For length, enter 3'.
   ■ For height, enter 3'.
   ■ Click Apply.

Flex (test) the family

18 In the Family Types dialog, for Name, select 72x18x48, and click OK.
19 Proceed to the next exercise, *Creating Panels* on page 378.

**Creating Panels**

In this exercise, you create 2 side panels and a back panel for the bookcase family.

To create the panels, you use alignment constraints to locate edges of the panel sketches and a length parameter to size the embedded sketches for panels (solid forms).

**Training File**

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_02.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.
Create side panels

1 In the Project Browser, verify Views ➤ Floor Plans ➤ Ref. Level is the current view.

2 Sketch the panels between the horizontal reference planes:
   ■ On the Design Bar, click Solid Form ➤ Solid Extrusion.
   ■ On the Options Bar, click (Rectangle).
   ■ Sketch 2 rectangles as shown.
   Since both panels will have the same height when extruded, you can create them with one sketch. Sketches can have multiple closed shapes.

3 Align and constrain (lock) the left panel to the reference planes:
   ■ On the Tools toolbar, click (Align).
   ■ Select the Left reference plane.
   ■ Select the left edge of the sketch.
   ■ Click (Align).

   ■ Using the same method, align and constrain the top line of the panel sketch to the Back reference plane.

4 Align and constrain the bottom line of the sketch to the Front reference plane.

5 Using the same method, align and constrain the right panel sketch to the Right, Back, and Front reference planes.
Three sides of each panel are constrained to the reference planes.

Next, use a dimension to establish the thickness of the panels.

Create and apply a panel_thickness parameter

6 Dimension the thickness of the side panels:
  ■ On the Design Bar, click Dimension.
  ■ Select the Left reference plane.
  ■ Select the right edge of the left panel sketch, move the cursor above the sketch, and click to place the dimension.
  ■ Select the Right reference plane.
  ■ Select the left edge of the right panel sketch, and place the dimension.

Family dimensions can be edited in the Family Editor, but not in a project. You want to be able to set panel thickness for each bookcase family type. For any dimension value that you want editable in a project, use a length parameter. Length parameters can be given a meaningful name, can be used to store values, and can establish relationships between the components of the family.

7 Create and apply a panel_thickness parameter to the left panel:
  ■ On the Design Bar, click Modify.
  ■ On the left panel sketch, select the dimension.
  ■ On the Options Bar, for Label, select <Add parameter>.
  ■ In the Parameter Properties dialog, under Parameter Data, for Name, enter panel_thickness.
Click OK.

8 Apply the panel_thickness parameter to the right panel dimension:
- On the right panel sketch, select the dimension.
- On the Options Bar, for Label, select panel_thickness.

9 In the Project Browser, under Elevations, double-click Front.

10 On the Design Bar, click Finish Sketch.
   You will use the Top reference plane to modify the panel height.
11 Align and constrain the tops of the panels to the Top reference plane:
- Select one of the panels (solid forms).
  The panels were created with 2 sketches as 1 extrusion, so they behave as one object.
- Drag the top grip that displays on the Center Left/Right reference plane to the Top reference plane, and click .

12 On the View toolbar, click (Default 3D View).
The panel_thickness parameter used, by default, the dimension value but you can now specify values for the bookcase panels.

**TIP** If the displayed line width makes the panels hard to see, on the View toolbar, click (Thin Lines).
13 On the Design Bar, click Family Types.
14 In the Family Types dialog, under Other, for panel_thickness, enter 3/4''.
15 Click OK.

Create a back panel

16 Sketch the back panel clear of the reference lines and solid faces:
   ■ In the Project Browser, under Floor Plans, double-click Ref. Level.
   ■ On the Design Bar, click Solid Form ➤ Solid Extrusion.
   ■ On the Options Bar, click 
   ■ Sketch a horizontal back panel as shown.
17 Align and constrain the top line of the panel sketch to the Back reference plane:

- On the Tools toolbar, click \( \text{Align} \).
- Select the Back reference plane.
- Select the top horizontal line of the panel sketch.
- Click \( \text{\ } \) .

18 Align and constrain the left side of the sketch to the inside face of the left panel.
**BEST PRACTICE** Use dimensions from reference planes to avoid confusion when geometry is complex. You could locate the sketch with a dimension and apply the panel_thickness parameter. In this case the geometry is not complex, and you will verify by flexing the model that alignment with the inside face of the panel works. If, in a complex family, alignment with a face fails, then you have the option of dimensions from the reference plane.

19 Align and constrain the right side of the sketch to the inside face of the right panel.

Apply the `panel_thickness` parameter

20 Add a dimension:
   - On the Design Bar, click Dimension.
   - On the right side of the panel sketch, place a dimension between the Back reference plane and the bottom horizontal line of the sketch.
- On the Design Bar, click Modify.
- Select the dimension that you just placed, and on the Options Bar, for Label, select panel_thickness.

21 On the Design Bar, click Finish Sketch.
You can move dimensions by dragging the dimension line. You can also change the scale to adjust their size. They do not display in a project. Place and size them so they do not obscure solid forms as you continue to develop the family.
22 Align and constrain the Top reference plane and the top of the back panel:
- In the Project Browser, under Elevations, double-click Front.
- On the Tools toolbar, click .
- Select the Top reference plane.
- Click the top edge of the extruded panel.
- Click .

View and flex the family

23 On the View toolbar, click .

24 Flex the family:
- On the Design Bar, click Family Types.
- In the Family Types dialog, for Name, select 36x12x36.
Under Other, for panel_thickness, enter $3/4"$.

Click Apply.

25 Flex:

- For Name, select 60x18x60, and click Apply.
- Under Other, for panel-thickness, enter $3/4"$.
- Click Apply, and click OK.

26 Proceed to the next exercise, Creating the Base Plate on page 388.

Creating the Base Plate

In this exercise, you create the base plate of the bookcase. You learn how to reference a parameter to the extrusion properties of a solid form, creating the thickness of the base plate.
Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_03.rfa.

- If you are using the supplied training file, click File menu ➤ Save As.

- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Sketch a reference plane for the top of the base plate

1. In the Project Browser, under Floor Plans, double-click Ref. Level.
2. On the Design Bar, click Family Types.
3. In the Family Types dialog, for Name, select 72x18x48, and click OK.
4. In the Project Browser, under Elevations, double-click Front.

5. Sketch a horizontal reference plane above the Ref. Level:
   - On the Design Bar, click Ref Plane.
■ Draw a horizontal plane 4" above the existing Ref. Level, and name it Base Plate.

Create and apply a base_height parameter

6 Place a dimension between the horizontal reference planes:
   ■ On the Design Bar, click Dimension.
   ■ Move the cursor over the Ref. Level line and reference plane at the base of the bookcase.
   ■ Press TAB until the reference plane highlights, and select it.
   ■ Select the Base Plate reference plane, and place the dimension to the left of the reference planes.

7 Create a type parameter:
   ■ On the Design Bar, click Modify.
   ■ Select the dimension.
   ■ On the Options Bar, for Label, select <Add parameter>.
   ■ In the Parameter Properties dialog, under Parameter Data, for Name, enter base_height.
   ■ Verify that Type is selected.
   You create the parameter as a type parameter so that each family type can have a different value if desired.
Set a base_height value for all 3 bookcase types

8 On the Design Bar, click Family Types.
9 In the Family Types dialog:
   ■ Under Name, select 60x18x60.
   ■ Under Other, for base_height, enter 4''.
   ■ Click Apply.
   ■ Using the same method, change the base_height to 4'' for the 36x12x36 bookcase.
   ■ Under Name, select 72x18x48, and click OK.

Create the base plate

10 Sketch and constrain the base plate:
   ■ On the Design Bar, click Solid Form ➤ Solid Extrusion.
   ■ Click Set Work Plane.
   ■ In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane: Front, and click OK.
   ■ On the Options Bar, click (Rectangle).
   ■ Sketch a rectangle between the reference planes.
   ■ On the Tools toolbar, click (Align).
   ■ Align and constrain the top of the base plate sketch with the Base Plate reference plane.
- Align and constrain the bottom of the sketch with the bottom reference plane.

- Align and constrain the left side of the sketch to the inside of the left panel.

- Align and constrain the right side of the sketch to the inside of the right panel.
On the Design Bar, click Finish Sketch.

11 In the Project Browser, under Floor Plans, double-click Ref. Level.

12 Move and constrain the base plate extrusion:
   - Select the base plate to display its shape handles (grips).

   ![Diagram](image)

   - Drag the front face (bottom grip) to the Front reference plane, and lock it.

   ![Diagram](image)

   - Drag the back face so that it is approximately 2" from the front face.

   ![Diagram](image)
13 Add a parameter for base thickness:
   - On the Design Bar, click Family Types.
   - In the Family Types dialog, under Parameters, click Add.
   - In the Parameter Properties dialog, under Parameter Data, for Name, enter `base_thickness`.
   - For Type of Parameter, select Length.
   - Click OK.

14 In the Family Types dialog, under Other, for base_thickness, enter 1-1/2”, and click OK.

15 Add the base_thickness parameter to the base plate (solid form):
   - Select the base plate, and on the Options Bar, click [Element Properties].
   - In the Element Properties dialog, under Constraints, for Extrusion End, click [ ].
   - In the Associate Family Parameter dialog, select base_thickness.

16 Click OK twice.

Specify a base_thickness value for all 3 bookcase types

17 On the Design Bar, click Family Types.

18 In the Family Types dialog:
   - Under Name, select 60x18x60.
   - Under Other, for base_thickness, enter 1-1/2”.
   - Click Apply.
■ Using the same method, change the base_thickness to 1-1/2" for the remaining bookcase types.

■ Under Name, select 72x18x48, and click OK.

■ Click OK.

19 On the View toolbar, click ➤ (Default 3D View).

20 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

21 Proceed to the next exercise, Adding a Top Shelf on page 395.

Adding a Top Shelf

In this exercise, you create a top shelf with a downturn. A side view is appropriate for drafting the most representative shape of the top.
Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_04.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Sketch the top shelf

1. In the Project Browser, under Elevations, double-click Left.

2. On the Design Bar, click Solid Form ➤ Solid Extrusion.
3 Click Set Work Plane.
4 In the Work Plane dialog, under Specify a new Work Plane, for Name, select Reference Plane: Left.
5 Click OK.
6 On the View Control Bar, click the current scale, and click $3''=1'-0''$.
7 On the Design Bar, click Lines.
8 On the Options Bar, verify that Chain is selected.
9 Sketch a reverse L-shaped closed extrusion clear of all reference planes.

10 Add an arc to the sketch:
   - On the Design Bar, click Lines.
   - On the Options Bar, clear Chain.
   - Click $\square$, and click $\bigcirc$ (Fillet arc).
   - Select the adjacent edges of the top right corner of the sketch to create the arc.
   - Select the arc, and specify its radius value as $3/4''$. 
Click (Align), select the inside face of the back panel, and select the left edge of the sketch.

Lock the alignment.

Select the Front reference plane, and select the right face of the sketch.

Lock the alignment.

On the Design Bar, click Dimension, and place 2 dimensions as shown. Be sure to dimension the thickness of the downturn from the Front reference plane.

While pressing CTRL, select both dimensions.

On the Options Bar, for Label, select panel Thickness.
On the Design Bar, click Dimension.

Place dimensions to locate the top of the sketch 2" from the Top reference plane, and to locate the bottom of the downturn 3" below the underside of the top of the sketch. To edit dimensions, select the dimensioned sketch line, select the dimension value, and enter the modified value.

On the Design Bar, click Finish Sketch.
12 In the Project Browser, under Floor Plans, double-click Ref. Level.

The extrusion begins on the Left reference plane, but is not constrained. The sketch will always move with the reference plane, but you can adjust the start and end of extrusions. You can edit extrusion properties or use the face arrow grips.

Select the top solid form and constrain the edges to the inside of the side panels

13 On the Design Bar, click Modify.
14 Select the extrusion.

In order to make it easier to align the extrusion edges to the panels, you first move the edges clear of the panels.
15 Select the grip on the right side of the extrusion, and drag it toward the Center (Left/Right) reference plane.

16 Repeat for the left grip until the solid form displays as shown.

17 Align and lock both ends of the extrusion to the inside of the side panels:

- On the Tools toolbar, click .
- Select the inside face of the left panel.
- Select the left side of the extrusion, and lock the alignment.
Select the inside face of the right panel.
Select the right side of the extrusion, and lock the alignment.

18 On the View toolbar, click (Default 3D View).
19 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

Flex the family

20 On the Design Bar, click Family Types.
21 In the Family Types dialog, for Name, select 60x18x60.
22 Click Apply.
23 Repeat for 36x12x36 and 72x18x48.
Changing the Shape of the Side Panels

In this exercise, you change the shape of the bookcase side panels from rectangular to rounded. To accomplish this, you edit the panel sketches. In anticipation of future changes, you created the sketches in the Ref. Level view so that the side panels could be given a rounded face.

Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_05.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Modify the left panel

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 Select the left panel, and on the Options Bar, click Edit.
3 On the Design Bar, click Modify.
4 Select the left vertical line of the panel sketch, and press DELETE.

5 Replace the deleted line with a rounded panel:
   ■ On the Design Bar, click Lines.
   ■ On the Options Bar, click (Arc passing through three points).
   ■ In the location where you deleted the panel line, select the top endpoint.
   ■ Select the bottom endpoint.
   ■ Click to place the arc.
   ■ Modify the arc dimension to 2'.

6 On the Design Bar, click Modify.

7 Select the arc, and on the Options Bar, click (Element Properties).
8 In the Element Properties dialog, under Graphics, select Center Mark Visible, and click OK.
   Displaying the center mark allows you to dimension to the center of the circle.

9 On the Design Bar, click Dimension.
10 Dimension the Left reference plane and the center of the circle.
   This ensures that the arc center will stay at a fixed distance from the Left reference plane.
Modify the right panel

11 Using the same method, create a rounded panel on the right side of the bookcase.

12 On the Design Bar, click Finish Sketch.

13 On the View toolbar, click (Default 3D View).

14 Proceed to the next exercise, Creating and Assigning Subcategories on page 406.
Creating and Assigning Subcategories

In this exercise, you add a number of subcategories to the bookcase family so you can assign materials to its individual components, such as the shelves, door, base plate, panels, and top. After you create the subcategories, you assign each piece of the bookcase geometry to one of the subcategories.

Later in this tutorial, you apply different materials to each subcategory, allowing you to vary the materials that you apply to each component of the bookcase.

Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_06.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Create subcategories in the Furniture category

1. Click Settings menu ➤ Object Styles.
   The Object Styles dialog displays. In the next steps, you add subcategories under the main Furniture category. Later in this tutorial, you will use this dialog to specify default materials for each subcategory that you create.

2. In the Object Styles dialog, on the Model Object tab, under Category, select Furniture.
4. In the New Subcategory dialog, for Name, enter Base, and click OK.
5. Using the same method, create additional subcategories:
   - Top
   - Panels
   - Shelves
   - Door

6. When you finish creating subcategories, click OK.

Assign solid forms to the corresponding subcategories

7. While pressing CTRL, select the side and back panels of the bookcase.
On the Options Bar, click \(\text{Element Properties}\).

8 In the Element Properties dialog, under Identity Data, for Subcategory, select Panels, and click OK.

9 On the Design Bar, click Modify.

10 Using the same method, assign the corresponding subcategory to the top and the base of the bookcase.

Although you created Door and Shelves categories, you have not created the door and shelf geometry. You will create and assign them in subsequent exercises.

11 Proceed to the next exercise, Adding Shelves on page 407.

**Adding Shelves**

In this exercise, you add 3 shelves to the bookcase family. You create the shelves by sketching multiple closed loops. You then apply parameters to control the shelf spacing.
Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_07.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Sketch the shelves

1. In the Project Browser, under Elevations, double-click Front.
2. On the Design Bar, click Solid Form ➤ Solid Extrusion.
3. On the Options Bar, click \( \text{Rectangle} \).
4. Draw 3 stepped rectangles as shown.

5. Align and lock the left edges:

   - On the Tools toolbar, click \( \text{Align} \).
   - Select the left edge of the bottom rectangle, and then the left edge of the rectangle above.
   - Lock the alignment.
   - Select the left edge of the bottom rectangle, and then the left edge of the top rectangle.
6. Lock the alignment.

7. Repeat the process for the right edges of the rectangles.

8. Align and lock the bottom shelf edges with the inside face of the side panels:
   - On the Tools toolbar, click 📐.
   - Select the reference plane at the top of the base, select the bottom edge of the lowest rectangle, and lock the alignment.

9. Apply the panel_thickness parameter to the shelves
   - On the Design Bar, click Dimension.
   - Place individual dimensions (not a string) as shown to control shelf thickness and spacing.
10 Select the dimensions controlling the thickness of the shelf sketches, and apply the panel_thickness parameter.

Create and apply maximum and minimum shelf spacing parameters

11 Select the dimension between the bottom and middle shelves.
12 On the Options Bar, for Label, click <Add parameter>.
13 In the Parameter Properties dialog, under Parameter Name, enter shelf_maximum_spacing, and click OK.
14 On the Design Bar, click Modify.
15 Select the dimension between the middle and top shelves, and create a shelf_minimum_spacing parameter.
16 On the Design Bar, click Extrusion Properties.

17 In the Element Properties dialog:
   ■ Under Constraints, for Extrusion End, enter 1’.
     This is a temporary value as you will later constrain the shelves to the back panel.
   ■ Click OK.

Finish the shelves

18 On the Design Bar, click Finish Sketch.

19 In the Project Browser, under Floor Plans, double-click Ref. Level.

20 Select the shelf.

21 Drag and lock the sides of the shelf to the inside faces of the side panels.

22 Drag the top grip up and lock the edge of the shelf to the inside of the back panel.

23 On the View toolbar, click (Default 3D View).
Flex the family

24 On the Design Bar, click Family Types.
25 In the Family Types dialog, for Name, verify 72x18x48 is selected.
26 Under Other, for shelf_minimum_spacing, enter 6".
27 For shelf_maximum_spacing, enter 1'.
28 Click Apply.

29 For Name, select 60x18x60.
30 Under Other, for shelf_minimum_spacing, enter 6".
Shelf spacing can be specified with default values for each family type.
31 For shelf_maximum_spacing, enter 1'.
32 Click Apply.
33 For Name, select 36x12x36.
34 Under Other, for `shelf_minimum_spacing`, enter 4".
35 For `shelf_maximum_spacing`, enter 4".
36 Click Apply.

37 For Name, select 72x18x48, and click OK.

**Assign the Shelves subcategory**

38 On the Design Bar, click Modify.

39 Select the shelves, and click (Element Properties).
40 In the Element Properties dialog, under Identity Data, for Subcategory, select Shelves.
41 Click OK.
42 Proceed to the next exercise, Adding an Enclosure Panel on page 413.

**Adding an Enclosure Panel**

In this exercise, you add a vertical enclosure panel to the top shelf of the bookcase.
In the next exercise, you create a door to complete the enclosure.

**Training File**

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_08.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

**Create a reference plane for the vertical enclosure panel**

1. In the Project Browser, under Elevations, double-click Front.
2 On the Design Bar, click Ref Plane.
3 Sketch a vertical reference plane between the left and center planes.

4 On the Design Bar, click Modify.

5 Select the reference plane, and on the Options Bar, click (Element Properties).
6 In the Element Properties dialog, under Identity Data, for Name, enter **Enclosure**.
7 Click OK.

**Create a parameter to control the enclosure length**

8 On the Design Bar, click Dimension.
9 Select the Left reference plane.
10 Select the Enclosure reference plane.
11 Click to place the dimension.

12 On the Design Bar, click Modify.
13 Select the dimension you just placed, and on the Options Bar, for Label, select <Add parameter>.
14 In the Parameter Properties dialog, under Parameter Data, for Name, enter *enclosure_length*, and click OK.

15 On the Design Bar, click Family Types.
16 In the Family Types dialog, under Other, for enclosure_length, enter 2', and click Apply.
17 Apply the same value for enclosure_length to all the family types.
18 For Name, select 72x18x48, and click OK.

**Sketch the enclosure panel**

19 On the Design Bar, click Solid Form ➤ Solid Extrusion.

20 On the Options Bar, click (Rectangle).
21 Draw the sketch clear of reference planes.
22 On the Tools toolbar, click \(\text{Align}\).
23 Select the Enclosure reference plane.
24 Select the left edge of the rectangle, and lock the alignment.

25 Select the underside of the bookcase top.
26 Select the top of the rectangle, and lock the alignment.
27 Select the top face of the top shelf.

28 Select the bottom line of the rectangle, and lock the alignment.

29 Dimension between the Enclosure reference plane and the right edge of the rectangle:
   ■ On the Design Bar, click Dimension.
   ■ Select the Enclosure reference plane.
   ■ Select the right edge of the sketch.
Click to place the dimension.

**Add the panel_thickness parameter**

30 On the Design Bar, click Modify.
31 Select the dimension that you just placed.
32 On the Options Bar, for Label, select panel_thickness.

33 On the Design Bar, click Finish Sketch.
Align the panel

34 In the Project Browser, under Floor Plans, double-click Ref. Level.

35 Select the panel.

36 Drag the top grip to align with the inside face of the back panel and lock the alignment.
37 Drag the bottom grip to align with the inside face of the top shelf.
38 On the View toolbar, click (Default 3D View).

39 Assign a subcategory to the panel:

- Select the panel, and on the Options Bar, click (Element Properties).
- In the Element Properties dialog, under Identity Data, for Subcategory, select Panels, and click OK.
- Press ESC.

40 Proceed to the next exercise, Adding a Door on page 421.

**Adding a Door**

In this exercise, you add a door with a circular opening and a glass panel that adjusts to fit the enclosure. The same parameter that positions the vertical panel controls the door width.
Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_09.rfa.

- If you are using the supplied training file, click File menu ➤ Save As.

- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Use concentric rectangles to create the door

1. In the Project Browser, under Elevations, double-click Front.
2. On the Design Bar, click Solid Form ➤ Solid Extrusion.
3. Click Set Work Plane.
4. In the Work Plane dialog, under Specify a new Work Plane, verify that Name and Reference Plane: Front are selected.
5. Click OK.

6. On the Options Bar, click (Rectangle).
7. Sketch 2 concentric rectangles as shown.
   The inner sketch will be interpreted as a void by the software.
8 On the Design Bar, click Modify.

9 On the Tools toolbar, click \(\text{(Align)}\).

10 Align and lock the 4 edges of the outer sketch:
   - Align and lock the left edge to the inside of the side panel.
   - Align the top edge to the bottom of the downturn (top shelf).
   - Align the right edge to the outside face of the vertical panel.
   - Align the bottom edge to the top face of the shelf.

11 On the View Control Bar, click the current scale, and select 3"=1'-0".

12 Dimension the door sketch to locate the opening:
   - On the Design Bar, click Dimension.
   - Move the cursor over one of the lines of the outer sketch, press TAB until it highlights, and select it.
- Move the cursor to the parallel line of the inner sketch, select the line, and click to place the dimension.

- Using the same method, dimension the remaining sketch lines.

13 On the Design Bar, click Modify.

14 Select the inner sketch lines individually and adjust each offset distance to 3".

15 On the Design Bar, click Extrusion Properties.

16 In the Element Properties dialog, under Constraints, for Extrusion End, click □.
In the Associate Family Parameter dialog, under Existing family parameters of compatible type, select panel_thickness.

Click OK twice.

On the Design Bar, click Finish Sketch.

**Draw a solid form for the door glass**

On the Design Bar, click Solid Form ➤ Solid Extrusion.

Click Set Work Plane.

In the Work Plane dialog, under Specify a new Work Plane, verify that Name and Reference Plane: Front are selected.

Click OK.

On the Options Bar, click .

Sketch a rectangle directly on top of the rectangle that represents the void (the inner rectangle sketch).

Lock each line.

Because you sketched the rectangle on top of the other, alignment between the rectangles is assumed. This is a fast way to align elements. It is only applicable where there are not multiple superimposed faces or reference planes.

With the glass sketch still selected, on the Design Bar, click Extrusion Properties.

In the Element Properties dialog:

- Under Constraints, for Extrusion End, enter 1/2''.
- For Extrusion Start, enter 1/4''.
- Click OK.

On the Design Bar, click Finish Sketch.

In the Project Browser, under Floor Plans, double-click Ref. Level.

Confirm that the glass displays as shown.
You can edit the extrusion properties if the beginning and end of the extrusion need to be adjusted.

32 On the View toolbar, click (Default 3D View).
The glass now displays as a solid form. Later in this tutorial, you will apply a glass material to the form.

33 Assign a subcategory to the door:

- Select the door, and on the Options Bar, click (Element Properties).
- In the Element Properties dialog, under Identity Data, for Subcategory, select Door, and click OK.
- Press ESC.

Create a circular opening

34 In the Project Browser, under Elevations, double-click Front.
35 On the Design Bar:
- Click Void Form ➤ Void Extrusion.
Click Set Work Plane.

36 In the Work Plane dialog, under Specify a new Work Plane, verify that Name and Reference Plane: Front are selected.
37 Click OK.

38 On the Options Bar, click ▼, and click (Circle).
39 Sketch a circle with a 1" radius at the top right corner of the door.

40 On the Design Bar, click Modify.

41 Select the circle, and on the Options Bar, click (Element Properties).
42 In the Element Properties dialog, under Graphics, select Center Mark Visible, and click OK.
43 On the Design Bar, click Dimension.
44 Add 2 dimensions and position the center of the circle 1-1/4" from the top edges of the glass opening.
45 On the Design Bar, click Extrusion Properties.
46 In the Element Properties dialog:
   ▪ Under Constraints, for Extrusion End, enter 1".
   ▪ For Extrusion Start, enter 0.

You use a value greater than the thickness of the door.
47 On the Design Bar, click Finish Sketch.
Verify that you created a solid void extrusion that starts on the Front reference plane and ends beyond the door.

48 On the View toolbar, click (Default 3D View).

49 Proceed to the next exercise, Managing Visibility on page 429.
Managing Visibility

In this exercise, you specify the visibility of the bookcase family in different views. When you add bookcase instances to plan views, you want to make sure that a 2D symbolic linework representation of the bookcase displays, and not a hidden line representation of the more complex 3D bookcase. By specifying the appropriate visibility settings in each view, you reduce the regeneration time of the bookcase element in your projects.

Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_10.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Create symbolic lines for detail levels

1. In the Project Browser, under Floor Plans, double-click Ref. Level.
3. On the Options Bar:
   - Clear Chain.
   - Click \( \Box \), and click \( \overrightarrow{\Box} \) (Arc passing through three points).
4. Using the Line and Arc tools, create a closed sketch as shown, clear of the existing bookcase geometry.
5. On the Options Bar, click \( \Box \) (Align).
6. Align the sketch in the following order:
   - Align the top of the sketch to the Back reference plane.
   - Align both arcs to the arced side faces.
   - Align the bottom line to the Front reference plane.
   The order in which you align the sketch geometry is important because you need to establish the relationships between the connected sides of the sketch.
7. On the Design Bar, click Modify, and select all of the bookcase geometry, including the sketch that you just aligned.
8. On the Options Bar, click \( \Box \) (Filter).
9. In the Filter dialog, click Check None.
10. Select Lines (Furniture), and click OK.
11 On the Options Bar, click Visibility.
12 In the Family element visibility settings dialog, under Detail Levels, verify that Coarse, Medium, and Fine are selected, and click OK.
   The outline symbolic linework will display at all detail levels.
13 On the Design Bar, click Symbolic Lines.
14 Draw and constrain a symbolic line on the inside face of the back panel and on the inside face of both side panels.

15 While pressing CTRL, select the 3 lines.
16 On the Options Bar, click Visibility.
17 In the Family element visibility settings dialog, under Detail Levels, clear Coarse.
   The additional 3 symbolic lines will display in the Medium and Fine detail levels. You still need to ensure that the 3D geometry does not show in plan views where it could increase regeneration time.
18 Click OK.
19 On the View toolbar, click (Default 3D View).
20 Select all of the 3D geometry.
   The symbolic lines only display parallel to the view in which they were drawn, so they are not available for selection in the 3D view.
21 On the Options Bar, click Visibility.
22 In the Family Element Visibility Settings dialog:
   ■ Under View Specific Display, clear Plan/RCP.
   
   **NOTE** Furniture families cannot be cut in Plan/RCP. Families such as windows or doors would have this option.

   ■ Click OK.
   The 3D model will not display in plan views. This only becomes clear to you when you see the family in a project.
23 On the Design Bar, click Modify.
24 Open the _art_gallery.rvt project, and open the Level 1 floor plan.
25 Open Bookcase.rfa, and on the Design Bar, click Load into Projects.
Click Component.

Place the bookcase, and test its display in coarse, medium, and 3D views.

The symbolic linework shown in plan views does not hide a pattern on a floor, so you must also add a masking region to the bookcase family. You want the model to display as shown when viewed at medium or fine detail on a floor with a material pattern.

Proceed to the next exercise, Adding a Masking Region on page 431.

Adding a Masking Region

In this exercise, you create a masking region to ensure that the bookcase hides any floor materials on which it is placed in a plan view.

Training File

Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_11.rfa.

If you are using the supplied training file, click File menu ➤ Save As.

In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Create a masking region

1 In the Project Browser, under Floor Plans, double-click Ref. Level.
2 Select all the bookcase geometry.
3 On the Options Bar, click (Filter).
4 In the Filter dialog, click Check None.
5 Select Lines (Furniture), and click OK.
6 On the View Control Bar, click Click Temporary Hide/Isolate ➤ Hide Category. This removes the lines from the view so you can more easily align the masking region to the geometry.

7 On the Design Bar, click Masking Region.

8 On the Options Bar, use (Line) and (Arc passing through three points) to create a closed sketch as shown, clear of the existing geometry.

Align and constrain the masking region

9 On the Tools toolbar, click (Align).

10 Align and lock the masking region:
   ■ Align the top line to the Back reference plane.
   ■ Align both arcs to the arced side faces.
   ■ Align the bottom line to the Front reference plane.

11 On the Design Bar, click Finish Sketch.

12 On the View Control Bar, click Click Temporary Hide/Isolate ➤ Reset Temporary Hide/Isolate.

13 Proceed to the next exercise, Creating and Assigning Materials on page 432.

Creating and Assigning Materials

In this exercise, you create and apply materials to the components of the bookcase family: the base plate, the door, the glass panel in the door, the panels, the shelves, and the bookcase top. To apply materials to these different components, you apply them directly and by family subcategory.

You begin by applying a glass material to the panel in the bookcase door. This panel is intended to be glass and is unlikely to change, so you apply it directly to the Material parameter of the panel in its Element Properties.
Next, you decide to apply a different material to each of the remaining components of the bookcase. When you create bookcases with the finished family, you also want to be able to apply a different material to each component and update all instances of the bookcase to reflect the material change.

To accomplish this, you apply different materials to each of the family subcategories: Base, Door, Panels, Shelves, and Top. Changing the material that is applied to the Shelves subcategory will change the shelf material of all bookcases that you create with the Bookcase family.

You can also create material parameters within a family to provide a list of alternate materials. The material can be unique within the bookcase. Material parameters are covered in the next exercise.

**Training File**
- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_12.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

**Apply a glass material to the bookcase door**

1. If necessary, on the View toolbar, click (Default 3D View), and zoom in to the door.
2. Select the solid form that represents the door glass.
3 On the Options Bar, click (Element Properties).
4 In the Element Properties dialog, under Materials and Finishes, for Material, click in the Value field, and click .
5 In the Materials dialog, under Materials, select Glass.
6 In the right pane, on the Graphics tab, review the Shading settings.
   The Glass material has a blue color and a Transparency value of 75%.
7 Click OK twice.
8 On the Design Bar, click Modify.
   The bookcase door glass displays as both blue and transparent in the project.
   After you apply a material in the Element Properties, you can only change it in the Family Editor.
   You cannot change it in an instance of the family in a project.

**TIP** When creating proprietary furniture families, use this method to apply all the necessary furniture materials. The materials display in projects as designed and are not easily modified.
Create new materials for the bookcase

9 Click Settings menu ➤ Materials.
10 In the Materials dialog, under Materials, select Default.

11 In the bottom left pane of the Materials dialog, click (Duplicate).
12 In the Duplicate Revit Material dialog, for Name, enter Bookcase_Base, and click OK.
The new material displays in the Materials list.

**TIP** Use a material naming convention like this one to group family materials under a common prefix (in this example, Bookcase). Materials applied to family components are loaded into a project with the family.

13 Using the same method, create the following bookcase materials by duplicating the Bookcase_Base material (keep the Materials dialog open when you’re finished creating materials):
- Bookcase_Top
- Bookcase_Panels
- Bookcase_Shelves
- Bookcase_Door

Next, assign display properties and render appearances to each of the materials that you just created. Later, when you apply the material to a family component, the display properties determine the component color in shaded views. The render appearance determines the display of the component when it is rendered.

**Specify the material display properties and render appearances**

14 In the Materials dialog, under Name, select Bookcase_Base.
15 On the Graphics tab, under Shading, click the color swatch.
16 In the Color dialog, select a brown color for the bookcase base, and click OK.
This is usually similar in color to the render material and is useful in visually differentiating material assignments.
17 In the Materials dialog, click the Render Appearance tab.
18 Under Render Appearance Based On, click Replace.
19 In the Render Appearance Library, for Class, select Paint.
20 Select the Paint Brindle Glossy render appearance.
21 Click OK.
22 Using the same method, assign the following colors and render appearances to the other bookcase materials:

<table>
<thead>
<tr>
<th>Material</th>
<th>Color</th>
<th>Render Appearance</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bookcase_Door</td>
<td>Red</td>
<td>Paint Light Red Glossy</td>
</tr>
<tr>
<td>Bookcase_Panels</td>
<td>Blue-green</td>
<td>Paint Dark Cadet Blue Glossy</td>
</tr>
<tr>
<td>Bookcase_Shelves</td>
<td>Light brown</td>
<td>Wood Birch Natural Medium Gloss</td>
</tr>
<tr>
<td>Bookcase_Top</td>
<td>Medium brown</td>
<td>Paint Brindle Glossy</td>
</tr>
</tbody>
</table>

**NOTE** When you assign the Wood Birch Natural Medium Gloss render appearance to the shelves, notice that it contains a bitmap image to depict the wood grain. Materials with bitmap images like this one are visible only when you render an element in a project to which the material is applied.

23 Click OK.

Next, apply the Bookcase materials to the corresponding family subcategories in order to apply them to the family components.

**Apply the bookcase materials to the Furniture subcategories**

24 Click Settings menu ➤ Object Styles.
25 In the Object Styles dialog, on the Model Objects tab, under Category ➤ Furniture, select Base.
26 For Base, click in the Material field, and click .
27 In the Materials dialog, under Materials, select Bookcase_Base, and click OK.
28 Using the same method, assign the remaining bookcase materials to the corresponding subcategories:

<table>
<thead>
<tr>
<th>Subcategory</th>
<th>Material</th>
</tr>
</thead>
<tbody>
<tr>
<td>Door</td>
<td>Bookcase_Door</td>
</tr>
<tr>
<td>Panels</td>
<td>Bookcase_Panels</td>
</tr>
<tr>
<td>Shelves</td>
<td>Bookcase_Shelves</td>
</tr>
<tr>
<td>Top</td>
<td>Bookcase_Top</td>
</tr>
</tbody>
</table>

29 Click OK.

The bookcase family displays with the colors that you assigned to it.

30 Proceed to the next exercise, **Creating a Material Parameter** on page 437.
Creating a Material Parameter

In this exercise, you add a material parameter to the bookcase family. When you add bookcases to a project, this parameter gives you the option to change the door material for a single bookcase or for each type of bookcase that you create, independent of the material that is applied to the bookcase door by family subcategory.

Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_13.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Add a material parameter to the Bookcase family

1 On the Design Bar, click Family Types.
2 In the Family Types dialog, under Parameters, click Add.
3 In the Parameter Type dialog:
   ■ Under Parameters, for Name, enter door_finish.
   ■ Under Group Parameter under, select Materials and Finishes.
   ■ Under Type of Parameter, select Material.
   ■ Select Instance.
      By creating this parameter as an instance parameter, you will be able to choose different
door finishes for each instance of the bookcase family that you place in a project.

4 Click OK twice.

Apply the door_finish parameter to the door

5 Select the door, and click (Element Properties).
6 In the Element Properties dialog:
   ■ Under Materials and Finishes, for Material, click .
   ■ In the Associate Family Parameters dialog, for Existing family parameters of compatible type,
      select door_finish.

7 Click OK twice.
8 Save the bookcase family.

Load the bookcase family into a new project

9 Click File menu ➤ New ➤ Project.
10 Name and save the new project, but do not close it.
11 Open Bookcase.rfa, and on the Design Bar, click Load into Projects.

   The new project displays.

Place 3 instances of the bookcase family

12 On the Design Bar, click Component.
13 In the Type Selector, select a bookcase type, and place 3 bookcases of the same type in the
   project.

14 Click Modify.

15 On the View toolbar, click (Default 3D View).

   All 3 bookcases have materials applied to their components by family subcategory.

16 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
Vary the material applied to the bookcase doors

17 Select the middle bookcase.

18 On the Options Bar, click .

19 In the Element Properties dialog:
   - Under Other, for door_finish, click in the Value field, and click .
   - In the Materials dialog, under Materials, select Bookcase_Top.
     The same material applied to the top of the bookcase will be applied to the door.

20 Click OK twice.
21 Select the third bookcase.
22 Using the same method, apply the Bookcase_Shelves material to the door_finish parameter.
23 Proceed to the next exercise, *Controlling the Door Visibility* on page 441.
Controlling the Door Visibility

In this exercise, you add a visibility parameter to the bookcase family that lets you control whether a bookcase that you place in a project includes the glass panel door. The parameter controls the visibility of both the door and glass for each instance of the bookcase.

When you create the parameter, you name it door_included so that its function is obvious. The parameter offers a yes/no selection when you view the properties of the bookcase door and glass. You choose yes to display the door and glass, or no to turn their visibility off.

Training File

- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_14.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

Add a parameter to control the door visibility

1. On the Design Bar, click Family Types.
2. In the Family Types dialog:
   - Under Parameters, click Add.
   - In the Parameter Properties dialog, under Parameter Data, for Name, enter door_included.
   - Under Group parameter under, select Materials and Finishes.
   - Under Type of Parameter, select Yes/No. The parameter will have a yes/no option for visibility.
   - Select Instance so that even with multiple instances of the same bookcase, you can decide which display with doors.
3. Click OK twice.
Associate the parameter with the door

4 In the drawing area, select the bookcase door.

5 On the Options Bar, click (Element Properties).
6 In the Element Properties dialog:
   ■ Under Graphics, for Visible, click .
   ■ In the Associate Family Parameters dialog, under Existing family parameters of compatible type, select door_included.
7 Click OK twice.

Associate the parameter with the door glass

8 In the drawing area, select the glass in the door.

9 On the Options Bar, click .
10 In the Element Properties dialog:
   ■ Under Graphics, for Visible, click .
   ■ In the Associate Family Parameters dialog, under Existing family parameters of compatible type, select door_included.
11 Click OK twice.

Add bookcases to a project

12 Click File menu ➤ New ➤ Project.
13 Name and save the new project, but do not close it.
14 Open Bookcase.rfa, and on the Design Bar, click Load into Projects.
   The new project displays.
15 On the Design Bar, click Component.
16 In the Type Selector, select Bookcase: 72x18x48, and add a bookcase to the project.
17 Using the same method, add a 60x18x60 and a 36x12x36 bookcase to the project.

18 Click Modify.

Test the visibility of the door and glass in the project

19 On the View toolbar, click (Default 3D View).
20 Select the 60x18x60 bookcase.

21 On the Tools toolbar, click (Copy).

22 Drag the cursor forward, and click to create a copy.

23 Select the copy, and on the Options Bar, click .

24 In the Element Properties dialog:
   ■ Under Materials and Finishes, clear door_included.
   ■ Click OK.
   The bookcase door and glass no longer display in the copy of the bookcase.

25 Proceed to the next exercise, Creating a Type Catalog on page 444.
Creating a Type Catalog

In this exercise, you create a type catalog for the Bookcase family. A type catalog is a dialog that displays when you load a family into a project. It lists all the types in the family, allowing you to select and load only the types that the current project requires.

**Bookcase family type catalog**

To create a type catalog, you create an external text file that contains the parameters and parameter values that create the different types in the family. You place this file in the location of the family file. When you load the family, the type catalog displays.

Type catalogs are most useful with large families, such as steel sections, that contain many types. Selecting and loading only the types that you need for a project helps keep the project file size smaller.

**BEST PRACTICE** Create type catalogs for families that contain 6 or more types.

**Training File**
- Continue to use the family that you used in the previous exercise, Bookcase.rfa, or open training file Imperial\Families\Furniture\Bookcase_15.rfa.
- If you are using the supplied training file, click File menu ➤ Save As.
- In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Furniture\Bookcase.rfa.

**Create a new type catalog file**

1. Open Microsoft® Notepad.

   **NOTE** Although you use Notepad to create the type catalog in this exercise, you can use any available text editor.

2. Click File menu ➤ Save As.
3. Save the file as Bookcase.txt in the same location that you saved Bookcase.rfa.

   The type catalog must have the same name as the family.

**Enter first line of the type catalog file**

4. On the first line in the text file, enter:
   \,length##length##inches

5. On the same line, at the end of the previous text, enter:
   \,width##length##inches

6. On the same line, at the end of the previous text, enter:
The first line should now read:

, length##length##inches, width##length##inches, height##length##inches

Enter the second line of the type catalog file

7 Specify the name and dimensions of the first type:
   36x12x36, 36, 12, 36

   The family type name will display as 36x12x36, and the values that are delimited by commas
display in the same order as they are in the first line of the file.

8 Add the 2 remaining types on separate lines:
   60x18x60, 60, 18, 60
   72x18x48, 72, 18, 48

   Your completed type catalog should look like this:

   , length##length##inches, width##length##inches, height##length##inches
   36x12x36, 36, 12, 36
   60x18x60, 60, 18, 60
   72x18x48, 72, 18, 48

9 Save and close the type catalog.

Load bookcase types into a project with the type catalog

10 Open i_art_gallery.rvt, and open the Level 1 floor plan.
11 On the Design Bar, click Component.
12 On the Options Bar, click Load.
13 In the Open dialog, under Look in, navigate to the location where you saved Bookcase.rfa, select it, and click Open.

   The type catalog displays, listing the 3 bookcase types.


14 In the Specify Types dialog, under Types, select 36x12x36, and click OK.
15 In the Type Selector, notice that only the single type that you selected was loaded into the project.
16 Add a 36x12x36 bookcase to the art gallery project.
In this tutorial, you use reference lines to create portions of 2 different families. Reference lines are similar in use to reference planes in that they help to create the parametric family skeleton that you reference when you create family geometry. However, you use them specifically to create and control the angular dimensions of a family. In the following exercises, you create a bookcase door and a seat back, both with adjustable angles.

**Bookcases featuring doors with varying swing angles**

**Chair with adjustable seat back**
To create the adjustable angle for the door or seat back, you begin by constraining one end of the reference line and leaving the other end free. You then sketch the door or seat back geometry, and constrain it to the reference line. When the sketch is complete, you create a parameter that controls the angle between the reference line and a reference point. When you assign this parameter different values, the door swings or the seat back adjusts.

**Creating a Bookcase Door with a Reference Line**

In this exercise, you use a reference line to add a door with an adjustable swing to a bookcase family. The family contains several types (sizes), and the door must adjust in size and length to accommodate each type.

To create a hinge on which the door swings, you constrain one end of the reference line to the bookcase. After the reference line is in place, you create the solid door geometry and constrain it to the reference line. By creating a door angle parameter, you can adjust the swing angle of the door.
When the door is complete, you add several bookcase types to a project, test the door swing angle, and change the material of the door.

**Open the bookcase family and specify a new work plane**

1. Click File menu ➤ Open.
2. In the left pane of the Open dialog, click Training Files, and open Imperial\Families\Furniture\Bookcase with Door.rfa.
   
   A view of the bookcase, minus the door, displays.

3. In the Project Browser, under Floor Plans, double-click Ref. Level.
4. Zoom in to the top of the bookcase.

5. Click Tools menu ➤ Work Plane ➤ Set Work Plane.
6. In the Work Plane dialog:
   - Under Specify a new Work Plane, for Name, select Reference Plane: Top.
   - Click OK.

**Sketch an angled reference line**

8. Draw the reference line at a 45 degree angle:
   - Specify the start point of the line.
     The precise point is not necessary, as you constrain this point to the hinge location in a later step.
Move the cursor diagonally down to the right, until a 45 degree angle displays.

When the cursor is near the vertical enclosure reference plane, select an endpoint for the line.
Notice that the reference line displays as a solid green line to differentiate it from a reference plane. Like reference planes, reference lines do not have a visibility property.

On the Design Bar, click Modify.
Select the reference line to view its endpoints.
The reference line endpoints display as solid blue circles. Unlike reference planes, you can dimension to the reference line endpoints.

**Dimension the reference line**

9 Place a dimension between the Left reference plane and the reference line endpoint:
- On the Design Bar, click Dimension.
- Select the Left reference plane.
Select the upper endpoint of the reference line.

Move the cursor up, and click to the right of the dimension to place it.
10 Place a dimension between the Front reference plane and the reference line endpoint:
   - Select the Front reference plane.
   - Select the upper endpoint of the reference line.
   - Move the cursor to the left of the bookcase, and click to place the dimension. Later, you use these 2 dimensions to locate the hinge point of the reference line.

11 Place an angular dimension:
   - On the Options Bar, click (Angular).
   - Select the reference line.
Select the Front reference plane.

Move the cursor between the reference line and plane, and click to place the dimension. In the next steps, you use this angular dimension to control the door swing angle.

Select the angular dimension and create a door swing parameter

12 On the Design Bar, click Modify.
13 Select the angular dimension that you just placed.
14 On the Options Bar, for Label, select Add parameter.
15 In the Parameter Properties dialog:
   ■ Under Parameter Data, for Name, enter *door_angle*.
   ■ Select Instance.
      Selecting instance ensures that the door swing angle can be adjusted for every instance of this bookcase family that you add to a project.
Click OK.

Assign a parameter to fix the hinged end of the reference line

16 Select the dimension between the Left reference plane and the reference line endpoint.

17 On the Options Bar, for Label, select panel_thickness. This length parameter is provided in the exercise file.
18 Using the same method, assign the panel_thickness parameter to the other dimension. This fixes the location of the end of the reference line (the hinge).

Because the reference line is constrained and locked to one end of the bookcase, changing the value of the door_angle parameter causes the reference line to reposition, allowing you to vary the angle of the door swing.

Assign a parameter to control the length of the reference line.

19 On the Design Bar, click Dimension.

20 Position the cursor over the upper end of the reference line, press Tab until the point displays, and click to select the point.

NOTE The Tab key may have to be pressed several times to display the point.
21 Repeat for the other end of the reference line, and place the dimension above the line.
22 On the Design Bar, click Modify.
23 Select the dimension.
24 On the Options Bar, click Label, and select enclosure_length.
   This is the same parameter used to position the vertical panel, so you are ensuring that the
   reference line length matches the length of the enclosure. The door is later created on the
   reference line so that the door length matches that of the enclosure.

Flex the family to test the swing angle of the reference line

25 On the Design Bar, click Family Types.
26 In the Family Types dialog, under Other, for door_angle, enter 0.
27 Click OK.
   The reference line "closes" to 0 degrees.
   In the next steps, you create a door from a solid extrusion and constrain it to the reference line.
   After you constrain the door, adjusting the value of the door_angle parameter changes the door
   swing angle.

Sketch a door on a reference plane associated with the reference line

28 On the View toolbar, click (Default 3D View).
29 Spin the bookcase to orient it as shown.

NOTE The reference planes, reference lines (such as the one shown), and dimensions that you use
   to create the family do not display when you add family elements to a project. They are used in family
   creation to ensure precise placement of geometry.
30 On the Design Bar, click Solid Form ➤ Solid Extrusion.
31 On the Design Bar, click Set Work Plane.

Reference lines, provide 4 planes on which you can sketch. The 2 end planes are not of interest in this situation. Your reference line has a plane parallel to the top, and another perpendicular to that plane.

32 In the Work Plane dialog:
   ■ Under Specify a new Work Plane, select Pick a Plane.
   ■ Click OK.

33 Move the cursor over the reference line, press TAB until the reference line plane displays as shown, and select it.

34 Sketch a rectangle clear of any existing geometry:
   ■ On the Options Bar, click (Rectangle).
   ■ For Depth, enter -1”.
     This is a temporary value for the depth of the extrusion. A negative value ensures that the sketch extrudes away from you when it is finished.

**NOTE** Extrusion properties can be edited to change values for the beginning and end of an extrusion. Positive and negative numbers control the extrusion direction.
- Specify a point for the lower left corner of the rectangle, as shown.

- Move the cursor diagonally up and to the right, and specify a point for the upper right corner of the rectangle.

- On the Design Bar, click Finish Sketch.

Flex the family to ensure the door extrusion swings with the reference line

35 On the Design Bar, click Family Types.
36 In the Family Types dialog:
- Under Other, for door_angle, enter 45.
- Click Apply, and click OK.
Dimension and label the door thicknesses in plan view

37 In the Project Browser, under Floor Plans, double-click Ref. Level.
38 On the Design Bar, click Dimension.
39 Select the reference line.
40 Select the inside face of the door, move the cursor to the right, and click to place the dimension.

41 On the Design Bar, click Modify, and select the dimension that you just placed.
42 On the Options Bar, for Label, select panel_thickness.
By assigning a parameter, you establish relationships in the family, and you allow values to be changed in a project. If you do not anticipate changes, you can simply draw geometry to the desired size.

43 Select the door.
44 Select the blue arrow grip for the face that is coincident with the reference line, and drag it away from the reference line.
45 Drag it back onto the reference line and lock it.
Flex the family again to ensure the door swings with the reference line

46 On the Design Bar, click Family Types.
47 In the Family Types dialog:
   - Under Other, for door_angle, enter 20.
   - Click Apply.
     The door swing should adjust to a 20 degree angle from the front of the bookcase.

For door_angle, enter 0.
Click Apply.
The door swing should adjust to a 0 degree angle from the front of the bookcase, appearing to be closed.
- For door_angle, enter 45.
- Click Apply, and click OK.

Constrain the left door face to the hinge location:
- Select the door to display its grips.
- Select the upper left blue triangular grip, and drag it to the hinge location, as shown.

Click to lock the alignment.
49 Using the same method, lock the right door face to the lower end of the reference line.

50 On the Design Bar, click Modify.

**Constrain the top and bottom of the door**

51 In the Project Browser, under Elevations, double-click Front, and zoom to the top left corner of the bookcase.

52 Constrain the top and bottom of the door to the bookcase:

- On the Tools toolbar, click (Align).
- Select the line above the top of the door. This is the downturn for the bookcase top.
- Select the top of the door.
- Click to lock the alignment.

53 Using the same method, constrain the bottom of the door to the top face of the bookcase shelf, and lock the alignment.
54 On the View toolbar, click .

Flex the family to ensure the door displays in the 3 bookcase types (sizes)

55 On the Design Bar, click Family Types.
56 In the Family Types dialog:
   ■ For Name, select 36x12x36.
   ■ Click Apply.
For Name, select 60x18x60.

Click OK.

Sketch a circular knob on the door

57 Spin the bookcase to view the front face of the door.

58 Zoom in to the top portion of the door.

59 On the Design Bar, click Solid Form ➤ Solid Extrusion.

60 On the Options Bar, for Depth, enter 2”.

61 On the Design Bar, click Set Work Plane.
62 In the Work Plane dialog:
- Under Specify a new Work Plane, select Pick a Plane.
- Click OK.

63 Move the cursor over the reference line, and press TAB until the front-facing reference line plane highlights, and select it.

64 Sketch the knob:
- On the Options Bar, click , and click (Circle).
- Specify a point approximately 4" from the top right corner of the door.
- Move the cursor out, until a 1" radius displays, and click to create the knob sketch.

65 On the Design Bar, click Modify.
Position the knob on the door

66 Select the circle, and on the Options Bar, click (Element Properties).

67 In the Element Properties dialog:
   ■ Under Graphics, select Center Mark Visible.
   ■ Click OK.

68 Place 2 dimensions to locate the knob 4" from the top and right door faces:
   ■ On the Design Bar, click Dimension.
   ■ Move the cursor over the top face of the door, press TAB until it highlights as shown, and select the face.

   ■ Select the circle center.
Move the cursor to the left, and click to place the dimension.

Using the same method, dimension from the left face of the door to the circle center. Place the dimension below the circle.

69 Locate the door knob:

- On the Design Bar, click Modify.
- Select the circle.
- Select the top dimension value, enter 4", and press ENTER.
- Select the right dimension value, enter 4", and press ENTER.

70 On the Design Bar, click Finish Sketch.
Flex the family to test the enclosure length parameter

71 On the Design Bar, click Family Types.
72 In the Family Types dialog:
   ■ Under Other, for enclosure_length, enter 12''.
   ■ Click OK.

Flex the family to retest the enclosure length parameter

73 On the View toolbar, click .
74 On the Design Bar, click Family Types.
75 In the Family Types dialog:
   ■ For Name, select 36x12x36.
   ■ Under Other, for enclosure length, enter 18''.
   ■ Click OK.
   The door enclosure length adjusts as needed.
Click File menu ➤ Save.

Next, you test the stability of the family by adding bookcase types to a new project and varying the door swing angle.

**Add a bookcase of all 3 sizes (types) to a new project**

76 Create a new project:
- Click File menu ➤ New Project.
- In the New Project dialog, under Create new, select Project.
- Under Template file, verify the second option is selected, and click Browse. In the left pane of the dialog, click Training Files, and open Imperial\Templates\default.rte. Click OK.

77 On the Design Bar, click Load into Projects.

78 On the View toolbar, click .

Next, you place 3 bookcases from right to left, as shown.

80 On the Design Bar, click Component.
81 In the Type Selector, select Bookcase: 72x18x48.
82 Specify an insertion point in the project.
83 In the Type Selector, select Bookcase: 60x18x60.
84 Specify an insertion point in the project.
85 In the Type Selector, select Bookcase: 36x12x36.
86 Specify an insertion point in the project.
87 On the Design Bar, click Modify.
Assign a different swing angle to each bookcase door

88 Select the 72x18x48 bookcase, and click .

89 In the Element Properties dialog:

- Under Other, for door_angle, enter 80.
- Click OK.

90 Using the same method, change the door angle of the 60x18x60 bookcase to 60.

91 Using the same method, change the door angle of the 36x12x36 bookcase to 0.

92 Copy the 72x18x48 bookcase and place the copy clear of the other bookcases.
93 Select the copied bookcase.  
   This is the second instance of the same bookcase type.

94 On the Options Bar, click .

95 In the Element Properties dialog:
   ■ Under Other, for door_angle, enter 20.
   ■ Click OK.

You made the bookcase so any instance of any bookcase type can have a unique value for the door swing.

96 Save and close the new project.
Creating an Angled Chair Back with a Reference Line

In this exercise, you create an adjustable angled seat back for a chair family.

To control the seat back angle, you constrain the seat back geometry to a reference line. One endpoint of the reference line is constrained to the chair seat, while the other endpoint is free, creating a hinge between the seat and seat back. An angular parameter controls the reference line angle, which in turn controls the angle of the seat back that is constrained to it.

After you create the chair back and test the adjustable angle, you create a bench type by widening the seat of the chair.
Open the chair family

1. Click File menu ➤ Open.
2. In the left pane of the Open dialog, click Training Files, and open Imperial\Families\Furniture\Chair.rfa.
   A view of the chair, minus the angled back, displays.

Add a reference line to control the angle of the seat back

3. In the Project Browser, under Elevations (Elevation 1), double-click Left.
4. Zoom in to the chair hinge.
5 On the Design Bar, click Reference Lines.

6 Specify the start point and endpoint of the reference line:
   ■ Move the cursor over the intersection of the 2 reference planes in the center of the circular hole.
   ■ Press TAB until the intersection displays, and select it.
   ■ Move the cursor up at a 45 degree angle until it is located near the vertical reference plane as shown, and click to specify the endpoint.
7 On the Design Bar, click Modify.  
**Align and constrain the reference line to the hinge location**

8 On the Tools toolbar, click (Align).

9 Select the vertical connect_plane2 reference plane.
10 Move the cursor over the endpoint of the reference line, press TAB until the endpoint displays, and click to select it.

11 Click to lock the alignment.

12 With the Align command still active, select the horizontal connect_plane reference plane.

13 Move the cursor to the endpoint of the reference line, press TAB until the endpoint displays, and select it.
14 Click .

Create a parameter to control the angle of the seat back

15 Place an angular dimension between the horizontal connect_plane reference plane and the reference line:
   ■ On the Design Bar, click Dimension.
   ■ On the Options Bar, click (Angular).
   ■ Select the connect_plane reference plane.
   ■ Select the reference line.
   ■ Specify a point between the reference line and the bottom reference plane to place the dimension.
16 Label the dimension to create a parameter:
   - Select the angular dimension.
   - On the Options Bar, for Label, select Add parameter.
   - In the Parameter Properties dialog, under Parameter Data, for Name, enter `angle_seat_back`.
   - Verify Type is selected.
   - Click OK.
   The `angle_seat_back` parameter label displays on the dimension.

Flex the family to test the `angle_seat_back` parameter

17 On the Design Bar, click Family Types.
18 In the Family Types dialog, under Other, for `angle_seat_back`, enter 90.
19 Click OK.
   The reference line repositions at a 90 degree angle from the connect_plane reference plane.
Open an elevation view of the chair

20 In the Project Browser, under Elevations, double-click Front.

Sketch the seat back

21 On the Design Bar, click Solid Form ➤ Solid Extrusion.
22 On the Design Bar, click Set Work Plane.
23 In the Work Plane dialog, under Specify a new Work Plane, select Pick a plane, and click OK.
24 Move the cursor over the reference line, press TAB until the reference line plane displays as shown, and select it.
25 Sketch a rectangle clear of the existing geometry:
- On the Design Bar, verify Lines is selected.
- On the Options Bar, click (Rectangle).
- Specify a point above the chair geometry for the bottom right corner of the rectangle. Precise placement of the point is not necessary.
- Move the cursor diagonally up, and specify a second point for the top left corner of the rectangle.

Constrain the sides of the seat back

26 Place a dimension between the left side of the sketch and Left reference plane:
- On the Design Bar, click Dimension.
- Select the Left reference plane.
- Select the left vertical side of the rectangle sketch, and click to the right of the dimension to place it.
27 Using the same method, dimension the Right reference plane and the right vertical side of the sketch.

28 Edit the dimensions:
- On the Design Bar, click Modify.
- Select the left vertical line of the sketch, and then select the dimension value.
- Enter 3", and press ENTER.
29 Using the same method, change the right dimension to 3”.

30 On the Design Bar, click Modify.
31 Align and constrain the seat back to the reference line:

■ On the Tools toolbar, click (Align).
■ Select endpoint of the reference line, as shown.
■ Select the bottom horizontal line of the rectangle.
■ Click .
Create a parameter to control the height of the seat back

32 Dimension the height of the rectangle sketch:
   ■ On the Design Bar, click Dimension.
   ■ Select the bottom edge of the sketch.
   ■ Select the top edge of the sketch.
   ■ Move the cursor to the left, and click to place the dimension.

33 Label the dimension to create a parameter:
   ■ Select the dimension that you just placed.
   ■ On the Options Bar, for Label, select Add parameter.
   ■ In the Parameter Properties dialog, under Parameter Data, for Name, enter `height_seat_back`.
   ■ Click OK.

34 On the Design Bar, click Finish Sketch.
Flex the family to ensure that the height of the seat back is adjustable

35 On the Design Bar, click Family Types.
36 In the Family Types dialog:
   ■ Under Other, for height_seat_back, enter 1'-6".
   ■ Click OK.

Center the seat back on the reference line for a side view

37 In the Project Browser, under Elevations, double-click Left.

38 Select the seat back to display blue triangular grips.
39 Select the grip on the front face of the seat back, and drag it to the right, clear of the reference line.
Precise placement of the face is not necessary.

40 Create an equal dimension constraint:
- On the Design Bar, click Dimension.
- Select the back face of the seat back sketch.
- Select the reference line (not the dashed reference plane).
- Select the front face of the seat back sketch.
- Move the cursor up, and click to place the dimension above the seat back.
If displays above the dimension, click it. The 2 segments of the dimension are now equal.

Specify the thickness of the seat back as the same thickness as the chair sides

41 Dimension the thickness of the seat back:
    ■ On the Design Bar, click Dimension.
    ■ Select the front and back faces of the seat back.
    ■ Move the cursor up, and click to place the dimension above both the other dimension and the seat back.
    ■ On the Design Bar, click Modify.

42 Label the dimension to create a parameter:
    ■ Select the dimension that you just placed.
    ■ On the Options Bar, for Label, select side_thickness.
    ■ On the Design Bar, click Modify.

The thickness of the side of the chair adjusts to 1", the value currently set for the side_thickness parameter.
Sketch a solid extrusion for the bottom of the seat back

43 Zoom in to the chair hinge.
44 On the Design Bar, click Solid Form ➤ Solid Extrusion.

45 On the Options Bar, click , and click (Circle).
46 At the center of the hinge hole, select the endpoint of the reference line at the intersection of the reference planes.
47 Specify a point on the hole perimeter.

48 On the Design Bar, click Finish Sketch.
Sketch a solid extrusion for the seat back

49 In the Project Browser, under Elevations, double-click Front.
50 Select the cylindrical solid form.
51 Align and lock the left and right sides of the solid form to the vertical reference planes:
   - On the Tools toolbar, click .
   - Select the Left reference plane.
   - Select the left side of the solid form.
   - Click .
   - Select the Right reference plane.
   - Select the right side of the solid form.
   - Click .

52 On the View toolbar, click (Default 3D View).

Test the angle of the seat back

53 On the Design Bar, click Family Types.
54 In the Family Types dialog:
   ■ Under Other, for angle_seat_back, enter 110.
   ■ Click OK.

Create a new bench type to test the family

55 On the Design Bar, click Family Types.
56 In the Family Types dialog:
   ■ Under Family Types, click New.
       ■ In the Name dialog, for Name, enter bench 5', and click OK.
       ■ Under Dimension, for seat_width, enter 5'.
   ■ Click OK.

57 Click File menu ➤ Save, and close the project.
Tutorials: Advanced
Standard Component
Families
Creating Shared Families

In this tutorial, you create a window family using nested windows. The example illustrates how to create a family for common window combinations, such as custom window assembly. First, you create the window geometry and test how it behaves in a project. Then, you change the nested families in the window to shared and see how this change affects the window when it is loaded into a project.

Skills used in this lesson include:
- Creating a nested family from standard components
- Adding family type parameters in order to control component type
- Testing the family in a project
- Tagging and scheduling windows
- Specifying nested families as shared
- Changing the family category in order to control scheduling

Creating a Window Family with Nested Windows

In this exercise, you create a window assembly family with 2 standard window families. You add family parameters to control the width and type of the windows.
Open a window family template

1. Click File menu ➤ New ➤ Family.
2. In the Left pane of the New dialog, click Training Files, and open Imperial\Templates\Window.rft.
3. Click File menu ➤ Save.
4. In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Shared Window.rfa.

Delete the existing opening in the template

5. Select the opening cut in the center of the wall.

6. Press DELETE.
   When you load the other windows as nested components, they cut the host, so the opening is not necessary.

Load and place a fixed window

8. Click Yes, to load a component.
9. In the left pane of the Open dialog, click Training Files, and open Imperial\Families\Windows\Fixed.rfa.
10. In the Type Selector, select Fixed : 36” x 48”.
11. Click the top face (exterior), near the center of the wall, to place the component.
   The fixed window is the center unit of the window assembly.

   **NOTE** When placing windows, make sure they are oriented in the wall correctly with respect to interior and exterior. The narrow part of the frame geometry is the exterior side of the window. After a window is placed, if it is not oriented correctly, you can use the flip control to switch the orientation. It may be helpful to change the display from coarse to medium or fine to see the exterior wall components.

12. Align and lock the fixed window to the center line of the family:
   - On the Tools toolbar, click (Align).
   - Select the Center (Left/Right) reference plane.
   - Select the vertical center line of the window.
Load and place the double hung window

13 On the Design Bar, click Component.
14 On the Options Bar, click Load.
15 In the left pane of the Open dialog, click Training Files, and open Imperial\Families\Windows\Double Hung.rfa.
16 In the Type Selector, select Double Hung : 24" x 48".
17 Place 2 windows, 1 on either side of the fixed window. Select the top face (exterior) as you place them.
The double hung windows create the sides of the window assembly.

18 On the Design Bar, click Modify.
19 Align and lock the double hung windows to reference planes:
   - On the Tools toolbar, click (Align).
   - Select the Left reference plane, click the right edge of the left window, and click .
   - Select the Right reference plane, click the left edge of the right window, and click .
On the Design Bar, click Modify.

The reference planes (aligned to the width of the center window) now control the placement of the center and side windows.

Add family type labels to the side and center windows

Select the 2 double hung windows, and on the Options Bar, for Label, select Add parameter. You add family type parameters so that you can specify alternate window families or types.

In the Parameter Properties dialog, for Name, enter Side Window Type, for Group parameter under, select Construction, and click OK.

Select the center window, and on the Options Bar, for Label, select Add parameter.

In the Parameter Properties dialog, for Name, enter Center Window Type, for Group parameter under, select Construction, and click OK.

The family type labels allow you to control the windows by changing types.

Create family type parameters for the window widths

On the Design Bar, click Family Types.

You create parameters for the center and side window widths. These parameters are used to calculate the overall opening, and to determine placement of the reference planes that control the position of the side windows.

In the Family Types dialog, under Parameters, click Add.

Add parameter properties:
- For Name, enter Center Window Width.
- For Group parameter under, select Dimensions.
- For Type of Parameter, select Length.
- Click OK.

Using the same method, add another Length parameter, named Side Window Width.

Create family types for window configurations

In the Family Types dialog, under Construction, for Side Window Type, select Double Hung: 24" x 48".

In the Family Types dialog, under Construction, for Center Window Type, select Fixed: 36" x 48".

Under Dimensions, for Side Window Width, enter 2', and for Center Window Width, enter 3'.

NOTE You specify the side and center window width parameters manually because there is no way to pass the width information from a nested family (window unit) to the host family (window assembly).

Under Family Types, click New.

In the Name dialog, enter 24-36-24W x 48H, and click OK.

Under Family Types, click New.

In the Name dialog, enter 16-24-16W x 48H, and click OK.

Specify the family type parameters and the width parameters for the second family type:
- For Name, verify that 16-24-16W x 48H is selected.
- Under Construction, for Side Window Type, select Double Hung: 16" x 48".
- For Center Window Type, select Fixed: 24" x 48".
Under Dimensions, for Side Window Width, enter 16".

For Center Window Width, enter 2'.

Click OK.

Apply the Center Window Width parameter

37 Select the Width dimension, and on the Options Bar, for Label, select Center Window Width. (If necessary, move the Interior label so it doesn’t overlap the width label.)

When you apply the Center Window Width parameter, the reference planes with the constrained side windows flex in position along the edge of the center window.

38 On the Design Bar, click Family Types.

39 In the Family Types dialog, under Dimensions, for Width ➤ Formula, enter Center Window Width + (Side Window Width*2).

This formula adds the center window width and the 2 side window widths. The resulting value is the full width of the window assembly as it is reported in a schedule.

40 For Height, enter 4', and click OK.

This value must match the height of the individual window units because it displays in the schedule for the window assembly.

41 On the Standard toolbar, click (Default 3D View).
42 Click File menu ➤ Save.
43 Proceed to the next exercise, Using a Shared Family in a Project on page 498.

Using a Shared Family in a Project

Next, you place the window family into a project environment. Because you want the individual windows inside the window assembly to be scheduled as separate items, you change the nested windows to shared families.

Test window assemblies in a project

1 Click Window menu ➤ Project1 - Floor Plan: Level 1.
2 On the Design Bar, click Wall.
3 Sketch a wall from left to right (approximately 24').
   The top face of the wall is the exterior side.
4 On the Design Bar, click Modify.
5 Click Window menu ➤ Shared Window.rfa - 3D View: {3D}.
6 On the Design Bar, click Load into Projects.
7 If the Load into Projects dialog displays, select Project1, and click OK.
   The family is loaded into the new project.

Place the family in the project

8 On the Design Bar, click Window.
9 Place 2 instances of the window into the project, one of each type:
   ■ In the Type Selector, verify that Shared Window : 24-36-24W x 48H is selected, and click the wall on the top face to place the window assembly.
   ■ In the Type Selector, select Shared Window : 16-24-16W x 48H, and click to place the smaller window assembly.
   ■ On the Design Bar, click Modify.
10 Zoom in to the 2 windows.
   Windows have been inserted and labeled as expected.

NOTE The tag numbers are editable, either on the tag or in a schedule.
Create a window schedule

11 Click View menu ➤ New ➤ Schedule/Quantities.
12 In the New Schedule dialog, under Category, select Windows, and click OK.
13 In the Schedule Properties dialog, under Available fields, select Type Mark, and click Add.
14 Using the same method, add the following fields:
   - Width
   - Height
   - Family
15 With Family selected under Scheduled fields, click Move Up twice to reorder the fields, and click OK.

<table>
<thead>
<tr>
<th>Window Schedule</th>
<th>Family</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Shared Window</td>
<td>6” x 8”</td>
<td>4” x 0”</td>
</tr>
<tr>
<td>11</td>
<td>Shared Window</td>
<td>6” x 8”</td>
<td>4” x 0”</td>
</tr>
</tbody>
</table>

There are 2 entries in the window schedule, listing the total width for each type of the window assembly. In order to schedule the individual window units within the assembly as separate items, you make the families shared.

**IMPORTANT** Sharing families allows individual family instances that are loaded into another family to be counted and scheduled.

Open the family for editing

16 In the Project Browser, under Floor Plans, double-click Level 1.
17 Select either window assembly, and on the Options Bar, click Edit Family.
18 In the confirmation dialog, click Yes to open Shared Window.rfa.
19 In the drawing area, select a side window and on the Options Bar, click Edit Family.
20 In the confirmation dialog, click Yes to open the double hung window for editing.
Make the families shared

21 Click Settings menu ➤ Family Category and Parameters.
22 In the Family Category and Parameters dialog, under Family Parameters, select Shared, and click OK.
23 On the Design Bar, click Load into Projects.
24 In the Load into Projects dialog, clear Project1, select Shared Window.rfa, and click OK.
25 In the Reload Family dialog, select Override parameter values of existing types, and click Yes.
26 Use the same method to make the center fixed window shared, and reload it into the Shared Window.rfa family.

Reload the shared family into the project

27 On the Design Bar, click Load into Projects.
28 In the Load into Projects dialog, select Project1, and click OK.
29 In the Reload Family dialog, select Override parameter values of existing types, and click Yes.
30 In the Reload shared family dialog, verify that Family and Override parameter values of existing types are selected, and click OK.

Tag windows in the window assembly

31 Select both window tags and move them away from the wall to leave space for window unit tags, and on the Design Bar, click Modify.
32 On the Drafting tab of the Design Bar, click Tag All Not Tagged.

Now that the families have been shared, each window in the window assembly can be tagged.
33 In the Tag All Not Tagged dialog, under Category, select Window Tags, and click OK.
Open the window schedule

34 In the Project Browser, expand Schedules/Quantities, and double-click Window Schedule. Individual instances of the windows in the window assembly are included in the schedule. Again, depending on requirements and office standards, you may not want the overall window assembly to be displayed in the schedule. A schedule filter can be applied to filter the window assembly entries, or the hosting family category can be altered so that it is not included in the schedule.

<table>
<thead>
<tr>
<th>Window Schedule</th>
<th>Family</th>
<th>Widths</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>10</td>
<td>Shared Window</td>
<td>7'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
<tr>
<td>11</td>
<td>Shared Window</td>
<td>8'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
<tr>
<td>20</td>
<td>Double Hung</td>
<td>2'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
<tr>
<td>35</td>
<td>Double Hung</td>
<td>3'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
<tr>
<td>25</td>
<td>Double Hung</td>
<td>3'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
<tr>
<td>51</td>
<td>Fixed</td>
<td>5'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
<tr>
<td>02</td>
<td>Fixed</td>
<td>5'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
</tbody>
</table>

Modify the window assembly family category

35 Click Window menu ➤ Shared Window Family.rfa - 3D View: {3D}.
36 Click Settings menu ➤ Family Category and Parameters.
37 In the Family Category and Parameters dialog, under Family Category, select Generic Models, and click OK.
   When you change the category of the window from Window to Generic Models, the window is no longer included in the window schedule.
38 On the Design Bar, click Load into Projects.
39 In the Load into Projects dialog, select Project1, and click OK.
40 In the Reload Family dialog, click Yes to overwrite the existing family version.
41 In the warning message dialog, click OK.
   This message notifies you that the tags that had been previously placed will be deleted since the window assembly is no longer categorized as a window.

42 In the Project Browser, under Schedules/Quantities, double-click Window Schedule. The window assembly families are no longer reported on the window schedule.
43 Right-click on the schedule and select View Properties.
44 In the Element Properties dialog, under Other, for Sorting/Grouping, click Edit.
45 In the Schedule Properties dialog, for Sort by, select Type Mark.
46 Click OK twice.

<table>
<thead>
<tr>
<th>Type Mark</th>
<th>Width</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>3'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
<tr>
<td>02</td>
<td>3'-0&quot;</td>
<td>4'-0&quot;</td>
</tr>
</tbody>
</table>

47 Close the project with or without saving it.
Creating a Complex Window Family
Creating a Complex Window Family

In this tutorial, you create a complex window family from a basic template. The window is defined to be used in a cavity wall, with wall components that wrap to the window frame on both the interior and exterior of the wall. The window is composed of 2 window types: an operable casement window (width defined by the user) and a fixed window.

In addition to creating the 3D geometry, you add symbolic lines to the family so that it displays cleanly in plan and elevation views.
Finally, you nest standard sill families into the window to be displayed and scheduled.
Creating a Complex Wall Opening

In this lesson, you open a file based on a window template and create a complex opening for the window. You delete the existing opening in the wall, and create a new opening by cutting the wall with a series of voids. You use a series of voids rather than a single sketch because the void sizes are different values.

**Complex wall opening with interior and exterior wrap**

Skills used in this lesson:
- Creating void geometry
- Using the Cut Geometry tool
- Adding parameters to control wrap values, where wall components will overlap, and the depth of the window frame.
- Adding family types for window sizes
- Testing the family in a project
- Modifying properties to define wall closure and wrap options

**Creating a Void to Cut the Exterior Wall Face**

In this exercise, you create a void extrusion to cut an opening in the exterior wall face.

**Open the family file**

1. Click File menu ➤ Open.
2. In the left pane of the New dialog, click Training Files, and open Imperial\Families\Windows\Complex_Window_Start.rfa.
3. Click File menu ➤ Save As.
4 In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Complex_Window.rfa.

**Modify the size of the host wall**

5 In the drawing area, select the wall, and on the Options Bar, click (Properties).

You alter the size of the host wall in the family template because this family will be used in a cavity wall, which is typically thicker than a standard wall. By making the host wall in the template thicker, it will also provide more room to create the reference planes needed when you make the complex opening.

6 In the Element Properties dialog, click Edit/New.

7 In the Type Properties dialog, under Construction, for Structure, click Edit.

8 In the Edit Assembly dialog, for Layer 2, click in the Thickness field, and enter 12".

9 Click OK 3 times.

10 On the Design Bar, click Modify.

11 Select the bottom middle sketch line (opening cut).

   **NOTE** Press TAB to highlight the opening cut if you are having trouble selecting it.

   ![Opening Cut](image)

12 Press DELETE.

Because you are creating a more complex opening, the existing opening in the template can be deleted. You replace this opening with a series of voids.

![Void in Wall](image)

13 On the View Control Bar, click the scale value, and select 1 1/2" = 1'0".

Increase the scale to resize the dimension text and make it more readable as you work on the window area.

**Add reference planes to define voids for complex geometry**

14 On the Design Bar, click Ref Plane.

15 Sketch a horizontal reference plane just above the Center (Front/Back) horizontal reference plane.

![Reference Plane](image)

16 On the Design Bar, click Modify.
17 Select the new reference plane, and on the Options Bar, click (Properties).

18 In the Element Properties dialog, under Identify Data, for Name, enter **Ext Wrap Depth**, and click OK.

When you name the reference planes, it is easier to dimension and align to them when the family is placed in a project.

19 Sketch 2 vertical reference planes, 1 to the left and 1 to the right of Center (Left/Right), as shown:

20 On the Design Bar, click Modify.

21 Name the new reference planes Ext Wrap Left and Ext Wrap Right, accordingly.

**Create a void extrusion**

22 On the Design Bar, click Void Form ➤ Void Extrusion.

23 Click Set Work Plane.

24 In the Work Plane dialog, for Name, select Reference Plane: Sill.

The void sketch will be drawn starting at sill height.

25 Click OK.

26 On the Options Bar, click (Rectangle), and verify that the Depth is 1'.

27 Sketch a rectangle, and align/lock it to the reference planes:

**NOTE** Sketching the geometry above the wall, rather than inside it, makes it easier to align the geometry and ensures that hidden constraints are not created.

- Sketch a rectangle above the wall between the inner vertical reference planes, as shown:
■ On the Tools toolbar, click (Align).

■ Select the Ext Wrap Depth reference plane.

■ Select the bottom sketch line, and click .

■ Select the Ext Wall Face reference plane, select the top sketch line, and click .

■ Select the Ext Wrap Left reference plane, select the left sketch line, and click .

■ Select the Ext Wrap Right reference plane, select the right sketch line, and click .

28 On the Design Bar, click Finish Sketch.
Dimension reference planes

29 Dimension the vertical reference planes:
- On the Design Bar, click Dimension.
- Dimension the 2 left reference planes, and dimension the 2 right reference planes.

TIP When modifying dimensions, select the line that is to move when the dimension changes (in this case, the inner reference planes).
Add an overhang parameter

30 Select the left dimension, and on the Options Bar, for Label, select <Add parameter>.

31 In the Parameter Properties dialog, for Name, enter **Ext. Wrap Overhang**, for Group parameter under, select Construction, and click OK.

This parameter describes how far the exterior wall wrap will overhang on the window frame.

32 Select the right dimension, and on the Options Bar, for Label, select Ext. Wrap Overhang.

33 In the Project Browser, expand Elevations, and double-click Exterior.

34 Add a reference plane and assign the Ext. Wrap Overhang parameter to the window head:

- On the Design Bar, click Ref Plane.
- Sketch a horizontal reference plane 3" below the Head reference plane, and name it Ext Wrap Top.
On the Design Bar, click Dimension.

Dimension the top 2 reference planes.

Select the dimension, and on the Options Bar, for Label, select Ext. Wrap Overhang.
NOTE In this example, the same parameter is used for the head wrap and jamb for simplicity. Another parameter could be created and assigned to define a different width at the head and jambs.

Cut the void from the host wall

35 On the Tools toolbar, click \(\text{Align}\).

36 Select the Ext Wrap Top reference plane, select the top line of the cut extrusion, and click \(\text{Cut}\).

37 In the Project Browser, under Floor Plans, double-click Ref. Level.

38 On the Tools toolbar, click \(\text{Cut Geometry}\).
39 Select the extrusion, select the wall, and on the Design Bar, click Modify.

Add depth parameter

40 On the Design Bar, click Dimension.
41 Dimension the Ext Wall Face and Ext Wrap Depth reference planes, and click Modify. The dimension value is not important.

42 Select the dimension, and on the Options Bar, for Label, select <Add parameter>.
43 In the Parameter Properties dialog, for Name, enter Ext. Wrap Depth, for Group parameter under, select Construction, and click OK.

Create family types and flex the model geometry

44 In the Project Browser, under Elevations, double-click Exterior.
On the Design Bar, click Family Types.

You should flex the family after you add each level of geometry. To make it easy to flex the family, you add family types with different dimensions. You then apply the types and observe the geometry.

Move the Family Types dialog so you can see the drawing area as you apply new types.

In the Family Types dialog, under Family Types, click New.

In the Name dialog, enter 4'0" H x 3'0" W_1'6" Casement, and click OK.

In the Family Types dialog, under Family types, click New.

In the Name dialog, enter 4'0" H x 5'0" W_1'6" Casement, and click OK.

Under Dimensions, for Height, enter 4' 0'', for Width, enter 5', and click Apply.

Using the same method, add a third family type, and name it 5'6" H x 6'0" W_2'0" Casement.

Under Dimensions, for Height, enter 5' 6'', for Width, enter 6', click Apply.

For Name, select 4'0" H x 3'0" W_1'6" Casement, and click OK.

Click File menu ➤ Save.

Proceed to the next exercise, Creating a Void for the Frame Geometry on page 515.

Creating a Void for the Frame Geometry

In this exercise, you create a solid void in the complex opening for the window frame geometry.

Add a reference plane

1 In the Project Browser, under Floor Plans, double-click Ref. Level.
2 On the Design Bar, click Ref Plane.
3 Sketch a reference plane 3" below the Center (Front/Back) reference plane, and name it Int Wrap Depth.

This reference plane between the interior face of the wall and the center reference plane is used to create the remaining 2 voids for the opening.

4 On the Design Bar, click Dimension.
5 Dimension the Int Wrap Depth and the Ext Wrap Depth reference planes.

The dimension value is not important.
6 Select the dimension, and on the Options Bar, for Label, click <Add parameter>.
7 In the Parameter Properties dialog, for Name, enter **Frame Depth**, for Group parameter under, select Construction, and click OK.

**Create a void**

8 On the Design Bar, click **Void Form ➤ Void Extrusion**.

9 On the Options Bar, click **(Rectangle)**.

10 Sketch a rectangle below the wall, approximately as shown:

11 On the Tools toolbar, click **(Align)**.

12 Select the Left reference plane, select the left sketch line, and click **.**

13 Select the Right reference plane, select the right sketch line, and click **.**
14 Select the Ext Wrap Depth reference plane, select the top sketch line, and click .

15 Select the Int Wrap Depth reference plane, select the bottom sketch line, and click .

16 On the Design Bar, click Finish Sketch.
17 In the Project Browser, under Elevations, double-click Exterior.
18 On the Tools toolbar, click \( \text{(Align)} \).

19 Select the Head reference plane, select the top of the cut extrusion, and click \( \text{(Align)} \).

20 Using the method you learned previously, open the Family Types dialog, and apply the family types to flex the geometry.

**Cut the void from the host wall**

21 In the Project Browser, under Floor Plans, double-click Ref. Level.

22 On the Tools toolbar, click \( \text{(Cut Geometry)} \).

23 Select the void, select the wall, and click Modify.
Creating a Void to Cut the Interior Wall Face

In this exercise, you create a third void for the complex opening to cut the interior face of the wall. You place reference planes for the wrap on the interior face of the wall. These reference planes will be constrained to assume the thickness of the interior finish material. The overhang value could be defined with a parameter, but to simplify this exercise, it will be a constrained dimension.

Add reference planes to define the void

1. On the Design Bar, click Ref Plane.

2. On the Options Bar, click (Pick Lines), for Offset, enter $\frac{1}{2}''$, and press ENTER.

3. Select the Right reference plane so that the new reference plane is positioned toward the center of the window.

4. Select the Left reference plane so that the new reference plane is positioned toward the center of the window.

5. Name the new reference planes Int Wrap Left and Int Wrap Right, accordingly.


7. Dimension the left 2 reference planes, and click .
8 Dimension the right 2 reference planes, and click ➤.

Create the third void

9 On the Design Bar, click Void Form ➤ Void Extrusion.

10 On the Options Bar, click (Rectangle).

11 Sketch a rectangle below the wall, approximately as shown:
12 Align and lock the sketch lines:

- On the Tools toolbar, click Align.

- Select the Int Wrap Left reference plane, select the left sketch line, and click .

- Select the Int Wrap Right reference plane, select the right sketch line, and click .

- Select the Int Wrap Depth reference plane, select the top sketch line, and click .
Select the Int Wall Face reference plane, select the bottom sketch line, and click #.

13 On the Design Bar, click Finish Sketch.

Create a reference plane at the window head

14 In the Project Browser, under Elevations, double-click Exterior.

15 Zoom in to the upper left corner of the window opening.
16 On the Design Bar, click Ref Plane.

17 On the Options Bar, click (Pick Lines), for Offset, enter 1/2", and press ENTER.

18 Select the Head reference plane so that the new reference plane is offset below it, and name the reference plane Int Wrap Top.

19 On the Design Bar, click Dimension.

20 Dimension the 2 horizontal reference planes, as shown:

21 Click .

22 Zoom out, and on the Tools toolbar, click (Align).

23 Select the Int Wrap Top reference plane, select the top of the cut extrusion, and click .
In the Project Browser, under Floor Plans, double-click Ref. Level.

On the Tools toolbar, click (Cut Geometry).

Select the cut extrusion, select the wall, and on the Design Bar, click Modify.

On the Standard toolbar, click (Default 3D View).

Using the method you learned previously, open the Family Types dialog, and apply the family types to flex the geometry.

Click File menu ➤ Save.

Proceed to the next exercise, Testing the Window Family on page 525.
Testing the Window Family

In this exercise, you load the complex window family into a project, place the window component in a cavity wall, and test the family.

Load and place the family in a project

2. On the Design Bar, click Wall.
   You draw a test wall to host the window.
   This is a cavity wall type.
4. Sketching from left to right, sketch a 24' horizontal wall in the center of the drawing area.
   The exterior of the wall is the top edge.
5. On the Design Bar, click Modify.
6. Click Window menu ➤ Complex_Window.rfa - 3D View: {3D}.
7. On the Design Bar, click Load into Projects.
   The complex window is loaded into the test project.
8. On the Basics tab of the Design Bar, click Window, and in the Type Selector, select Complex_Window : 4'0" H x 5'0" W_1'6" Casement.
9. Click the wall on the top edge (exterior) to place the window.

Change the detail level and scale

11. On the View Control bar, click Detail Level ➤ Fine.
12. On the View Control Bar, for Scale, select 1 1/2" = 1'-0".

Adjust wrap depth

13. In the Drawing Area, select the window.
14 On the Options Bar, click (Properties).
15 In the Element Properties dialog, click Edit/New.
16 In the Type Properties dialog, under Construction, for Ext. Wrap Depth, enter 6 5/8''.
17 Click OK twice.
   You adjust the depth of the exterior wrap so it accounts for the depth of the exterior material and the cavity, in this case 6 5/8''.

18 On the Design Bar, click Modify.
   The opening appears correct, except the wall materials are not wrapping the window opening. Next, you open the window family to make changes to correct this issue.

Specify the Wall Closure property in the window family

19 Click Window menu ➤ Complex_Windo.rfa - Floor Plan: Ref. Level.
20 Select the Ext Wrap Depth reference plane.

21 On the Options Bar, click (Properties).
22 Under Other, for Is Reference, select Not a Reference.
23 Under Construction, select Wall Closure, and click OK.
   You modify reference plane properties to define the stop point for the wrap.

24 Repeat the previous steps for the Int Wrap Depth reference plane.
25 On the Design Bar, click Family Types.
26 In the Family Types dialog, under Construction, for Wall Closure, select Both.
   Specifying the value Both for wall closure allows both sides to close as intended.

27 Repeat the previous step for each of the other 2 family types.
28 For Name, verify that 4’0”H x 5’0”W_1’6”Casement is selected, and click OK.

Reload the window family and test

29 On the Design Bar, click Load into Projects.
30 In the Reload Family dialog, click Yes.

31 Select the wall, and on the Options Bar, click (Properties).
32 In the Element Properties dialog, click Edit/New.
33 In the Type Properties dialog, under Construction, for Wrapping at Inserts, select Both.
34 Click OK twice.
35 On the Design Bar, click Modify.
Now the brick is wrapping on the exterior and the gypsum board is wrapping on the interior face.

36 Click File menu ➤ Save.
37 In the left pane of the Save As dialog, click Training Files, and save the project as Imperial\i_complex_window.rvt.
38 Proceed to the next lesson, Creating the Window Geometry on page 529.
Creating the Window Geometry

Now that the opening is complete, you are ready to add the window geometry. First, you create an adjustable center post between the fixed window and the casement windows. Next, you add the window frame, window sash, and glass geometry. After the 3D geometry is complete, you add symbolic lines to the window family for plan and elevation views.

Skills used in this lesson:

- Creating solid geometry, including extrusions and sweeps
- Setting the work plane for sketching geometry
- Specifying subcategories for solid geometry display
Creating symbolic lines for casement swing in plan and elevation views
Using a reference line to constrain to an angle
Adding a flip control to determine the position of a casement window

Creating the Center Post Geometry

In this exercise, you create an adjustable center post between the fixed and the casement windows. You associate the post with the casement window so that when that window width changes, the post location changes. The post also has an adjustable width parameter.

Training File

Continue to use the family that you used in the previous exercise, Complex_Window.rfa, or open training file Imperial\Families\Windows\Complex_Window_01.rfa.

Rename family file

1 If you are using the supplied training file, click File menu ➤ Save As.
2 In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Complex_Window.rfa.

Create reference planes to define the edges of the post

3 In the Project Browser, under Floor Plans, double-click Ref. level.
4 Add 3 reference planes:
   • On the Design Bar, click Ref Plane.
   • Sketch 3 vertical reference planes to the left of the Center (Left/Right) reference plane, as shown:

On the Design Bar, click Modify.

5 Starting from left to right, name the new reference planes:
   • Post Left
   • Post Center
- Post Right

6 Dimension the reference planes to establish a center for the post:

- On the Design Bar, click Dimension.

- Dimension the 3 post reference planes, and click EQ. The EQ toggle establishes a center point for the post.

- Dimension the Post Left and Post Right reference planes, and on the Design Bar, click Modify.

Assign parameters for the post

7 Assign a parameter to the post width:

- Select the last dimension you added, and on the Options Bar, for Label, select <Add parameter>.

- In the Parameter Properties dialog, for Name, enter Post Width.

- For Group parameter under, select Construction.

- Click OK.

8 On the Design Bar, click Dimension.

9 Select the Left reference plane of the window, select the Post Center reference plane, and click to place the dimension.

10 On the Design Bar, click Modify.

11 Select the dimension, and on the Options Bar, for Label, select <Add parameter>. 

Creating the Center Post Geometry | 531
You assign a parameter to establish a location for the post center line. In order to control the parameter parametrically, you add a formula based on the post width and the casement window width.

12 In the Parameter Properties dialog, for Name, enter **Post Location**, for Group parameter under, select Construction, and click OK.

13 On the Design Bar, click Family Types.

14 In the Family Types dialog, under Parameters, click Add.

15 Create a new parameter to establish the casement window width:
   - In the Parameter Properties dialog, for Name, enter **Casement Width**.
   - For Group parameter under, select Dimensions.
   - For Type of Parameter, select Length.
   - Click OK.

16 In the Family Types dialog:
   - For Name, verify 4’0"H x 5’0"W_1’6”Casement.
   - Under Dimensions, for Casement Width, enter 1’6”.
   - Under Construction, for Post Width, enter 3”.
   - Click Apply.
     You specify the casement width to match the width in the type name.

17 In the Formula field for Post Location, enter **Casement Width + (Post Width/2)**.

18 Define values for the other window types, and flex the family:
   - For Name, select 4’0"H x 3’0"W_1’6”Casement.
   - Under Dimensions, for Casement Width, enter 1’6”.

---

**Chapter 19  Creating the Window Geometry**
Under Construction, for Post Width, enter 3".
For Name, select 5’6”H x 6’0”W_2’0”Casement.
For Casement Width, enter 2’.
For Post Width, enter 4", click Apply, and click OK.

Add reference planes for the center post geometry

19 Zoom in to the area for the center post.
20 On the Design Bar, click Ref Plane.
You create and constrain reference planes to establish the front and back edges of the center post. The post should extend 1/4” from the face of the frame on both sides.
21 Sketch a short horizontal reference plane above the Ext Wrap Depth reference plane, as shown, and name the plane Ext Post Face.
22 Sketch a short horizontal reference plane below the Int Wrap Depth reference plane, as shown, and name the plane Int Post Face.
23 Dimension and constrain the new reference planes 1/4” from the Ext Wrap Depth and Int Wrap Depth reference planes.
24 Using the method you learned previously, open the Family Types dialog, and apply the family types to flex the geometry.

Create the center post geometry


26 On the Options Bar, click  (Rectangle).
27 Sketch a rectangle for the post within the reference planes, as shown:

28 If necessary, on the View toolbar, click  .

29 On the Tools toolbar, click  (Align).
30 Align and lock the sketch as shown:
31 On the Design Bar, click Finish Sketch.
32 In the Project Browser, under Elevations, double-click Exterior.
33 On the Tools toolbar, click Align.
34 Select the Head reference plane, select the top of the post extrusion, and click Align.
35 On the Design Bar, click Modify.
36 Click File menu ➤ Save.
37 Proceed to the next exercise, Creating the Window Frame Geometry on page 536.
Creating the Window Frame Geometry

In this exercise, you create solid sweeps for the window frames. You align the path and sweep edges to the reference planes, ensuring that the family flexes as intended.

**Sketch the path for the frame sweep**

1. If necessary, in the Project Browser, under Elevations, double-click Exterior.
3. Click Sketch 2D Path.
4. Click Set Work Plane.
5. In the Work Plane dialog, for Name, select Reference Plane: Center (Front/Back).
6. Click OK.
7. On the Options Bar, click (Rectangle).

**NOTE** When sketching the path for a sweep, the profile icon will appear on the first segment of the path drawn.

8. Starting in the lower left corner and moving to the upper right corner, sketch a rectangle to the right of the center post, as shown. This ensures that the profile location is at the bottom of the sketch.

9. Align and constrain the path to the reference planes defining the second opening:
   - On the Tools toolbar, click (Align).
   - Align and lock the sketch to reference planes, as shown:
10 On the Design Bar, click Finish Path.

**Sketch the profile for the frame sweep**

11 On the Design Bar, click Sketch Profile.

12 In the Go To View dialog, with Elevation: Left selected, click Open View.

13 On the Options Bar, click Rectangle.

14 Sketch a small rectangle in the bottom of the window frame, as shown:
15 On the Tools toolbar, click (Align).

16 Select the Sill reference plane, select the bottom of the profile, and click .

17 Align and lock the sides of the profile to the Ext Wrap Depth and Int Wrap Depth reference planes.

18 On the Design Bar, click Modify.

19 Select the top of the profile, click the dimension, enter 2", and press ENTER. Adjusting the profile creates a 2" frame.

20 On the Design Bar, click Finish Profile.

21 Click Finish Sweep.

22 On the Standard toolbar, click (Default 3D View).
Create the second frame

23 Using the method you just learned, create the frame on the other side of the post:

- Open the Exterior elevation view, and sketch a 2D path for the solid sweep.

- Align and constrain the path to the opening reference planes.
- Sketch a profile for the frame sweep.
- Align and constrain the profile to reference planes.
- Specify 2" for the final edge of the profile.
- Finish the profile and sweep, and view the window in 3D.
Specify the wrap overhangs and the frame width

24 On the Design Bar, click Family Types.
25 For Name, verify 5'6"H x 6'0"W_2'0"Casement is selected.
26 In the Family Types dialog:
   ■ Under Construction, for Frame Depth, enter 6".
   ■ Under Other, for Ext. Wrap Overhang, enter 1".
   ■ Click Apply.

27 For Name, select 4'0"H x 5'0"W_1'6"Casement, for Frame Depth, enter 4", for Ext. Wrap Overhang, enter 3/4", and click Apply.
For Name, select 5'6"H x 6'0"W_2'0"Casement, click Apply, and click OK.

Click File menu ➤ Save.

Proceed to the next exercise, Creating the Window Sash and Glass Geometry on page 542.

Creating the Window Sash and Glass Geometry

In this exercise, you create solid extrusions for the window sash and glass geometry. You also specify subcategories for the solid geometry to control the display of the glass and frame/mullion components.

Add a reference plane for the glass

1 In the Project Browser, under Floor Plans, double-click Ref. Level.

2 On the Design Bar, click Ref Plane.

To make it easier to create the sash and glass portions of the window, you add a reference plane to establish a center axis for the glass. The position of this axis is constrained to the exterior face of the window frame.

3 Sketch a horizontal reference plane below the Ext Wrap Depth reference plane, and name the plane Glass Axis.

You provide a name for the reference plane so that it can be selected as a work plane in later steps.
4 Zoom in to the right side of the wall.
5 On the Design Bar, click Dimension.
6 Dimension and constrain the Glass Axis reference plane:
   ■ Select the Glass Axis reference plane, select the Ext Wrap Depth reference plane, and click to place the dimension.
   ■ On the Design Bar, click Modify.
   ■ Select the Glass Axis reference plane, select the dimension, enter 2'', and press ENTER.
   ■ Click Modify, select the dimension, and click .

Create the geometry for the left sash
7 In the Project Browser, under Elevations, double-click Exterior.
8 On the Design Bar, click Solid Form ➤ Solid Extrusion.
9 On the Design Bar, click Set Work Plane.
10 In the Work Plane dialog, for Specify a new Work Plane, select Reference Plane : Glass Axis, and click OK.
11 On the Options Bar, click (Rectangle).
12 Sketch a rectangle within the left frame for the sash extrusion.
13 On the Tools toolbar, click \( \text{Align} \).  
14 Align and lock the sketch lines to the interior face of the window frame, as shown:  

15 On the Design Bar, click Lines.  
16 On the Options Bar, click \( \text{Offset} \), and for Offset, enter \(-2''\).  
17 Click the lower left endpoint of the sash sketch, and click the upper right endpoint to create the second closed loop.

**NOTE** When the second loop is created, relationships are established to the first loop. These relationships are based on how Revit Architecture determines design intent. Often, these relationships are correct, but the relationships may have to be more explicitly defined using dimensions or parameters.
18 On the Design Bar, click Extrusion Properties.
You specify the extrusion properties to extend on both sides of the glass axis (the current work plane).

19 In the Element Properties dialog:
   ■ Under Constraints, for Extrusion End, enter -3/4".
   ■ For Extrusion Start, enter 3/4".
   ■ Click OK.

20 On the Design Bar, click Finish Sketch.

21 On the Standard toolbar, click (Default 3D View).

Create geometry for the right sash

22 Open the Exterior elevation view and, using the method you just learned, add a sash to the other side of the window:
   ■ In the Exterior elevation view, sketch the shape of the sash extrusion.
■ Align and lock the extrusion to the interior face of the window frame.

■ Create the second closed loop sketch for the sash, offset -1" from the first sketch.
Specify extrusion properties, finish the sketch, and view the window in 3D.

23 Open the Family Types dialog, and flex the model to test geometry behavior.

Create a solid extrusion for the window glass

24 In the Project Browser, under Elevations, double-click Exterior.
26 Click Set Work Plane.
27 In the Work Plane dialog, for Specify a new Work Plane, verify that Name and Reference Plane: Glass Axis are selected, and click OK.

28 On the Options Bar, click (Rectangle), and sketch 2 rectangles, one for each pane of glass, as shown:
29 On the Tools toolbar, click \( \text{(Align)} \).

30 Align and lock the extrusions to the sash faces, as shown:

31 On the Design Bar, click Extrusion Properties.

32 In the Element Properties dialog, for Extrusion End, enter \(-1/4"\), and for Extrusion Start, enter \(1/4"\), and click OK.

This method establishes the glass thickness without additional reference planes.

33 On the Design Bar, click Finish Sketch.

34 On the Standard toolbar, click \( \text{(Default 3D View)} \).

35 Open the Family Types dialog, and flex the model to test geometry behavior.
Specify subcategories for geometry

36 Select the glass, and on the Options Bar, click Properties. Specify the subcategories for the solid geometry created in the previous steps. This gives you control over the display of these items when you load them into a project.

37 In the Element Properties dialog, under Identity Data, for Subcategory, select Glass, and click OK.

38 On the Design Bar, click Modify.

39 While pressing CTRL, select the window frame, both sashes, and the post geometry, and on the Options Bar, click Properties.
40 In the Element Properties dialog, under Identity Data, for Subcategory, select Frame/Mullion, and click OK.

41 On the Design Bar, click Modify.

42 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

43 Click File menu ➤ Save.

44 Proceed to the next exercise, Adding Symbolic Lines on page 550.

Adding Symbolic Lines

The window geometry is complete. Next, you add symbolic lines to the window family to represent the casement swing in plan and elevation views. You also turn off the visibility of the glass and replace it with a single symbolic line, so that the window displays cleanly in plan view. When the extrusion for the glass is visible, it creates a double line that is too heavy for the graphic standards.

Training File

Continue to use the family that you used in the previous exercise, Complex Window.rfa, or open training file Imperial\Families\Windows\Complex_Window_02.rfa.

Rename family file

1 If you are using the supplied training file, click File menu ➤ Save As.

2 In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Complex_Window.rfa.

Turn off visibility of the glass in plan views

3 In the Project Browser, under Floor Plans, double-click Ref. Level.

4 Select the glass, and on the Options Bar, click Visibility.
5 In the Family Element Visibility Settings dialog, clear Plan/RCP and When cut in Plan/RCP (if category permits).
6 Click OK.

**Add symbolic lines to represent the glass in plan view**

7 On the Design Bar, click Symbolic Lines.
8 In the Type Selector, select Glass [cut].
9 Zoom in to the left glass element.

10 Sketch a line along the Glass Axis reference plane to represent the glass:
   - Select the midpoint of the sash on the right.
   - Select the midpoint of the sash on the left.
   - On the Design Bar, click Modify.

11 Select the symbolic line.
12 Click the 3 lock icons to constrain the endpoints of the line to the sash and to the glass axis.
13 Using the same method, add and constrain a symbolic line to the glass on the other side of the post.

Add a reference plane to control the reference line

14 On the Design bar, click Ref Plane.
15 Sketch a vertical reference plane on the left side of the opening, close to the inner face of the frame.
16 On the Design Bar, click Dimension.
17 Dimension the Left reference plane and the new reference plane.
18 On the Design Bar, click Modify.

19 Click on the new reference plane, select the dimension you just placed, enter 2", and press ENTER.

The dimension now matches the frame width. The hinge point of the window swing symbol will be at the intersection of the glass line and the reference plane on the inside face of the frame.

NOTE It is best practice to dimension from reference planes and reference lines to control placement of geometry. The symbolic lines for the window are drafted on a reference line so that you can control the angle of the opening.
20 Click Modify, select the dimension, and click .

Add a reference line for the window swing

21 On the Design Bar, click Reference Lines.

You use a reference line to establish the position of the symbolic line (at a 45-degree angle to the window). Because a reference line has endpoints (unlike a reference plane that extends "infinitely" in all directions), it can be used to create a parametric relationship using an angle.

22 Click to select the midpoint of the left edge of the glass frame.

23 Move the cursor up and to the right at a 45-degree angle, and click to select the endpoint.

The length is not important.

24 Click Modify, select the reference line, and click below the left endpoint.


26 Using TAB, select each endpoint of the reference line, and place the dimension.

27 Click Modify, and select the dimension.

28 On the Options Bar, for Label, click <Add parameter>.

You add a parameter to control the length of the swing line.
In the Parameter Properties dialog, for Name, enter **Swing Width**, and click OK.

Dimension and constrain the angle of the reference line:
- On the Design Bar, click Dimension.
- On the Options Bar, click (Angular).
- Select the reference line, select the Glass Axis reference plane, and click to place the dimension.

On the Design Bar, click Modify.

Select the angle dimension and on the Options Bar, for Label, select <Add parameter>.

In the Parameter Properties dialog, for Name, enter **Swing Angle**, and click OK.
Add a formula to control the swing width

34 On the Design Bar, click Family Types.
35 In the Family Types dialog, under Other, for Swing Width Formula, enter Casement Width - 4", and click Apply.
   The length of the symbolic line should be as long as the sash portion of the window. The 4" measurement is the width of the frame (both sides) that you drew in previous steps.
36 For Swing Angle, enter 30, and click Apply.
   This is to confirm the reference line moves as anticipated around the hinge.
37 For Swing Angle, enter 45, and click Apply.
38 Under Name, select 4'0"H x 5'0"W_1'6"Casement, and click Apply.
39 Under Name, select 5'6"H x 6'0"W_2'0"Casement, click Apply, and click OK.

Add a symbolic line for the swing width

40 On the Design Bar, click Symbolic Lines.
41 In the Type Selector, select Elevation Swing [cut].
   This is a dashed line type.
42 Sketch a symbolic line using the endpoints of the reference line, and click Modify.
43 Select the symbolic line, and click the lock icon adjacent to the swing width to constrain the length to the reference line.

Add an arc for the symbolic swing display

44 On the Design Bar, click Symbolic Lines.
45 On the Options Bar, click \[ \text{Arc from center and endpoints} \], and click \[ \text{(Arc from center and endpoints)} \].
46 Click the lower endpoint of the symbolic line, click the upper endpoint, click the midpoint of the frame, and click \[ \text{to constrain the end to the glass line} \].
47 On the Design Bar, click Modify.
48 Using the method you learned previously, open the Family Types dialog, and apply the family types to flex the geometry.

Add swing lines to the elevation of the window

49 In the Project Browser, under Elevations, double-click Exterior.
50 On the Design Bar, click Ref Plane.
51 Sketch a horizontal reference plane through the middle of the window.

52 On the Design Bar, click Dimension.
53 Dimension the Head reference plane, the new reference plane, and the Sill reference plane, and click EQ.
54 On the Design Bar, click Symbolic Lines, and on the Options Bar, verify that Chain is selected.
55 In the Type Selector, select Elevation Swing [projection].
56 Zoom in to the right glass pane.
57 Sketch the symbolic lines:

- Select the upper left corner of the glass.
- Move the cursor down and to the right, and select the midpoint at the intersection of the glass and the center reference plane.
- Move the cursor down and to the left, and select the lower left corner of the glass.
- On the Design Bar, click Modify.

58 Select the bottom symbolic line, and click .
Flex the window family

59 On the Design Bar, click Family Types.
60 In the Family Types dialog, for Name, select 4'0"H x 5'0"W_1'6"Casement, and click Apply.
61 For Name, select 5'6"H x 6'0"W_2'0"Casement, click Apply, and click OK.

Add a horizontal flip control

62 In the Project Browser, under Floor Plans, double-click Ref. Level.

63 On the Design Bar, click Control, and on the Options Bar, click (Double Horizontal).
   You add a horizontal flip control so the casement window can be positioned on the left or right side.

64 Click above the right area of the window to add the flip control.

65 Click File menu ➤ Save.

Load the window into a project

66 Click File menu ➤ Open.
67 In the left pane of the Open dialog, click Training Files, and open Imperial\i_complex_window.rvt.
68 Click Window menu ➤ Complex_Window.rfa - Elevation : Exterior.
69 On the Design Bar, click Load into Projects.
70 In the Load into Projects dialog, select i_complex_window.rvt, and click OK.
71 In the Reload Family dialog, click Yes.

72 Select the window, and click \(\leftrightarrow\) (Flip the instance hand) to change the position of the casement window.

73 On the Standard toolbar, click \(\square\) (Default 3D View).

74 Click File menu ➤ Save.

75 Proceed to the next lesson, Nesting Sill Families into the Window Family on page 561.
Nesting Sill Families into the Window Family

You can import families into other families, which nests them. You can then model parts of the nested family separately from the main family model. Using family type parameters in the main family, you can switch between imported families of the same category.

In this lesson, you import window sill families into the window family and associate parameters of the nested families to the main family.

Creating Sill Families

There are 2 window sill families available in the training folders. In this exercise, you open the families and explore how they are designed.

**Open the Concrete Sill family**

1. Close all open projects or families.
2. Click File menu ➤ Open.
3. In the left pane of the Open dialog, click Training Files, navigate to Imperial\Families\Windows\Concrete Sill.rfa, and click Open.
4. In the Project Browser, under Floor Plans, double-click Ref. Level.

The concrete sill family consists of a solid extrusion, a Width type parameter, a Depth instance parameter, and a fixed dimension for the sill overhang. The Back and Center (Left/Right) reference planes define the origin of the family. The sills are not defined as work plane-based.
In the Project Browser, under Elevations, double-click Left.

The elevation view shows reference planes with fixed dimensions. The sketch lines of the extrusion are locked to all exterior reference planes. The Bottom reference plane defines the origin of the family.

6 In the Project Browser, under 3D views, double-click View 1.
7 Select the solid geometry, and on the Options Bar, click (Properties).
   The sill is placed on a subcategory Window Sill, has a fixed material Window Sill Concrete assigned, and is visible only in detail level Fine.

8 In the Element Properties dialog, click Cancel.

9 Click Settings menu ➤ Family Category and Parameters.

10 In the Family Category and Parameters dialog, under Family Category, notice that Windows is selected.

11 Under Family Parameters, select Work Plane-Based.
   Unlike a window which is level-based, it is helpful to be able to place the sill on a sill reference plane.

12 Click OK.

Open the Metal Sill family

13 Save and close the concrete sill file.

14 Click File menu ➤ Open.

15 In the left pane of the Open dialog, click Training Files, navigate to Imperial\Families\Windows\Metal Sill.rfa, and click Open.

16 Select the solid geometry, and on the Options Bar, click (Properties).
   The sill is placed on a subcategory Window Sill, has a fixed material Window Sill Metal assigned, and is visible only in detail level Fine. Parameters, Reference Planes, and Origins are as in the concrete sill family.

17 In the Element Properties dialog, click Cancel.

18 Click Settings menu ➤ Family Category and Parameters.

19 In the Family Category and Parameters dialog, under Family Category, notice that Windows is selected.

20 Under Family Parameters, select Work Plane-Based.
   Unlike a window which is level-based, it is helpful to be able to place the sill on a sill reference plane.

21 Click OK.

Both sill families were created with the Generic Model family template and changed to a window family. The category of a family can be changed under Settings menu ➤ Family Category and Parameters.
Loading Sill Families into the Window Family

Families opened in the Family Editor can be loaded directly into other families. In this exercise, you open the main family first, and then load families into the complex window family you created.

**Training File**

Continue to use the family that you used in a previous exercise, Complex_Window.rfa, or open training file Imperial\Families\Windows\Complex_Window_03.rfa.

**Rename family file**

1. If you are using the supplied training file, click File menu ➤ Save As.
2. In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Complex_Window.rfa.

**Load the concrete sill**

3. Click File menu ➤ Open.
4. In the Open dialog, navigate to Imperial\Families\Windows\Concrete Sill.rfa, and click Open.
5. On the Design Bar, click Load into Projects.
6. If the Load into Projects dialog displays, select Complex_Window.rfa, and verify that Metal Sill.rfa is cleared.
7. Click OK.
   The concrete sill family is now loaded into the Window family.

**Load the metal sill**

8. Click Window menu ➤ Metal Sill.rfa -3D View: View1.
9. Load the sill family into the Window family.
10. Click Window menu ➤ Tile.

11. Close Metal Sill.rfa and Concrete Sill.rfa.
12. Maximize Complex_Window.rfa.
   As both sill families have been defined as Window families, they appear in the Project Browser under Families ➤ Windows.
**Associate the Width parameter to nested families**

13 In the Project Browser, under Families ➤ Windows ➤ Concrete Sill, double-click Concrete Sill.
14 In the Type Properties dialog, for Dimensions ➤ Length, click .
15 In the Associate Family Parameter dialog, select Width.
   The sill length needs to be equivalent to the exterior width of the window family.
16 Click OK twice.
17 Using the same method, associate the Length parameter of the Metal Sill family.
   The Length type parameter of the nested families now has the same value as the Width parameter of the window family.

**Placing the Sill Family**

In this exercise, you place the concrete sill in the Complex Window project, aligning it to reference planes in both plan and elevation views.

**Place the family**

1 In the Project Browser, under Floor Plans, double-click Ref. Level.
2 On the View Control Bar, click Detail Level ➤ Fine.
3 In the Project Browser, expand Families ➤ Windows ➤ Concrete Sill.
4 Drag Concrete Sill into the drawing area.
5 On the Options Bar, click (Place on Work Plane).
6 For Plane, select Reference Plane: Sill
7 Click to place the sill above the window.
8 On the Design Bar, click Modify.

![Diagram of placing the sill family](image)

**Associate an instance parameter**

9 Select the solid geometry of the concrete sill, and on the Options Bar, click (Properties).
10 In the Element Properties dialog, for Dimensions ➤ Width, click .
11 In the Associate Family Parameter dialog, select Ext. Wrap Depth.
12 Click OK twice.
The Width instance parameter of the nested sill family now has the same value as the Ext. Wrap Depth parameter of the window family.

The sill needs to be positioned and aligned in plan and elevation views.

**Align the sill**

13 On the Tools toolbar, click (Align).

14 Select the Center (Left/Right) reference plane of the window family, select the hidden Center (Left/Right) reference plane of the Sill family, and lock the alignment.

15 Using the same method, align the lower horizontal edge of the sill to the Ext. Wrap Depth reference plane (2nd from the top), and lock the alignment.

16 In the Project Browser, under Elevations, double-click Left.

17 On the View Control Bar, click Detail Level ➤ Fine.

18 On the Tools toolbar, click (Align).

19 Select the Sill reference plane of the window family, align the bottom edge of the sill family, and lock the alignment.

20 In the Project Browser, under 3D Views, double-click View 1.
21 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.
22 On the View Control Bar, click Detail Level ➤ Fine.
   The sill is placed in the desired position.

TIP If the sill does not display, click and spin the wall.

Creating a Shared Parameter

In order to switch the sill from concrete to metal on an instance level, you add a Sill Type parameter.

To display the custom parameter in a schedule, you must define the parameter as shared. If the family is then loaded into a project, the parameter appears as an available field on the Fields tab of the Schedule Properties dialog.

NOTE You could create a family parameter to control the sill type when the window family is used in a project; however, family parameters are not available for scheduling. If you wish to include a parameter in a schedule, it must be defined as a shared parameter.

Create the shared parameter

1 Click File menu ➤ Shared Parameters.
2 In the Edit Shared Parameters dialog, click Create.
3 In the left pane of the Save As dialog, click Training Files.
4 Under File name, enter Training Shared Parameter, and click Save.
5 In the Edit Shared Parameters dialog, under Groups, click New.
6 In the New Parameter Group dialog, for Name, enter Windows, and click OK.
7 In the Edit Shared Parameters dialog, under Parameters, click New.
8 In the Parameter Properties dialog:
   ■ For Name, enter Sill Type.
Under Type of Parameter, select <Family Type>.

9 In the Select Category dialog, select Windows.
10 Click OK 3 times.

Add the parameter to a family

11 On the Design Bar, click Family Types.
12 In the Family Types dialog, under Parameters, click Add.
13 In the Parameter Properties dialog, under Parameter Type, select Shared parameter, and click Select.
14 In the Shared Parameters dialog, click OK.
   Note that the last created Shared Parameter file has been automatically opened.
15 In the Parameter Properties dialog, for Group parameter under, select Construction, and select Instance.
16 Click OK twice.

Associate the parameter to geometry

17 In the drawing area, select the Concrete Sill family.
18 On the Options Bar, for Label, select Sill Type.

Testing Nested Families

You can test the correct behavior of the nested families directly in the window family.

1 On the Design Bar, click Family Types.
2 In the Family Types dialog, for Construction ➤ Sill Type (default), select Metal Sill.
3 Click Apply.
   The metal sill replaces the concrete sill.

4 Click OK.
Testing the Family in a Project Environment

Finally, you test the window in the project environment, and create a window schedule.

Test windows and sills

1. Click File menu ➤ Open.
2. Navigate to the location of i_complex_window.rvt that you saved previously, and open the project.
3. Click Window menu ➤ Complex_Window.rfa - 3D View: View 1.
5. In the Reload Family dialog, click Yes.
7. In the Type Selector, select Complex_Window : 4'0"H x 5'0"W_1’6"Casement, and place the window in the wall to the left of the existing window.
10. In the View Control Bar, click Detail Level ➤ Fine.

TIP: If the sill does not display, click and spin the wall.

11. Select the window you just added, and on the Options Bar, click (Properties).
12. In the Element Properties dialog, for Construction ➤ Sill Type, select a new sill type, and click OK.

   Note that the window sill has changed.

Create a window schedule

13. Click View menu ➤ New ➤ Schedule/Quantities.
14. In the New Schedule dialog:
   - Under Category, select Windows.
   - Under Name, enter **Window Schedule with Sills**.
   - Click OK.

   Sill Type is now displayed in the schedule table.
### Window Schedule with Sills

<table>
<thead>
<tr>
<th>Mark</th>
<th>Width</th>
<th>Height</th>
<th>Sill Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>5'-0&quot;</td>
<td>4'-0&quot;</td>
<td>Metal Sill</td>
</tr>
<tr>
<td>2</td>
<td>5'-0&quot;</td>
<td>4'-0&quot;</td>
<td>Concrete</td>
</tr>
</tbody>
</table>

16 Save and close all project files.
Creating a Solar Shade
Family
Creating a Solar Shade Family

In this tutorial, you create a parametric solar shade family that has 3 types of supports: braced, hung, and cantilever.

*Braced support*

*Hung support*
First you create the support geometry for the shade. To have better control over the shade elements, you create the support structure and louver as separate families, and then nest them into the shade family.

By adding parameters to the solar shade, you can easily control the mounting height, type of support, and length of the shade.

By adjusting the length of the shade and adding sunlight and shadows to the view, you can choose the most effective shade options for the building.
Creating the Shade Support

In this lesson, you create the solid geometry for the shade support. You create the elements to provide 3 types of support: braced, hung, and cantilever. A length parameter is also specified so the length of the shade support can be changed.

Shade support geometry showing 3 types of support:
hung, braced, and cantilever

Skills used in this lesson:

- Creating solid geometry, including extrusions and sweeps
- Assigning materials to 3D geometry
- Adding family types for shade support variations
- Creating yes/no parameters to control geometry visibility

Creating the Main Support Beam

First, you create the main support beam geometry. You also dimension the beam and add a parameter to control the length of the shade support.
Create a family from a general model template

1. Click File menu ➤ New ➤ Family.
2. In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Generic Model.rft.
4. Click File menu ➤ Save As.
5. In the left pane of the Save As dialog, click Training Files, and save the file as Imperial\Families\Support Beam.rfa.
   The family file is saved automatically with the .rfa extension.

Create the mounting plate for the support beam

6. Zoom in to the intersection of the reference planes.
8. On the Options bar, for Depth, enter 1/4", and press ENTER.
9. On the Options bar, click (Rectangle).
10. Sketch a 6" x 4" rectangle over the intersection of the reference planes, as shown:

12. Move the rectangle so it is centered over the intersection of the reference planes:
   - In the drawing area, select the rectangle.
   - On the Tools toolbar, click (Move).
   - Select the midpoint of the upper sketch line, and select the Center (Left/Right) reference plane.
- On the Tools toolbar, click (Move).
- Select the midpoint of the right vertical sketch line, and select the horizontal reference plane.

13 On the Design Bar, click Finish Sketch.

14 In the Project Browser, under Floor Plans, double-click Ref. Level.
15 Zoom in to the extrusion.

Add reference planes for the left and right faces of the support beam

16 On the Design Bar, click Ref Plane.

17 On the Options Bar, click (Pick Lines), for Offset, enter 1/4" and press ENTER.
18 Select the Center (Left/Right) reference plane twice to add 2 reference planes—1 offset to the right and 1 to the left.
19 On the Design Bar, click Modify.
20 Name the 2 reference planes:

- Select the left vertical reference plane, and click \(\square\) (Properties).
- In the Element Properties dialog, under Identity Data, for Name, enter **Left Edge**, and click OK.
- Using the same method, name the right vertical reference plane **Right Edge**.

21 In the Project Browser, under Elevations, double-click Right.

**Create the support beam**

22 Zoom in to the left of the intersection of the reference planes.

23 Define a reference plane to set the length of the support beam:

- On the Design Bar, click Ref Plane.
- Sketch a vertical reference plane on the left, as shown:
24 On the Design Bar, click Sold Form ▶ Solid Extrusion.
26 In the Work Plane dialog, for Name, select Reference Plane : Left Edge, and click OK. You specify the work plane as the left face of the beam created in previous steps.
27 Sketch the profile for the extrusion. (The exact size and position are not important because you will use the Align and Move tools to specify the size.)
   ■ On the Options bar, click (Rectangle), for Depth, enter 1/2'', and press ENTER.
   ■ Sketch a rectangle centered over the reference level, as shown:

   ![Rectangle Sketch](image)

   ■ Select the vertical dimension, enter 4'', and press ENTER.

   ![Vertical Dimension Sketch](image)

28 Use the Align tool to align and lock both ends of the sketch to the reference planes:
   ■ On the Edit toolbar, click (Align).
- Select the Center (Front/Back) reference plane, select the right sketch line, and click.

- Select the left vertical reference plane, select the left sketch line, and click.

- On the Design Bar, click Modify.

29 Center the sketch over the horizontal reference level:
- Select all the sketch lines.

- On the Tools toolbar, click (Move).
- Select the midpoint of the left sketch line.

- Select the intersection of the reference planes.
- On the Design Bar, click Finish Sketch.
Create a parameter to control the length of the support beam

30 On the Design Bar, click Family Types.
31 In the Family Types dialog, under Parameters, click Add.
32 Specify parameter properties:
   ■ For Name, enter **Support Length**.
   ■ For Group parameter under, select Dimensions.
   ■ For Type of Parameter, select Length.
   ■ Click OK twice.
33 On the Design Bar, click Dimension.
34 Select the left and right vertical reference planes, and click to add a dimension.
35 On the Design Bar, click Modify.

Flex the family to verify that the geometry is constrained as intended

36 Select the dimension, and on the Options bar, for Label, select Support Length.

Flex the family to verify that the geometry is constrained as intended

37 On the Design Bar, click Family Types.
38 Move the Family Types dialog so you can also see the drawing area.
39 Modify the Support Length value:
   ■ Enter 1', and click Apply.
   ■ Enter 5', and click Apply.
   ■ Enter 2' 6'', and click Apply.
   ■ Click OK.
40 Click File menu ➤ Save.
41 Proceed to the next exercise, Creating Geometry for Hung and Braced Support on page 582.

Creating Geometry for Hung and Braced Support

Now that the main support beam has been created, you model the geometry for the 2 other support conditions: hung and braced.

Add reference planes for support connection points

1 On the Design Bar, click Ref Plane.
2 Sketch a vertical reference plane 4" to the right of the left reference plane.
3 On the Design Bar, click Dimension. Next, you dimension and constrain the reference plane for the support connection points.

4 Select the left-most reference plane, select the reference plane to the right, click to position the dimension, and click .

5 On the Design Bar, click Ref Plane. You add reference planes for the top and bottom connection points for the supports.

6 Sketch 2 horizontal reference planes, 1 above and 1 below the extrusion.
7 On the Design Bar, click Modify.
8 Dimension and constrain the top reference plane:
   - On the Design Bar, click Dimension.
   - Select the reference level, select the top reference plane, and click to position the dimension to the right.
   - On the Design Bar, click Modify.
   - Select the top reference plane.
   - Select the dimension value, enter 2', and press ENTER.
   - Select the dimension, and click .

9 Using the same method, dimension and constrain the bottom reference plane 2' from the reference level.
10 On the Design Bar, click Modify.

Create an extrusion for the brace

11 On the Design Bar, click Solid Form ➤ Solid Extrusion.
12 On the Options bar, for Depth, verify that the value is 1/2".
13 Select the intersection of the bottom of the extrusion and the inner-left reference plane:

**IMPORTANT** Use TAB to be sure you highlight the Intersection of Nearest to Extrusion and Nearest to [Reference planes : Reference Plane] before selecting.

14 Move the cursor diagonally down and to the right, and select the intersection of the bottom and right reference planes.
15 On the Design Bar, click Modify.
16 Select the diagonal sketch line.
17 Click the 2 lock icons to constrain the line to the horizontal bottom edge of the support and vertical reference plane.

18 Sketch lines to complete the extrusion:
   ■ On the Design Bar, click Lines.
   ■ On the Options bar, click (Pick Lines), and for Offset, enter 1".
   ■ Select the diagonal sketch line so the new line is offset to the right.
On the Options bar, click \(\text{(Draw)}\), and for Offset, enter \(0''\).

Beginning at the upper-left endpoint of the left sketch line, draw a line horizontally to connect to the right sketch line, as shown:

Sketch a line from the lower-left endpoint of the left sketch line vertically to connect to the right sketch line, as shown:

19 On the Edit toolbar, click \(\text{(Trim)}\).
20 Select the sketch lines to clean up the ends and create a closed loop sketch, as shown:
21 On the Design Bar, click Dimension.
You dimension and constrain the parallel sketch lines for the brace so the shape of the support
does not change with the length of the support beam.

22 Select the right and left long sketch lines, click to add the dimension, and click **.  

23 On the Design Bar, click Finish Sketch.
Flex the family to verify that the geometry is behaving as expected:

- On the Design Bar, click Family Types.
- In the Family Types dialog, for Support Length, enter 5', and click Apply.
- Enter 18", and click Apply.
- Enter 2' 6", click Apply, and click OK.

Create the mounting plate geometry for the brace

Copy the mounting plate geometry:

- Select the mounting plate geometry on the right.
- On the Tools toolbar, click \( \text{Move Copies} \).
- Select the midpoint of the right-face of the mounting plate.
- Move the cursor down, and select the midpoint of the lower-right end of the brace.
26 On the Design Bar, click Modify.
27 In the Project Browser, under Elevations, double-click Front.
28 Select the lower mounting plate, and on the Options bar, click Edit.
29 Select the right sketch line, select the dimension, enter 2’, and press ENTER.

30 Center the plate geometry:
   - Select the sketch lines, and on the Tools toolbar, click \(\text{(Move)}\).
   - Select the midpoint of the top sketch line.
Select the Center (Left/Right) reference plane.

31 On the Design Bar, click Finish Sketch.

32 In the Project Browser, under Elevations, double-click Right.
Create geometry for the support hanger

33 On the Design Bar, click Solid Form ➤ Solid Sweep.
34 On the Design Bar, click Sketch 2D Path.
35 On the Design Bar, click Set Work Plane.
36 In the Work Plane dialog, for Name, select Reference Plane : Center (Left/Right), and click OK.
   You adjust the work plane to create the sweep at the centerline of the support beam geometry.
37 Sketch the 2D path:
   ■ If necessary, on the Options bar, clear Chain.
   ■ Select the intersection of the horizontal extrusion (support beam) and the inner left vertical
     reference plane.
   IMPORTANT Use Tab to be sure you highlight the correct intersection before selecting.
   ■ Move the cursor diagonally up to the right and select the intersection of the Center
     (Front/Back) and top reference planes.
   ■ Click the 2 lock icons to constrain the sweep path to the extrusion and to the vertical reference
     plane.
On the Design Bar, click Finish Path.

38 On the Standard toolbar, click (Default 3D View). You open the 3D view in order to sketch the sweep profile.

39 On the Design Bar, click Sketch Profile.

40 On the Options bar, click (Circle).

If does not display on the toolbar, select it from the drop-down list.

41 On the Options bar, select Radius, and for the radius value, enter 1/8", and press ENTER.

42 Zoom in to the intersection of the profile plane and the path (red dot) on the support hanger.
43 Select the midpoint of the sweep path to create the circle.

44 On the Design Bar, click Finish Profile.

45 On the Design Bar, click Finish Sweep.
46 Zoom to fit the shade support in the view.
47 Flex the family to test the hanger geometry:
- On the Design Bar, click Family Types.
- In the Family Types dialog, for Support Length, enter 5', and click Apply.
- Enter 18", and click Apply.
- Enter 2' 6", click Apply, and click OK.

48 Click File menu ➤ Save.

**Add a connection bracket for the hanger**

49 In the Project Browser, under Elevations, double-click Front.
50 Zoom in to the top of the geometry to view the hanger support.
Create a round extrusion for the bracket:

- On the Design Bar, click Solid Form ➤ Solid Extrusion.

- On the Options bar, click (Circle), for Depth, enter 1/4", and press ENTER.

- Zoom in to the end of the hanger support.

- Sketch a circle with a 1" radius from the intersection of the reference planes at the hanger end.

- On the Design Bar, click Finish Sketch.
52 Create a second extrusion for the bracket:
- On the Design Bar, click Solid Form ➤ Solid Extrusion.
- On the Options bar, click (Circle), for Depth, enter 1/2''15 mm, and press ENTER.
- Sketch a circle with a 3/4'' radius from the intersection of the reference planes at the hanger end.
- On the Design Bar, click Finish Sketch.

53 On the Standard toolbar, click (Default 3D View).
Creating Family Types and Controlling Visibility

Now that you have created the geometry and it is flexing correctly, you create family types for the different support conditions. You add yes/no parameters to the family types to control which elements of the geometry display for each support condition. To make the geometry more realistic, you define and apply materials to the geometry.

Add family types for the shade supports

1 On the Design Bar, click Family Types.
2 In the Family Types dialog, click New.
3 In the Name dialog, enter Hung Support, and click OK.
4 Using the same method, add family types named Braced Support and Cantilever Support.
Add yes/no parameters for each family type

5 In the Family Types dialog, under Parameters, click Add.
6 Specify parameter properties:
   ■ For Name, enter Hung.
   ■ For Group parameter under, select Structural.
   ■ For Type of Parameter, select Yes/No.
   ■ Click OK.
7 Add 2 more yes/no parameters under the Structural group, and name them Braced and Cantilever.
8 In the Family Types dialog, assign parameters to family types:
   ■ For Name, verify that Cantilever Support is selected, and under Structural, clear Braced and Hung.
   ■ For Name, select Braced Support, and clear Cantilever and Hung.
   ■ For Name, select Hung Support, and clear Cantilever and Braced.
   ■ Click OK.

Assign yes/no parameters to geometry visibility

9 In the drawing area, use a crossing window to select the hanger support and bracket geometry, and click (Properties).
10 In the Element Properties dialog, under Graphics, for Visible, click the small icon in the = column on the right.

11 In the Associate Family Parameter dialog, select Hung.

12 Click OK twice.

13 On the Design Bar, click Modify.

14 In the drawing area, select the brace geometry and mounting plate, and click (Properties).

15 In the Element Properties dialog, under Graphics, for Visible, click the small icon in the = column on the right.

16 In the Associate Family Parameter dialog, select Braced.

17 Click OK twice.

18 On the Design Bar, click Modify.

19 On the Design Bar, click Family Types.

20 Flex the family types to verify that the correct geometry is visible:

   - In the Family Types dialog, for Name, select Braced Support, and click Apply. Notice that the Hung geometry is displayed in halftone.
■ In the Family Types dialog, for Name, select Cantilever Support, and click Apply. The hung and braced geometry are displayed in halftone.

21 Click OK.

Create materials

22 Click Settings menu ➤ Materials.

23 Add an aluminum material:

■ In the Materials dialog, click (Duplicate).
■ In the Duplicate Revit Material dialog, enter Metal - Aluminum, and click OK.
■ On the Graphics tab of the Materials dialog, select Use Render Appearance for Shading.
■ On the Render Appearance tab, for Render Appearance Based On, click Replace.
■ In the Render Appearance Library dialog, for Class, select Metal, click Aluminum Anodized Light Grey, and click OK.
24 Add a painted steel material:

- In the Materials dialog, with Metal - Aluminum selected, click (Duplicate).
- In the Duplicate Revit Material dialog, enter **Metal - Steel, Painted Maroon**, and click OK.
- On the Render Appearance tab, click Replace.
- In the Render Appearance Library dialog, for Class, select Paint, click Paint Dark Red Glossy, and click OK.

25 Add a galvanized steel material:

- In the Materials dialog, with Metal - Steel, Painted Maroon selected, click (Duplicate).
- In the Duplicate Revit Material dialog, enter **Metal - Steel, Galvanized**, and click OK.
- On the Render Appearance tab, click Replace.
- In the Render Appearance Library dialog, for Class, select Metal, and click Stainless Steel Satin.
- Click OK twice.

**Assign materials to geometry**

26 Assign the galvanized steel material to the hanger support:

- In the drawing area, select the hanger, and click (Properties).
- In the Element Properties dialog, under Materials and Finishes, click <By Category>, and click .
- In the Materials dialog, verify that Metal - Steel, Galvanized is selected, and click OK twice.
- On the Design Bar, click Modify.

27 Assign the aluminum material to the hanger bracket:

- In the drawing area, select the 2 extrusions for the hanger bracket, and click (Properties).
In the Element Properties dialog, under Materials and Finishes, click <By Category>, and click .

In the Materials dialog, select Metal - Aluminum, and click OK twice.

On the Design Bar, click Modify.

28 In the drawing area, select the remaining geometry (main support beam, brace, and 2 mounting plates), and click .

29 Using the same method, assign Metal - Steel, Painted Maroon to the remaining geometry.

30 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

31 On the Design Bar, click Modify.
32 Click File menu ➤ Save.

33 Proceed to the next lesson, *Adding the Shade Support to the Solar Shade Family* on page 605.
Adding the Shade Support to the Solar Shade Family

In this lesson, you create the Solar Shade family and load the Support Beam family into it. You add parameters to control the shade support mounting height, type, and length. By arraying the shade support and adding parameters, you control the number of supports and the support spacing for the solar shade.

Shade support number and spacing determined by user parameters

TIP  When creating a complex family that includes an array, it is a best practice to create the arrayed elements as a nested family to have better control over constraints and placement.

Skills used in the lesson:

- Creating a family from a generic line-based template
Nesting the Shade Support Family and Adding Parameters

In this exercise, you nest the Support Beam family into a new Solar Shade family. You also add parameters to control the mounting height of the shade support, the type of support used, and the length of the shade.

Create the Solar Shade Family

1. Click File menu ➤ New ➤ Family.
2. In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Generic Model line based.rft.
3. Click File menu ➤ Save As.
4. In the left pane of the Save As dialog, click Training Files and save the file as Imperial\Families\Solar Shade.rfa.
   The family file is saved automatically with the .rfa extension.
5. Click Window menu ➤ Support Beam.rfa - 3D View: [3D].
Load the Support Beam family into the Solar Shade family

6 On the Design Bar, click Load into Projects.
7 If the Load into Projects dialog displays, select Solar Shade.rfa, and click OK.
8 On the Design Bar, click Component.
9 In the drawing area, click to place the support beam below the intersection of the left and horizontal reference planes.
10 On the Design Bar, click Modify.

Align and lock the support beam

11 Zoom in to the mounting plate (top portion of the support beam).
12 On the Edit toolbar, click (Align).

13 Select the horizontal reference plane, select the top line of the mounting plate, and click .

14 Select the vertical reference plane, select the center of the beam, and click .

15 On the Design Bar, click Modify.
Add a reference plane for the mounting height

16 In the Project Browser, under Elevations, double-click Front.

17 On the Design Bar, click Ref Plane.

18 Sketch a horizontal reference plane above the Ref. Level, and on the Design Bar, click Modify.
   The exact placement of the reference plane is not important. Later, you specify a parameter for
   this reference plane.

19 Select the shade support geometry.
20 Move the support beam closer to the reference plane so it can be aligned to the new horizontal reference plane:

- On the Tools toolbar, click (Move).
- Select a move start point to the left of the shade support.

![Diagram showing move start point]

- Move the cursor up, and select a point above the new horizontal reference plane.

![Diagram showing point above reference plane]

21 On the Design Bar, click Modify.

22 Zoom in to the mounting plate.

You cannot align the support beam because you can’t see the horizontal reference plane to align to at the center point of the mounting plate. To resolve this problem, you must open the Support Beam family and modify a reference plane property.
Modify the Is Reference value of the Reference Plane

23 Click Window menu ➤ Support Beam.rfa - 3D View: [3D].
24 In the Project Browser, under Elevations, double-click Front.
25 In the Front view, select the reference plane at the center of the upper mounting plate, and click (Properties).
   Use TAB to select the reference plane instead of the reference level.

26 In the Element Properties dialog, under Other, for Is Reference, select Weak Reference, and click OK.

NOTE The Is Reference value was specified as Not A Reference. This is why you could not access it to align or constrain the support beam in the solar shade family. Changing this value to Weak Reference will allow you to select it as an alignment point.

27 On the Design Bar, click Load into Projects.
28 If the Load into Projects dialog displays, select Solar Shade.rfa, and click OK.
29 In the Reload Family dialog, click Yes.
30 If necessary, in the Project Browser, under Elevations, double-click Front.
**Add a parameter for the mounting height**

31 Align and lock the support beam center to the reference plane:

- On the Edit toolbar, click \( \text{(Align)} \).
- Select the horizontal reference plane.
- Select the center of the mounting plate.

32 On the Design Bar, click Dimension.

33 Select the 2 horizontal reference planes, and click to place the dimension.
34 On the Design Bar, click Modify.
35 Select the dimension, and on the Options bar, for Label, select <Add parameter>.
36 In the Parameter Properties dialog, for Name, enter **Mounting Height**, for Group parameter under, select Dimensions, and click OK.

Flex the family to test the Mounting Height parameter

37 On the Design Bar, click Family Types.
38 In the Family Types dialog, edit the value for Mounting Height:
   - Enter **5'**, and click Apply.
   - Enter **1'**, and click Apply.
   - Enter **3'**, and click Apply.
Create a parameter to control the support type for the Support Beam family

39 On the Design Bar, click Family Types.

40 In the Family Types dialog, under Parameters, click Add.

41 Specify the parameter properties:
   - For Name, enter **Support Type**.
   - For Type of Parameter, select `<Family Type>`.
   - In the Select Category dialog, select Generic Models. The Support Beam family is a generic model family. Selecting the Generic Models category ensures that this parameter can be used to control generic model families.
   - Click OK 3 times.

Connect the family type parameter to the shade support

42 In the drawing area, select the shade support, and click ![Properties](Properties).

43 In the Element Properties dialog, under Other, for Label, select Support Type, and click OK.

44 Flex the support type parameter:
   - On the Design Bar, click Family Types.
   - In the Family Types dialog, under Other, for Support Type, select Support Beam: Braced Support, and click Apply.
- Select Support Beam: Cantilever Support, and click Apply.

- Select Support Beam: Hung Support, click Apply.

- Click OK.
Create a reference plane to establish the support length

45 In the Project Browser, under Floor Plans, double-click Ref. Level.

46 On the Design Bar, click Ref Plane.

47 Sketch a horizontal reference plane below the shade support.

48 Zoom in to the bottom of the shade support.

49 Align the reference plane to the front edge of the support beam:

- On the Edit toolbar, click (Align).
- Select the bottom line of the shade support.
- Select the lower horizontal reference plane.

**IMPORTANT** Do not lock this position. Locking will overconstrain the geometry and prevent the family from working properly.
50 On the Design Bar, click Dimension.

51 Dimension the 2 horizontal reference planes, and click Modify.

52 Select the dimension, and on the Options bar, for Label, select <Add parameter>.

53 In the Parameter Properties dialog, for Name, enter Support Length, for Group parameter under, select Dimensions, and click OK.

54 Link the support length parameter from the Solar Shade family to the support length parameter for the Support Beam:

- In the drawing area, select the shade support, and click "Properties".
- In the Element Properties dialog, click Edit/New.
In the Type Properties dialog, under Dimensions, for Support Length, click the small icon in the = column on the right.

In the Associate Family Parameter dialog, select Support Length.

Click OK 3 times.

Flex the family Support Length parameter:

On the Design Bar, click Family Types.

In the Family Types dialog, for Support Length, enter 5', and click Apply.

Enter 18", and click Apply.

Enter 26", click Apply, and click OK.

Click File menu ➤ Save.

Save and close Support Beam.rfa. Solar Shade remains open for editing.

Proceed to the next exercise, Arraying the Shade Support on page 618.

**Arraying the Shade Support**

In this exercise, you create an array of the shade support so that multiple supports can be used, depending on the length of the solar shade.
**Array the shade support**

1. In the drawing area, select the shade support.

2. On the Tools toolbar, click \( \text{Array} \).

3. On the Options bar, for Number, verify that the value is 2, and for Move to, select Last.

4. Select the left vertical reference plane.

5. Move the cursor horizontally to the right, and select a point just to the left of the right vertical reference plane.

6. Press `ENTER` to accept the array count of 2.

7. On the Edit toolbar, click \( \text{Align} \).

8. Select the right vertical reference plane.

9. Zoom in and select the center of the right support beam, and click \( \text{Align} \).
10 Zoom to fit the solar shade in the view.

11 On the Standard toolbar, click (Default 3D View).

12 Click Window menu ➤ Tile.

   By tiling the plan, elevation, and 3D views, you can see if there are problems in any direction.

13 On the Design Bar, click Family Types.
14 In the Family Types dialog, apply the following values to the Length field:
- 10'
- 2'
- 4'

15 For Mounting Height, enter 5', and click Apply.
   The arrayed copy is not responding because it is not locked to the mounting height reference plane.

16 In the Family Types dialog, click OK.

**Align the center of the mounting plate to the Mounting Height parameter**

17 In the drawing area, maximize the window for the Front elevation.
18 Zoom in to the right shade support.

19 On the Edit toolbar, click (Align).
20 Select the upper horizontal reference plane, select the center of the mounting plate, and click .
21 On the Design Bar, click Modify.
22 Zoom to fit the solar shade in the window.

**Flex the mounting height**

23 On the Design Bar, click Family Types.
24 In the Family Types dialog, for Mounting Height, enter 2', and click Apply.
25 For Mounting Height, enter 3', click Apply, and click OK.

26 Click File menu ➤ Save.
27 Proceed to the next exercise, *Adding Parameters to Control the Number and Spacing of Supports* on page 622.

**Adding Parameters to Control the Number and Spacing of Supports**

In this exercise, you add parameters to control the number of supports created when the Solar Shade family is placed into a project.

**Add a parameter to control the number of shade supports**

1 On the Design Bar, click Family Types.
2 In the Family Types dialog, under Parameters, click Add.
You create an instance parameter because you will use a formula based on the length of the family to derive the number of supports. The Length parameter is an instance parameter. When using parameters in formulas, type parameters cannot contain instance parameters as part of the formula.

3 Specify the parameter properties:
   ■ For Name, enter **Number of Supports**.
   ■ Under Parameter Data, select Instance.
   ■ For Type of Parameter, select Integer.
     Integer is used because you need a whole number result.
   ■ Click OK.

4 In the Family Types dialog, for Number of Supports Formula (to the right of =), enter \( \frac{\text{Length}}{2} + 1 \), click Apply, and click OK.

5 Select the left shade support.

6 Select the array. (Use **TAB** to select the line of the array instead of the array value.)

7 On the Options bar, for Label, select Number of Supports.
   Notice that after applying the Number of Supports parameter (and formula), Revit Architecture calculates that 3 supports are required.
8 On the Design Bar, click Modify.
9 On the Design Bar, click Family Types.
   Flex the Length parameter to test the parameter formula.
10 In the Family Types dialog, for Length, enter 10', and click Apply.
11 For Length, enter 6', click Apply, and click OK.

Add a parameter in order to specify the maximum spacing of the shade supports

12 On the Design Bar, click Family Types.
13 In the Family Types dialog, under Parameters, click Add.
14 Specify the parameter properties:
   ■ For Name, enter **Max Support Spacing**.
   ■ Under Parameter Data, select Instance. Create an instance parameter because it will be used in a formula for an instance parameter.
   ■ For Type of Parameter, select Length.
   ■ For Group parameter under, select Dimensions.
   ■ Click OK.
15 In the Family Types dialog, under Dimensions, for Max Support Spacing, enter 3', and click OK.
   This step specifies a default value for Max Support Spacing. You must exit the Family Types dialog to save the default value before you can use the parameter in a formula.
16 Adjust the formula for Number of Supports so it responds to the new parameter:
   ■ On the Design Bar, click Family Types.
   ■ In the Family Types dialog, under Other, for the Number of Supports formula, replace the value 2' with the parameter name **Max Support Spacing**, as shown:
17 On the Standard toolbar, click (Default 3D View).

18 Flex the Length and Max Support Spacing parameters:
   - On the Design Bar, click Family Types.
   - In the Family Types dialog, for Length, enter 10', and click Apply.
   - For Length, enter 12', and click Apply.
   - For Max Support Spacing, enter 2', and click Apply.
   - Click OK.

19 Click File menu ➤ Save.

20 Proceed to the next lesson, Creating the Louver for the Solar Shade on page 627.
Creating the Louver for the Solar Shade

The basic structure for the solar shade has been created. In this lesson, you create the louvers for the solar shade. Again, in order to better control placement of elements in an array, you create a nested family for the louver, and then use an array of the louver to generate the geometry in the solar shade family.

Skills used in this lesson:

- Creating solid geometry using an extrusion
- Assigning materials to geometry
- Nesting a family, and constraining the position of the geometry
- Arraying the geometry of a nested family
- Assigning parameters to form a parametric relationship between a nested family and host family geometry
Creating the Louver

In this exercise, you create the louver geometry for the solar shade using a solid extrusion. You also constrain the louver so the length is adjustable, and assign a material to the geometry.

Create a family using the generic model family

1 Click File menu ➤ New ➤ Family.
2 In the left pane of the New dialog, click Training Files, and open Imperial\Templates\ Generic Model.rft.
3 Click File menu ➤ Save As.
4 In the left pane of the Save As dialog, click Training Files and save the file as Imperial\Families\Louver.rfa.

The family file is saved automatically with the .rfa extension.

Create a reference plane to control the louver length

5 On the Design Bar, click Ref Plane.
6 Sketch a vertical reference plane to the right of the Center (Left/Right) reference plane.
7 On the Design Bar, click Dimension.
8 Select the Center (Left/Right), select the new reference plane, and click to place the dimension.
9 On the Design Bar, click Modify.

10 Select the dimension, and on the Options bar, for Label, select <Add parameter>.

11 In the Parameter Properties dialog, for Name, enter **Length**, for Group parameter under, select **Dimensions**, and click OK.

12 On the Design Bar, under Elevations, double-click Right.

**Create an extrusion for the louver geometry**

13 On the Design Bar, click Solid Form ➤ Solid Extrusion.

14 On the Options bar, verify that the value for Depth is 1', and select Chain.

15 Zoom in to the lower-left quadrant of the drawing area.

16 Select points to sketch the rectangular profile of the louver, with approximate dimensions of 3 1/2" x 3/8", drawn at a 45 degree angle, as shown:
NOTE The exact placement of the sketch is not important. You will move it into position before the extrusion is complete.

17 On the Design Bar, click Modify.
18 Zoom in to the sketch, and select the long sketch line on the right.
19 If necessary to adjust the width, select the dimension, enter 3/8", and press ENTER.

Move the sketch to the intersection of the reference planes

20 Select the sketch lines, and on the Tools toolbar, click 
21 Select the midpoint of the long sketch line on the left.
22 Select the intersection of the reference planes.

23 On the Design Bar, click Finish Sketch.

24 Zoom to fit the drawing in the window.

25 Select the horizontal reference plane (press TAB to select the reference plane instead of the Ref. Level), and click (Properties).

26 In the Element Properties dialog, under Other, for Is Reference, select Weak Reference, and click OK.
You specify the reference plane as a Weak Reference so you can use it to align the louver after you load the louver into the solar shade family.

**Align and lock the extrusion to the right reference plane**

27 In the Project Browser, under Floor Plans, double-click Ref. Level.

28 On the Edit toolbar, click (Align).

29 Select the right vertical reference plane, select the right edge of the extrusion, and click .

30 On the Design Bar, click Modify.

**Flex the family to test the louver length parameter**

31 On the Design Bar, click Family Types.

32 In the Family Types dialog, for Length, enter 1’, and click Apply.

33 For Length, enter 5’, click Apply, and click OK.
Create and assign a material property to the extrusion

34 Click Settings menu ➤ Materials.

35 In the Materials dialog, with Default selected for Name, click (Duplicate).

36 In the Duplicate Revit Material dialog, enter **Metal - Aluminum, Painted White**, and click OK.

37 On the Graphics tab of the Materials dialog, select Use Render Appearance for Shading.

38 On the Render Appearance tab, click Replace.

39 In the Render Appearance Library dialog, for Class, select Paint, and click Paint White Cool Glossy.

40 Click OK twice.

41 In the drawing area, select the extrusion, and click (Properties).

42 In the Element Properties dialog, under Materials and Finishes, for Material, click <By Category>, and click .

43 In the Materials dialog, verify that Metal - Aluminum, Painted White is selected, and click OK twice.

44 On the Design Bar, click Modify.

45 Click File menu ➤ Save.

46 Proceed to the next exercise, **Adding the Louver to the Solar Shade Family** on page 633.

**Adding the Louver to the Solar Shade Family**

In this exercise, you place the louver into the Solar Shade family. You constrain it into the correct position, and create an array to model multiple louvers parametrically, as the shade support changes length.
Training Files

Continue to use the Solar Shade and Louver families that you created in the previous exercises, or open the following training files:

- Imperial\Families\Generic Models\Solar_Shade_01.rfa
- Imperial\Families\Generic Models\Louver_Complete.rfa

Load the Louver into the Solar Shade Family

1. Verify Solar Shade is open and Louver is open and active.
2. On the Design Bar, click Load into Projects.
3. If necessary, in the Load into Projects dialog, select the Solar Shade project, and click OK.
4. In the Project Browser, under Floor Plans, double-click Ref. Level.
5. On the Design Bar, click Component.
6. In the drawing area, click between the first two supports to place the louver, and on the Design Bar, click Modify.

The exact position is not important. You use the Align tool to position and constrain the louver.

7. On the Edit toolbar, click (Align).
8. Select the left vertical reference plane, select the left edge of the louver, and click .
9 On the Design Bar, click Modify.

10 In the drawing area, select the louver, and click (Properties).

11 In the Element Properties dialog, click Edit/New.

12 In the Type Properties dialog, for Length, click the small icon in the = column on the right.

13 In the Associate Family Parameter dialog, select Length.

14 Click OK 3 times.

You link the Length parameter of the louver to the Length parameter of the Solar Shade family.

Flex the family Length property

15 On the Design Bar, click Family Types.

16 In the Family Types dialog, for Length, enter 5', and click Apply.

17 For Length, enter 10', click Apply, and click OK.
18 In the Project Browser, under Elevations, double-click Right.

19 On the Edit toolbar, click (Align).

20 Select the horizontal reference plane through the support beam.

21 Zoom in to the louver.

22 Select the center of the louver (use TAB if necessary).

23 Click .
24 On the Design Bar, click Modify.
26 In the drawing area, sketch a vertical reference plane through the left side of the support beam and another one through the right side, as shown:
   These reference planes will be used to align the louver array.

27 On the Design Bar, click Modify.
28 Position the reference planes 2" from the front of the support beam and from the rear of the support beam:
   - Select the right reference plane that you just added, select the right dimension, enter 2", and press ENTER.
Select the left reference plane that you just added, select the left dimension, enter 2'', and press ENTER.

29 On the Design Bar, click Dimension.
30 Dimension and lock the left 2 vertical reference planes, as shown:
31 On the Edit toolbar, click (Align).

32 Select the right inner vertical reference plane.

33 Select the center of the louver.

Align the louver family to the reference plane near the rear of the support beam.

34 Click .
On the Design Bar, click Modify.

Create an array of the louver

Select the louver, and on the Tools toolbar, click (Array).

On the Options bar, verify that Number is 2 and Move To is Last.

Select a point above the louver.

Move the cursor to the left, and select a 2nd point.

Placement of the second louver is not important. It will be aligned and locked in subsequent steps.

Press ENTER to accept the array count of 2.
41 Align the 2nd instance in the array to the vertical reference plane near the front of the support beam, and align it to the horizontal reference plane:

- On the Edit toolbar, click ➡️ (Align).
- Select the inner left vertical reference plane.

![Diagram showing alignment process]

- Select the center of the 2nd instance of the louver (use TAB), and click ➡️.

![Diagram showing second alignment step]

- Select the horizontal reference plane, and select the center plane of the louver.

![Diagram showing final alignment]

- Click ➡️.
- On the Design Bar, click Modify.

Create parameters to control the number of louvers in the array

42 On the Design Bar, click Family Types.
43 In the Family Types dialog, under Parameters, click Add.
44 Specify the parameter properties:
  - For Name, enter **Max Louver Spacing**.
Under Group parameter under, select Dimensions.

For Type of Parameter, select Length.

Click OK.

45 In the Family Types dialog, for Max Louver Spacing, enter 4", and click OK.

When you exit the dialog, the Max Louver Spacing parameter is registered into the database so that the parameter can be used in a formula.

Create a parameter to determine the number of louvers required

46 On the Design Bar, click Family Types.

47 In the Family Types dialog, under Parameters, click Add.

48 In the Parameter Properties dialog, for Name, enter **Louver Number**, for Type of Parameter, select Integer, and click OK.

49 In the Family Types dialog, for Louver Number Formula, enter `\((\text{Support Length} - 4")/\text{Max Louver Spacing}\) + 1`, click Apply, and click OK.

<table>
<thead>
<tr>
<th>Driver</th>
<th>Support Be &quot;</th>
<th>Support Be &quot;</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of Supports (default)</td>
<td>X</td>
<td>(\text{Length} / \text{Max Support Spacing} + 1)</td>
</tr>
<tr>
<td>Louver Number</td>
<td>0</td>
<td>(\text{Support length - 4&quot;)/Max Louver spacing} + 1)</td>
</tr>
</tbody>
</table>

Louver Number uses a formula based on the support beam length and maximum louver spacing you specified.

**NOTE**

- To account for the reference plane offsets from each end, 4" is subtracted from the support length.
- The louver spacing is divided into the resulting length.
- An array can never equal 1, so 1 is added in case the result of the first part of the formula is very small.

50 Select the left louver, select the array on the array line, and on the Options bar, for Label, select Louver Number.

Test louver spacing, support beam length, and mounting height

51 On the Design Bar, click Family Types.

52 In the Family Types dialog, apply the following values:

- For Max Louver Spacing, enter 2", and click Apply.
- For Max Louver Spacing, enter 6", and click Apply.
■ For Support Length, enter 48", and click Apply.
■ For Support Length, enter 18", and click Apply.

■ For Mounting Height, enter 2', and click Apply.
■ For Mounting Height, enter 4', and click Apply.
53 Click OK.

54 On the Standard toolbar, click Zoom ➤ Zoom To Fit.

55 On the Standard toolbar, click (Default 3D View).

56 On the View Control Bar, click Model Graphics Style ➤ Shading with Edges.

57 Click File menu ➤ Save.

58 Proceed to the next lesson, *Finishing the Solar Shade* on page 645.
Finishing the Solar Shade

In this lesson, you use symbolic linework to simplify the display of the solar shade in plan view. In the final exercise, you load the Solar Shade family into the art gallery project, and place the shade component on southern curtain walls.

After placing the shades, you add sunlight to the view, and modify the length of the shade to determine the most effective option.
Skills used in this lesson:

- Editing nested families
- Creating symbolic and model lines
- Modifying visibility options for 3D geometry
- Placing a family in a project and modifying family properties
- Adding sunlight to an elevation view

**Adding Symbolic Linework to the Solar Shade**

The 3D geometry for the solar shade is complete. Next, you create symbolic linework for the family to display in plan view. In this exercise, you add an overhead line to the Support Beam family and to the Solar Shade family to represent the centers of the support beams and the outer edge of the shade.

![Symbolic linework representing the solar shade in a plan view](image)

**Training File**

Continue to use the Solar Shade family that you use in the previous exercise, or open Imperial\ Families\ Generic Models\ Solar_Shade_02.rfa.

**Open the Support Beam family for editing**

1. Select the shade support on the left, and on the Options bar, click Edit Group.
2 Select the support beam again, and on the Options bar, click Edit Family.

3 In the confirmation dialog, click Yes.
   The support beam opens in the Family Editor.

4 In the Project Browser, under Views ➤ Floor Plans, double-click Ref. Level.
Create an object style category

5 Add a category to the family object styles:
You will use this category to draw the overhead lines, representing the centers of the support beams.

- Click Settings menu ➤ Object Styles.
- In the Object Styles dialog, under Modify Subcategories, click New.
- In the New Subcategory dialog, for Name, enter **Overhead**, and click OK.
- For Overhead Line Pattern, select Overhead, and click OK.
  The new object style is assigned to the Overhead line pattern.

Draw a symbolic line to represent the center line of the support beam

6 Zoom in to the support beam.

7 On the Design Bar, click Symbolic Lines, and in the Type Selector, select Overhead [projection].
8 To the right of the support beam, sketch a vertical symbolic line between the top and bottom horizontal reference planes.
The exact position of the line when drawn is not important because you will align and lock it to the reference planes. For clarity, draw the line away from the geometry.

9 On the Design Bar, click Modify.

10 Select the symbolic line, and click the 2 lock icons to lock the endpoints to the horizontal reference planes.

When the length of the support increases, the line length will also increase.

11 Align the line to the center line of the support beam:

- On the Edit toolbar, click (Align).
- Select the Center (Left/Right) reference plane.
Select the symbolic line.

Click ⬇️.

On the Design Bar, click Modify.

12 In the Project Browser, under Elevations, double-click Front.

Add a reference plane to constrain a model line

In order for the symbolic lines to display when the family is above the cut plane (this family will always be placed above the cut plane), you must create something that can be cut in the family. Next, you create a hidden model line that stretches from the reference level to the mounting height of the support beam. This hidden element ensures that the family is cut by the cut plane of the view.

13 On the Design Bar, click Ref Plane.
14 Sketch a horizontal reference plane below the bottom reference plane.
15 Dimension and label the reference plane so it can be controlled with a parameter:
■ On the Design Bar, click Dimension.
■ Select the new reference plane, select the center reference plane, and click to place the dimension. Use  TAB  to select the reference plane rather than the reference level.
■ On the Design Bar, click Modify.
■ Select the dimension, and on the Options bar, for Label, select <Add parameter>.
■ In the Parameter Properties dialog, for Name, enter  Mounting Height, for Group parameter under, select Dimensions, and click OK.

16 Zoom in to the support beam.

Add an invisible model line

17 On the Design Bar, click Model Lines.
18 In the Work Plane dialog, from the drop-down list, select Reference Plane : Center (Front/Back), and click OK.
19 In the Type Selector, select <Invisible lines>.
20 Zoom in to the top mounting plate.
21. Select the intersection of the mounting plate and the reference planes.

22. Zoom out and select a point below the bottom mounting plate on the bottom reference plane.

23. On the Design Bar, click Modify.
24. Select the model line, and click the 3 lock icons.
   The lock icons constrain the end points of the line and also constrain it to the center line of the support beam.

Flex the family

26 On the Design Bar, click Family Types.

27 In the Family Types dialog, for Mounting Height, enter 5', click Apply, and click OK.

Modify geometry visibility

28 On the Standard toolbar, click (Default 3D View).
29 Select the support brace and the brace mounting plate, and on the Options bar, click Visibility. You change the visibility of the 3D geometry so it will not display in plan. Only the symbolic center line will display in plan.

30 In the Family Element Visibility Settings dialog, clear Plan/RCP, and click OK.

31 Using the same method, change the visibility for the remaining 3D geometry:
- Hanger
- Bracket
- Beam
- Mounting Plate

Load the Support Beam family into the Solar Shade family

32 In the Project Browser, under Floor Plans, double-click Ref. Level.
33 On the Design Bar, click Load into Projects.
34 If the Load into Projects dialog displays, select Solar Shade.rfa, and click OK.
35 In the Reload Family dialog, click Yes.
All instances of the shade support are updated in the Solar Shade family. Notice that the hidden model line is now part of the support beam family.

**Edit the shade support properties**

36 Select the shade support, and click (Properties).
   Notice that the invisible line highlights when the family is selected.

37 In the Element Properties dialog, click Edit/New.

38 For Mounting Height, click the small icon in the = column.

39 In the Associate Family Parameter dialog, select Mounting Height.

40 Click OK 3 times.
   To keep the shade support and the solar shade synchronized, you associate their mounting height parameters.

41 On the Group Editing toolbar, click Finish.

**Add a line to represent the front edge of the solar shade**

42 In the Project Browser, under Floor Plans, double-click Ref. Level.

43 On the Design Bar, click Symbolic Lines.

44 In the Type Selector, select Overhead [projection].
   This category was added when you reloaded the Support Beam family.

45 Sketch a horizontal line above the shade between the vertical reference planes, and click Modify.
46 Select the line, and click the 2 locks to constrain the endpoints of the line to the reference planes.

47 Align and lock the reference plane:
- On the Edit toolbar, click (Align).
- Select the bottom horizontal reference plane.
- Select the symbolic line, and click .

48 On the Design Bar, click Modify.
Flex the family to test the symbolic line display

49 On the Design Bar, click Family Types.
50 In the Family Types dialog, for Mounting Height, enter 8', click Apply, and click OK.
You should see only the symbolic lines at the centers of the support beams and the line on the front edge of the solar shade.
On the Standard toolbar, click [Default 3D View].

Change the visibility of the louver geometry

In the 3D view, select one of the louvers.

On the Options bar, click Edit Group.

Select the louver again, and on the Options bar, click Visibility.

You change the visibility of the louver so that it won’t display in plan.

In the Family Element Visibility Settings dialog, clear Plan/RCP, and click OK.

On the Group Editing toolbar, click Finish.

Click File menu ➤ Save, and keep the file open.
Proceed to the next exercise, Testing the Solar Shade in a Project on page 658.

Testing the Solar Shade in a Project

The components and parametric relationships for the solar shade family are complete. Next, you load the family into a project. You place the solar shade and modify the shade properties to adjust for the curtain wall mullions and window height.

You also test shade options by using accurate solar modeling and flexing the support length parameter for the solar shade. The flexibility in the design allows you to easily adjust the amount of shade provided.

NOTE In this tutorial, you load the family into an actual project. During the family authoring process a best practice recommendation is to load the family into a test project and flex all parameters in a project environment in order to verify family functionality.

Training File

- Click File menu ➤ Open.
- In the left pane of the Open dialog, click Training Files, and open Imperial\i_art_gallery.rvt.

Load the solar shade into a project

1 In the Project Browser, under Floor Plans, double-click Level 1.
2 Click Window menu ➤ Solar Shade.rfa - 3D View: [3D].
3 On the Design Bar, click Load into Projects.
4 If the Load into Projects dialog displays, select i_art_gallery.rvt, and click OK.
   The solar shade is loaded into the i_art_gallery.rvt project.

**Place the solar shade component**

5 Zoom to the bottom left corner of the left wing of the building.

6 On the Design Bar, click Component.
7 In the Type Selector, verify that Solar Shade is selected.

8 On the Options bar, click (Place on Work Plane).
   Because the Solar Shade family was created based on a reference level, you use the reference level mode when placing this family.

9 Select a point at the left corner of the curtain wall.
10 Select a point at the right corner.

11 On the Design Bar, click Modify.

12 Using the same method, place a solar shade component on the adjacent curtain wall.

13 On the Design Bar, click Modify.

View the curtain wall

14 In the Project Browser, under 3D Views, double-click 3D View 1. The solar shade is visible in the 3D view.
15 Zoom in to the curtain wall.
16 Click Window menu ➤ Tile.
   Tile the views to see both plan and 3D views at the same time. Close any additional views, if necessary.

Adjust shade properties to match the curtain wall

17 In the plan view, select the solar shade on the angled curtain wall, and click (Properties).
18 In the Element Properties dialog, for Max Support Spacing, enter 4', and click OK.
   The support spacing matches the mullion pattern.

19 With the shade still selected, click (Properties).
20 In the Element Properties dialog, click Edit/New.
21 For Mounting Height, enter 7', for Support Length, enter 36'', and click OK twice.
   The mounting height matches the height of the gallery windows, and the support length of the beam is increased.
22 Using the same method, change the Max Support Spacing of the adjacent solar shade to 4'.

The max support spacing was created as an instance parameter because of the formula used, so it must be specified for each instance of the solar shade. The other parameters changed were type parameters, so those changes were automatically made for all instances of the solar shade.

Copy the solar shades to the 2nd level

23 In the plan view, select both instances of the solar shade.
24 Click Edit menu ➤ Copy to Clipboard.
25 Click Edit menu ➤ Paste Aligned ➤ Select Levels by Name.
26 In the Select Levels dialog, select Level 2, and click OK.
View the solar shade with shadows on

27 In the Project Browser, under Elevations, double-click South.
28 Zoom to fit the elevation in the view.
29 If necessary, on the View Control bar, click Model Graphics Style ➤ Shading with Edges.
30 On the View Control bar, click Shadows Off ➤ Shadows On.

31 On the View Control bar, click Shadows On ➤ Advanced Model Graphics.

32 In the Advanced Model Graphics Settings dialog, for Sun Position, click ... .
33 On the Still tab of the Sun and Shadows Settings dialog, select Sunlight from Top Left.
34 Click OK twice.
35 Zoom in to the curtain wall (left side of the building).

36 Select a solar shade, and click (Properties).
37 In the Element Properties dialog, click Edit/New.
38 In the Type Properties dialog, for Support Length, enter 18".
39 Click OK twice.
40 With the shade still selected, click (Properties).
41 In the Element Properties dialog, click Edit/New.
42 In the Type Properties dialog, for Support Length, enter 48”.
43 Click OK twice.
44 Click File menu ➤ Save.
Troubleshooting Families
Troubleshooting Families

Troubleshooting is a form of problem solving. It is the step-by-step search for the source of a problem so that you can resolve it. In Revit Architecture, troubleshooting family components is often a process of elimination—eliminating potential causes of a problem.

In this tutorial, you explore several Revit Architecture families that do not perform as desired or intended. By understanding the expected behavior of the family, you identify when problems occur.

As you identify and resolve problems with the families in these exercises, keep in mind the following recommended troubleshooting practices:

■ Pin reference planes that define the origin.
■ Align and constrain geometry to reference planes/lines, not to other geometry.
■ Work with one piece of geometry at a time.
■ Remove any formulas and replace with a logical value.
■ Use nested elements for all arrays in the family.
■ Remove parameters one at a time.
■ Check warnings for a direction on what to fix.

Standard Checklist for Testing Revit Architecture Family Components

Testing in the Family Editor

■ Check for common conditions or conditions that you can easily test (for example, flex the family and view the changes).
■ Test all family parameters.
■ Check all views to ensure that the geometry or symbolic representation displays appropriately.
■ For hosted families, change the host dimensions and observe how the family changes. (Make sure to test both larger and smaller values.)

Testing the family in a project

■ Load the family.
■ Apply all family types.
■ Inspect the display of the family in all views.
■ Modify all parameters to create new types (25% - 400%).
■ Dimension to all reference planes/lines.
■ Snap all references to walls.
■ Observe how the family displays in different graphic modes, such as wireframe, shaded with edges, and so on.
■ Modify the host thickness for hosted families (25% - 400%).
■ Modify the family using editing tools, such as Copy/Paste, Rotate, and Mirror.
■ Check visibility parameters on objects.
■ Cut and paste geometry in place or into another family file.

Troubleshooting Window Families

In this lesson, you troubleshoot 2 window families. In the first family, a nested lintel component is not constrained properly, and therefore does not change size or position as you flex the family. When you test the second family, you discover that the geometry and symbolic lines do not flex with the family. In both exercises, you make corrections and resolve the issues with the family files.

Problem: Nested Family Not Flexing

In this exercise, you troubleshoot a window family that is not working as expected. When you flex the window family, the nested lintel remains the same size and in the same position. You determine the problem and resolve the issue.

Window with lintel constrained correctly

Open the family

1 Click File menu ➤ Open.
2 In the left pane of the Open dialog, click Training Files and open Common\Fixed w_Lintel.rfa.
3 On the View toolbar, click (SteeringWheels).
4 Using the SteeringWheel tools, spin the view to the inside of the wall, as shown.
Flex the family

5 On the Design Bar, click Family Types.

6 In the Family Types dialog, for Name, apply each of the following types:
   - 16" x 72"
   - 36" x 48"
   - 24" x 24"

Notice that the lintel nested component maintains the same size and position. The desired behavior is for the lintel to flex with the window.

7 In the Family Types dialog, click OK.

The lintel geometry is not responding, indicating either that there are no constraints specified or that incorrect constraints are applied. Because the lintel is a nested component, select the lintel and view the constraints you can control.
View parameters for the lintel family

8 Select the lintel geometry, and on the Options Bar, click (Properties).
Most of the constraints (parameters) for the lintel are type based. One of the parameters controlled
at the instance level is the offset value. You can change the offset value later, if necessary, to
position the lintel correctly. Next, you explore the parameters that are part of the type definition.

9 In the Element Properties dialog, click Edit/New.
In the Type Properties dialog, you see additional parameters. Because these parameters are not
connected to the host family values, the lintel does not respond when you flex the window.
You associate the host family parameters with the nested component so parameter values pass
to the nested family.

Associate host family width parameter to the nested component

10 In the Type Properties dialog, under Dimensions, for Width, click .
11 In the Associate Family Parameter dialog, select Width, and click OK.
You still have 2 parameters to associate (Mounting Height and Overhang), but you need matching
parameters in the host family to which to associate them.

12 Click OK twice.

Create parameters to control nested geometry

13 On the Design Bar, click Family Types.
14 In the Family Types dialog, under Parameters, click Add.
15 In the Parameter Properties dialog, specify the following:
  ■ For Name, enter Lintel Mounting Height.
  ■ For Group parameter under, select Dimensions.
  ■ For Type of Parameter, select Length.
  ■ Click OK.
16 Using the same method, add a Lintel Overhang parameter.
17 In the Family Types dialog, under Dimensions, for Lintel Overhang, enter 2”.
18 For Lintel Mounting Height ➤ Formula, enter Default Sill Height + Height, and click OK.
  This formula establishes the window head (where you want to position the lintel).

Associate the new parameters

19 Select the lintel, and on the Options Bar, click (Properties).
20 In the Element Properties dialog, click Edit/New.
21 In the Type Properties dialog, under Dimensions, for Overhang, click .
22 In the Associate Family Parameter dialog, select Lintel Overhang, and click OK.
23 Using the same method, associate Mounting Height with Lintel Mounting Height.
24 Click OK twice.
  The lintel position is still incorrect because of the Offset instance value. Because the Mounting
  Height parameter is now controlling the position of the lintel, change the offset value to 0.
25 Select the lintel, and on the Options Bar, click (Properties).
26 In the Element Properties dialog, for Offset, enter 0'0'', and click OK.

Flex the family

27 On the Design Bar, under Constraints, click Family Types.
28 In the Family Types dialog, apply the following types, and specify the Lintel Overhang:
   ■ Select 36'' x 72'', and for Lintel Overhang, enter 4''.
   ■ Select 24'' x 72'', and for Lintel Overhang, enter 4''.
   ■ Select 16'' x 48'', and for Lintel Overhang, enter 4''.
   ■ Click OK.

The Lintel is flexing as intended.
When troubleshooting geometry that is not moving when a family type changes, make sure that the geometry has constraints applied to it. While creating families, it is easy to overlook constraining the geometry. Look closely at one piece of geometry at a time to make sure that it is constrained.

29 Close the file with or without saving it.
30 Proceed to the next exercise, Problem: Unconstrained Sketch on page 672.

**Problem: Unconstrained Sketch**

In this exercise, you troubleshoot 3 issues with a window family:

- The frame geometry does not move for one type when you flex the family.
- The symbolic swing lines do not move correctly when flexed.
- The family is designed to show 2 different opening operations for the window, but the symbolic lines do not display correctly.

Window properly constrained with vertical swing lines visible

Flex the family

1 Click File menu ➤ Open.
2 In the left pane of the Open dialog, click Training Files and open Common\Dbl Plain EDIT.rfa.
3 On the Design Bar, click Family Types.
4 In the Family Types dialog, apply each of the types:
   When flexing the family, pay attention to what changes, but also note what stays the same. 
   These observations can help isolate the issue.
   - Dbl Plain 3
   - Dbl Plain 2
   - Dbl Plain
   Notice that the vertical swing line is not following the width of the glass in any of the types. In 
   the last type (Dbl Plain), the outer frame of the window does not follow the opening. The outer 
   frame looks correct for the other 3 types, but those types share the same window height. It is 
   when the height changes, as in Dbl Plain, that you see that the top edge of the frame is not 
   constrained correctly.

5 In the Family Types dialog, click OK.

**Edit the frame sweep**

6 Select the large frame sweep, and on the Options Bar, click Activate Dimensions.

7 Click 🔓 to unlock the constraint.
   It is a good idea to remove the constraint when troubleshooting to help isolate behavior. If this 
   geometry is constrained incorrectly, you should also test any elements that are constrained to 
   the geometry.
8 On the Options Bar, click Edit Sweep.
9 On the Design Bar, click Sketch 2D Path.

You edit the path of the frame. The sides are flexing correctly, but the top is not.

10 On the Tools toolbar, click (Align).
11 Select the Head reference plane, select the top horizontal sketch line, and click .

12 On the Design Bar, click Finish Path.
13 On the Design Bar, click Finish Sweep.
You now see that the center mullion geometry is locked to the outer frame sweep and is not constrained correctly. For better performance, lock elements to reference planes rather than to the faces of other elements.

Constrain the center mullion

14 On the Tools toolbar, click (Align).
You align and lock the vertical center mullion to the top of the opening.

15 Select the Head reference plane, select the top of the vertical center mullion, and click .

16 On the Design Bar, click Modify.

Dimension the vertical swing lines

17 Zoom in to the swing lines in the left pane.
The vertical swing lines are not constrained. Adding a dimension constrains the lines and allows them to move as expected.
18 On the Design Bar, click Dimension.
19 Select the inside left frame, select the intersection of the vertical swing lines and the top frame, and select the inside right frame.
20 Click above the window to place the dimension.

21 Click EQ.
22 On the Design Bar, click Modify.

**Flex the model**

23 On the Design Bar, click Family Types.

24 In the Family Types dialog, apply the 3 other types:
- Dbl Plain 2
- Dbl Plain 3
- Dbl Plain 4

25 In the Family Types dialog, click OK.

Create a test project

26 On the Standard toolbar, click (New).

27 On the Design Bar, click Wall.

28 Sketch a horizontal wall to host the window.

29 On the Design Bar, click Modify.

30 Click Window menu ➤ Dbl Plain EDIT.rfa - Elevation: Exterior.

**Test the window in the project**

31 On the Design Bar, click Load into Projects.

32 On the Design Bar, click Window.

33 In the Type Selector, select Dbl Plain EDIT : Dbl Plain 4.

34 Click to place the window in the center of the wall.

35 In the Project Browser, expand Elevations, and double-click South.
Both vertical and horizontal swing lines display; however, you only want one set to display at a time, depending on the desired operation of the window. Modify the family to control the visibility of the swing lines.

Add parameters for swing types

36 Click Window menu ➢ Dbl Plain EDIT.rfa - Elevation: Exterior.
37 On the Design Bar, click Family Types.
   In order to control visibility based on a type selection, you create parameters that you can select and associate with the visibility of the swing lines.
38 In the Family Types dialog, under Parameters, click Add.
39 In the Parameter Properties dialog:
   ■ For Name, enter Horizontal Swing.
   ■ For Group parameter under, select Construction.
   ■ For Type of Parameter, select Yes/No.
   ■ Click OK.
40 Using the same method, create a Yes/No parameter named Vertical Swing.
41 In the Family Types dialog, click OK.

Assign visibility to the swing lines

42 While pressing CTRL, select the 2 horizontal swing lines, and on the Options Bar, click (Properties).
43 In the Element Properties dialog, under Graphics, for Visible, click 

44 In the Associate Family Parameter dialog, select Horizontal Swing.

45 Click OK twice.

46 Select the 2 vertical swing lines, and use the same method to associate the Visible property with the Vertical Swing parameter.

Create family types for each swing direction

47 On the Design Bar, click Family Types.

48 In the Family Types dialog, with Dbl Plain 4 selected, under Construction, clear Horizontal Swing.

49 Under Family Types, click Rename.

50 In the Name dialog, enter **Dbl Plain 4 - Vertical**, and click OK.

51 Under Family Types, click New.

52 In the Name dialog, enter **Dbl Plain 4 - Horizontal**, and click OK.

53 Under Construction, clear Vertical Swing, select Horizontal Swing, and click OK.

Notice the swing lines not used by the type display as solid gray, indicating that they are part of the family, but have visibility turned off.
Test the family in the project

54 On the Design Bar, click Load into Projects.
55 In the Reload Family dialog, click Yes.
56 In the Project Browser, under Elevations, double-click South.
57 Select the window, and in the Type Selector, select Dbl Plain EDIT : Dbl Plain 4 - Horizontal.
   The swing line changes as appropriate for the type.

58 In the Type Selector, select Dbl Plain EDIT : Dbl Plain 4 - Vertical.

59 Close the project with or without saving it.
60 Proceed to the next lesson, Troubleshooting an Awning Family on page 680.

Troubleshooting an Awning Family

In this lesson, you explore the structure of an awning family because you would like to modify the awning to accommodate various lengths. Working with the existing geometry, you create a nested awning family that includes types for different awning lengths and automatically adjusts the number of awning supports to fit the length.

- In the first exercise, you determine that the awning support components are modeled with copies of simple extrusions. You simplify the geometry, and align and constrain the required components.
- In the second exercise, you cut and paste the awning frame and roof joint extrusions into new generic family templates. You want to array the awning support components in order to allow them to increase or decrease in number, depending on the length of the awning. You create separate families for the support geometry because it is recommended to array a nested family rather than an extrusion.
- In the final exercise, you nest and array the support families in the original awning family. Because the awning family is a wall-hosted family, you also test different wall widths and adjust constraints as necessary.
Modify the Awning Geometry

In this exercise, you modify the awning family so that different lengths can be created as types. You delete copies of support geometry, and align and constrain a single awning frame and roof joint component. The resulting family contains the minimum geometry required for the awning.

Awning with single support components

Open the awning family

1. Click File menu ➤ Open.
2. In the left pane of the Open dialog, click Training Files, and open Common\3060-Awning.rfa.
Create a family type

3 On the Design Bar, click Family Types.
   You create a family type for a different length. Notice that there is no parameter defined to
   control the number of supports. Later, you add a parameter to control the number of supports.

4 In the Family Types dialog, under Family Types, click New.
5 In the Name dialog, enter 20' Long, and click OK.
6 Under Dimensions, for Length, enter 20', and click Apply.
   When you apply the new type, constraint errors display.

7 In the error message dialog, click Remove Constraints.
   When troubleshooting families, it is often easier to remove all constraints and redefine them.

8 In the Family Types dialog, click OK.
   After removing the constraints, the geometry shifts into incorrect locations. Also, the length of
   the awning does not change. This behavior indicates that the awning constraints were removed
   or defined incorrectly. The awning supports and the roof joints also are not constrained correctly.
9 Select the awning, and on the Options Bar, click Ungroup.

The roof panels and the roof joints are grouped in this family. Because you cannot use parameters to constrain items in a group, you ungroup the family.

NOTE Using groups in a family is not recommended. If you need a group, it is better to create the geometry as a nested family.

10 On the Design Bar, click Modify.

Open views to observe constraints

11 In the Project Browser, under Floor Plans, double-click Ref. Level.

You open all views in order to see the labeled constraints.
12 Select the length dimension.

13 Press DELETE.
   In the Ref. Level view, the length dimension is not labeled and is not required. The other dimension constrains the reference plane to the face of the wall. It is part of the template and cannot be deleted.

14 In the Project Browser, open each of the following views to observe any constraints:
   ■ Ceiling Plans ➤ Ref. Level
   ■ 3D Views ➤ View 1
   ■ 3D Views ➤ [3D]
   ■ Elevations ➤ Back side
   The length dimension is labeled and constrains the reference planes. However, the dimension is not helpful in this view because the geometry is not visible.
15 Select the Length dimension, and press DELETE.

16 In the Project Browser, under Elevations, double-click Left.

17 In the Project Browser, under Elevations, double-click Placement Side.

Several dimensions in this view are unnecessary. The placement of the supports is controlled by several EQ constraints. This type of relationship is more easily controlled with an array. To control spacing, you can specify a formula for the array that is based on the awning length. The dimension for the length of the host wall is unnecessary and clutters the view.

18 While pressing CTRL, select all dimensions except the EQ constraints set on the outer reference planes, and press DELETE.

Delete copied extrusions

19 In the Project Browser, under 3D Views, double-click View 1.
While pressing **CTRL**, select all of the roof joint extrusions, except 1, and press **DELETE**.

You delete all but one extrusion from the family. To allow the roof joints to increase or decrease in number depending on the length of the awning, in a later exercise, you create an array from the extrusion. Using an array of a nested family is a better practice than creating multiple copies of mass geometry.

On the View toolbar, click (SteeringWheels), and spin the view to see the underside of the awning supports, as shown.

As with the roof joint geometry, each awning support extrusion was copied and positioned with EQ constraints. With this design, removing or adding a support results in an error and the need to recreate dimensions. Later, you use an array to create the awning supports.
22 Select all but one of the awning supports, and press DELETE.

You now have the minimum geometry required to create the family. You specify parameters and test that the geometry is constrained correctly.

Add a Length dimension

23 In the Project Browser, under Elevations, double-click Placement Side.
24 On the Design Bar, click Dimension.
25 Select the left reference plane, select the right reference plane, and click below the awning to place the dimension.

26 On the Design Bar, click Modify.
27 Select the dimension, and on the Options Bar, for Label, select Length.

Constrain extrusions to left and right reference planes

28 Select the roof metal extrusion (top line of the drawing).

You use the shape handles to stretch the geometry of the extrusion and make the edges visible for selection.
29 Drag the left and right sides of the extrusion slightly in order to see the edges, as shown.

30 On the Tools toolbar, click \( \text{Align} \).

31 Constrain the edges of the roof metal extrusion and the edges of the wood extrusion to the left and right reference planes:

- Select the left reference plane, select the left edge of the metal extrusion, and click \( \text{Align} \).

- Select the left reference plane, select the left edge of the wood extrusion, and click \( \text{Align} \).
Using the same method, align and lock the right edges of the metal and wood extrusions to the right reference plane.

**NOTE** Use TAB to make sure that you select the right edge of the wood extrusion rather than the awning frame.

32 On the Design Bar, click Modify.

**Flex the family**

33 In the Project Browser, under 3D Views, double-click View 1, and spin the view, if necessary.

34 On the Design Bar, click Family Types.

35 In the Family Types dialog, for Name, select 15' Long, click Apply, and click OK.
Proceed to the next exercise, Creating Generic Families for Awning Components on page 690.

Creating Generic Families for Awning Components

In this exercise, you create individual families for the roof joint geometry and the awning frame geometry using a generic family template. Later, you nest these generic families into the awning project, and array the geometry to create the required awning support. (When using arrays in families, it is a best practice to array a nested family rather than an extrusion.)

Roof joint family
Create a generic family for the roof joint

1. In the Project Browser, under 3D Views, double-click View 1.
2. Select the roof joint extrusion.

3. Click Edit menu ➤ Copy to Clipboard.
   You reuse the roof joint geometry rather than recreate it because it’s drawn to a specific angle. When troubleshooting families, if possible, try to reuse existing geometry, especially if the geometry is complex. For simple geometry, it is sometimes easier to recreate it.

4. Click File menu ➤ New ➤ Family.
5. In the left pane of the New Family - Select Template File dialog, click Training Files, and open Imperial\Templates\Generic Model.rft.
6. Click Edit menu ➤ Paste Aligned ➤ Current View.
The geometry is not visible because it is outside of the view range. Open the Front view to see the pasted geometry.

7 In the Project Browser, under Elevations, double-click Front.

8 On the Options Bar, click Edit Work Plane.
Aligning the geometry to the reference planes makes it easier to control the family after you nest it in the host family.

9 In the Work Plane dialog, with Name selected, select Reference Plane: Center (Left/Right), and click OK.
The extrusion is still not oriented properly to the reference planes. The location of the geometry indicates that ineffective values are specified in the extrusion properties.

10 With the extrusion selected, on the Options Bar, click (Properties).
11 In the Element Properties dialog:
- Under Constraints, for Extrusion End, enter \( \frac{1}{8}'' \).
- For Extrusion Start, enter \( -\frac{1}{8}'' \).
- Click OK.

12 Move the extrusion:
- On the Edit toolbar, click \( \text{Move} \).
- Zoom in to the bottom of the extrusion, and select the midpoint of the second sketch line from the bottom (front edge of the extrusion geometry).
- Select the intersection of the reference planes.
**13** On the Design Bar, click Modify.

Create a reference plane and position the roof joint

**14** In the Project Browser, under Elevations, double-click Left.

**15** On the Design Bar, click Ref Plane.

In the Left view, you establish the position of the roof joint with a reference plane. After you nest the roof joint family into the host family, you align and constrain the geometry with this reference plane. (You determine the position of the reference plane by inspecting the geometry of the awning family.)

**16** On the Options Bar, click (Pick Lines), and for Offset, enter 2".

**17** Select the Center (Left/Right) reference plane so that the new reference plane is offset to the left.
18 On the Design Bar, click Modify.
19 Select the extrusion.
20 Move the extrusion:

- On the Edit toolbar, click (Move).
- Select the upper right endpoint of the extrusion.
- Move the cursor to the right horizontally, and select the new reference plane.
- On the Design Bar, click Modify.
Specify reference plane properties

21 Select the horizontal reference plane (use TAB to select the plane rather than the level).

22 On the Options Bar, click (Properties).

23 In the Element Properties dialog, under Other, for Is Reference, select Weak Reference, and click OK.

In the generic family, the horizontal reference plane property is specified as Not a Reference. You specify the plane as a weak reference in order to use this plane to align the geometry.

24 Select the left vertical reference plane, and on the Options Bar, click (Properties).

25 In the Element Properties dialog, under Other, for Is Reference, select Not a Reference, and click OK.

The vertical reference plane you added is not needed for alignment when the family is nested, it is only used for positioning the geometry in this family.

26 On the Design Bar, click Modify.

Save the family and load it into the project

27 Click File menu ➤ Save As.

28 In the left pane of the Save As dialog, click Training Files, and save the family as Imperial\Families\Roof Joint.rfa.

29 On the Design Bar, click Load into Projects.

30 If the Load into Projects dialog displays, select 3060-Awning.rfa, and click OK.

Observe the awning frame geometry

31 In the Project Browser, under 3D Views, double-click View1.

Open the nested awning frame family and make sure that there are no elements in this family to cause additional problems.

32 Select the awning frame, and on the Options Bar, click Edit Family.

NOTE Notice that the extrusion has been placed as a nested family. When troubleshooting, it is a good idea to edit and investigate the nested family to ensure that it is not causing errors in the host family.
In the confirmation dialog, click Yes. After the family is open for editing, you see that there are 2 potential problems:

- The family is defined as a group. Generally, it is not recommended to use groups in a family unless they were created as an array.

- The geometry is wall-hosted. You are nesting the awning frame into a wall-hosted family. If the awning frame is also wall-hosted, you may have problems defining constraints in the host family.

Create a generic family for the awning frame

34 Select the frame, and on the Options Bar, click Ungroup.

35 With the frame selected, click Edit menu ➤ Copy to Clipboard.

You copy the awning frame geometry into a generic model, just as you did for the roof joint. Creating a separate family for the awning frame simplifies placement in the host family.

36 Click File menu ➤ New ➤ Family.

37 In the left pane of the New dialog, click Training Files, and open Imperial\Templates\Generic Model.rft.

38 Click Edit menu ➤ Paste Aligned ➤ Current View.

39 Click OK, and ignore the 2 warnings that display. (You can still copy the geometry into this new family.)

40 In the Project Browser, under Elevations, double-click Front.

Align geometry to the reference planes

41 On the Options Bar, click Activate Dimensions.

42 Select the extrusion, and on the Options Bar, click Edit Work Plane.
In the Work Plane dialog, for Name, select Reference Plane : Center (Left/Right), and click OK. You change the work plane of the extrusion in order to center the extrusion on the Center (Left/Right) reference plane.

On the Design Bar, click Modify.

Move the extrusion to the reference level to make it easier to position in the host family:

- Select the extrusion, and on the Edit toolbar, click (Move).
- Zoom in to the bottom of the extrusion, and select the midpoint.
- Select the intersection of the reference planes.
On the Design Bar, click Modify.

Create a reference plane and position the awning frame

46 In the Project Browser, under Elevations, double-click Left.

In the Left view, you add a reference plane just as you did for the roof joint. You use this reference plane to position the awning frame correctly after you load it into the host family. (Again, the location of the reference plane is derived by looking at the original awning family to determine a logical position.)

47 On the Design Bar, click Ref Plane.

48 On the Options Bar, click (Pick Lines), and for Offset, enter 2".

49 Select the Center (Left/Right) reference plane so that the new reference plane is positioned to the left.
50 On the Design Bar, click Modify.

51 Move the awning frame into the correct position:

- Select the awning frame, and on the Edit toolbar, click (Move).
- Select the end point of the extrusion.

- Move the cursor to the right, and select the new reference plane.
On the Design Bar, click Modify.

Specify reference plane properties

52 Select the left vertical reference plane, and on the Options Bar, click \(\text{(Properties)}\).
53 In the Element Properties dialog, under Other, for Is Reference, select Not a Reference, and click OK.
The vertical reference plane you added is not needed for alignment when the family is nested.
54 Select the horizontal reference plane.
55 On the Options Bar, click \(\text{(Properties)}\).
56 In the Element Properties dialog, under Other, for Is Reference, select Weak Reference, and click OK.

Save the family and load it into the project

57 Click File menu ➤ Save As.
58 In the left pane of the Save As dialog, click Training Files, and save the family as Imperial\Families\Awning Frame.rfa.
59 On the Design Bar, click Load into Projects.
60 In the Load into Projects dialog, select 3060-Awning.rfa, and click OK.
61 Proceed to the next exercise, Nesting and Arraying Awning Component Families on page 701.

Nesting and Arraying Awning Component Families

In the previous exercise, you loaded the roof joint and awning frame families into the awning family. In this exercise, you place and array the 2 families, and add a formula so that you can control the number of instances of the geometry. You also make adjustments to the constraints in the awning family to allow for different width hosts and to test the family in a project.

Arrayed awning frame and roof joint components in plan view

Place roof joint and awning frame components

1 In the Project Browser, under Elevations, double-click Placement Side.
2 While pressing CTRL, select the roof joint and the awning support, and press DELETE.
Because you created the geometry for the roof joint and the awning frame in new families, you delete the existing geometry.
3 In the Project Browser, under Floor Plans, double-click Ref. Level.
4 On the Design Bar, click Component.
5 Click to the left of the awning to place the Awning Frame, as shown.

6 In the Type Selector, select Roof Joint.
7 Click to place the Roof Joint, as shown.

8 On the Design Bar, click Modify.
9 Purge unused items from the family:
   ■ Click File menu ➤ Purge Unused.
You purge the family, deleting any unused components, groups, and so on, that add unnecessary information to the family.

- In the Purge unused dialog, review the selected items, and click OK.

**Align and lock the awning frame and roof joint**

10 In the Project Browser, under Elevations, double-click Left.

11 On the Tools toolbar, click (Align).

12 Select the Wall Edge reference plane, select the vertical Awning Frame reference, and click .

13 Add a reference plane at the bottom of the wood extrusion:

- On the Design Bar, click Ref Plane.
Select the bottom endpoint of the wood extrusion.

Move the cursor to the right side of the wall, and click to add a horizontal reference plane.

14 On the Tools toolbar, click (Align).
15 Select the new horizontal reference plane, select the horizontal awning frame reference, and click .

Placement Side
16 Select the new horizontal reference plane, select the horizontal roof joint reference, and click 📷.

![Placement Side](image1)

17 Select the Wall Edge reference plane, select the vertical roof joint reference, and click 📷.

![Placement Side](image2)

18 On the Design Bar, click Modify.

**Determine correct placement of the roof joint**

19 Zoom in to the lower left roof edge.

When zoomed in to the roof edge condition, you see that the geometry of the nested roof joint family is incorrect.
20 Move the roof joint into position:

- Select the roof joint, and on the Edit toolbar, click (Move).
- Click the bottom left endpoint of the roof joint.
- Move the cursor up (90 degrees), enter $1.25''$, and press ENTER. A warning dialog displays indicating that constraints are not satisfied.

- Click Remove Constraints. You undo this step later, and re-establish the constraint.
- On the Design Bar, click Modify.

You move the family into position so you can measure the required change.

21 On the Tools toolbar, click (Tape Measure).

Use the Tape Measure tool to see how far to extend the roof joint to meet the roof edge.
22 Click the horizontal reference plane at the roof edge, and click the lower right endpoint of the roof joint to measure the distance.

23 On the Standard toolbar, click (Undo).
   Undo the move of the roof joint to place it back to the original location and to re-establish the constraint to the horizontal reference plane.

24 On the Design Bar, click Modify.

**Edit the position of the roof joint family**

25 Select the roof joint, and on the Options Bar, click Edit Family.
26 At the confirmation prompt, click Yes.
27 In the Project Browser, under Elevations, double-click Left.

28 Select the roof joint, and on the Edit toolbar, click (Move).
   As determined previously, the roof joint geometry must move up 1 1/4".

29 Select a start point to the right of the roof joint, move the cursor up (at 90 degrees), enter 1.25", and press ENTER.

30 On the Design Bar, click Modify.
31 Zoom in to the lower endpoint of the roof joint.
32 Select the roof joint, and on the Options Bar, click Edit.
As you determined earlier, the end of the extrusion must extend 1 1/8" so it meets the roof edge in the family.

33 Using a selection window, select the extrusion, and on the Edit toolbar, click (Move).

34 Click to the right of the extrusion, move the cursor down and parallel to the joint (120 degrees), enter 1.125", and press ENTER.

35 On the Design Bar, click Finish Sketch.

Reloading the roof joint into the awning project

36 On the Design Bar, click Load into Projects.

37 In the Load into Projects dialog, select 3060-Awning.rfa, and click OK.

38 In the Reload Family dialog, select Override parameter values of existing types, and click Yes.

All the components are in the correct relationship to one another in the Left Elevation view and are constrained to their positions. The next step is to create the arrays of the nested families and add the appropriate parameters.
Align and array the awning frame and roof joint

39 In the Project Browser, under Elevations, double-click Placement Side.

40 Align and lock the awning frame to the reference planes in the Placement Side view:

- On the Tools toolbar, click (Align).
- Select the right reference plane.
- Select the right edge of the awning frame, and click .
- Select the horizontal reference plane.
- Select the bottom awning frame reference, and click .

- On the Design Bar, click Modify.

41 Array the awning frame:

- Select the awning frame, and on the Edit toolbar, click (Array).
- On the Options Bar, for Move To, select Last.
- Click the top endpoint of the awning frame for the start point.
- Move the cursor to the left, and click to specify the end position for the array, as shown (the exact position is not important):
Enter 4, and press **ENTER**.
To make sure that the element arrays, assign an array value greater than 2.

On the Design Bar, click Modify.

42 Align and lock the last instance of the array to the reference planes (constraining the array vertically and horizontally):
- On the Tools toolbar, click Align.
- Select the left reference plane.
- Select the left edge of the last instance of the awning frame, and click .
- Select the horizontal reference plane.
- Select the bottom awning frame reference, and click .
- On the Design Bar, click Modify.
43 Select the last instance of the awning frame, and select the array (use TAB to select the array instead of the array value).
44 On the Options Bar, for Label, select <Add parameter>.
45 In the Parameter Properties dialog, for Name, enter **# of Supports**, for Group parameter under, select Construction, and click OK.
46 Using the same method, create an array of the roof joint:
   - Align and lock the instances on each end of the array to the vertical and horizontal reference planes.
   - Specify an array value of 20.
   - Add a label parameter to the roof joint array, named **# of Joints**.

Add a formula to control the number of roof joints
47 On the Design Bar, click Family Types.
48 In the Family Types dialog:
   - Under Construction, for **# of Joints** ➤ Formula, enter \((\text{Length}/1')+1\).
     This formula creates a joint approximately every 1', starting and ending at each end of the awning roof.
   - For **# of Supports**, enter 3.
   - For Name, select 20’ Long, click Apply, and click OK.
You flex the family to the different lengths to make sure all of the components are working as expected.

Modify the wall width
49 In the Project Browser, under Floor Plans, double-click Ref. Level.
50 Select the wall, and on the Options Bar, click ![Properties](Properties). Because the family is wall-hosted, it is important to test the family with multiple width hosts.
51 Create a wall type with a different width:

- In the Element Properties dialog, click Edit/New.
- In the Type Properties dialog, click Duplicate.
- In the Name dialog, click OK to accept Wall2.
- In the Type Properties dialog, under Construction, for Structure, click Edit.
- In the Edit Assembly dialog, for Wall material 1 ➤ Thickness, enter 12".
- Click OK 3 times.

After you modify the host width, the awning frame and the roof joints no longer maintain their position in relation to the face of the wall. You need to align and lock the last instance of each family to the face of the wall.

52 Use TAB to select the Wall Edge reference plane (located horizontally on the awning edge of the wall).

53 Drag the left endpoint past the left edge of the wall to make the reference plane easier to select.

54 Select the last instance of the awning frame and drag it above the awning.

55 In the error dialog, click Remove Constraints.

In troubleshooting, sometimes it is easier to move geometry and remove the constraints, and then realign.

56 Align and lock the awning frame:

- On the Tools toolbar, click (Align).
- Select the Wall Edge reference plane.
- Select the awning frame reference (make sure that you select the small reference plane that displays slightly below the awning frame).
- Click **Click**.
- On the Design Bar, click **Modify**.

57 Using the same method, align the last instance of the roof joint to the Wall Edge Reference plane. (Again, move the roof joint above the awning, and make sure to select the small reference plane slightly below the roof joint.)
The awning frame and roof joint instances align to the wall edge reference plane.

58 Using the same method, also align the first instances of both arrays to the wall edge reference plane.

59 In the Project Browser, under 3D Views, double-click View 1.
Test the awning in a project

60 Create a test project for the awning.
61 Add a wall to the test project.

62 On the View toolbar, click \(\text{Default 3D View}\).
63 Load the awning into the test project.
64 On the Design Bar, click Component.

You place both awning types into the project to make sure that the geometry is correct.

65 Place the 3060-Awning : 15’ Long component on the left end of the wall.
66 In the Type Selector, select 3060-Awning : 20’ Long, and place the component on the right end of the wall.
67 On the Design Bar, click Modify.
In-Place Families
In-Place Families
Overview

In-place families are custom families that you create in the context of a project. Create an in-place family when your project needs unique geometry that you do not expect to reuse or geometry that must maintain one of more relationships to other project geometry.

For example, if you wanted to create a conference table that fit in the corner of an office with slanted walls, you could design it as an in-place furniture family. If the walls were resized, the in-place family table would change accordingly.

Conference table created as in-place furniture, parallel to the office walls
In a structural model, you may use the in-place family tool to create a thickened slab, or a wall extrusion that conforms to a uniquely shaped architectural wall that it supports.

**Thickened slab**

Because in-place families are intended for limited use in a project, each in-place family contains only a single type. You can create multiple in-place families in your projects, and you can place copies of the same in-place family element in your projects. Unlike system and standard component families, you cannot duplicate in-place family types to create multiple types.

Although in-place families are designed for use only within the project in which you create them, you can use them in other projects. You can copy them into other projects, or load them in other projects as groups.

**WARNING** You should transfer in-place families between projects only when necessary, as in-place families can increase file size and slow software performance.

**Viewing In-Place Families in a Project**

You can use the Project Browser to view any in-place families that are in use in a project. If the in-place family is not used in the project, it does not display in the Project Browser.

1. Open a project.
2. In the Project Browser, expand Families.
   A list of all family categories in the project displays. The list includes the in-place families, as well as any standard component and system families that may be in the project.
3 Expand the category that contains the in-place family type that you want to view.

   In-place family used
to create a custom
information counter

   - Casework
     - Information Counter

4 Expand the family type to view the in-place family.
   Because in-place families are custom families and are not meant to be duplicated, they do not contain multiple types.

   - Casework
     - Information Counter
     - Information Counter

5 Select the type, right-click, and click Select All Instances.

   **NOTE** Because in-place families do not support multiple types, if you right-click the in-place family or family type in the Project Browser, then commands to create a new type or to duplicate an existing type are not available.

   All elements in the view that use the family display as red.
In-place information counter used in an the first floor of an art gallery

In the lower right of your screen, the number of selected elements displays.

**IMPORTANT** If the element that uses the selected family type is not visible in the current view, but is in the project, you will not see it.

6 Open other project views.
Any of the elements that use the family type display as red.

7 Press ESC to restore the original display of the elements.

## Creating and Modifying In-Place Families

Use in-place families in your projects when you need to add unique project-specific elements to your building models.

Although you can create, place, and copy unlimited in-place families, use them only when necessary. Projects that contain multiple and complex in-place families can slow software performance.

### Creating an In-Place Family

1 Do either of the following:
   - If the in-place family is an element that you can create from a Design Bar command, click the command, and on the Options Bar, click Create in-place.
   - If the in-place family is not an element that you can create from a Design Bar command, on the Modelling tab of the Design Bar, click Create.

2 If you created the family with the Create in place option, in the Family Category dialog, select a category for the family, and click OK.
   The category that you choose will be the category under which the in-place family will display in the Project Browser, in which it will schedule, and in which you can control its visibility.

3 In the Name dialog, type a name, and click OK.
The Family Editor opens.
4 Use the tools on the Family Editor Design Bar to create your in-place family. Create the in-place family as you would a standard component family. See Creating a Standard Component Family on page 72.

5 When you finish creating the in-place family, on the Design Bar, click Finish Family.

Modifying an In-Place Family

1 Select the in-place family.
2 On the Options Bar, click Edit.
3 To edit individual elements of the in-place family in sketch mode, select the element, right-click, and click Edit Sketch.
4 When you finish editing the sketch, on the Design Bar, click Finish Sketch.
5 When you finish editing the in-place family, on the Design Bar, click Finish Family.

Copying In-Place Families

You can copy an in-place family within a project.

WARNING Placing multiple copies of an in-place family increases the file size of the project. Depending on the size and complexity of the in-place family, the copies may slow software performance as you work in the project.

If the in-place family that you want to copy was created on a reference plane, you must either select and copy the reference plane with the instance of the in-place family, or save the in-place family as a group and load it into a project. See Loading an In-Place Family into a Project as a Group on page 725.

1 Open the project view that contains the in-place family that you want to copy.
2 Do either of the following:
   ■ Select the in-place family instance.
   ■ In the Project Browser, under the family category and family, select the in-place family type.
3 If you want to paste the family into a different view, open the view.
4 Click Edit menu ➤ Paste from Clipboard.
5 Click in the view to place the in-place family element.

The pasted element is selected so that you can modify it if needed. Depending on the type of element you pasted, you may be able to use the Move, Rotate, and Mirror tools to modify it. You can also use options on the Options Bar.

6 To finish the paste operation and deselect the element, click in the drawing area away from the pasted element. (For some types of elements, you can also click Finish on the Options Bar.)

Deleting In-Place Families

1 Do either of the following:
   ■ In the Project Browser, expand Families, expand the family category, and select the family type of the in-place family.
   ■ In the project, select the in-place family element.
2 Do either of the following:
   ■ Right-click, and click Delete.
   ■ Press DELETE.

   If you are deleting the in-place family type from the Project Browser, and an instance of the type is in the project, and a warning displays.

3 In the alert dialog, click OK to delete the instance of the type, or click Cancel.

4 If you click Cancel, change the type of the instance, and redelete the type.

   The in-place family element is deleted from the project, and no longer displays in the Project Browser.

---

Using In-Place Families in Other Projects

Although in-place families are not intended to be shared between Revit Architecture projects, you can add them to other projects.

To use an in-place family in another project, you can:

   ■ copy and paste it into another project
   ■ save the in-place family as a group and then load it into another project

**WARNING** Copying or loading an in-place family into another project increases the file size of the target project. Depending on the size and complexity of the in-place family, the copied or loaded family may slow software performance when you work in the target project.

If the in-place family that you want to copy to another project was created on a reference plane, you must either select and copy the reference plane with the instance of the in-place family, or save the in-place family as a group and load it into a project. See Loading an In-Place Family into a Project as a Group on page 725

---

Copying an In-Place Family Between Projects

1 Open the project view that contains the in-place family that you want to copy.
2 Do either of the following:
   ■ Select the in-place family instance.
   ■ In the Project Browser, under the family category and family, select the in-place family type.
3 Right-click, and click Copy to Clipboard.
4 Open the project and view into which you want to copy the in-place family.
5 Click Edit menu ➤ Paste from Clipboard.
6 Click in the view to place the in-place family element.

The pasted element is selected so that you can modify it if needed. Depending on the type of element you pasted, you may be able to use the Move, Rotate, and Mirror tools to modify it. You can also use options on the Options Bar.

7 To finish the paste operation and deselect the element, click in the drawing area away from the pasted element. (For some types of elements, you can also click Finish on the Options Bar.)
Loading an In-Place Family into a Project as a Group

1. Open the project that contains the in-place family that you want to copy.
2. Select the in-place family.
3. On the Edit toolbar, click (Group).
4. In the Create Model Group dialog, for name, enter the name of the in-place family.
5. If you want to open the group in the Group Editor, select the Open in Group Editor.
   The Group Editor lets you add or remove elements from a group, attach detail groups (for model groups), and view group properties.
6. Click OK, and save the project.
7. Open the project into which you want to load the in-place family group.
8. Click File menu ➤ Load from Library ➤ Load File as Group.
9. In the Load File as Group dialog, browse to the location of the project that contains the group, select the project, and click Open.
10. In the Project Browser, expand Group and Model.
11. Select the in-place family group, right-click, and click Create Instance.
12. Click in the view to place the group.
Tutorial: Creating an In-Place Family

In-place families are often created for unique components and are modeled within the framework of an existing project. In this tutorial, you create an in-place family for an information counter to be used in an art gallery. You learn to:

■ Create the solid geometry for the family using the Blend, Extrusion, Array, and Void tools
■ Assign materials to the geometry
■ Turn off the visibility of 3D geometry and add 2D information to be used in orthographic views

3D view of information counter family
Creating the 3D Geometry for the Information Counter

In this exercise, you create an in-place family for an information counter. The shape of the information counter is roughly sketched in 2D to help you create the geometry for the in-place family. The 2D lines are for layout purposes only and you erase them after creating the in-place family.

Tile the views

1. Click File menu ➤ Open.
2. In the left pane of the Open dialog, click Training Files, and open Imperial\i_art_gallery.rvt.
3. In the Project Browser, under Floor Plans, double-click Level 1.
4. In the Project Browser, under 3D Views, double-click [3D].
5. Click Window menu ➤ Tile.
6. Close any additional windows and position the tiled windows for the Level 1 plan and 3D views as shown:
Tiling the floor plan and 3D views allows you to see the results of the creation process in 2D and 3D simultaneously.

7 Select the Floor Plan: Level 1 window to make it active.

**Open Family Editor mode**

8 On the Basics tab of the Design Bar, click Component.

9 On the Options Bar, click Create in place.

10 In the Family Category and Parameters dialog, under Family Category, select Casework, and click OK.

11 In the Name dialog, for Name, enter *Information Counter*, and click OK.

This name displays in the Project Browser under the Families section. You are now in Family Editor mode.

12 Zoom in to the center of the floor plan, to the linework for the curved information counter.
Use the Blend tool

13 On the Design Bar, click Solid Form ➤ Solid Blend.

You create the wall of the information counter using the Blend tool. The shape of the wall is an outward sloping arc, so the sketch for the bottom of the blend is positioned slightly inside the top sketch.

14 On the Options Bar, for Depth, enter 3'10", and click (Pick Lines).

15 In the drawing area, select the lines for the bottom of the wall (these are the thicker lines in the drawing):

- inner thick arc line
- outer thick arc line
- left end line
NOTE If you have difficulty selecting the end lines, press TAB to highlight the line, and click to select it.

16 On the Design Bar, click Edit Top.
17 Using the same method, select the dashed lines for the wall top (inner and outer dashed arc lines and 2 end lines).
18 On the Tools toolbar, click \( \text{(Trim)} \).
19 Trim the sketch lines at each end of the arc to form a closed top sketch, as shown:

![Trimmed Sketch](image)

20 On the Design Bar, click Finish Sketch, and view the geometry in the 3D view. The blend creates an outward sloping curved wall for the information counter.

![3D View](image)

Assign a material to the curved wall

21 In the 3D view, select the curved wall, and click \( \text{(Properties)} \).
22 In the Element Properties dialog, under Materials and Finishes, for Material, click \(<\text{By Category}>\), and click \( \text{(Browse)} \).
23 In the Materials dialog, in the left pane, select Finishes - Interior - Paints and Coatings - Yellow, Glossy.
24 Click OK twice.

The yellow finish material is applied to the curved wall.
26 On the Design Bar, click Solid Form ➤ Solid Extrusion. You create the desk surface using a solid extrusion.

27 Specify the extrusion properties:
   - On the Design Bar, click Extrusion Properties.
   - In the Element Properties dialog, under Constraints, for Extrusion Start, enter 2’5”.
   - For Extrusion End, enter 2’6”.
   - Under Materials and Finishes, select the Material value, and click (Browse).
   - In the Materials dialog, under Name, select Laminate - Navy, Matte.
   - Click OK twice.

28 On the Options Bar, click (Pick Lines).

29 In the floor plan view, select lines to create the desk surface:
   - innermost arc line (thin line)
   - outer thick line
Chapter 27   Tutorial: Creating an In-Place Family
30 On the Tools toolbar, click [Trim], and trim the sketch lines to form a closed loop, as shown:

31 On the Design Bar, click Finish Sketch.

Create a glass countertop

32 Click Solid Form ➤ Solid Extrusion.
33 Specify the extrusion properties:
   ■ On the Design Bar, click Extrusion Properties.
   ■ In the Element Properties dialog, under Constraints, for Extrusion End, enter 48".
   ■ For Extrusion Start, enter 47.5".
   ■ Under Materials and Finishes, select the Material value, and click (Browse).
   ■ In the Materials dialog, in the left pane, select Glass - Clear, Frosted.
   ■ Click OK twice.
34 Pick lines to create the glass countertop:
   ■ On the Options Bar, click [Pick Lines].
   ■ For Offset, enter 5", and press ENTER.
- In the floor plan view, select the outermost arc line (wall top), so the offset is positioned outside the arc.

- On the Options bar, for Offset, enter 2", and press ENTER.

- Select the inside arc line of the wall top, so the offset is positioned inside the arc.

- On the Options Bar, for Offset, enter 0", and press ENTER.

- Select the left end line.

- Select the right end line.
35 On the Tools toolbar, click \( \text{Trim} \), and trim the sketch lines to form a closed loop, as shown:

36 On the Design Bar, click Finish Sketch.

Create a countertop mounting bracket

37 Click Solid Form ➤ Solid Extrusion.

38 Specify the extrusion properties:

- On the Design Bar, click Extrusion Properties.
- In the Element Properties dialog, under Constraints, for Extrusion End, enter 48.25".
- For Extrusion Start, enter 46".
- Under Materials and Finishes, select the Material value, and click (Browse).
- In the Materials dialog, in the left pane, select Metal - Aluminum.
- Click OK twice.

39 On the Options Bar, click (Circle).
40 In the floor plan view, sketch a circle at the left end of the countertop, as shown:

41 Select the dimension, enter 2", and press ENTER.

42 Zoom in to the circle.
43 On the Design Bar, click Modify.
44 Select the circle, and move it near the edge of the counter between the 2 dashed lines, as shown:
45 Zoom out so you can see the entire information counter, and click Finish Sketch.

Use the Array tool

46 In the drawing area, select the circle.

47 On the Edit toolbar, click (Array).

48 Specify options to array the circle along the top edge of the counter:

- On the Options Bar, click (Radial).
- For Move To, click Last.
- For Number, enter 5.
- Verify that Group And Associate is selected.

49 Create the radial array:

- Drag the center of the rotation symbol from inside the circle to the center of the information counter.
■ Click below and to the left of the circle to position where the arc of the array begins. (A line radiates from the center of rotation symbol to the cursor position.)

■ Click to select a point to end the array (slightly less than 180 degrees), as shown:
NOTE In order to display the arrayed brackets on the correct side of the counter, you must first specify an angle of less than 180 degrees, and then adjust the array end point.

- Press ENTER to accept the array count (5).
- Drag the end handle of the array to the right end of the countertop to evenly disperse the arrayed brackets, and click Modify.

Use the Extrusion tool

50 Click Void Form ➤ Void Extrusion.
   You create a reveal along the outside face of the information counter.

51 Click Extrusion Properties.
52 In the Element Properties dialog, for Extrusion Start, enter 2’6”.
53 For Extrusion End, enter 2’10”, and click OK.
54 Pick lines to create the reveal:
   - On the Options Bar, click (Pick Lines).
   - Select the outer thick arc line (wall bottom).
On the Options Bar, for Offset, enter 6".

Select the same arc line, so the offset is positioned outside the arc.

Change the Offset to 0", and select the 2 end lines.

55 On the Design Bar, click Modify.

56 On the Tools toolbar, click (Trim), and trim the sketch lines to form a closed loop, as shown:
57 Click Finish Sketch.

58 Click Finish Family.

59 Click File menu ➤ Save As.

60 Save the project as i_art_gallery_in_progress.rvt.
Creating a 2D Representation of the Information Counter

In some cases, you may want to add 2D information to a family. The 3D geometry may not display exactly as desired. By using 2D symbolic lines and turning off the visibility of 3D geometry in specific views, the desired look can be achieved, and product performance optimized.

In this exercise, you make the following changes to the information counter representation for orthographic views:

- Turn off visibility of the mounting bracket for the glass
- Change the glass counter to a hidden line
- Change the surrounding wall into a cut projection

Plan view of the information counter

Delete 2D linework

1. Continue working with the file you saved in the previous exercise, i_art_gallery_in_progress.rvt, with the Level 1 floor plan and 3D views tiled. You start the exercise in the floor plan view.

2. In the floor plan view, draw a selection window around the information counter to select all the elements.
3 On the Options Bar, click Filter.
You can use the filter tool to select just the linework.

4 In the Filter dialog, clear Casework and Furniture, and click OK.

5 Press DELETE.
You are now left with only the 3D geometry that makes up the family.

Add symbolic lines to the in-place family

6 In the drawing area, select the information counter, and on the Options Bar, click Edit.
You are now in Family Editor mode.

7 On the Design Bar, click Symbolic Lines, and in the Type Selector, click Hidden Lines [projection].

8 On the Options Bar, click Pick Lines.
You lock symbolic lines to 3D geometry using the Pick Lines option and the lock feature. Any
changes made to the 3D geometry are also made in the symbolic lines.

9 Select the outer arc line, and click .
10 Select and lock the right end line.

11 Select and lock the left end line.

12 In the Type Selector, select Casework [cut].

13 Select and lock the inner arc line.
14 On the Options Bar, for Offset, enter 6", and press ENTER.
15 Select the inner arc line again, positioning the offset to the outside of the arc.

16 Zoom in to the lower left corner of the information counter.

17 On the Options Bar, click (Draw).

18 For Offset, enter 0", and click (Line).
19 Select the endpoint of the middle symbolic line.

NOTE Warnings created when drawing overlapping lines can be ignored in this case.
Move the cursor along the end line and select the endpoint of the inner symbolic line.

20 Pan to the right end of the information counter, and use the same method to draw a symbolic line on the right.
   ■ Select the endpoint of the left symbolic line.

21 On the Design Bar, click Modify.
22 Zoom out to see the entire information counter.

Modify visibility settings

23 In the 3D view, select the glass counter top, and on the Options Bar, click Visibility.

24 In the Family Element Visibility Settings dialog, clear Plan/RCP, and click OK.
25 Using the same method, hide the information counter wall from plan view.
26 Select one of the counter brackets, and on the Options Bar, click Edit Group. Because the brackets are created and grouped as an array, they must be edited as a group. In Group Edit mode, you can change component visibility. The change is made in all instances of the bracket in the array.

27 In the drawing area, select a bracket, and on the Options Bar, click Visibility.

![Image of a bracket]

28 In the Family Element Visibility Settings dialog, clear Plan/RCP, and click OK.

**NOTE** In this example, you leave the desk visible in Plan view so that the chair is obscured by the solid form.

29 On the Edit Group toolbar, click Finish.

You only see visibility changes to elements after clicking Finish Family.

30 Click Finish Family.

31 In the floor plan view, observe the changes in the plan representation of the family.

![Image of a floor plan]

32 Click File menu ➤ Save.
Appendices
## Appendix A: Revit System Families and Settings

### Revit System Families

<table>
<thead>
<tr>
<th>Family</th>
<th>Revit Architecture</th>
<th>Revit Structure</th>
<th>Revit MEP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ceilings</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Curtain Panels</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Curtain Wall Mullion</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Detail Items</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Ducts</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rectangular Duct</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Round Duct</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Flex Ducts</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Flex Rectangular Duct</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Flex Round Duct</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Flex Pipes</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Family</td>
<td>Revit Architecture</td>
<td>Revit Structure</td>
<td>Revit MEP</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------</td>
<td>-----------------</td>
<td>-----------</td>
</tr>
<tr>
<td>Flex Pipe Round</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Floors</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Slab Edge</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fluids</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Model Text</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Pipes</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Railings</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Ramps</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Roofs</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Fascia</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Gutter</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Roof Soffit</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Sloped Glazing</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Site - Pad</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Stairs</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Structural Columns</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Structural Beam System</td>
<td>X</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Structural Foundations</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Foundation Slab</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Wall Foundation</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
### Structural Loads

<table>
<thead>
<tr>
<th>Load Type</th>
<th>Revit Architecture</th>
<th>Revit Structure</th>
<th>Revit MEP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Area Loads</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
<tr>
<td>Line Loads</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
<tr>
<td>Point Loads</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
</tbody>
</table>

### Structural Rebar

<table>
<thead>
<tr>
<th>Rebar Type</th>
<th>Revit Architecture</th>
<th>Revit Structure</th>
<th>Revit MEP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rebar Bar</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
<tr>
<td>Rebar Hook</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
</tbody>
</table>

### Walls

<table>
<thead>
<tr>
<th>Family</th>
<th>Revit Architecture</th>
<th>Revit Structure</th>
<th>Revit MEP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Walls</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

### Revit System and Project Settings

<table>
<thead>
<tr>
<th>Setting</th>
<th>Revit Architecture</th>
<th>Revit Structure</th>
<th>Revit MEP</th>
</tr>
</thead>
<tbody>
<tr>
<td>Abbreviations (for area/path reinforcement)</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
<tr>
<td>Area and Volume Calculations</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Arrowheads</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Color Fill Schemes</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Detail Level</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Dimensions</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Drawing Sheets</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Electrical</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Elevations</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Filled Regions/Fill Patterns</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Setting</td>
<td>Revit Architecture</td>
<td>Revit Structure</td>
<td>Revit MEP</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>--------------------</td>
<td>-----------------</td>
<td>-----------</td>
</tr>
<tr>
<td>Filters</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Grids</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Heating and Cooling Constr.</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Keynoting</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Levels</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Lines</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Load Types</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Match Lines</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Materials</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Mechanical</td>
<td>-</td>
<td>-</td>
<td>X</td>
</tr>
<tr>
<td>Model Text</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Object Styles</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Phases</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Project Browser Organization</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Project Units</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Rebar Cover</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
<tr>
<td>Sections</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Site Settings</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Spot Coordinates</td>
<td>-</td>
<td>X</td>
<td>-</td>
</tr>
<tr>
<td>Spot Dimensions</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Snaps</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Structural Settings</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Setting</td>
<td>Revit Architecture</td>
<td>Revit Structure</td>
<td>Revit MEP</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>--------------------</td>
<td>----------------</td>
<td>-----------</td>
</tr>
<tr>
<td>Sun and Shadow Settings</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Temporary Dimensions</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Text</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Viewports</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View Tags (Callout, Elevation, Section)</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>View Templates</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>
Appendix B: Exploring Family Templates

Exploring Family Templates

Revit Architecture ships with a large number of family templates. When you create a new family, you start with the selection of a family template. Based on the template you select, the new family has specific default contents, such as reference planes and sub-categories. Revit Architecture differs between templates for model families, annotation families, and title blocks.

Model Family Templates

The templates for model families are in Documents and Settings/All Users/Application Data/Autodesk/RAC 2009/Imperial Templates. The following table gives an overview of the templates for model families:

<table>
<thead>
<tr>
<th>Template Name *.rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baluster</td>
<td>Family template for baluster families.</td>
</tr>
</tbody>
</table>

Category: None
<table>
<thead>
<tr>
<th>Template Name * . rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baluster - Panel</td>
<td>Family template for baluster panel families.</td>
</tr>
<tr>
<td></td>
<td>Baluster Panel Elevation</td>
</tr>
<tr>
<td>Category: None</td>
<td></td>
</tr>
<tr>
<td>Baluster - Post</td>
<td>Family template for posts of balusters.</td>
</tr>
<tr>
<td></td>
<td>Baluster Post Elevation</td>
</tr>
<tr>
<td>Category: None</td>
<td></td>
</tr>
<tr>
<td>Casework wall based</td>
<td>Family template for casework. Contains sample wall geometry. Wall based families can only be placed on wall faces in a project.</td>
</tr>
</tbody>
</table>

![Baluster Panel Elevation Diagram](image)

![Baluster Post Elevation Diagram](image)
<table>
<thead>
<tr>
<th>Template Name *.rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Casework</strong></td>
<td>Family template for casework. Geometry can be locked to upper and lower reference level in elevation views.</td>
</tr>
</tbody>
</table>

If a column intersects a wall, the column inherits the material of the wall.

**Column**

Family template to create columns. Geometry can be locked to upper and lower reference level in elevation views.

Category: Casework

Category: Columns
<table>
<thead>
<tr>
<th>Template Name *.rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Curtain Wall Panel</td>
<td>Family template for filling elements of curtain walls.</td>
</tr>
<tr>
<td></td>
<td>![Diagram of Curtain Wall Panel]</td>
</tr>
<tr>
<td>Category: Curtain Panels</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Detail Component line based</th>
<th>2D family, contains a reference line and left and right reference planes. Geometry can use length parameter as “stretch” value. Includes the filled region tool.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category: Detail Items</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Detail Component</th>
<th>2D family, is used to create 2D detail components, includes the filled region tool.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category: Detail Items</td>
<td>![Diagram of Detail Component]</td>
</tr>
<tr>
<td>Template Name</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Door - Curtain Wall</td>
<td>Family template for door elements of curtain walls.</td>
</tr>
<tr>
<td>Door</td>
<td>Family template for doors.</td>
</tr>
<tr>
<td>Electrical Equipment</td>
<td>Family template to create electrical equipment families.</td>
</tr>
<tr>
<td>Electrical Fixture ceiling based</td>
<td>Family template to create electrical equipment</td>
</tr>
<tr>
<td>Template Name * .rft</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>families. Contains a sample ceiling geometry. Ceiling based families can only be placed on any ceiling in a project.</td>
<td></td>
</tr>
</tbody>
</table>

**Category: Electrical Fixtures**

| Electrical Fixture wall based families. Contains sample wall geometry. Wall based families can only be placed on wall faces in a project. |
|---------------------|-------------|
| Family template to create electrical equipment |

**Category: Electrical Fixtures**
<table>
<thead>
<tr>
<th>Template Name * . rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Electrical Fixture</td>
<td>Family template to create electrical equipment families.</td>
</tr>
<tr>
<td>Category: Electrical Fixtures</td>
<td></td>
</tr>
<tr>
<td>Entourage</td>
<td>Family template to create entourage families.</td>
</tr>
<tr>
<td>Category: Entourage</td>
<td></td>
</tr>
<tr>
<td>Furniture System</td>
<td>Family template to create furniture system families.</td>
</tr>
<tr>
<td>Category: Furniture Systems</td>
<td></td>
</tr>
<tr>
<td>Furniture</td>
<td>Family template to create furniture families.</td>
</tr>
<tr>
<td>Category: Furniture</td>
<td></td>
</tr>
<tr>
<td>Template Name *.rft</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Generic Model ceiling based</td>
<td>Family template to create any generic model geometry. Contains a sample ceiling geometry. Ceiling based families can only be placed on ceiling in a project.</td>
</tr>
</tbody>
</table>

![Diagram of Generic Model ceiling based family template]

Category: Generic Models

| Generic Model face based | Family template to create any generic model geometry. Face based families can only be placed on any face in a project. |

![Diagram of Generic Model face based family template]

Category: Generic Models

| Generic Model floor based | Family template to create any generic model geometry. Contains sample floor geometry. Floor |

![Diagram of Generic Model floor based family template]
<table>
<thead>
<tr>
<th>Template Name *.rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>based families can only be placed on a floor face in a project.</td>
<td></td>
</tr>
</tbody>
</table>

**Category:** Generic Models

**Generic Model line based**

Family template to create any generic model geometry. Contains a reference line and left and right reference planes. Geometry can use length parameter as “stretch” value. Includes the filled region tool.

*Category:* Generic Models

**Generic Model roof based**

Family template to create any generic model geometry. Contains sample roof geometry. Roof based families can only be placed on any roof face in a project.
<table>
<thead>
<tr>
<th>Template Name * .rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Generic Model wall based Family template to create any generic model geometry. Contains sample wall geometry. Wall based families can only be placed on wall faces in a project.</td>
<td></td>
</tr>
</tbody>
</table>

Category: Generic Models Sample: Wall Opening with 2D graphics in plan view and a void extrusion.
<table>
<thead>
<tr>
<th>Template Name * . rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Generic Model</strong></td>
<td>Family template to create any generic model geometry.</td>
</tr>
<tr>
<td><strong>Lighting Fixture floor based</strong></td>
<td>Family template to create lighting fixtures. Contains sample floor geometry. Floor based families can only be placed on a floor face in a project. The family has illumination properties for the rendering tools.</td>
</tr>
<tr>
<td><strong>Lighting Fixture roof based</strong></td>
<td>Family template to create lighting fixtures. Contains sample roof geometry. Roof based families can only be placed on a roof.</td>
</tr>
<tr>
<td>Template Name * . rft</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Family template to create lighting fixtures. The family has illumination properties for the rendering tools.</td>
<td></td>
</tr>
</tbody>
</table>

Category: Lighting Fixtures

<table>
<thead>
<tr>
<th>Lighting Fixture ceiling based</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Family template to create lighting fixtures. Contains sample ceiling geometry. Ceiling based families can only be placed on a ceiling face in a project. The family has illumination properties for the rendering tools.</td>
<td></td>
</tr>
</tbody>
</table>

Category: Lighting Fixtures

Diagram: Lighting Fixture ceiling based
<table>
<thead>
<tr>
<th>Template Name *.rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>properties for the rendering tools.</td>
</tr>
<tr>
<td>Category: Lighting Fixtures</td>
<td></td>
</tr>
<tr>
<td>Lighting Fixture wall based</td>
<td></td>
</tr>
<tr>
<td>Family template to create lighting fixtures. Contains sample wall geometry. Wall based families can only be placed on a wall face in a project. The family has illumination properties for the rendering tools.</td>
<td></td>
</tr>
<tr>
<td>Category: Lighting Fixtures</td>
<td></td>
</tr>
<tr>
<td>Lighting Fixture</td>
<td></td>
</tr>
<tr>
<td>Family template to create lighting fixtures. The family has illumination properties for the rendering tools.</td>
<td></td>
</tr>
<tr>
<td>Template Name *.rft</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>properties for the rendering tools.</td>
</tr>
<tr>
<td></td>
<td>Category: Lighting Fixtures</td>
</tr>
<tr>
<td>Linear Lighting Fixture</td>
<td>Family templates to create linear lighting fixtures. The family has illumination properties for the rendering tools. Contains the same defaults as the Lighting Fixtures. Category: Lighting Fixtures</td>
</tr>
<tr>
<td>floor based; Linear Lighting Fixture roof based; Linear Lighting Fixture ceiling based; Linear Lighting Fixture wall based; Linear Lighting Fixture</td>
<td></td>
</tr>
<tr>
<td>Mass</td>
<td>Family template to create massing families. Faces of masses can be used to create other model elements like walls, slabs, and roofs. Massing families can also be generating floor area faces. Masses can report gross volume, gross surface area, and gross floor areas.</td>
</tr>
<tr>
<td></td>
<td>Category: Mass Sample: Mass families from the content library.</td>
</tr>
<tr>
<td>Template Name *.rft</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Mechanical Equipment ceiling based</td>
<td>Family template to create mechanical equipment families. Contains sample ceiling geometry. Ceiling based families can only be placed on ceiling faces in a project.</td>
</tr>
<tr>
<td>Mechanical Equipment wall based</td>
<td>Family template to create mechanical equipment families. Contains sample wall geometry. Wall based families can only be placed on wall faces in a project.</td>
</tr>
</tbody>
</table>

Category: Mechanical Equipment
<table>
<thead>
<tr>
<th>Template Name *.rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mechanical Equipment</td>
<td>Family template to create mechanical equipment families.</td>
</tr>
<tr>
<td>Category: Mechanical Equipment</td>
<td></td>
</tr>
<tr>
<td>Parking</td>
<td>Family template to create parking families.</td>
</tr>
<tr>
<td>Category: Parking</td>
<td></td>
</tr>
<tr>
<td>Planting</td>
<td>Family template to create planting families.</td>
</tr>
<tr>
<td>Category: Planting</td>
<td></td>
</tr>
<tr>
<td>Plumbing Fixture wall based</td>
<td>Family template to create plumbing fixture families. Contains sample wall geometry. Wall based families can only be placed on wall faces in a project.</td>
</tr>
<tr>
<td>Template Name * .rft</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Plumbing Fixture</strong></td>
<td>Family template to create plumbing fixture families.</td>
</tr>
<tr>
<td><strong>Profile</strong></td>
<td>Family template to create 2D profiles. Profile usage (fascia, gutter, mullion, slab edge, wall sweep) can be explicitly assigned under Settings menu ➤ Family Category and Parameters.</td>
</tr>
</tbody>
</table>

Category: Plumbing Fixtures

Category: Profiles. A profile is only used in combination with system families.
<table>
<thead>
<tr>
<th>Template Name * .rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Profile-Hosted</td>
<td>Family template to create 2D profiles for hosts. Families based on this template can be used in a project with the tools in the Modelling menu ➤ Host Sweeps. Profile usage can be explicitly assigned.</td>
</tr>
<tr>
<td></td>
<td><img src="image1.png" alt="Diagram of Profile-Hosted" /></td>
</tr>
<tr>
<td></td>
<td>Category: Profiles. A profile is only used in combination with system families.</td>
</tr>
<tr>
<td>Profile-Mullion</td>
<td>Family template to create 2D profiles for mullions.</td>
</tr>
<tr>
<td></td>
<td><img src="image2.png" alt="Diagram of Profile-Mullion" /></td>
</tr>
<tr>
<td></td>
<td>Category: Profiles. A profile is only used in combination with system families.</td>
</tr>
<tr>
<td>Template Name *.rft</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Profile-Rail</td>
<td>Family template to create 2D profiles for rails. Contains default reference planes Rail Centerline and Rail Top.</td>
</tr>
<tr>
<td></td>
<td>Category: Profiles. A profile is only used in combination with system families.</td>
</tr>
<tr>
<td>Profile-Reveal</td>
<td>Family template to create 2D profiles for wall sweeps and wall reveals. Profile usage can be explicitly assigned.</td>
</tr>
<tr>
<td></td>
<td>Category: Profiles. A profile is only used in combination with system families.</td>
</tr>
<tr>
<td>Profile-Stair Nosing</td>
<td>Family template to create 2D profiles for stair nosing.</td>
</tr>
<tr>
<td>Template Name *.rft</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Category: Profiles.</strong> A profile is used only in combination with system families.</td>
<td></td>
</tr>
</tbody>
</table>

**RPC Family**

Family template for models using the Real People Collection product family. The family has an rpc file link included.

**Category: Entourage**

**Site**

Family template to create Site families.

**Category: Site**

**Speciality Equipment wall based**

Family template to create specialty equipment families. Contains sample wall geometry. Wall based families can only be placed on wall faces in a project.
<table>
<thead>
<tr>
<th>Template Name * . rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Category: Specialty Equipment</strong></td>
<td></td>
</tr>
<tr>
<td>Speciality Equipment</td>
<td>Family template to create specialty equipment families.</td>
</tr>
<tr>
<td><strong>Category: Specialty Equipment</strong></td>
<td></td>
</tr>
<tr>
<td>Spot Lighting Fixture</td>
<td>Family templates to create spot lighting fixtures. The family has illumination and spot properties for the rendering tools. Contains the same defaults as the Lighting Fixtures. Category: Lighting Fixtures</td>
</tr>
<tr>
<td>Structural Column</td>
<td>Family template to create structural columns. Geometry can be locked to upper and lower reference level in elevation views.</td>
</tr>
</tbody>
</table>

If a structural column intersects a wall, the column cuts out the wall. Beams can be placed on structural columns.
Under Settings menu ➤ Family Category and Parameters, specific settings for symbolic representation and the structural material type can be defined.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Structural Material Type</td>
<td>Precast Concrete</td>
</tr>
<tr>
<td>Symbolic Representation</td>
<td>From Family</td>
</tr>
<tr>
<td>Always export as geometry</td>
<td>Off</td>
</tr>
<tr>
<td>Beam cutted in plan</td>
<td>From bounding box</td>
</tr>
<tr>
<td>Shared</td>
<td>On</td>
</tr>
<tr>
<td>Show family pre-out plan view</td>
<td>On</td>
</tr>
</tbody>
</table>

A structural column can be defined as a room-bounding element if the structural material type is set to concrete or precast concrete. Category: Structural Columns

---

**Structural Foundation**

Family templates to create structural foundation families.

If a structural foundation family is placed below a column, it moves its position if the base of the structural column is moved. Category: Structural Foundations

---

**Structural Framing - Beams and Braces**

Family template to create structural framing families, such as beams and braces. The family templates contain specific reference planes for members and stick symbols.
Under Settings menu ➤ Family Category and Parameters, specific setting for symbolic representation and the structural material type can be defined.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Always vertical</td>
<td>✔️</td>
</tr>
<tr>
<td>Symbols Representation</td>
<td>From Family</td>
</tr>
<tr>
<td>Structural Material Type</td>
<td>Concrete</td>
</tr>
<tr>
<td>Always export as geometry</td>
<td></td>
</tr>
<tr>
<td>Shared</td>
<td></td>
</tr>
</tbody>
</table>

Category: Structural Framing

Structural Framing - Complex and Trusses
Family template to create structural framing families, such as trusses.

Category: Structural Framing

Window - Curtain Wall
Family template for window elements of curtain walls.
<table>
<thead>
<tr>
<th>Template Name *.rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Category: Curtain Panels</strong></td>
<td></td>
</tr>
<tr>
<td>Window with trim</td>
<td>Family template for windows including trim on the exterior side.</td>
</tr>
<tr>
<td><strong>Category: Windows</strong></td>
<td></td>
</tr>
<tr>
<td>Window</td>
<td>Family template for windows.</td>
</tr>
</tbody>
</table>

**Annotation Family Templates**

The templates for annotation families are in Documents and Settings/All Users/Application Data/Autodesk/RAC 2009/Imperial Templates/Annotation.
Annotation families consist mainly of lines, filled regions, text, and parameters. The intersection of 2 reference planes defines the insertion point of a tag.

Annotation families are scale-dependent. Symbol size, text size, and parameter text size are always related to the current scale of the View Control Bar. Thus, parameter text created with a text height of has a size of on a plotted sheet. The following table gives an overview of the templates for annotation families:

<table>
<thead>
<tr>
<th>Template Name * .rft</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Callout Head</td>
<td>Family template for the tag of a callout. Category: Callouts</td>
</tr>
<tr>
<td>Door Tag</td>
<td>Family template for door tags. Category: Door Tags</td>
</tr>
<tr>
<td>Generic Annotation</td>
<td>Family template for generic annotations. The category can be set under Settings menu ➤ Family Category and Parameters. Category: Generic Annotation</td>
</tr>
<tr>
<td>Generic Tag</td>
<td>Family template for tags. The category can be set under Settings menu ➤ Family Category and Parameters. Category: Generic Model Tags</td>
</tr>
<tr>
<td>Grid Head</td>
<td>Family template for the grid heads. Category: Grid Heads</td>
</tr>
<tr>
<td>Level Head</td>
<td>Family template for level heads. Category: Level Heads</td>
</tr>
<tr>
<td>Multi-Category Tag</td>
<td>Family template for Multi-Category tags. On the Drafting tab of the Design Bar, click Tag ➤ Multi-Category to add a tag. A Multi-Category tag needs a shared parameter as filter parameter. The same shared parameter is added to a project as a project parameter and can be used to filter selected elements to</td>
</tr>
<tr>
<td>Template Name *.rft</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Room Tag</td>
<td>Family template for room tags. Category: Room Tags</td>
</tr>
<tr>
<td>Section Head</td>
<td>Family template for section heads. In the family the intersection of the horizontal and right reference planes define connection location with the system section line. Category: Section Marks</td>
</tr>
<tr>
<td>Spot Elevation Symbol</td>
<td>Family template to define the symbol for spot elevations. Category: Spot Elevation Symbols</td>
</tr>
<tr>
<td>View Title</td>
<td>Family template to define view title of a view in a sheet. Category: View Titles</td>
</tr>
<tr>
<td>Window Tag</td>
<td>Family template for window tags. Category: Window Tags</td>
</tr>
</tbody>
</table>

**Titleblock Family Templates**

The templates for titleblock families are in Documents and Settings/All Users/Application Data/Autodesk/RAC 2009/Imperial Templates/Titleblocks.

Title block families consist mainly of lines for the plan border, filled regions, text, and parameters. You import images to your title block. The following table gives an overview of the templates for title block families:

<table>
<thead>
<tr>
<th>Template Name</th>
<th>Comments</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Imperial</strong></td>
<td>Family templates for title blocks using common standard sizes. In a project, the title block can be assigned to a sheet using View menu ➤ New ➤ Sheet. In the Select a Titleblock</td>
</tr>
<tr>
<td>Template Name</td>
<td>Comments</td>
</tr>
<tr>
<td>---------------</td>
<td>----------</td>
</tr>
<tr>
<td><strong>Metric</strong></td>
<td>dialog, all loaded title block families are listed for selection.</td>
</tr>
<tr>
<td>■ A0 metric.rft</td>
<td></td>
</tr>
<tr>
<td>■ A1 metric.rft</td>
<td></td>
</tr>
<tr>
<td>■ A2 metric.rft</td>
<td></td>
</tr>
<tr>
<td>■ A3 metric.rft</td>
<td></td>
</tr>
<tr>
<td>■ A4 metric.rft</td>
<td></td>
</tr>
<tr>
<td>■ New Site Metric.rft</td>
<td></td>
</tr>
</tbody>
</table>
Appendix C: Best Practices for Creating Revit Architecture Families

Best Practices for Creating Revit Architecture Families

These best practices are a summary of the guidelines and tips presented in the Revit Architecture Families tutorials.

Design Considerations

- **Will the family need to accommodate multiple sizes?**
  For a custom piece of furniture that only comes in one configuration, create an in-place family. For a window that is available in several preset sizes, or a bookshelf that can be built in any length, create a standard component family. Size variability and the degree of complexity of the object determine whether you create an in-place family or a standard component family.

- **How should the family display in different views?**
  The way the object should display in views determines the 3D and 2D geometry that you need to create, as well as how to define the visibility settings. Determine whether the object should display in a plan view, elevation view, and/or sectional views.

- **Does this family require a host?**
  For objects typically hosted by other components, such as a window or light fixture, start with a host-based template. How the family is hosted (or what it does or does not attach to) determines which template file should be used to create the family.

- **How much detail should be modeled?**
  In some cases, you may not need 3D geometry. You may only need to sketch a 2D shape to represent your family. Also, you may simplify the 3D geometry of your model to save time in creating the family. For example, less detail is required for a wall outlet that will only be seen in interior elevations from a distance, than for a door with raised panels and a sidelight that will be seen in an interior rendering.
What is the **origin** point of this family?
For example, the insertion point for a column family could be the center of the circular base. The insertion point for an accessible toilet may be 18 inches off the adjacent wall to meet code. Determining the appropriate insertion point will help users place the family in a project.

**Process: Creating a Family**

1. Select the appropriate family template.
2. Define the origin, and ensure that the template reference planes are pinned.
3. Lay out reference planes to aid in drawing component geometry.
4. Add dimensions to specify parametric component geometry or 2D representation.
5. Label dimensions to create type or instance parameters or 2D representation.
6. Define family type variations by specifying different parameters.
7. Flex the skeleton.
8. Add a single level of geometry in solids and voids, and constrain the geometry to reference planes.
9. Flex the new model (types and hosts) to verify correct component behavior.
10. Repeat previous steps until the family geometry is complete.
11. Define subcategories for the family to help control object visibility.
12. Specify 2D and 3D geometry display characteristics with subcategory and entity visibility settings.
13. Save the newly defined family, and then load it into a project for testing.

**Naming Conventions**

**Families/Types**

- Use title case for family and type names.
- Do not repeat the family name in type names.
- Type names should mirror actual usage. To indicate size in the name, use specific dimensions rather than non-specific descriptions like "large."
- Imperial units in names should be formatted as \(a' \cdot b \cdot c/d'' \times a' \cdot b \cdot c/d''\). In most cases, sizes should be in inches, that is, \(aa'' \times bb''\).
- Metric units in names should be formatted as \(ZZZZ \times YYYY \text{mm}\).
- Nominal sizes should not use a units indicator in names, that is, \(2 \times 4\), not \(2'' \times 4''\) for dimension lumber.

**Units**

- Families that are units-neutral should have at least one type for each unit system, unless the family represents an item that is manufactured and sold only in one system.

**Parameters**

- Parameter names should be as close as possible to natural language. Minimize the use of abbreviations and truncation.
- Standard parameter names should be used whenever possible.
Use title case for parameter names; parameters are case sensitive.
Create parameters only to reflect meaningfully differentiated types that represent real world possibilities.
Parameter names reused to create equalities should be carefully checked for name coherence.

**Organizing Family Content**

Organize family content into a system that mimics the Revit Architecture Library. This makes it much easier for users to find a family they need. It also means that when there is a new release you can replace the entire Revit Architecture library, running the Upgrade Files utility only on custom family content.

Consider adding a parameter to families to indicate the version (based on the software version). This lets you compare the version of a door loaded into the project with the version of the door in your library. You may also want to add a parameter for authorship.

**Family Creation Guidelines**

**Laying Out Reference Planes**

Add reference planes before creating any family geometry. You can then use those reference planes as you create geometry and snap sketches and geometry to them.

- Pin the existing template reference planes: Center Left/Right and Center Front/Back.
- Position new reference planes so that they align with the major axes of the planned geometry.
- Specify the Is Reference property for reference planes that will be dimensioned to when the family is placed in a project.
- Name reference planes so that you can assign it to be the current work plane. Without a name, you must be able to see the reference plane so you can select it to use as a work plane.
- Label parameters.

**Sketching**

- Use a phase-based approach to adding geometry by creating a single level of geometry and flexing it, before adding the next level.
- Use the Align tool to attach geometry or 2D representation to reference planes.
- Use TAB to highlight a reference plane for selection.
- Rather than sketching geometry directly on the reference planes, sketch the shape roughly and then align it to the reference planes. The key is to make these sketch lines lock to the reference planes.
- Moving a sketch line off and back onto a reference plane will display the lock symbols, allowing you to lock or unlock the sketch line. (The Align tool also allows you to create constraints using the lock symbols.)
- Lock all extrusion ends to any reference planes they must move with. Test by varying surface position or host dimensions.
- Dimension the depth of extrusion for all extrusions that must maintain a constant depth or where depth is to be parametrically controlled.
- All lines must be locked to any reference planes they must move with. Test by varying surface position.
Adding Constraints to Family Geometry

- Keep constraints to a minimum. This practice helps prevent "Can't keep joined" errors to a minimum when you are moving objects, and avoids unnecessary performance penalties.

- Do not dimension objects inside of a sketch and then constrain the objects outside of the sketch. Create all constraints either inside the sketch or outside of the sketch.

- Use the equality option (EQ) in a dimension string to force elements to stay equally spaced relative to each other.

- The anchor symbol that displays when a member of 3 equality constrained elements is selected, determines how the constraint is applied and therefore how the elements will stretch or flex. This anchor can be dragged to the middle element so the 3 elements will flex equally from the middle. If the anchor is on the left element, for example, the 3 reference planes will flex from the left side toward the right.

- The Constraints not satisfied warning usually means that the parameter is trying to control a part that is already constrained by another parameter. As more parameters are added to the model, be sure to flex multiple parameters to test them. For instance, if flexing the width works well, then set a new width, and flex the height. Try different combinations to assure all is moving as expected.

- A Circular chain reference warning may display when a parameter or variable is used in multiple formulas, and the values rely on each other to compute a result.

- Host objects should be large enough to accommodate all reasonable variations of the family.

- Floor-hosted elements cannot be installed in a project until a user has placed a floor plate. Most floor-based families will perform better if built in a level based template. Use floor hosts only where the element makes a change in the floor, or where it is anticipated that the element will usually be installed on a sloping floor.

Determining the Level of Detail

- If you do not need to show content as a solid in a 3D view, build it using 2D elements only. Most components can be handled better by adding detail to the plan or elevation representations.

- Do not depict any detail that users would not typically represent (avoid modeling tiny things).

- Use scale-dependent representation where appearance change is meaningful at scales other than typical whole building scale and would be expressed on actual projects.

- Check different view scales to ensure that only the correct elements are visible.

- If detail is important in some views, assign level-of-detail visibility to elements to hide them when not needed and/or assign them to the appropriate coarse, medium, or fine detail level.

Employ Visibility Settings

- When modeling geometry, take advantage of visibility settings. Set the detail levels for plan and elevation representations (coarse, medium, fine) and view-specific display options in the visibility settings.

- View-specific representations must be drawn for any views in which an element is to be represented in a manner different than as a cut or projection of the 3D element.

- Check element visibility in all views so that symbolic elements do not duplicate cuts or projections of 3D elements visible in the same view.

- The Temporary Hide Isolate tool is helpful while you are working inside the Family Editor. For example, elements are not hidden when a yes/no parameter is assigned to them; they are dimmed out. It may be helpful to temporarily hide elements while you are working.
If you change the view scale within the Family Editor, you can improve the line quality of the display. This makes it much easier to deal with complex families that have many parameters and constraints.

- Assign elements to appropriate sub-categories as required allowing appropriate visibility control.
- Assign lines to the proper representation style (cut vs. projection) of their subcategory by selecting from the properties drop-down list.
- Do not rename sub-categories.

**Using Type Catalogs**

Type Catalogs make a long list of types manageable and easier to enter in a text file. The family itself is much simpler to test because the family editor isn't cluttered with multiple types to check values.

- Where real-world examples come in typical sizes, predefined types should be generated.
- Where there are to be more than 6 predefined types in a family, use a type catalog to organize the types.

**Performance Considerations**

- Not all families need to be parametric.
- Avoid overuse of voids, formulas, and arrays.
- Limit the use of detailed, nested, and highly parameterized families.
- Use symbolic lines instead of geometry in plan views.
- Always test in the project environment.
- When components are going to be reused, create a standard component instead of an in-place family.
- Instance parameters can make a family too flexible and not representative of real-world objects. Variable families like windows and doors may make excellent early design placeholders, but they should eventually be replaced with objects that better represent those that will be installed.
Glossary

Glossary Terms

**blend** A blend smoothly connects two 2D shapes (a base sketch and a top sketch) placed parallel to each other. The base sketch and the top sketch must be closed loops with no intersecting sketch lines. Each sketch in a blend is set to a different height.

**category** A group of components that you use to model or document a building design. For example, within the Furniture category, you may have family components for a desk, a dresser, and a sofa. When you select a category for a new family, the properties of the family category are assigned to the component.

**circular chain of reference** This condition occurs in drawing geometry when one element references another, and the second one references the first one (there may be more than 2 elements in the reference loop). The following is an example of a condition that causes this error:

- create a floor that references a wall
- edit the wall elevation profile and constrain it to the floor
**constraint** A relationship between elements in a building design. For example, you create constraints by placing dimensions and locking them or by creating equality constraints.

**cuttable** If a family is cuttable, the family displays as cut when the cut plane of a view intersects that family in all types of views. In the Family Element Visibility Settings dialog, the "When cut in Plan/RCP" option determines if family geometry displays when the cut plane intersects that family. For example, in door families, the geometry for plan swing displays when the door is cut in plan views, but does not display when the door is not cut.

**defines origin** Specify this reference plane property to identify the intersection of reference planes as the origin for the family. The origin is the point at which Revit Architecture loads the family into the project (insertion point) as well as the parametric origin. The Defines Origin option is already selected for the reference planes in the family templates, but can be modified by the user.

**detail components** Detail components are pre-drawn, line-based, 2D elements that you can add to any view (typically a detail or drafting view). They are visible only in the view in which they are added. Examples of detail components include a wood framing component, a metal stud, or a shim. A detail component displays in symbolic form and does not display in 3D.

**directional reference** Predefined system value that defines a direction (for example, left, right, top). If a reference plane defines the left edge of a family, use Left for the Is Reference value in the Element Properties dialog.

**element** An individual item in a building model. Revit Architecture projects use 3 types of elements:

- Model elements represent the actual 3D geometry of a building (for example, walls, windows, doors, and roofs).
• Annotation elements help to document the model (for example, dimensions, text notes, and section tags).

• Datum elements are non-physical items that are used to establish project context (for example, levels, grids, and reference planes).

**element properties** Parameters or settings that control the appearance or behavior of an element in a project. Element properties are the combination of the instance parameters and the type parameters of an element. To view or change element properties, select the element in the drawing area, and on the Options Bar, click the Element Properties icon.

**extrusion** Use extrusions to define 3D geometry for families. You create an extrusion by defining a 2D sketch on a plane; Revit Architecture then extrudes that sketch between a start point and an endpoint.

**family** A group of elements with a common set of parameters and related graphical representation, such as all internal doors of a building.

**family editor** A sketch-based editor in Revit Architecture that allows you to create families to include in a project. When you start creating a family, you open a template to use in the editor. The editor has the same look and feel as the project environment in Revit Architecture, but includes different commands on the Design Bar.

**family template** A collection of settings and default content that you can use as a starting point for creating a family. Among other elements, the template can include reference planes and dimensions.

**family type parameter** A parameter that is used to control the type of family within a nested family. After you label a nested component as a family type parameter, subsequently loaded families of the same category automatically become interchangeable. For example, if you add 2 transoms to a door family, you only have to position one of the transoms and label it as a family type parameter; the other transom becomes part of the list of available transoms. If you load 5 more transom types, they are all available for selection.

**family types** Family types allow you to predefine variations of a family. For example, you could create family types for different sizes of the same component. Each type is represented with selected parameters.

**flexing** A way to test a family by switching between family types, adjusting the dimensions, and switching between host types, if appropriate. These tests ensure that the skeleton of the family adjusts correctly.

**formula** A way to control the value of a parameter that depends on other parameters for its values. A simple example would be a width parameter set to equal twice the height of an object.

**host sweep** A sweep cuts the geometry from the host component, such as a wall or roof. Examples of host sweeps are wall sweeps, roof fascia, gutters, and slab edges.
**host-based family** A family that has components requiring hosts (for example, a door family hosted by a wall family). You can place a host-based family in a project only if an element of its host type is present.

**in-place family** A family that is exclusive to the current project that you are working on. Like a system family, you create and modify an in-place family in a project and save it in the project file. Whenever you make changes in the project, the in-place family is updated accordingly. An in-place family cannot be loaded into other projects.

**instance parameter** A setting that controls a single element of a parametric family, such as the length/arc angle of an ornate molding. When you change the value of an instance parameter, only that instance of the type changes.

**is reference** A reference plane property where you specify the strength of the reference plane. When you place the family in a project, the value of this property determines snapping, dimensioning, and the creation of shape handles.

**join geometry** A command used to create a union between 2 separate pieces of geometry. Joining inherits the material and visibility properties from the host element.
library A folder structure in which families are stored. To load a family into a project, you select the Load from Library ➤ Load Family command, and navigate to the directory containing the family you wish to load. You can load families from local or networked libraries, or from the Web library. After loading the family, it is saved with the project.

model lines Lines used to sketch 2D geometry where you do not need to show solid geometry. For example, you could sketch door panels and hardware as 2D rather than sketch solid extrusions. Model lines exist in 3D space and are visible in all views.

nested families A family that has been loaded into another family. You can represent parts of the nested family separately from the main family model. For example, you could create a windowsill family and nest it in a window family.

non-cuttable A family that displays in projection, regardless of whether the cut plane intersects it. Examples of non-cuttable families include balusters, entourage, furniture, and planting.

not a reference A parameter assigned to a reference plane that can be used in a family, but cannot be accessed in a project for alignment or dimensioning. The reference plane does not snap and does not have shape handles.

overconstrain Adding too many relationships among the elements of a family. When a family is overconstrained, all constraints cannot be satisfied without causing an error condition.

parameter A property that is used to control the size and appearance of an element. Different elements in a family can have different values for some or all parameters, but the parameter set is the same for all of the elements in the family.

profile family A family that is a series of closed 2D lines and arcs, which can be applied to any type of solid geometry in the project. To create other 3D geometry, use profiles to define object cross sections such as railings, balusters, soffits, cornices, and other sweep-defined objects.

reference plane A 3D plane used as a reference or a work plane when designing model element families or placing elements in a building model.

reveal A cutout in a wall that removes material from the wall.

revolve Solid geometry that revolves around an axis. You create revolve forms by rotating a closed 2D sketch around an axis. Examples of revolve geometry include door knobs, a dome roof, or columns.
**shape handles** Grips that are used to resize a family component when it is loaded into a project. To add shape handles to a family, align and lock a reference plane (Is Reference parameter set to weak or strong) parallel to where you want the shape handles to display. Dimension the component geometry to the reference plane, and label the dimension as an instance parameter.

**shared parameter** A parameter stored in a text file independently of a family or project. A shared parameter can be added to families or projects and shared with other families and projects. It also allows you to add specific data that is not already defined in the family file or project template. In addition, a shared parameter can be used in tags and in schedules.

**skeleton** The reference planes used to create a family that form the structure of the solid geometry.

**solid forms** Geometry that defines a 3D component. Revit Architecture supports several types of solid forms: blends, sweeps, swept blends, extrusions, and revolves. A solid form creates a continuous mass.
standard component family  A family of standard sizes that has the configurations of the common components and the symbols that are used in the building design. You create and modify a standard component family in the Family Editor and save it as an external RFA file with the .rfa extension.

strong reference  A parameter for a reference plane that is the highest priority for dimensioning and snapping. When you select a family in a project, temporary dimensions display at the strong references. Strong references dimensioned with instance parameters add shape handles to family components when the components are loaded into a project.

NOTE  A reference plane with the Is Reference property set to Strong Reference or a named reference (such as Top) is a strong reference.

subcategory  A way to control the visual properties of a subgroup of elements in a category. By assigning a subcategory, you control the line pattern, line weight, line color, and material used when the geometry displays in a project.

sweep  A tool for creating geometry that requires you to sketch or apply a profile (shape), and extrude that profile along a path. You might use a sweep to create moldings, railings, or simple pipes. Two sketches are required for a sweep:

- The path can be either a closed loop or an open series of connected lines, splines, and arcs.
- The profile must be a closed loop with no intersecting sketch lines.

NOTE  The first line of the path defines the work plane for the profile.

symbolic lines  A line that is not part of the solid geometry and is intended for symbolic purposes only. For example, when creating a door family, you might sketch symbolic lines in a plan view to represent the door swing. Symbolic lines are visible parallel to the view in which you sketch them.

system family  A family of basic building elements in a Building Information Model (BIM). The family contains components (such as roofs, floors, and walls) that are built on-site in the real-world, rather than delivered and installed. The properties and graphical representation of a system family is predefined in the product.

type catalog  A delimited TXT file that defines the types in a family. A type catalog allows you to sort through the family catalog and load only the specific family type required for the project. This selection process helps decrease project size and minimizes the length of the Type Selector drop-down list when selecting types.

type parameter  A property that controls the appearance of all the elements of the parametric family type, such as the arc radius of ornate molding. If you change the value of a type parameter, all instances of the type in the project change.

unhosted family  A family that does not require a host component to be placed in a model.
**unjoin geometry**  A command used to remove a join (between 2 or more elements) that was applied using the Join Geometry command.

**void forms**  The shaped spaces that cut a solid form. Like solids, there are several types of void forms: blends, sweeps, extrusions, and revolves.

**weak reference**  A parameter for a reference plane that is the lowest priority for dimensioning. The reference plane can be accessed in a project for alignment or dimensioning, but you may have to use TAB to highlight the reference plane.

**work plane**  A planar surface on which you can add sketch lines or other component geometry. Each view in Revit Architecture is associated with a work plane. Named reference planes can define a work plane.